Re: No Transmit QCX


James Daldry W4JED
 

On Wed, 4 Apr 2018 11:37:35 +0100
"Alan de G1FXB via Groups.Io" <g1fxb@...> wrote:

James W4JED,

    if it's not too late, before you discover it the hard way...
The kit designer has implemented a gotcha to discourage unauthorised
copies of the QCX being built.
Burning a non genuine QRP-Labs supplied ATmega IC will not result in
a functioning QCX,
(I believe it's being reported elsewhere it displays something to the
effect 'none genuine'?)

https://groups.io/g/QRPLabs/message/17805

You should be OK to reflash the original IC.


You may wish to review the Mods / Trouble shooting pages, to see if
yours is a result of incomplete MCU boot / reset
Also separate comment specifically in the*Buttons / rotary encoder
don't work properly* section, highlighting need to check / modify if
necessary if yours is a Ver 1/2 PCB.

https://www.qrp-labs.com/qcx/qcxtrouble.html#digital

Looking over the past posts when used before a factory reset, it has
being reported to 'fix' some side tone / no alignment signal
'funnies' where the MCU saved data becomes corrupt,
Sometimes it goes beyond repair?
It may fix your keying signal working in one function and not
another, may be not?
It won't cost anything to check.

Alan

On 02/04/2018 14:41, James Daldry W4JED wrote:
On Sun, 01 Apr 2018 18:15:54 -0700
"Jim Carlson"<tshotshoto@...> wrote:

Hi Jack,

I'd be happy to look at your QCX with the commitment on your part
that no money changes hands!  I'm just happy to help.  I have built
one QCX but it worked the first time so I don't have experience
trouble shooting but I am a retired electronics engineer (from
Motorola) so I have a lot of experience.  I have the proper test
equipment for this task.  Let me know if you would like to send it
to me.  My contact information is correct on qrz.com.

73,
Jim W7EED
Hi, Jim

For about 10 years at my last job (1988 - 2010) I repaired VCR's and
camcorders almost exclusively - maybe 40 a week. Yes, most of these
were mechanical problems - belts, etc - but a fair number were logic
problems. Most of these, in turn, were things like bad pickup coils,
bad hall effect devices, bad optocouplers, etc, but a significant
fraction were microcontroller problems. VCR's have anywhere from no
micro's (Panasonic NV-8170, with 2 large boards full of CMOS), to 6
or 7, depending on how servo systems were designed. Some micro's had
blown cmos capacitors on input pins (circuit is loaded down by the
input pin, and can be made to work by adding a current amplifier),
weak output "totem poles", etc, but occasionally you would have bad
firmware like a whole family of Matsushita 1985 decks that would
burn the front load assembly motor because there was no timeout on
the basket motor drive. The replacement was MN15846VRG3, which
replaced one without the 3. We kept 2 of that one in stock.

In this case I have a key_out line that is not responding to the
NOT_dit signal, but does respond to the keyer code practice
function. So the output pin is good. When you disable the key_out
by pulling the pin out of the socket, the s-meter goes full-scale
on key presses. The dit pin is functioning. The only thing between
them is the micro and its program. So - I've downloaded the hex
file and will be firing up avrdude to burn it to one of my own
'328's. I have a current-limitted supply so I won't be letting the
magic smoke out. Thanks for volunteering, but I think I have this
handled.

73

Jim Daldry W4JED


Hi, Guys

The bogus chip message is "Use original IC!". Ask me how I know.
Anyway, since the original is burned to use a crystal oscillator it
won't work off-board, so I spent yesterday evening wiring up an
in-circuit programming cable, tracing the wires from the socket pins on
the usbasp to the pins on the socket. Sometime today I'll be trying it
out. Here's hoping!

Jim

Join QRPLabs@groups.io to automatically receive all group messages.