Topics

Protocol nightmare

Dan Goldfarb
 

I am completely out of my depth on this one.
I am very tempted indeed to completely uninstall the Perseus programme which I used to enjoy using.
I was using version 4 for remote access only.
Until lightning / static caused severe problems I had my modem properly set up.
On instruction of a guru at my ISP I acted like an imbecile and followed his advice.
MASSIVE MISTAKE!
I pressed the factory reset button which wiped out the installed Perseus application settings in the fibre-optic modem (BT Home Hub).
I have tried many different settings within the Advanced Settings for Firewall in the modem. Could somebody tell me in idiot terms how to programme it properly. UDP / TCP is like Chinese characters for me. Do I need both or just one? I have tried every possible combination.
Now I get the Perseus screen still showing but I cannot connect to anybody. No waterfall and no audio
Before I lose my sanity could somebody please give me a step by step series of instruction?
I am very tempted to uninstall and try again from scratch.
Finally i am still soldiering on happily with Windows 7. Hopefully this riddle will be solved before the end of 2019!
73 Dan

barry williams
 

Hi Dan,


I’m nowhere near being any sort of modem/router expert, but I’ve learned a couple of things along the way. Here are several things I do know:


For remote access you need “Port Forwarding”. To select this you need to know the numerical, 4 group ID such as “123.123.0.0."  Find the devices on your router, and one will be the computer that you use for remote access with the Perseus. That address for the computer is your port forwarding address.

Look for the Port Forwarding setup in your router, and use the computer address mentioned above. Also, select UDP/TCP, or Both. It should be in the Port Forwarding setup.

I think that’s all you need to do when the router loses power. It forgets everything and you have to know how to set up Port Forwarding. Good luck.



Barry

P.s. maybe rebooting your computer is a good idea. I don’t know if you really need it, but it never hurts



On Aug 1, 2019, at 12:34 PM, Dan Goldfarb via Groups.Io <djg524@...> wrote:

I am completely out of my depth on this one.
I am very tempted indeed to completely uninstall the Perseus programme which I used to enjoy using.
I was using version 4 for remote access only.
Until lightning / static caused severe problems I had my modem properly set up.
On instruction of a guru at my ISP I acted like an imbecile and followed his advice.
MASSIVE MISTAKE!
I pressed the factory reset button which wiped out the installed Perseus application settings in the fibre-optic modem (BT Home Hub).
I have tried many different settings within the Advanced Settings for Firewall in the modem. Could somebody tell me in idiot terms how to programme it properly. UDP / TCP is like Chinese characters for me. Do I need both or just one? I have tried every possible combination.
Now I get the Perseus screen still showing but I cannot connect to anybody. No waterfall and no audio
Before I lose my sanity could somebody please give me a step by step series of instruction?
I am very tempted to uninstall and try again from scratch.
Finally i am still soldiering on happily with Windows 7. Hopefully this riddle will be solved before the end of 2019!
73 Dan

Stuart Heathcock
 

You need to port forward udp traffic on port 8014 (by default) in your router to the PC running the Perseus software. The IP address of the PC typically begins 192.168. If you access a Win7 Command Prompt and run ipconfig you will see the ip address you need as “IPV4 Address” – you’ll have to google or ask someone for how to do PF in your particular modem/router.

 

Regards

 

Stuart

 

 

 

 

 

From: Perseus-SDR@groups.io <Perseus-SDR@groups.io> On Behalf Of barry williams
Sent: 01 August 2019 19:36
To: Perseus-SDR@groups.io
Subject: Re: [Perseus-SDR] Protocol nightmare

 

Hi Dan,

 

 

I’m nowhere near being any sort of modem/router expert, but I’ve learned a couple of things along the way. Here are several things I do know:

 

 

For remote access you need “Port Forwarding”. To select this you need to know the numerical, 4 group ID such as “123.123.0.0."  Find the devices on your router, and one will be the computer that you use for remote access with the Perseus. That address for the computer is your port forwarding address.

 

Look for the Port Forwarding setup in your router, and use the computer address mentioned above. Also, select UDP/TCP, or Both. It should be in the Port Forwarding setup.

 

I think that’s all you need to do when the router loses power. It forgets everything and you have to know how to set up Port Forwarding. Good luck.

 

 

 

Barry

 

P.s. maybe rebooting your computer is a good idea. I don’t know if you really need it, but it never hurts

 

 



On Aug 1, 2019, at 12:34 PM, Dan Goldfarb via Groups.Io <djg524@...> wrote:

 

I am completely out of my depth on this one.
I am very tempted indeed to completely uninstall the Perseus programme which I used to enjoy using.
I was using version 4 for remote access only.
Until lightning / static caused severe problems I had my modem properly set up.
On instruction of a guru at my ISP I acted like an imbecile and followed his advice.
MASSIVE MISTAKE!
I pressed the factory reset button which wiped out the installed Perseus application settings in the fibre-optic modem (BT Home Hub).
I have tried many different settings within the Advanced Settings for Firewall in the modem. Could somebody tell me in idiot terms how to programme it properly. UDP / TCP is like Chinese characters for me. Do I need both or just one? I have tried every possible combination.
Now I get the Perseus screen still showing but I cannot connect to anybody. No waterfall and no audio
Before I lose my sanity could somebody please give me a step by step series of instruction?
I am very tempted to uninstall and try again from scratch.
Finally i am still soldiering on happily with Windows 7. Hopefully this riddle will be solved before the end of 2019!
73 Dan

 

Sylvain Naud
 

Hi Dan,

See attached the related Microtelecom document, which can be found BTW in the same folder as your Perseus.exe

Sylvain

Le 2019-08-01 à 13:34, Dan Goldfarb via Groups.Io a écrit :
I am completely out of my depth on this one.
I am very tempted indeed to completely uninstall the Perseus programme which I used to enjoy using.
I was using version 4 for remote access only.
Until lightning / static caused severe problems I had my modem properly set up.
On instruction of a guru at my ISP I acted like an imbecile and followed his advice.
MASSIVE MISTAKE!
I pressed the factory reset button which wiped out the installed Perseus application settings in the fibre-optic modem (BT Home Hub).
I have tried many different settings within the Advanced Settings for Firewall in the modem. Could somebody tell me in idiot terms how to programme it properly. UDP / TCP is like Chinese characters for me. Do I need both or just one? I have tried every possible combination.
Now I get the Perseus screen still showing but I cannot connect to anybody. No waterfall and no audio
Before I lose my sanity could somebody please give me a step by step series of instruction?
I am very tempted to uninstall and try again from scratch.
Finally i am still soldiering on happily with Windows 7. Hopefully this riddle will be solved before the end of 2019!
73 Dan

Dan Goldfarb
 

I am so thankful for all of your inputs. New effort made. My correct ISPv4 address is linked to the Perseus application in my modem - BT Home Hub5.
I have added two separate details in the Port Forwarding part - to configure the Perseus application.
One is UDP at 8014 and another showing TCP at 8014 as the relevant ports.
Now I still can't get the audio or waterfall.
Mystified. Someone must be able to spot where I have gone wrong. In future I will take a camera shot of the modem settings for the Perseus application and hang it on the wall once I get it properly set up! 

lasse moell
 

You does not seem to be alone with port forwarding problems using the BT modem...

Make sure the port is "forward" and also open in the firewall. Remember you may have to open up the windows firewall too (but if it did work on that specific computer before you may not have to do that)

When you open your Perseus s/w look at network settings to make sure that it is the default port 8014 that is beeing used. Maybe you had this altered for some reason? No fun open up wrong port :)

/Lasse SM5GLC

1 augusti 2019 21:28:03 +02:00, skrev Dan Goldfarb via Groups.Io <djg524@...>:

I am so thankful for all of your inputs. New effort made. My correct ISPv4 address is linked to the Perseus application in my modem - BT Home Hub5.
I have added two separate details in the Port Forwarding part - to configure the Perseus application.
One is UDP at 8014 and another showing TCP at 8014 as the relevant ports.
Now I still can't get the audio or waterfall.
Mystified. Someone must be able to spot where I have gone wrong. In future I will take a camera shot of the modem settings for the Perseus application and hang it on the wall once I get it properly set up! 

Bruce Churchill
 

Dan

 

Be aware that not all Perseus servers use 8014 as their port – I always use a range of port addresses from 8014 to 9100. Your router has to be able to forward a number of different incoming ports. Also the IP address of your PC that acts as the receiver is usually a local network address, typically starting with 192.168.1.xxx or 10.99.1.xxx. These addresses are assigned by your router to all devices on your home network. Your ISP’s IP address for your account is not the correct IP address to use in setting up the router. That IP address is what identifies your router to your ISP account.

 

Bruce Churchill

 

From: Perseus-SDR@groups.io <Perseus-SDR@groups.io> On Behalf Of Dan Goldfarb via Groups.Io
Sent: Thursday, August 1, 2019 12:28 PM
To: Perseus-SDR@groups.io
Subject: Re: [Perseus-SDR] Protocol nightmare

 

I am so thankful for all of your inputs. New effort made. My correct ISPv4 address is linked to the Perseus application in my modem - BT Home Hub5.
I have added two separate details in the Port Forwarding part - to configure the Perseus application.
One is UDP at 8014 and another showing TCP at 8014 as the relevant ports.
Now I still can't get the audio or waterfall.
Mystified. Someone must be able to spot where I have gone wrong. In future I will take a camera shot of the modem settings for the Perseus application and hang it on the wall once I get it properly set up! 

Dan Goldfarb
 

Tack så mucket.
Even after a restart the programme is becoming increasingly UNhappy. 
I will try tomorrow since it is so very frustrating. Your forwarding of the correct guide matches exactly what I see on the module settings. Why should it be so difficult?

Port Forwarding

Port Forwarding is used by devices, such as games consoles, and applications, such as servers, to make sure that data coming from the internet gets to the device that needs to use it. When Port Forwarding is enabled, your BT Home Hub will send all incoming traffic for that application or game to the chosen device.

Game or Application

Device

 
Select game or application  Select game or application   ABC(Another Bittorent Client) Age of Empires Age of Mythology AIM Talk Aliens vs. Predator America's Army Azureus Bay VPN BearShare BitTorrent Black and White BT Homesafe Alarm BT Homesafe Camera Call of Duty Call of Duty - United Offensive CarbonCopy32 Castle Wolfenstein Championship Manager 03-04 Checkpoint FW1 VPN Command and Conquer Generals Command and Conquer Zero Hour Counter Strike Cu-SeeMe Cornell Cu-SeeMe White Pine 3.1.2 and 4.0 Dark Reign 2 Delta Force Destroyer Command Diablo II Direct Connect DirectX 7 DirectX 8 DirectX 9 Doom3 Dune 2000 Dungeon Siege eDonkey Elite Force eMule Enemy Territory Everquest Evil Islands F-22 Lightning 3 Falcon 4 Far Cry FastTrack Fighter Ace II Fighter Ace II(DX) FTP FW1 VPN Gamespy Arcade Ghost Recon Gnutella Half-Life Half-Life 2 Halo Heretic II Hexen II HTTP Server (World Wide Web) HTTPS IL 2 ILS iMesh KALI KaZaA Laplink Links Lock On Lotus Notes Mail Server (SMTP) Medal of Honor (WII) Medal of Honor series Microsoft Remote Desktop Microsoft Terminal Moove MSN Game Zone MSN Game Zone (DX) MSN Messenger Myth Napster Need for Speed Need for Speed - Underground Need for Speed 3 NetMeeting Neverwinter Nights Neverwinter Nights Gamespy News Server (NNTP) NNTP NTP OpenFT Outlaws PalTalk PC Anywhere Playstation 3 POP3 PPTP Quake 3 Rainbow Six RealAudio Realm Games (Blizzard) Remote Anything Remote Anywhere Rogue Spear Rome Total War RTSP RUDP Secure Shell Server (SSH) Secure Web Server (HTTPS) Shareaza Shiva VPN Silent Hunter II SMTP Soldier of Fortune Soldiers: Heroes of World War II Soulseek SSH Server - Secure Shell StarCraft Starsiege Tribes Steam Games Telnet Tiberian Sun Time Server(NTP) Ultima Unreal Tournament Unreal Tournament 2004 Virtual Terminal Server (TELNET) VNC Warcraft III Web Server (HTTP) Westwood Online Win MX World of Warcraft XBConnect Xbox Live Select device  Select device   android-c13eb3aa18920de1 Dan-PC Galaxy-S8 Martin-HP Roberts Stream 93i 00226130e41c User Defined IP Address

Application

Device

 
     
Perseus

 

 

Stuart Heathcock
 

“… Your router has to be able to forward a number of different incoming ports”

 

This is not true. To listen to remote Persii your router has to forward only the port you have defined in the network settings – which by default is 8014 UDP. If the remote server is using a different port for incoming connections that is taken care of in the connection box when you click on Addr.

 

You can open 8014 for TCP if you wish but TCP is only used when your Perseus is used as a server.

 

I am at a loss to understand why you are not getting audio. Check in Network Settings that Client UDP Port is set to 8014 and double check your PC IP address.

 

Stuart

 

 

 

From: Perseus-SDR@groups.io <Perseus-SDR@groups.io> On Behalf Of Bruce Churchill
Sent: 01 August 2019 21:06
To: Perseus-SDR@groups.io
Subject: Re: [Perseus-SDR] Protocol nightmare

 

Dan

 

Be aware that not all Perseus servers use 8014 as their port – I always use a range of port addresses from 8014 to 9100. Your router has to be able to forward a number of different incoming ports. Also the IP address of your PC that acts as the receiver is usually a local network address, typically starting with 192.168.1.xxx or 10.99.1.xxx. These addresses are assigned by your router to all devices on your home network. Your ISP’s IP address for your account is not the correct IP address to use in setting up the router. That IP address is what identifies your router to your ISP account.

 

Bruce Churchill

 

From: Perseus-SDR@groups.io <Perseus-SDR@groups.io> On Behalf Of Dan Goldfarb via Groups.Io
Sent: Thursday, August 1, 2019 12:28 PM
To: Perseus-SDR@groups.io
Subject: Re: [Perseus-SDR] Protocol nightmare

 

I am so thankful for all of your inputs. New effort made. My correct ISPv4 address is linked to the Perseus application in my modem - BT Home Hub5.
I have added two separate details in the Port Forwarding part - to configure the Perseus application.
One is UDP at 8014 and another showing TCP at 8014 as the relevant ports.
Now I still can't get the audio or waterfall.
Mystified. Someone must be able to spot where I have gone wrong. In future I will take a camera shot of the modem settings for the Perseus application and hang it on the wall once I get it properly set up! 

Dan Goldfarb
 

"Connection to host failed".
Current settings - UDP only with 8014 as the range.
Very great care taken re which machine is allocated to the application.
Still I can't even get a link to another machine.
Really looking like I will need to spend a lot of time and effort in uninstalling and then installing Perseus from scratch. Maybe then I can finally succeed to install version 5?
The most frustrating thing of all is that the modem providers yell at me "third party product" and refuse to give me any help whatsoever on Perseus in any phone call. I presume that I will upset Nico if I bother him on this.

DO1INT Germany
 

Hi,

 

did not read the whole tread and it might be an answer you already have: Some Modems / Routers need  an extra click  in a different menu to allow port forwarding.  It it sometimes a bit strange, so it was with mine. Guess it is a double security thing or so.  Which modem / router you have? It has definitively something to do with the settings or the firewall.

 

73s  Chris DO1INT

 

Von: Perseus-SDR@groups.io [mailto:Perseus-SDR@groups.io] Im Auftrag von Dan Goldfarb via Groups.Io
Gesendet: Freitag, 2. August 2019 09:57
An: Perseus-SDR@groups.io
Betreff: Re: [Perseus-SDR] Protocol nightmare

 

"Connection to host failed".
Current settings - UDP only with 8014 as the range.
Very great care taken re which machine is allocated to the application.
Still I can't even get a link to another machine.
Really looking like I will need to spend a lot of time and effort in uninstalling and then installing Perseus from scratch. Maybe then I can finally succeed to install version 5?
The most frustrating thing of all is that the modem providers yell at me "third party product" and refuse to give me any help whatsoever on Perseus in any phone call. I presume that I will upset Nico if I bother him on this.

Dan Goldfarb
 
Edited

Vielen Dank.
I have a BT Home Hub 5. Lasse  attached the online "BT manual" extract (which deals with port forwarding) to this thread.
I am completely mystified. Since I cannot find a difference between what I have on my modem settings and the ideal set out in "Lasse's document" I am at a loss to understand.
If my phone call to BT fails I will perform a big task to uninstall and reinstall. I at least have my own Perseus receiver. I still have no antenna attached to it yet but for remote listening I will be fine. All of this assumes that I can succeed with the modem settings!

DO1INT Germany
 

Hi Dan,

 

I think a lot of people have problems with these own modems from providers. I had it here with German Telecom and changed to an independent router.

 

It has definitively something to do with the settings. The perseus connected once to the machines allows the software to use the network, even if the Perseus is not connected. If you cannot access the online perseus network, it proves that the portforwarding does not work. I had a check and found something

 

https://community.bt.com/t5/Home-setup-Wi-Fi-network/Port-forwarding-is-not-working-Home-Hub-5/td-p/1524279

 

Good luck!

 

Chris DO1INT

 

Von: Perseus-SDR@groups.io [mailto:Perseus-SDR@groups.io] Im Auftrag von Dan Goldfarb via Groups.Io
Gesendet: Freitag, 2. August 2019 10:45
An: Perseus-SDR@groups.io
Betreff: Re: [Perseus-SDR] Protocol nightmare

 

[Edited Message Follows]

Vielen Dank.
I have a BT Home Hub 5. Lasse  attached the online "BT manual" extract (which deals with port forwarding) to this thread.
I am completely mystified. Since I cannot find a difference between what I have on my modem settings and the ideal set out in "Lasse's document" I am at a loss to understand.
If my phone call to BT fails I will perform a big task to uninstall and reinstall. I at least have my own Perseus receiver. I still have no antenna attached to it yet but for remote listening I will be fine. All of this assumes that I can succeed with the modem settings!

Mauno_Ritola
 

But was it the same modem, which worked before the recent modem reset?

Mauno

DO1INT Germany kirjoitti 2.8.2019 klo 11:53:

Hi Dan,

 

I think a lot of people have problems with these own modems from providers. I had it here with German Telecom and changed to an independent router.

 

It has definitively something to do with the settings. The perseus connected once to the machines allows the software to use the network, even if the Perseus is not connected. If you cannot access the online perseus network, it proves that the portforwarding does not work. I had a check and found something

 

https://community.bt.com/t5/Home-setup-Wi-Fi-network/Port-forwarding-is-not-working-Home-Hub-5/td-p/1524279

 

Good luck!

 

Chris DO1INT

 

Von: Perseus-SDR@groups.io [mailto:Perseus-SDR@groups.io] Im Auftrag von Dan Goldfarb via Groups.Io
Gesendet: Freitag, 2. August 2019 10:45
An: Perseus-SDR@groups.io
Betreff: Re: [Perseus-SDR] Protocol nightmare

 

[Edited Message Follows]

Vielen Dank.
I have a BT Home Hub 5. Lasse  attached the online "BT manual" extract (which deals with port forwarding) to this thread.
I am completely mystified. Since I cannot find a difference between what I have on my modem settings and the ideal set out in "Lasse's document" I am at a loss to understand.
If my phone call to BT fails I will perform a big task to uninstall and reinstall. I at least have my own Perseus receiver. I still have no antenna attached to it yet but for remote listening I will be fine. All of this assumes that I can succeed with the modem settings!

Dan Goldfarb
 

Yes. The very same modem. It had the factory reset button pressed.
The modem works smoothly for ALL OTHER FUNCTIONS

Stuart Heathcock
 

You do not install Perseus software - you simply unzip unto the folder. You have a settings problem somewhere.

Have you tried disabling your AV temporarily?

Stuart


On 2 Aug 2019, at 08:56, Dan Goldfarb via Groups.Io <djg524@...> wrote:

"Connection to host failed".
Current settings - UDP only with 8014 as the range.
Very great care taken re which machine is allocated to the application.
Still I can't even get a link to another machine.
Really looking like I will need to spend a lot of time and effort in uninstalling and then installing Perseus from scratch. Maybe then I can finally succeed to install version 5?
The most frustrating thing of all is that the modem providers yell at me "third party product" and refuse to give me any help whatsoever on Perseus in any phone call. I presume that I will upset Nico if I bother him on this.

Stuart Heathcock
 

Another thing you can check is to see if port 8014 is open to udp traffic or not (spoiler alert it won’t be...). You can google “check port is open windows” but netstat -a may do the job - see https://www.sevenforums.com/network-sharing/228017-check-if-port-ip-open-cmd.html

If port 8014 is not open then you know the issue is the router and not the Perseus app.

Stuart


On 2 Aug 2019, at 11:21, Stuart Heathcock <satnipper@...> wrote:

You do not install Perseus software - you simply unzip unto the folder. You have a settings problem somewhere.

Have you tried disabling your AV temporarily?

Stuart


On 2 Aug 2019, at 08:56, Dan Goldfarb via Groups.Io <djg524@...> wrote:

"Connection to host failed".
Current settings - UDP only with 8014 as the range.
Very great care taken re which machine is allocated to the application.
Still I can't even get a link to another machine.
Really looking like I will need to spend a lot of time and effort in uninstalling and then installing Perseus from scratch. Maybe then I can finally succeed to install version 5?
The most frustrating thing of all is that the modem providers yell at me "third party product" and refuse to give me any help whatsoever on Perseus in any phone call. I presume that I will upset Nico if I bother him on this.

lasse moell
 

Dan,
I honestly do not think it's the Perseus s/w that causes the problems and there is nothing to be gained by reinstalling. This should be true if Perseus s/w starts and when you tries to connect all looks OK but you do not get any audio nor waterfall... i.e. the UDP stream fails.

Looking on what others have written on the net about the BT modem, there may be a problem with built-in firewall, and when setting up the application name things can go wrong for unknown reason.

Yesterday I tried to get one of my laptops operate with Perseus client, and hit a stone wall.... but it then dawn to me (at 2 a.m. ) that in my router I had set several rules, and adding the one for this laptop ended up last in the list. The router goes through the list and one old rule (earlier in the list) prevented the laptop to get a proper UDP stream. So it can be quite tricky to see what is going wrong.  Some routers (modems) do have a DMZ function which sets one specific LAN IP address outside of the firewall, and you do not need to fiddle with port forwarding. If you have this feature you may try this, at least as a starter to get things working.

Finally I noticed even my windows 7 machine said that there had been a change in the windows defender firewall. It is of course important that you allow Perseus in Windows Defender. If you suspect Defender to be problematic, you may (at your own discretion) disable this function temporarely to verify if it works.

Other than than, I assume that BT do ALLOW port 8014? Some providers may be very naughty, and close ports with-out telling the subscriber.
/Lasse SM5GLC

2 augusti 2019 10:53:25 +02:00, skrev DO1INT Germany <senne@...>:

Hi Dan,

 

I think a lot of people have problems with these own modems from providers. I had it here with German Telecom and changed to an independent router.

 

It has definitively something to do with the settings. The perseus connected once to the machines allows the software to use the network, even if the Perseus is not connected. If you cannot access the online perseus network, it proves that the portforwarding does not work. I had a check and found something

 

https://community.bt.com/t5/Home-setup-Wi-Fi-network/Port-forwarding-is-not-working-Home-Hub-5/td-p/1524279

 

Good luck!

 

Chris DO1INT

 

Von: Perseus-SDR@groups.io [mailto:Perseus-SDR@groups.io] Im Auftrag von Dan Goldfarb via Groups.Io
Gesendet: Freitag, 2. August 2019 10:45
An: Perseus-SDR@groups.io
Betreff: Re: [Perseus-SDR] Protocol nightmare

 

[Edited Message Follows]

Vielen Dank.
I have a BT Home Hub 5. Lasse  attached the online "BT manual" extract (which deals with port forwarding) to this thread.
I am completely mystified. Since I cannot find a difference between what I have on my modem settings and the ideal set out in "Lasse's document" I am at a loss to understand.
If my phone call to BT fails I will perform a big task to uninstall and reinstall. I at least have my own Perseus receiver. I still have no antenna attached to it yet but for remote listening I will be fine. All of this assumes that I can succeed with the modem settings!



Dan Goldfarb
 

Lasse,
An excellent reply. My system is more complex. The renowned Bitdefender Total Security Antivirus actually overrides the Windows Firewall. After a quick check on the Firewall settings of my Bitdefender program I see that the Perseus programme is set with the most general (and generous) protocol. In summary the Perseus is allowed any protocol, both directional traffic, any port, any IP and ticked "access" by my antivirus programme.
I will try DMZ for Perseus. The function is so "wrong" now that it might work!

Dan Goldfarb
 

A trial under DMZ was not good. The whole desktop PC had to go into this setting. The modem couldn't go directly to a specific programme.
So still stuck.