Can't write to parameters.txt file

Wayne Johnson

Hi all, hoping someone can steer me in the right direction here. 

I have completed construction of my PPHSNA, no problems encountered with all that, however when I try to go through the calibration process starting with slope /intercept  measurements all goes well until I try to write the 2 figures back to the parameters.txt file... The 'write' button on the control display when tapped returns with 'can't write to file' or words to that affect and says 'can't find parameters.txt file'

I did rename to parameters file to .txt etc. Both the windows files(.Exe) and parameters.txt files are together in a folder on my desktop and when trying to write to it from PHSNA control screen the path referred to by PHSNA are correct to the word but it will not update the parameters.txt file.

I also tried manually editing the parameters.txt file with notepad++ and it takes the new figures which are saved to the file but restart will not show the new figures being implemented, even DDS type ("0") in my case and COM4 will not be loaded on next restart

The system is clearly working and produces a trace graph (albeit out of cal) but just can't get the parameters file to be written to and consequently loaded.

I suspect it some silly mistake I'm making but it seems so simple that I need to create a folder on desktop, copy the unzipped files (Parameters.txt and PHSNA.exe) and run the program from there.

I even tried deleting everything including the arduino sketch and starting from scratch but same stuff, different day😪

Can anybody see what's wrong....jeez, didn't think I was this thick😀




Hi Wayne,

Have you received any of my off-list replies?

Jim, N5IB

---In PHSNA@..., <vk6eh@...> wrote :

Hi all, hoping someone can steer me in the right direction here.

Wayne Johnson

Gday Jim,
Yes thanks I did get your reply, very much appreciated, and I have confirmed the .txt rename etc but still having trouble.
its early AM here so I will drop you a more detailed off line report once I have COFFEE 😄
Thanks for the reply Jim