Ver. 1.42 and crystal measurement

Ted KX4OM
 

Welcome to the new moderators!

I've been measuring a lot of crystals the past week, about a hundred in all. About 50 in 8.192 HC49/U from a batch of 100 of which I had measured previously, and about 50 8.386 HC49/US that Harold Smith, KE6TI gave me a few years ago, about 100 in all. The latter have an average Q of around 200,000 while the 8.162 ones are about 100,000. The PHSNA makes it so easy, much moreso than my homebrew K8IQY PVXO and G3UUR rigs.

Here is my problem: A year ago, I upgraded to Rev 1.42 and used it to check my 40m dipole to set its length. That replaced my G5RV. Great, no problem. I had also used it to sweep some Heathkit SSB and CW crystal filters. That's all I used it for. I *think* I did the new crystal measurement frequency polynomial coefficients correctly when I installed 1.42; the ones in parameters.txt aren't Nick's from the 1.42 files. Last week when I started to measure the crystals, it would search for a long time and then would send an error message "Unable to find peak RF frequency" or something like that. I reinspected the parameters.txt file and everything looked okay. I ended up saving 1.42 to a bak directory and replaced it with 1.40, the last version I had used to do crystals back in 2018. What is odd is that I could do a response sweep in 1.42 on a crystal and get the peak frequency, but I couldn't sweep a jumpered holder in the standard PHSNA crystal test board (not using the amplifer, and always using an additional 4 dB attenuator from the SNA.

From reading the docs, I think I understand that I could put in some value for the five coefficients in 1.42 that aren't real, and that would allow the crystal measure to function as if it was a later version. Any ideas?

Ted, KX4OM

Join PHSNA@groups.io to automatically receive all group messages.