Cant run ICC on my compute nodes


DARDO ARIEL VIÑAS VISCARDI
 

I had a problem when I tried to run a test domain in WRF on my cluster. 

 [prun] Error: Expected Job launcher mpiexec.hydra not found for impi

So I shh to my node, and try to run the command myself (after loading the intel and impi module)
 
icc
-bash: icc: command not found
mpiexec.hydra
-bash: mpiexec.hydra: command not found
mpirun
-bash: mpirun: command not found

Any idea why this happends? On my master I cant find the commands after loading the module (my master isn't acting as a compute node).

This is my slurm.conf config for the nodes:

# COMPUTE NODES
# OpenHPC default configuration
PropagateResourceLimitsExcept=MEMLOCK
AccountingStorageType=accounting_storage/filetxt
Epilog=/etc/slurm/slurm.epilog.clean
NodeName=yaku04 Weight=100 Sockets=2 CoresPerSocket=16 ThreadsPerCore=1 State=UNKNOWN
NodeName=yaku03 Weight=100 Sockets=2 CoresPerSocket=16 ThreadsPerCore=1 State=UNKNOWN
NodeName=yaku02 Weight=100 Sockets=2 CoresPerSocket=16 ThreadsPerCore=1 State=UNKNOWN
NodeName=yaku01 Weight=100 Sockets=2 CoresPerSocket=16 ThreadsPerCore=1 State=UNKNOWN
NodeName=yaku Weight=10 Sockets=2 CoresPerSocket=16 ThreadsPerCore=1 State=UNKNOWN
PartitionName=normal Nodes=yaku0[1-4] Default=YES MaxTime=24:00:00 State=UP PriorityTier=1
PartitionName=mono Nodes=yaku01 Default=NO MaxTime=4:00:00 State=UP PriorityTier=1
PartitionName=intensiva Nodes=yaku0[1-4] Default=NO MaxTime=UNLIMITED State=UP PriorityTier=1 PreemptMode=requeue
PartitionName=hipri Nodes=yaku0[1-4] Default=NO MaxTime=UNLIMITED State=UP PriorityTier=2 PreemptMode=off
PartitionName=Infiniband Nodes=yaku0[2-4] Default=NO MaxTime=UNLIMITED State=UP PriorityTier=2 PreemptMode=off
ReturnToService=1


 
 

Join OpenHPC-users@groups.io to automatically receive all group messages.