Import ADIF from MLDX into ACLog ignores date field


Ted VE3TRQ
 

I decided to import the entries from my MacLoggerDX log program on my Mac into ACLog, so I could more easily log JS8Call QSOs using ACLog using Win10 on Parallels. So far so good - JS8Call integrates nicely with FDLog and ACLog.

Now the problem - when I import the ADIF file created with MLDX, the resulting ACLog database ends up with all QSO dates set to 0001/01/01 :-( I have verified the ADIF file contains the QSO date, and when I import into N1MM+, all is well.

What am I doing wrong? Or is there a problem?

VE3TRQ Ted


Scott Davis
 

Hi Ted,

Thanks for your e-mail.  I'm sorry that you've run into trouble.  For the date to import properly, it must conform to ADIF format specifications.  To see the date format that AC Log is expecting, go ahead and export a record from AC Log and open it in Notepad.  Alternatively, you can check the ADIF specification here:

https://www.adif.org/312/ADIF_312.htm#Date

A properly formatted QSO date will look like this:

<QSO_Date:8>20210507

Since you were successfully able to import into N1MM, you could try then exporting from N1MM, using that file to import to AC Log and see if that corrects the problem.

Be well and enjoy!

73, Kimberly, KA3SEQ

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: Ted VE3TRQ <ve3trq@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Sun, May 9, 2021 4:48 pm
Subject: [N3FJPSoftwareUsers] Import ADIF from MLDX into ACLog ignores date field

I decided to import the entries from my MacLoggerDX log program on my Mac into ACLog, so I could more easily log JS8Call QSOs using ACLog using Win10 on Parallels. So far so good - JS8Call integrates nicely with FDLog and ACLog.

Now the problem - when I import the ADIF file created with MLDX, the resulting ACLog database ends up with all QSO dates set to 0001/01/01 :-( I have verified the ADIF file contains the QSO date, and when I import into N1MM+, all is well.

What am I doing wrong? Or is there a problem?

VE3TRQ Ted


Ted VE3TRQ
 

Answered my own question: Do not import multi-line ADIF fields from non-Windows/DOS to Windows/DOS :-(

The EOL characters are different in number from Unix (LF) to Windows (CR/LF), so the implied CR/LF ADI convention is broken unless the Unix/Mac logging software is smart enough to export CORRECT ADI multi-line text fields, with the appropriate associated character count. MLDX has an option to NOT export the Address field - I guess that's why. Using a character converter does not work unless the character count for the field is adjusted.

Solution for MLDX-to-ACLog is to uncheck the "Export Addresses" checkbox in MLDX ADIF Export. With that, the ADI file export works just fine.
--
VE3TRQ Ted


Scott Davis
 

Thanks so much for the good information Ted!

Be well and enjoy!

73, Kimberly, KA3SEQ

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: Ted VE3TRQ <ve3trq@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Mon, May 10, 2021 11:54 am
Subject: Re: [N3FJPSoftwareUsers] Import ADIF from MLDX into ACLog ignores date field

Answered my own question: Do not import multi-line ADIF fields from non-Windows/DOS to Windows/DOS :-(

The EOL characters are different in number from Unix (LF) to Windows (CR/LF), so the implied CR/LF ADI convention is broken unless the Unix/Mac logging software is smart enough to export CORRECT ADI multi-line text fields, with the appropriate associated character count. MLDX has an option to NOT export the Address field - I guess that's why. Using a character converter does not work unless the character count for the field is adjusted.

Solution for MLDX-to-ACLog is to uncheck the "Export Addresses" checkbox in MLDX ADIF Export. With that, the ADI file export works just fine.
--
VE3TRQ Ted