Flex 6600 API Interface #setup


Jack Di Palo
 

Hello,
I have a Flex 6600, with a maestro hooked up to the same LAN network. I'm trying to set up the N3FJP interface using the Flex API option, but am not having any luck. The blue rectangle says "polling rig", but it's not tracking the frequency. Looking through this group it looks like there have been others with this problem, but couldn't find any conclusive solutions posted. Anyway, I'm sure the problem is some type of operator error! Any help/suggestions would be great
Jack,
WZ1Y


Dave wo2x
 

Check your firewall software. It is probably blocking N3FJP program from communicating with the radio.

Dave wo2x


On Jul 19, 2021, at 2:14 PM, Jack Di Palo <jfdipalo@...> wrote:

Hello,
I have a Flex 6600, with a maestro hooked up to the same LAN network. I'm trying to set up the N3FJP interface using the Flex API option, but am not having any luck. The blue rectangle says "polling rig", but it's not tracking the frequency. Looking through this group it looks like there have been others with this problem, but couldn't find any conclusive solutions posted. Anyway, I'm sure the problem is some type of operator error! Any help/suggestions would be great
Jack,
WZ1Y


AB8WD-Willie
 

Why are you not  using rig control flex radio?


JoAnn Donaldson
 

Make sure you have "Use freq on Main Form" checked in Settings/Rig Control.

JoAnn
AB8YZ

On Monday, July 19, 2021, 2:25:26 PM CDT, AB8WD-Willie via groups.io <ab8wd@...> wrote:


Why are you not  using rig control flex radio?


Jack Di Palo
 

Thank you all for the suggestions. I’ll try them when I’m back on-site, but for today I made it work using CAT control via the com ports. Would be nice to get the interface working through Flex API of course.
Thanks,
jack wz1y 


Dave wo2x
 

If you are trying to make the API connection work remote, it won’t. The Flex UDP broadcast traffic on port 4992 will not be forwarded to your remote site where N3FJP is running.

It only works for logging program local to the radio (same subnet).

 

Dave wo2x

 

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of Jack Di Palo
Sent: Monday, July 19, 2021 10:18 PM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] Flex 6600 API Interface #setup

 

Thank you all for the suggestions. I’ll try them when I’m back on-site, but for today I made it work using CAT control via the com ports. Would be nice to get the interface working through Flex API of course.
Thanks,
jack wz1y 


JoAnn Donaldson
 

I have found using the TS-2000 setting and Comm Port 4 (default on Flex) at 38KBaud worked the best.

JoAnn
AB8YZ

On Monday, July 19, 2021, 10:08:30 PM CDT, Dave wo2x <rocketnj@...> wrote:


If you are trying to make the API connection work remote, it won’t. The Flex UDP broadcast traffic on port 4992 will not be forwarded to your remote site where N3FJP is running.

It only works for logging program local to the radio (same subnet).

 

Dave wo2x

 

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of Jack Di Palo
Sent: Monday, July 19, 2021 10:18 PM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] Flex 6600 API Interface #setup

 

Thank you all for the suggestions. I’ll try them when I’m back on-site, but for today I made it work using CAT control via the com ports. Would be nice to get the interface working through Flex API of course.
Thanks,
jack wz1y 


Patrick Moonen
 



I use this settings Flexradio and Maestro follow.