Topics

ACL 6.7 woe's


JeffBanke
 

I updated to ACL 6.7, now my rig (ICOM 7300) is not talking to the computer correctly. I have gone through rig interface the setup again and still it does not talk fully. When I do the interface test it does not report frequency, but does report PH mode.
Naturally since that aspect is not working correctly others are not as well, I mean it is not reporting county, but does report country.
To log all my QSO's I have to enter frequency manually.
I have tried all of the com ports, one (Com 3) does the partial connection the others do nothing.
My rig interface settings are those SCOTT has provided for an ICOM 7300, (Baud 9600, parity=none, data bits=8, stop bits=1, connection power=none, mode determined by frequency, command to read frequency=FE FE 94 EO 03 FD, Command to read mode=FE FE 94 EO 04 FD) and up until this change worked fabulously.

What to do? Any suggestions?

Jeff


Scott Davis
 

Hi Jeff,

Thanks for your e-mail.  I'm sorry that you ran into trouble.  You have put an alphabetic O after the E instead of a numeric 0.  Replace the O with the 0 and you will be all set.  

FE FE 94 E0 04 FD

Complete details are here:

http://www.n3fjp.com/help/righelp.html

To retrieve county, you will need to interface with a Callbook data source that provides that information, such as QRZ Premium XML service.  Details on that are here:

http://www.n3fjp.com/help/callbookmenu.html

Enjoy!

73, Scott
N3FJP

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: JeffBanke <jeffbanke@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Thu, Oct 8, 2020 6:44 pm
Subject: [N3FJPSoftwareUsers] ACL 6.7 woe's

I updated to ACL 6.7, now my rig (ICOM 7300) is not talking to the computer correctly. I have gone through rig interface the setup again and still it does not talk fully. When I do the interface test it does not report frequency, but does report PH mode.
Naturally since that aspect is not working correctly others are not as well, I mean it is not reporting county, but does report country.
To log all my QSO's I have to enter frequency manually.
I have tried all of the com ports, one (Com 3) does the partial connection the others do nothing.
My rig interface settings are those SCOTT has provided for an ICOM 7300, (Baud 9600, parity=none, data bits=8, stop bits=1, connection power=none, mode determined by frequency, command to read frequency=FE FE 94 EO 03 FD, Command to read mode=FE FE 94 EO 04 FD) and up until this change worked fabulously.

What to do? Any suggestions?

Jeff


JeffBanke
 

On Thu, Oct 8, 2020 at 04:58 PM, Scott Davis wrote:
I corrected to "O" for the "0", but it is still behaving the same
Here is the data copied to the clipboard
Rig Name = Icom
Read Frequency Command = FE FE 94 E0 03 FD
Read Mode Command = FE FE 94 E0 04 FD
Convert To Hex = True
Com Port Name = COM3
Baud Rate = 9600
Parity = None
Stop Bits = 1
Data Bits = 8
Power Option = None
Numeric Frequency = 0
String Frequency =
Mode = PH
Polling Rig = True
Polling Rate = 2000
Return Mode = True
Return Frequency = False
Mode From Frequency = True
Version = Rig Interface Setup 2.8    (Ctrl R)
Buffer = þþ”àý
Buffer Converted from HEX = FE FE 94 E0 03 FD


AI3KS
 

Jeff,

I just checked my 7300. Everything was working ok. I changed the baud rate in ACLog and experienced the same thing you have. You may want to double check both ACLog and the 7300.

Hope this helps.

Steve, AI3KS

On 20/10/09 12:41, JeffBanke wrote:
On Thu, Oct 8, 2020 at 04:58 PM, Scott Davis wrote:
I corrected to "O" for the "0", but it is still behaving the same
Here is the data copied to the clipboard
Rig Name = Icom
Read Frequency Command = FE FE 94 E0 03 FD
Read Mode Command = FE FE 94 E0 04 FD
Convert To Hex = True
Com Port Name = COM3
Baud Rate = 9600
Parity = None
Stop Bits = 1
Data Bits = 8
Power Option = None
Numeric Frequency = 0
String Frequency =
Mode = PH
Polling Rig = True
Polling Rate = 2000
Return Mode = True
Return Frequency = False
Mode From Frequency = True
Version = Rig Interface Setup 2.8    (Ctrl R)
Buffer = þþ”àý
Buffer Converted from HEX = FE FE 94 E0 03 FD


Lou Everett, Sr.
 

Good advice.  Baud Rates must match

On Fri, Oct 9, 2020 at 12:48 PM AI3KS <AI3KS.01@...> wrote:
Jeff,

I just checked my 7300. Everything was working ok. I changed the baud rate in ACLog and experienced the same thing you have. You may want to double check both ACLog and the 7300.

Hope this helps.

Steve, AI3KS

On 20/10/09 12:41, JeffBanke wrote:
On Thu, Oct 8, 2020 at 04:58 PM, Scott Davis wrote:
I corrected to "O" for the "0", but it is still behaving the same
Here is the data copied to the clipboard
Rig Name = Icom
Read Frequency Command = FE FE 94 E0 03 FD
Read Mode Command = FE FE 94 E0 04 FD
Convert To Hex = True
Com Port Name = COM3
Baud Rate = 9600
Parity = None
Stop Bits = 1
Data Bits = 8
Power Option = None
Numeric Frequency = 0
String Frequency =
Mode = PH
Polling Rig = True
Polling Rate = 2000
Return Mode = True
Return Frequency = False
Mode From Frequency = True
Version = Rig Interface Setup 2.8    (Ctrl R)
Buffer = þþ”à ý
Buffer Converted from HEX = FE FE 94 E0 03 FD


JeffBanke
 

I originally had the baud rate at 19.2, everything was working. Updated and changed both the rig and ACLog to 9.6, after watching the video and reading suggestions on the baud rate.
Still is not functioning correctly.
Running the com test it reads the mode, but not the frequency. Obviously doing the Freq test from the settings page does not change the rig since it appears there is no communication for frequency data in either direction.
I have also had this window pop up when entering a call sign into ACLog that says it is having a communication problem with QRZ, although it seems to enter all the data, like name, country, address, etc, however omits the county. This probably  a separate issue, but who knows. I am running Windows 10 with ACLog on an HP i5 proc, 8GB RAM laptop.
Any suggestions would be welcome
Jeff


Scott Davis
 

Hi Jeff,

Thanks for your follow up.  We can help you best if you'll stay with one problem at a time and keep each question on a separate thread.  

Regarding rig interface, please send a screen shot of your rig interface form, like this:

Capture.JPG

73, Scott
N3FJP

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: JeffBanke <jeffbanke@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Sat, Oct 10, 2020 3:24 pm
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

I originally had the baud rate at 19.2, everything was working. Updated and changed both the rig and ACLog to 9.6, after watching the video and reading suggestions on the baud rate.
Still is not functioning correctly.
Running the com test it reads the mode, but not the frequency. Obviously doing the Freq test from the settings page does not change the rig since it appears there is no communication for frequency data in either direction.
I have also had this window pop up when entering a call sign into ACLog that says it is having a communication problem with QRZ, although it seems to enter all the data, like name, country, address, etc, however omits the county. This probably  a separate issue, but who knows. I am running Windows 10 with ACLog on an HP i5 proc, 8GB RAM laptop.
Any suggestions would be welcome
Jeff


JeffBanke
 

As requested Scott, here is the screen with the software set to follow rig

On Sat, Oct 10, 2020 at 12:54 PM Scott Davis via groups.io <SNKDavis=aol.com@groups.io> wrote:
Hi Jeff,

Thanks for your follow up.  We can help you best if you'll stay with one problem at a time and keep each question on a separate thread.  

Regarding rig interface, please send a screen shot of your rig interface form, like this:

Capture.JPG

73, Scott
N3FJP

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: JeffBanke <jeffbanke@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Sat, Oct 10, 2020 3:24 pm
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

I originally had the baud rate at 19.2, everything was working. Updated and changed both the rig and ACLog to 9.6, after watching the video and reading suggestions on the baud rate.
Still is not functioning correctly.
Running the com test it reads the mode, but not the frequency. Obviously doing the Freq test from the settings page does not change the rig since it appears there is no communication for frequency data in either direction.
I have also had this window pop up when entering a call sign into ACLog that says it is having a communication problem with QRZ, although it seems to enter all the data, like name, country, address, etc, however omits the county. This probably  a separate issue, but who knows. I am running Windows 10 with ACLog on an HP i5 proc, 8GB RAM laptop.
Any suggestions would be welcome
Jeff


AI3KS
 

Jeff,

This shows your baud rate as 1200.

In a previous post you indicated 9600.

I would go back and double check both baud rates. I may be wrong, but I believe that if you change it in the 7300 you need to power cycle it to reset it.

Scott may be able to verify whether or not this matters, but I also have the CI-V port unlinked from remote and Echo Back on.

Steve, AI3KS


Scott Davis
 

Hi Jeff and Steve,

Yes, I don't have a 7300 myself, but from what I understand, the proper baud rate is required.


73, Scott
N3FJP

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: AI3KS <AI3KS.01@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Tue, Oct 13, 2020 11:46 am
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

Jeff,

This shows your baud rate as 1200.

In a previous post you indicated 9600.

I would go back and double check both baud rates. I may be wrong, but I believe that if you change it in the 7300 you need to power cycle it to reset it.

Scott may be able to verify whether or not this matters, but I also have the CI-V port unlinked from remote and Echo Back on.

Steve, AI3KS


AI3KS
 

Jeff,

I just played with my settings here.

I opened up the rig interface settings in ACLog and the CI-V settings menu in the 7300. I then played with changing baud rates first in ACLog and then matching that in the 7300 and then changing it in the 7300 and matching it in ACLog. In both instances, if I used the started the test in ACLog everything was ok. I then Ended the test, changed the baud rates and started the test. In both scenarios, as long as the baud rates matched, Frequency and Mode were returned. If the baud rates didn't match, there were problems in the returned data.

BTW, I am using Icom, not Icom2. Not sure if that will make a difference.

Hope this helps.

Steve, AI3KS


Frank MacKenzie-Lamb
 

Which is 115200 for the 7300

 

Frank

NG1I

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of Scott Davis via groups.io
Sent: Tuesday, October 13, 2020 11:55 AM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

 

Hi Jeff and Steve,

 

Yes, I don't have a 7300 myself, but from what I understand, the proper baud rate is required.

 

73, Scott

N3FJP

 

Serving the Amateur Radio community with contesting and general logging software since 1997.

 

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...

 

-----Original Message-----
From: AI3KS <AI3KS.01@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Tue, Oct 13, 2020 11:46 am
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

Jeff,

This shows your baud rate as 1200.

In a previous post you indicated 9600.

I would go back and double check both baud rates. I may be wrong, but I believe that if you change it in the 7300 you need to power cycle it to reset it.

Scott may be able to verify whether or not this matters, but I also have the CI-V port unlinked from remote and Echo Back on.

Steve, AI3KS


AI3KS
 

Frank,

That is the fastest speed, not the "required" speed. I just tested at 4800 and it worked just fine. They just have to match. Also, the actual CI-V port won't run faster than 19200. I think to run faster than 19200 you have to unlink from remote. If the ports are linked I believe that the top speed is 19200.

From page 12-9 of the full manual:

Selects the CI-V data transfer rate when remotely
controlling the IC-7300 through the [USB] CI-V port.
••Options: 4800, 9600, 19200, 38400, 57600, 115200
(bps), or Auto

This setting is valid only when the “CI-V USB Port”
item is set to “Unlink from [REMOTE].”


Steve, AI3KS

On 20/10/13 13:17, Frank MacKenzie-Lamb wrote:

Which is 115200 for the 7300

 

Frank

NG1I

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of Scott Davis via groups.io
Sent: Tuesday, October 13, 2020 11:55 AM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

 

Hi Jeff and Steve,

 

Yes, I don't have a 7300 myself, but from what I understand, the proper baud rate is required.

 

73, Scott

N3FJP

 

Serving the Amateur Radio community with contesting and general logging software since 1997.

 

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...

 

-----Original Message-----
From: AI3KS <AI3KS.01@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Tue, Oct 13, 2020 11:46 am
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

Jeff,

This shows your baud rate as 1200.

In a previous post you indicated 9600.

I would go back and double check both baud rates. I may be wrong, but I believe that if you change it in the 7300 you need to power cycle it to reset it.

Scott may be able to verify whether or not this matters, but I also have the CI-V port unlinked from remote and Echo Back on.

Steve, AI3KS



JeffBanke
 

I have double checked the baud rate, both are on 9.6k rig is set at 94h as you can see ACLog laso set there, still the same problem not talking. As was suggested recycled power on the rig, then checked that nothing has changed. If I change ACLog so that mode is set by frequency, it will set to PH or when to SSB.
If I switch from ICOM to ICOM2 in ACLOG everything gets set back to default I.E. rig set to 64, baud rate set to 1.2 which I didn't notice previously


On Tue, Oct 13, 2020 at 8:46 AM AI3KS <AI3KS.01@...> wrote:
Jeff,

This shows your baud rate as 1200.

In a previous post you indicated 9600.

I would go back and double check both baud rates. I may be wrong, but I believe that if you change it in the 7300 you need to power cycle it to reset it.

Scott may be able to verify whether or not this matters, but I also have the CI-V port unlinked from remote and Echo Back on.

Steve, AI3KS


AI3KS
 

Jeff,

Not sure where to go from here.

Have you actually verified the com port by removing power from the 7300 and checking device manager? (Turning off the 7300 does not work. You must actually turn off the power supply to the rig).

I know that I have an RF problem in the shack on 20 meters and above and have seen the com port stop working because of that, but a pc reboot always brings it right back.

I have also been reading on other forums that the latest windows 10 update has been doing some weird things, including destroying the boot sector and updating drivers without warning. May be worth uninstalling the Icom driver and reinstalling it.

Wish I could offer a definitive solution.

Steve, AI3KS


Scott Davis
 

Hi Jeff and Steve,

In addition to Steve's good suggestions, I am wondering if you changed other settings from default that may be adding to the problem.  

There have been no other problem reports from 7300 users whatsoever, so something specific to your setup is at play.,  First, stay with the Icom2 option as that doesn't require the echo back in your rig being enabled.  If you still have trouble, you may want to try resetting your rig to default.  

73, Scott
N3FJP

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: AI3KS <AI3KS.01@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Tue, Oct 13, 2020 3:31 pm
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

Jeff,

Not sure where to go from here.

Have you actually verified the com port by removing power from the 7300 and checking device manager? (Turning off the 7300 does not work. You must actually turn off the power supply to the rig).

I know that I have an RF problem in the shack on 20 meters and above and have seen the com port stop working because of that, but a pc reboot always brings it right back.

I have also been reading on other forums that the latest windows 10 update has been doing some weird things, including destroying the boot sector and updating drivers without warning. May be worth uninstalling the Icom driver and reinstalling it.

Wish I could offer a definitive solution.

Steve, AI3KS


Frank MacKenzie-Lamb
 

I understand and thank you

 

Frank

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of AI3KS
Sent: Tuesday, October 13, 2020 1:32 PM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

 

Frank,

That is the fastest speed, not the "required" speed. I just tested at 4800 and it worked just fine. They just have to match. Also, the actual CI-V port won't run faster than 19200. I think to run faster than 19200 you have to unlink from remote. If the ports are linked I believe that the top speed is 19200.

From page 12-9 of the full manual:

Selects the CI-V data transfer rate when remotely
controlling the IC-7300 through the [USB] CI-V port.
••Options: 4800, 9600, 19200, 38400, 57600, 115200
(bps), or Auto

This setting is valid only when the “CI-V USB Port”
item is set to “Unlink from [REMOTE].”


Steve, AI3KS

On 20/10/13 13:17, Frank MacKenzie-Lamb wrote:

Which is 115200 for the 7300

 

Frank

NG1I

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of Scott Davis via groups.io
Sent: Tuesday, October 13, 2020 11:55 AM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

 

Hi Jeff and Steve,

 

Yes, I don't have a 7300 myself, but from what I understand, the proper baud rate is required.

 

73, Scott

N3FJP

 

Serving the Amateur Radio community with contesting and general logging software since 1997.

 

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...

 

-----Original Message-----
From: AI3KS <AI3KS.01@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Tue, Oct 13, 2020 11:46 am
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

Jeff,

This shows your baud rate as 1200.

In a previous post you indicated 9600.

I would go back and double check both baud rates. I may be wrong, but I believe that if you change it in the 7300 you need to power cycle it to reset it.

Scott may be able to verify whether or not this matters, but I also have the CI-V port unlinked from remote and Echo Back on.

Steve, AI3KS

 


JeffBanke
 

I guess the frustrating thing is that it all worked perfectly before even at 19.2 baud rate.

I have tried the Icom2 selection even though I had it on Icom when it worked, but it behaves the same way.  Tried all of the com ports, most just sit there and ACLOG says "awaiting" only port that it does anything is com port 3, where I get the message as shown in the screen capture I sent before, it sits there switching the 03 for the 04, in the Hex line but does nothing,
As an fyi I am running windows 10, which we know is quirky.

Thanks for the suggestions and help, but I think I am going to have to reload the driver or something to get it to work again.

Jeff


On Tue, Oct 13, 2020 at 12:37 PM Scott Davis via groups.io <SNKDavis=aol.com@groups.io> wrote:
Hi Jeff and Steve,

In addition to Steve's good suggestions, I am wondering if you changed other settings from default that may be adding to the problem.  

There have been no other problem reports from 7300 users whatsoever, so something specific to your setup is at play.,  First, stay with the Icom2 option as that doesn't require the echo back in your rig being enabled.  If you still have trouble, you may want to try resetting your rig to default.  

73, Scott
N3FJP

Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: AI3KS <AI3KS.01@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Tue, Oct 13, 2020 3:31 pm
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

Jeff,

Not sure where to go from here.

Have you actually verified the com port by removing power from the 7300 and checking device manager? (Turning off the 7300 does not work. You must actually turn off the power supply to the rig).

I know that I have an RF problem in the shack on 20 meters and above and have seen the com port stop working because of that, but a pc reboot always brings it right back.

I have also been reading on other forums that the latest windows 10 update has been doing some weird things, including destroying the boot sector and updating drivers without warning. May be worth uninstalling the Icom driver and reinstalling it.

Wish I could offer a definitive solution.

Steve, AI3KS


Larry Stowell K1ZW
 


I have my 7610 and 705 unliked and run them at 115200

73 Larry K1ZW


On 10/13/2020 4:39 PM, Frank MacKenzie-Lamb wrote:

I understand and thank you

 

Frank

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of AI3KS
Sent: Tuesday, October 13, 2020 1:32 PM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

 

Frank,

That is the fastest speed, not the "required" speed. I just tested at 4800 and it worked just fine. They just have to match. Also, the actual CI-V port won't run faster than 19200. I think to run faster than 19200 you have to unlink from remote. If the ports are linked I believe that the top speed is 19200.

From page 12-9 of the full manual:

Selects the CI-V data transfer rate when remotely
controlling the IC-7300 through the [USB] CI-V port.
••Options: 4800, 9600, 19200, 38400, 57600, 115200
(bps), or Auto

This setting is valid only when the “CI-V USB Port”
item is set to “Unlink from [REMOTE].”


Steve, AI3KS

On 20/10/13 13:17, Frank MacKenzie-Lamb wrote:

Which is 115200 for the 7300

 

Frank

NG1I

 

From: N3FJPSoftwareUsers@groups.io <N3FJPSoftwareUsers@groups.io> On Behalf Of Scott Davis via groups.io
Sent: Tuesday, October 13, 2020 11:55 AM
To: N3FJPSoftwareUsers@groups.io
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

 

Hi Jeff and Steve,

 

Yes, I don't have a 7300 myself, but from what I understand, the proper baud rate is required.

 

73, Scott

N3FJP

 

Serving the Amateur Radio community with contesting and general logging software since 1997.

 

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...

 

-----Original Message-----
From: AI3KS <AI3KS.01@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Tue, Oct 13, 2020 11:46 am
Subject: Re: [N3FJPSoftwareUsers] ACL 6.7 woe's

Jeff,

This shows your baud rate as 1200.

In a previous post you indicated 9600.

I would go back and double check both baud rates. I may be wrong, but I believe that if you change it in the 7300 you need to power cycle it to reset it.

Scott may be able to verify whether or not this matters, but I also have the CI-V port unlinked from remote and Echo Back on.

Steve, AI3KS

 


JeffBanke
 

I meant to get back to everyone regarding my problem. It seems that Microsoft 10 does play nicely with the ICOM driver, in that every time Microsoft 10 does an update it kicks the ICOM driver off the system,. It also did it randomly while I was using it yesterday, I went to see if it was the same problem, and yes the driver was missing when I checked in "Device manager', reloaded the driver and was once again up and running.
Painful to have to be constantly aware that it might happen at any time, but at least I know what the problem is, and it is not anything to do with 6.7.

Jeff, NZ2S