ACLog, WSJTx, and Gridtracker #wsjtx


Scott Krell
 

Hi all,  I am struggling with getting all three connected and working as designed.  I have searched forums and watched hours of Youtube, but am missing something with the setup.  I really love the new callsign color coding that ACLog will display in WSJTx and want to keep that along with showing the grids that Gridtracker displays.  I do start ACLog first, then WSJTx and then Gridtracker.

Seems as though I can get ACLog and WSJTx to play together, or WSJTx and Gridtracker to play, but not all three.  I am sure it has to do with my Port Assignments and UDP settings across the three programs.  Unfortunately, I am not schooled enough in ports and multicast to figure it out.  Any help would be appreciated with specific settings in each program.  Many thanks,  Scott


Scott Davis
 

Hi Scott,

Thanks for your e-mail.  You can have multiple programs connected to WSJT-X simultaneously to take advantage of the features of each, but you will need to use the multicast option.

One of the things that seems to trip folks up most often when configuring multicasting is that there is a limited range of multicast IPs that you can use.  You must choose in a range of 224.0.0.1 and 239.255.255.255.  Details on setting up multicasting with WSJT-X and our software are here:

http://www.n3fjp.com/help/wsjt-x-integration-with-n3fjp-software.html

Enjoy!

73, Scott
N3FJP


Serving the Amateur Radio community with contesting and general logging software since 1997.

1 Peter 3 vs 15: Always be prepared to give an answer to everyone who asks you to give the reason for the hope that you have. But do this with gentleness and respect...


-----Original Message-----
From: Scott Krell <skrell56@...>
To: N3FJPSoftwareUsers@groups.io
Sent: Thu, Jul 1, 2021 5:53 pm
Subject: [N3FJPSoftwareUsers] ACLog, WSJTx, and Gridtracker #wsjtx

Hi all,  I am struggling with getting all three connected and working as designed.  I have searched forums and watched hours of Youtube, but am missing something with the setup.  I really love the new callsign color coding that ACLog will display in WSJTx and want to keep that along with showing the grids that Gridtracker displays.  I do start ACLog first, then WSJTx and then Gridtracker.

Seems as though I can get ACLog and WSJTx to play together, or WSJTx and Gridtracker to play, but not all three.  I am sure it has to do with my Port Assignments and UDP settings across the three programs.  Unfortunately, I am not schooled enough in ports and multicast to figure it out.  Any help would be appreciated with specific settings in each program.  Many thanks,  Scott


Scott Krell
 

Many thanks Scott. Will study the info and give it a try. I am always impressed at the support you and your family give to anyone who asks. All businesses could learn a bit from you about customer support. 
Thanks,
Scott
K1SMK


rossograph@...
 

Scott:
I followed your guide and really messed things up. I now can't get anything to work. Tried to go back, but to no avail. So, what settings am I getting wrong?
Ross
N8GMY


Christopher Davis
 

Hi Ross,

Thank you for your e-mail.  At first glance, your settings seem perfectly valid.  Something quick to try is adding your ethernet interface to the list of "Outgoing interfaces" in the WSJT-X Reporting Configuration screen.  In theory, loopback should be sufficient, but I've needed to add the additional ethernet interface on one of my systems even when communicating locally.  (Adjusting this will send the traffic to systems listening for this address on the local network as well)

image.png
Please note that WSJT-X needs to be actively decoding stations in order for messages to be passed and received from GridTracker and AC Log.  If decoding is not possible as part of configuration, typing any character inside of the DX Call textbox will trigger a message event.

Hope this helps!

Thanks,
Chris
KB3KCN


On Fri, Jul 2, 2021 at 5:27 PM <rossograph@...> wrote:
Scott:
I followed your guide and really messed things up. I now can't get anything to work. Tried to go back, but to no avail. So, what settings am I getting wrong?
Ross
N8GMY


Jim Polewczak <hamditter@...>
 

Ross, 
I think I see your problem. In the ACL API interface, you changed the port number to 2237.  i think if you change it back to 1100 and leave the rest alone that you will be OK.
When you click on the box listen for WSJT-X that will read  the configuration for WSJT-X and then pick up the proper place to listen for it.
Jim KG2H


rossograph@...
 

Thanks Jim and Chris. I used both of your suggestions and it fixed the problem. It looks like the three software's are playing well with each other.

Ross
N8GMY