ARRL DX v.5.0


VG M
 

I have ARRL DX v. 4.9 installed which I used last time. Any reason to install current v. 5.0?
Tnx & 73
Matt - AF2F

Join N3FJPSoftwareUsers@groups.io to automatically receive all group messages.