Topics

WSJT-X on N1MM+ #IC7300

B. Smith
 

There is a DigiDX contest coming up in a couple of weeks and I decided to get my IC-7300 set up using N1MM+ for logging along with WSJT-X. I followed the instructions at https://www.rttycontesting.com/ww-digi/ for the integration and ran into some problems getting IC-7300 interface to work. If you have done the same thing, or are just getting started on it, here's some quick tips.

1. Make sure that you have set your N1MM+ comm port to "None".
2. Do not try to use "DX Lab Suite Commander" for the WSJT-X Rig. Leave the Radio tab, and all WSJT-X settings, the way they are.
3. Use the SD Card settings that you normally use for WSJT-X.

My compliments to Don AA5AU's instructions, but beware!

Hope this helps. 73, Bill N3XL

Rick Ellison
 

Bill

This is completely wrong….

For N1MM to interact with WSJT in WSJT you must select DXLabs Suite Commander. N1MM has a built in TCP connection that emulates the DXLabs suite Commander. Do not set your radio port to “None” N1MM receives via messages over the TCP connection when to go to PTT and When to go back to RX.

For PTT (with the 7300. I use one daily.) on the Hardware tab you need to click on the radio setting and select PTT via radio command for SSB and for Digital.

 

There are detailed setup instruction at this link below.

https://n1mmwp.hamdocs.com/manual-windows/wsjt-x-decode-list-window/#within-wsjt-x

 

73 Rick N2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of B. Smith via Groups.Io
Sent: Tuesday, August 20, 2019 9:15 PM
To: N1MMLoggerPlus@groups.io
Subject: [N1MM+] WSJT-X on N1MM+ #IC7300

 

There is a DigiDX contest coming up in a couple of weeks and I decided to get my IC-7300 set up using N1MM+ for logging along with WSJT-X. I followed the instructions at https://www.rttycontesting.com/ww-digi/ for the integration and ran into some problems getting IC-7300 interface to work. If you have done the same thing, or are just getting started on it, here's some quick tips.

1. Make sure that you have set your N1MM+ comm port to "None".
2. Do not try to use "DX Lab Suite Commander" for the WSJT-X Rig. Leave the Radio tab, and all WSJT-X settings, the way they are.
3. Use the SD Card settings that you normally use for WSJT-X.

My compliments to Don AA5AU's instructions, but beware!

Hope this helps. 73, Bill N3XL


Virus-free. www.avast.com

B. Smith
 

Rick,
Please just consider my message as a tip for folks when and if DXLabs suite Commander doesn't work for them, as was the case for me. I see no problems with RX and TX when letting WSJT-X control things. If I'm completely wrong, why do the instructions discuss running with WSJT-X in control? To quote your instructions,  " If you do not have some kind of port splitting program to allow two programs to control the radio simultaneously, then plan on disabling rig control from N1MM+ and allowing WSJT-X to “drive” the radio settings whenever it is active."
Bill

Rick Ellison
 

Bill..

Those directions are from when there was no direct support for WSJT in N1MM. I have spent many numerous hours of programming to be able to support SO1R and SO2R direct support of WSJT from within the Logger. If everything is configured within N1MM and WSJT and the directions followed N1MM controls the radio for WSJT directly from within N1MM and there is no reason to use splitters and other means. N1MM now talks directly to WSJT via messages and has everything encapsulated within the Logger. Rich VE3KI has done very easy to follow directions on the website which I have posted the link to in the forum tonight. I use N1MM and WSJT with my 7300 every day and have made a couple of hundred qso’s as  I have been testing things.. I would suggest going and reading the directions Rich has done and you will find the changes have made things very simple to make qso’s and log directly in the logger. I don’t see this as a tip as the amount of time I have spent working on this to tell someone how to do it completely different from what I have programmed.

 

73 Rick n2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of B. Smith via Groups.Io
Sent: Tuesday, August 20, 2019 11:18 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] WSJT-X on N1MM+ #IC7300

 

Rick,
Please just consider my message as a tip for folks when and if DXLabs suite Commander doesn't work for them, as was the case for me. I see no problems with RX and TX when letting WSJT-X control things. If I'm completely wrong, why do the instructions discuss running with WSJT-X in control? To quote your instructions,  " If you do not have some kind of port splitting program to allow two programs to control the radio simultaneously, then plan on disabling rig control from N1MM+ and allowing WSJT-X to “drive” the radio settings whenever it is active."
Bill


Virus-free. www.avast.com

B. Smith
 

Your efforts are commendable.

73, Bill N3XL

ve3ki
 

"why do the instructions discuss running with WSJT-X in control?" Because prior to this spring, that was how the programs had to be used together. That text in the FAQ section of the page was a holdover from previous versions of the program before Rick rewrote the code in N1MM+ that interacts with WSJT-X. That older method is no longer supported, and the text describing it has now been removed from the manual.

73,
Rich VE3KI

B. Smith
 

I stand by my tip for those who may experience a problem with DXCommander - everything else is fine.

73, Bill N3XL

ve3ki
 

The method you are suggesting is: (a) unsupported, which means there is no guarantee that some future change to the program won't break it; and (b) clumsier in operation than the currently supported method (requires changes to mode control settings in the N1MM+ Configurer when changing operating modes).

You did not describe the cause of your original problem, so it is impossible to tell for sure, but it is likely that the cause of the problem lies in the Mode Control settings in the Configurer. For the IC-7300, the "Mode sent to radio" for PSK should be set to AFSK-R (this will force the radio into its USB-D mode when a digital sound card mode is selected in N1MM+, including when WSJT-X is loaded from N1MM+).

The manual pages on the Configurer and the WSJT-X Decode List window have been updated to emphasize the importance of this setting for proper operation with WSJT-X.

73,
Rich VE3KI


On Wed, Aug 21, 2019 at 07:36 AM, B. Smith wrote:
I stand by my tip for those who may experience a problem with DXCommander - everything else is fine.

73, Bill N3XL

B. Smith
 

The 7300/N1MM automatically uses AFSK-R .

B. Smith
 

When I heard that the TCP connection issues were fixed, I figured it was time to spend some time getting WSJT-X-ForEW1 working correctly. Wow! What fantastic patience and support by Rick Ellison, who spent all day helping me troubleshoot my lack of power out on the high bands. The issue was the power slider on the right-hand side of the WSJT-X screen. The high bands were all set 1/2 to 3/4 of the way down. Evidently, that was too low to generate power, even though it keyed the rig. Once I got the sliders up to 100% and reloaded the software all is well. I wanted to put a special note of thanks to Rick and a caution note for other IC-7300 users.