Topics

TS-590 / N1MM / WSJT-X

Andy k3wyc
 
Edited

I'm a long time user of WSJT-X with my TS-590S. I'm also familiar with setting up WSJT-X to use Commander, or OmniRig, or for a direct connection to the TS-590.

I have attempted to set up WSJT-X with N1MM but have a problem with rig keying mode. When I press "Tune" - the rig is keyed, Windows shows audio output, but there is no power output. This is almost certainly an indication that N1MM / WSJT-X is sending TX0 instead of TX1.  (Normal power output was obtained by sending TX1; from N1MM before selecting WSJT-x "tune")

When integrated with N1MM the instructions say WSJT-X should be configured for rig - DX Lab Commander. Both DXLab Commander and WSJT-X have the options to control which keying command is used ( Commander = data transmission from USB interface or ANI interface / WSJT-X = transmit audio source). Where is the equivalent keying command selection when WSJT-X is pretending to use Commander but Commander is not actually in use?

If anyone knows would you please point me to the menu setting, preferably with a screen shot.

Thanks and 73,
Andy, k3wyc

 

The problem sounds like one I had with my ICOM transceiver.  It was caused by N1MM+ sending the mode code USB when my ICOM needed USB-D
 
The fix was simple, stop N1MM+ from controlling the mode.  When it switched to USB my radio was expecting mike input, not the tones generated by my soundcard.
 
73  Stu  N7ZZ

----- Original Message -----
From: Andy k3wyc
Sent: Saturday, September 14, 2019 4:52 PM
Subject: [N1MM+] TS-590 / N1MM / WSJT-X

I'm a long time user of WSJT-X with my TS-590S. I'm also familiar with setting up WSJT-X to use Commander, or OmniRig, or for a direct connection to the TS-590.

I have attempted to set up WSJT-X with N1MM but have a problem with rig keying mode. When I press "Tune" - the rig is keyed, Windows shows audio output, but there is no power output. This is almost certainly an indication that N1MM / WSJT-X is sending TX0 instead of TX1.  (Normal power output was obtained by sending TX1; from N1MM before selecting WSJT-Z "tune")

When integrated with N1MM the instructions say WSJT-X should be configured for rig - DX Lab Commander. Both DXLab Commander and WSJT-X have the options to control which keying command is used ( Commander = data transmission from USB interface or ANI interface / WSJT-X = transmit audio source). Where is the equivalent keying command selection when WSJT-X is pretending to use Commander but Commander is not actually in use?

If anyone knows would you please point me to the menu setting, preferably with a screen shot.

Thanks and 73,
Andy, k3wyc

Andy k3wyc
 

"The fix was simple, stop N1MM+ from controlling the mode."

No, that's not my problem.  Mode is USB as it should be.  Power is output if N1MM is forced to send TX1; before starting WSJT-X tune.  Problem is that wrong TX command is used.

73,
Andy, k3wyc

John Bednar
 

Stu,

 

Sounds like you did not set Config, Mode Control tab correctly. That determines the mode that is sent to the radio for RTTY (FSK or AFSK) and the digital sound card modes.

 

John, K3CT

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Stu Hoar
Sent: Saturday, September 14, 2019 11:47 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] TS-590 / N1MM / WSJT-X

 

The problem sounds like one I had with my ICOM transceiver.  It was caused by N1MM+ sending the mode code USB when my ICOM needed USB-D

 

The fix was simple, stop N1MM+ from controlling the mode.  When it switched to USB my radio was expecting mike input, not the tones generated by my soundcard.

 

73  Stu  N7ZZ

----- Original Message -----

From: Andy k3wyc

Sent: Saturday, September 14, 2019 4:52 PM

Subject: [N1MM+] TS-590 / N1MM / WSJT-X

 

I'm a long time user of WSJT-X with my TS-590S. I'm also familiar with setting up WSJT-X to use Commander, or OmniRig, or for a direct connection to the TS-590.

I have attempted to set up WSJT-X with N1MM but have a problem with rig keying mode. When I press "Tune" - the rig is keyed, Windows shows audio output, but there is no power output. This is almost certainly an indication that N1MM / WSJT-X is sending TX0 instead of TX1.  (Normal power output was obtained by sending TX1; from N1MM before selecting WSJT-Z "tune")

When integrated with N1MM the instructions say WSJT-X should be configured for rig - DX Lab Commander. Both DXLab Commander and WSJT-X have the options to control which keying command is used ( Commander = data transmission from USB interface or ANI interface / WSJT-X = transmit audio source). Where is the equivalent keying command selection when WSJT-X is pretending to use Commander but Commander is not actually in use?

If anyone knows would you please point me to the menu setting, preferably with a screen shot.

Thanks and 73,
Andy, k3wyc

ve3ki
 

It occurred to me that if this relates to TX0 vs. TX1, the same problem must surely affect people using the TS-590 in other modes, for example for AFSK RTTY or for PSK31. In other words, it seems to me that it would have been encountered previously. With that in mind, I looked at the instructions for the TS-590 under "Supported Radios" in the manual. I found a reference to a check box called “Digital Modes Acc Jack Radio Command PTT”  in the setup window of the COM port used for radio control. This check box appears when you select "TS-590" as the radio type in the Configurer (it also appears for the TS-480 and TS-990 radio types). I don't have a TS-590 to check this with, but it sounds to me as if this might possibly be an option to use TX1; instead of TX0; for PTT control.

Is this check box checked? If it wasn't, does checking it fix the problem? If it does, please let us know so we can clarify this in the manual.

73,
Rich VE3KI



On Sat, Sep 14, 2019 at 08:25 PM, Andy k3wyc wrote:
I'm a long time user of WSJT-X with my TS-590S. I'm also familiar with setting up WSJT-X to use Commander, or OmniRig, or for a direct connection to the TS-590.

I have attempted to set up WSJT-X with N1MM but have a problem with rig keying mode. When I press "Tune" - the rig is keyed, Windows shows audio output, but there is no power output. This is almost certainly an indication that N1MM / WSJT-X is sending TX0 instead of TX1.  (Normal power output was obtained by sending TX1; from N1MM before selecting WSJT-x "tune")

When integrated with N1MM the instructions say WSJT-X should be configured for rig - DX Lab Commander. Both DXLab Commander and WSJT-X have the options to control which keying command is used ( Commander = data transmission from USB interface or ANI interface / WSJT-X = transmit audio source). Where is the equivalent keying command selection when WSJT-X is pretending to use Commander but Commander is not actually in use?

If anyone knows would you please point me to the menu setting, preferably with a screen shot.

Thanks and 73,
Andy, k3wyc

Andy k3wyc
 

On Sun, Sep 15, 2019 at 04:38 AM, ve3ki wrote:
With that in mind, I looked at the instructions for the TS-590 under "Supported Radios" in the manual. I found a reference to a check box called “Digital Modes Acc Jack Radio Command PTT”  in the setup window of the COM port used for radio control. This check box appears when you select "TS-590" as the radio type in the Configurer (it also appears for the TS-480 and TS-990 radio types).
Rich,

Thanks for pointing me in the right direction.   The checkbox "Digital Modes Acc Jack Radio Command PTT”  was not shown but then I realized I had Radio "Kenwood" selected not "TS-590".  With "TS-590" selected and "Details" opened I was able to select "Digital Modes Acc Jack Radio Command PTT”.  

WSJT-X "tune" now keys the radio and produces power output so I am now configured to use TX1;

I had been using N1MM with my TS-590S for RTTY and for sending voice messages but I had been using DATA VOX to support that.    Some time ago I had changed from using WSJT-X with Data VOX keying to CAT keying and was attempting to keep the same keying method for N1MM / WSJT-X.

I don't know why I had Kenwood selected instead of TS-590.  Perhaps years ago when I first set up the original N1MM logger (not plus) the specific radio models were not available?

Again - thank for helping me find the TX0/TX1 selection.   I thought it must be available somewhere.

73,
Andy, k3wyc

John Bednar
 

 

Our software uses TX1; when the program is configured to use the radio codec. It switches the radio codec to the modulator input for voice or digital transmissions.

 

There is a document in the Additional Support Files section for the TS-590 radio.

https://n1mmwp.hamdocs.com/mmfiles/categories/supportfiles/

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of ve3ki
Sent: Sunday, September 15, 2019 7:39 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] TS-590 / N1MM / WSJT-X

 

It occurred to me that if this relates to TX0 vs. TX1, the same problem must surely affect people using the TS-590 in other modes, for example for AFSK RTTY or for PSK31. In other words, it seems to me that it would have been encountered previously. With that in mind, I looked at the instructions for the TS-590 under "Supported Radios" in the manual. I found a reference to a check box called “Digital Modes Acc Jack Radio Command PTT”  in the setup window of the COM port used for radio control. This check box appears when you select "TS-590" as the radio type in the Configurer (it also appears for the TS-480 and TS-990 radio types). I don't have a TS-590 to check this with, but it sounds to me as if this might possibly be an option to use TX1; instead of TX0; for PTT control.

Is this check box checked? If it wasn't, does checking it fix the problem? If it does, please let us know so we can clarify this in the manual.

73,
Rich VE3KI



On Sat, Sep 14, 2019 at 08:25 PM, Andy k3wyc wrote:

I'm a long time user of WSJT-X with my TS-590S. I'm also familiar with setting up WSJT-X to use Commander, or OmniRig, or for a direct connection to the TS-590.

I have attempted to set up WSJT-X with N1MM but have a problem with rig keying mode. When I press "Tune" - the rig is keyed, Windows shows audio output, but there is no power output. This is almost certainly an indication that N1MM / WSJT-X is sending TX0 instead of TX1.  (Normal power output was obtained by sending TX1; from N1MM before selecting WSJT-x "tune")

When integrated with N1MM the instructions say WSJT-X should be configured for rig - DX Lab Commander. Both DXLab Commander and WSJT-X have the options to control which keying command is used ( Commander = data transmission from USB interface or ANI interface / WSJT-X = transmit audio source). Where is the equivalent keying command selection when WSJT-X is pretending to use Commander but Commander is not actually in use?

If anyone knows would you please point me to the menu setting, preferably with a screen shot.

Thanks and 73,
Andy, k3wyc

Andy k3wyc
 

On Thu, Sep 19, 2019 at 06:42 PM, John Bednar wrote:

Our software uses TX1; when the program is configured to use the radio codec. It switches the radio codec to the modulator input for voice or digital transmissions.

 

There is a document in the Additional Support Files section for the TS-590 radio.

https://n1mmwp.hamdocs.com/mmfiles/categories/supportfiles/

 

John, K3CT


John,

The referenced document seems to be incomplete with regard to use of TX0; or TX1; commands.    If the intuitive option "PTT via radio Command Digital Mode" is selected then TX0; is used.  To use TX1; the option "Dig Modes Acc Jack Radio Cmd PTT" must be selected as shown in the attached screen shot.

"Dig Modes Acc Jack radio Cmd PTT" would perhaps be better named as "CAT PTT USB or ACC (TX1)"

73,
Andy, k3wyc

John Bednar
 

Andy,

 

The document needs to be updated with the snapshots for Logger+ Audio.

 

In the baud rate window for the TS-590, uncheck the option "Dig Modes Acc Jack Radio Cmd PTT".

 

In the baud rate window for the TS-590, check “PTT via radio command for” digital and/or SSB mode. What mode(s) you want to use the radio codec.

 

In the Logger+ Audio setup window, Playback tab, select the radio codec in the TS-590.

In the Logger+ Audio setup window, Playback tab, check Internal Radio Codec.

In the Logger+ Audio setup window, Message Recording tab, select the radio codec in the TS-590.

 

The option "Dig Modes Acc Jack Radio Cmd PTT" is for the accessory jack in the rear of the radio.

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Andy k3wyc
Sent: Saturday, September 21, 2019 3:03 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] TS-590 / N1MM / WSJT-X

 

On Thu, Sep 19, 2019 at 06:42 PM, John Bednar wrote:

Our software uses TX1; when the program is configured to use the radio codec. It switches the radio codec to the modulator input for voice or digital transmissions.

 

There is a document in the Additional Support Files section for the TS-590 radio.

https://n1mmwp.hamdocs.com/mmfiles/categories/supportfiles/

 

John, K3CT


John,

The referenced document seems to be incomplete with regard to use of TX0; or TX1; commands.    If the intuitive option "PTT via radio Command Digital Mode" is selected then TX0; is used.  To use TX1; the option "Dig Modes Acc Jack Radio Cmd PTT" must be selected as shown in the attached screen shot.

"Dig Modes Acc Jack radio Cmd PTT" would perhaps be better named as "CAT PTT USB or ACC (TX1)"

73,
Andy, k3wyc

Andy k3wyc
 

On Sat, Sep 21, 2019 at 12:21 PM, John Bednar wrote:
The option "Dig Modes Acc Jack Radio Cmd PTT" is for the accessory jack in the rear of the radio.
Direct observation of N1MM shows that "Dig Modes Acc Jack Radio Cmd PTT" must be selected to generate the TX1 command.

The TS-590S and TS-590SG use TX1 to select the modulation source as USB OR ACC.  The specific source, USB or ACC, is selected by TS-590 menu.  The CAT command is the same for both.

TX0; selects the front panel mic jack as modulation source. TX1; selects USB or ACC as modulation source.

Andy, k3wyc

John Bednar
 

 

Andy,

 

The configuration that was in my previous email is the intended setup for radio codec use with SSB and Digital.

 

The option that you are using will only work with digital. It has the proper name and it was added to support the accessory connector for digital modes. Yes, that use also needs TX1; to be sent to the radio.

 

> Direct observation of N1MM shows that "Dig Modes Acc Jack Radio Cmd PTT" must be selected to generate the TX1 command.

I don’t believe this is true. I expect that when you configure N1MM Logger+ correctly, TX1 will be sent to the radio for SSB and digital modes.

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Andy k3wyc
Sent: Saturday, September 21, 2019 3:34 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] TS-590 / N1MM / WSJT-X

 

On Sat, Sep 21, 2019 at 12:21 PM, John Bednar wrote:

The option "Dig Modes Acc Jack Radio Cmd PTT" is for the accessory jack in the rear of the radio.

Direct observation of N1MM shows that "Dig Modes Acc Jack Radio Cmd PTT" must be selected to generate the TX1 command.

The TS-590S and TS-590SG use TX1 to select the modulation source as USB OR ACC.  The specific source, USB or ACC, is selected by TS-590 menu.  The CAT command is the same for both.

TX0; selects the front panel mic jack as modulation source. TX1; selects USB or ACC as modulation source.

Andy, k3wyc

Andy k3wyc
 

On Sat, Sep 21, 2019 at 12:21 PM, John Bednar wrote:

In the baud rate window for the TS-590, uncheck the option "Dig Modes Acc Jack Radio Cmd PTT".

 

In the baud rate window for the TS-590, check “PTT via radio command for” digital and/or SSB mode. What mode(s) you want to use the radio codec.

 

In the Logger+ Audio setup window, Playback tab, select the radio codec in the TS-590.

In the Logger+ Audio setup window, Playback tab, check Internal Radio Codec.

In the Logger+ Audio setup window, Message Recording tab, select the radio codec in the TS-590.

 

The option "Dig Modes Acc Jack Radio Cmd PTT" is for the accessory jack in the rear of the radio.


Once I regained access to the Configurer Audio tab I found that "Radio 1 Output Device is an Internal Radio Codec" was not checked.  When I checked that option and changed Radio Details to "PTT via Radio Command Digital Mode"  then TX1; was used.

TX1; is also used if "Dig Modes Acc Jack Radio Cmd PTT" is selected.

Thanks,
Andy, k3wyc

 

Andy k3wyc
 

On Sat, Sep 21, 2019 at 12:50 PM, John Bednar wrote:

> Direct observation of N1MM shows that "Dig Modes Acc Jack Radio Cmd PTT" must be selected to generate the TX1 command.

I don’t believe this is true. I expect that when you configure N1MM Logger+ correctly, TX1 will be sent to the radio for SSB and digital modes.

It is true if "Radio 1 output device is an internal radio codec" is not selected.  I had not noticed that configuration error since, before setting up for WSJT-X, I had been using DATA VOX keying.

Andy, k3wyc

John Bednar
 

Andy,

 

I recommend using Logger+ Audio. It solves several problems with the original audio player and adds many features. The only reason that it hasn’t been removed is for compatibility with WinXp.

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Andy k3wyc
Sent: Saturday, September 21, 2019 3:53 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] TS-590 / N1MM / WSJT-X

 

On Sat, Sep 21, 2019 at 12:21 PM, John Bednar wrote:

In the baud rate window for the TS-590, uncheck the option "Dig Modes Acc Jack Radio Cmd PTT".

 

In the baud rate window for the TS-590, check “PTT via radio command for” digital and/or SSB mode. What mode(s) you want to use the radio codec.

 

In the Logger+ Audio setup window, Playback tab, select the radio codec in the TS-590.

In the Logger+ Audio setup window, Playback tab, check Internal Radio Codec.

In the Logger+ Audio setup window, Message Recording tab, select the radio codec in the TS-590.

 

The option "Dig Modes Acc Jack Radio Cmd PTT" is for the accessory jack in the rear of the radio.


Once I regained access to the Configurer Audio tab I found that "Radio 1 Output Device is an Internal Radio Codec" was not checked.  When I checked that option and changed Radio Details to "PTT via Radio Command Digital Mode"  then TX1; was used.

TX1; is also used if "Dig Modes Acc Jack Radio Cmd PTT" is selected.

Thanks,
Andy, k3wyc

 

John Bednar
 

 

Andy,

 

I checked the source code and as I expected, checking "Dig Modes Acc Jack Radio Cmd PTT" will only send TX1; in digital mode.

 

Checking "Dig Modes Acc Jack Radio Cmd PTT" is simply incorrect advice for use with the TS-590 radio codec in SSB and digital modes.

 

You can respond if you want. This is my last reply. I am sure the users are tired of this thread.

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Andy k3wyc
Sent: Saturday, September 21, 2019 4:02 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] TS-590 / N1MM / WSJT-X

 

On Sat, Sep 21, 2019 at 12:50 PM, John Bednar wrote:

> Direct observation of N1MM shows that "Dig Modes Acc Jack Radio Cmd PTT" must be selected to generate the TX1 command.

I don’t believe this is true. I expect that when you configure N1MM Logger+ correctly, TX1 will be sent to the radio for SSB and digital modes.

It is true if "Radio 1 output device is an internal radio codec" is not selected.  I had not noticed that configuration error since, before setting up for WSJT-X, I had been using DATA VOX keying.

Andy, k3wyc