Topics

N1MM-WSJT Radio Connection - 1

Andy k3wyc
 

When WSJT-X is loaded from N1MM the "N1MM-WSJT Radio Connection - 1" window is opened and displays "WSJT-X has been loaded and connected" and a green box.   Later, for no known reason, the "N1MM-WSJT Radio Connection - 1" window message changes to "WSJT-X has been closed" but the green box remains.  WSJT-X was not closed and remains operational.  Later, again for no known reason, the message reverts to "WSJT-X has been loaded and connected".

At first the "WSJT has been closed" message appeared to be associated with a WSJT-X transmission but this is not fully repeatable and the message sometimes changes when there is no transmission. (This is not RFI as the problem was seen with 0 W TX to a dummy load).

Does anyone know why "WSJT-X has been closed" is displayed when WSJT-X is still open and operational?  Is this a known issue?  If not, what can I do to diagnose the problem?

(Win 8.1;  WSJT-X ver 2.1.0 64 bit,  N1MM V 1.0.7953.0; Kenwood TS-590S.)

73,
Andy, k3wyc

Rick Ellison
 

There is an issue with the way it looks to see if WSJT is still open and the tcp connection is still available. This will be reworked in a future update that is being worked on.

 

73 Rick N2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Andy k3wyc
Sent: Sunday, September 15, 2019 2:38 PM
To: N1MMLoggerPlus@groups.io
Subject: [N1MM+] N1MM-WSJT Radio Connection - 1

 

When WSJT-X is loaded from N1MM the "N1MM-WSJT Radio Connection - 1" window is opened and displays "WSJT-X has been loaded and connected" and a green box.   Later, for no known reason, the "N1MM-WSJT Radio Connection - 1" window message changes to "WSJT-X has been closed" but the green box remains.  WSJT-X was not closed and remains operational.  Later, again for no known reason, the message reverts to "WSJT-X has been loaded and connected".

At first the "WSJT has been closed" message appeared to be associated with a WSJT-X transmission but this is not fully repeatable and the message sometimes changes when there is no transmission. (This is not RFI as the problem was seen with 0 W TX to a dummy load).

Does anyone know why "WSJT-X has been closed" is displayed when WSJT-X is still open and operational?  Is this a known issue?  If not, what can I do to diagnose the problem?

(Win 8.1;  WSJT-X ver 2.1.0 64 bit,  N1MM V 1.0.7953.0; Kenwood TS-590S.)

73,
Andy, k3wyc


Virus-free. www.avast.com

Andy k3wyc
 

On Sun, Sep 15, 2019 at 12:34 PM, Rick Ellison wrote:
There is an issue with the way it looks to see if WSJT is still open and the tcp connection is still available.
Thanks Rick!

73,
Andy, k3wyc

Terry Glagowski / AFA1DI
 

The following window opens when you load WSJT-X from N1MM.

If you try to close it, N1MM hangs up and must be terminated.

The window cannot be minimized either…

This is quite an annoyance !

 

 

73, Terry / W1TR  :  )

Andy k3wyc
 

On Sun, Sep 15, 2019 at 12:34 PM, Rick Ellison wrote:
There is an issue with the way it looks to see if WSJT is still open and the tcp connection is still available. This will be reworked in a future update that is being worked on.
Rick,

I assume this fix is the one your referenced - 

"WSJT Radio: Attempts to speed up TCP routines for radios with slower poll rates. (Coded by N2AMG)"

When I observed the problem I was using a TS-590S and the poll rate for that radio is controlled by the polling device and not limited by the radio.    In "details" my radio Polling rate is set to "Normal"  but without putting a scope or sniffer on the interface I don't know what poll rate that represents.   

Could you please provide more information on what would cause a "slower polling rate" for the TS-590S.   The TS-590 polling rate seems to be completely under the control of N1MM when WSJT-X is configured to use "Commander".

if you need a TS-590S owner to assist with testing please let me know.  

73,
Andy, k3wyc

Rick Ellison
 

That is the connection to WSJT. When WSJT is open it will be shown and when WSJT closes it should close on its own. Just stick it over in the corner or someplace out of the way.

 

73 Rick N2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Terry Glagowski / AFA1DI
Sent: Monday, September 16, 2019 5:37 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM-WSJT Radio Connection - 1

 

The following window opens when you load WSJT-X from N1MM.

If you try to close it, N1MM hangs up and must be terminated.

The window cannot be minimized either…

This is quite an annoyance !

 

 

73, Terry / W1TR  :  )


Virus-free. www.avast.com

Rick Ellison
 

No I wasn’t referencing that fix. That fix was for mainly K3 Radio’s. and since doing so I have not heard of the dropping of the radio commands between N1MM and WSJT. For that fix I shaved off a few milliseconds from a few different processing routines by re-writing them to use a better coding method.

 

I am in the process of re-writing the TCP connection routines so WSJT will be allowed to reconnect after dropping the connection as long as it tries. With the present connecting means once WSJT drops the connection it cannot reconnect to N1MM unless the connection is restarted.

 

When that TCP work is done the TCP listener will be able to report back when it is connected and not, which will make the way the wsjt’s radio  routines that tell when it is connected function better than they currently do.

 

73 Rick N2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Andy k3wyc
Sent: Monday, September 16, 2019 9:30 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM-WSJT Radio Connection - 1

 

On Sun, Sep 15, 2019 at 12:34 PM, Rick Ellison wrote:

There is an issue with the way it looks to see if WSJT is still open and the tcp connection is still available. This will be reworked in a future update that is being worked on.

Rick,

I assume this fix is the one your referenced - 

"WSJT Radio: Attempts to speed up TCP routines for radios with slower poll rates. (Coded by N2AMG)"

When I observed the problem I was using a TS-590S and the poll rate for that radio is controlled by the polling device and not limited by the radio.    In "details" my radio Polling rate is set to "Normal"  but without putting a scope or sniffer on the interface I don't know what poll rate that represents.   

Could you please provide more information on what would cause a "slower polling rate" for the TS-590S.   The TS-590 polling rate seems to be completely under the control of N1MM when WSJT-X is configured to use "Commander".

if you need a TS-590S owner to assist with testing please let me know.  

73,
Andy, k3wyc


Virus-free. www.avast.com

Dennis Niles
 

I too share Terry's annoyance with the Radio-Connection -1 window.  This gotta get fixed.  73 Den

Paul K6PO
 

Seconded! (Thirded?) Make this window minimizable, or at least don't force it to be on top all the time.

73, Paul K6PO