Topics

N1MM-WSJT-K3S-no PTT when WSJT opened fromN1MM -

Hank Pfizenmayer
 

I give up --I cannot get PTT to operate when WSJT is opened from N1MM (using ARRL SEPT VHF if that matters)
and tonight using my normal DX day to day "contest" log it acts the same.

Latest version of N1MM and think I am up with latest method of setup. W7 pro  -.

WSJT by itself or N1MM by itself just fine.  Opening WSJT from N1MM using the Config menu - WSJT-x  for EW1 opens
 as shown in top bar above spectrum window  . Have  DX commander in the transceiver window settings.  Get the green box in the
window with the warnings about shutting off WSJT first . . The CAT and PTT buttons work (the K3 shows its inTX  - BUT i get no audio out of WSJT )

In fact if I type FT8 in the N1MM window the WSJT-X opens - dont have to use the config menu .

There  must be some magic UDP or whatever I have missed that is not telling WSJT to put out audio ???

N1MM accepts a FT8 adif file manually just fine (except now it says its all duplicates from the ARRLVHF wsjt adif 
-but when I look at the  file they are NOT duplicates and they dont show in the N1MM day to day "DX" log -so it 
looks like N1MM thinks the  qsos are there but they do not show in the log window - I went ahead and told N1MM
to import anyhow and it worked fine and no dupes inlog wondow and Cabrillo from that was fine.

Hank K7HP

ve3ki
 

In the first paragraph you say there is no PTT, but later on you say that the PTT button puts the K3 into TX, the problem is no audio. Which is it?

You should not expect to get audio when the PTT button in WSJT-X is pressed (it tests PTT, not audio). The button for testing audio is the Tune button on the main WSJT-X window.

If PTT switching is not working, then in the WSJT-X Settings window under the Radio tab, make sure that in the PTT area you have selected CAT. Then in the N1MM+ Configurer, make sure you have some method of PTT configured, such as the PTT via Radio Command Digital Mode check box in the settings for the K3's serial port.

If pressing Tune does not result in audio from WSJT-X, first check that the correct audio device is selected in WSJT-X. Do this test with WSJT-X opened from inside N1MM+; changes to the stand-alone settings have no effect on the copy of WSJT-X that is run from inside N1MM+. Then click on the Tune button on the main WSJT-X window and if necessary, adjust the various sound level controls (the Pwr slider in WSJT-X, normally left at the top; the Windows levels both for the device and the application-specific settings under Advanced sound options in the Windows sound settings, and the Line In gain on the K3) to get the desired 4-5 bars on the K3's ALC meter. Choose an audio frequency in WSJT-X that is not exactly equal to 1500 Hz when you do this - there may be aliasing artifacts in the K3's meter sampling circuit if the frequency is exactly 1500 Hz, but a change of a few Hz is enough to avoid them.

The K3 should be in DATA A mode. In WSJT-X's Settings window under the Radio tab, the Mode should be set to Data/Pkt.. In the N1MM+ Configurer, under the Mode Control tab, on the right-hand side the Mode sent to radio in the DIGI row should be set to PSK (this varies between different radio types; PSK is the correct setting for the K3 to put it into DATA A). The K3's CONFIG:MIC SEL should be set to LINE IN while the K3 is in DATA A mode, and the MIC control can be used to adjust the Line In level.

The reason you got the message about duplicates when you imported the QSOs from ADIF is that the same QSO is not allowed to be stored twice in the same database file (not just in the same log). For example, if there are two ARRL SEPT VHF logs in the same database file, they cannot both contain the same QSOs. If you had opened a new log in the same database and tried to import contacts that were already in another log in that database, the program would have considered them to be dupes. When you told N1MM+ to import anyway, it would have adjusted the times on every QSO by a few seconds so that the contacts were not exact duplicates.

73,
Rich VE3KI


On Tue, Sep 17, 2019 at 02:23 AM, Hank Pfizenmayer wrote:
I give up --I cannot get PTT to operate when WSJT is opened from N1MM (using ARRL SEPT VHF if that matters)
and tonight using my normal DX day to day "contest" log it acts the same.

Latest version of N1MM and think I am up with latest method of setup. W7 pro  -.

WSJT by itself or N1MM by itself just fine.  Opening WSJT from N1MM using the Config menu - WSJT-x  for EW1 opens
 as shown in top bar above spectrum window  . Have  DX commander in the transceiver window settings.  Get the green box in the
window with the warnings about shutting off WSJT first . . The CAT and PTT buttons work (the K3 shows its inTX  - BUT i get no audio out of WSJT )

In fact if I type FT8 in the N1MM window the WSJT-X opens - dont have to use the config menu .

There  must be some magic UDP or whatever I have missed that is not telling WSJT to put out audio ???

N1MM accepts a FT8 adif file manually just fine (except now it says its all duplicates from the ARRLVHF wsjt adif 
-but when I look at the  file they are NOT duplicates and they dont show in the N1MM day to day "DX" log -so it 
looks like N1MM thinks the  qsos are there but they do not show in the log window - I went ahead and told N1MM
to import anyhow and it worked fine and no dupes inlog wondow and Cabrillo from that was fine.

Hank K7HP

Pete Smith
 

Hi Hank - the fact that the CAT and PTT buttons work (I assume that includes seeing your transceiver switch to transmit) means to me that there's something wrong in your audio setup, either in WSJT or more likely in your computer.  I've long forgotten how audio worked in Windows 7, but the thing I would try to do is trace the audio coming out of WSJT-X and make sure that the sound card input it is feeding and the sound card output that is sending the audio to the rig are both properly connected to the transceiver and working properly

73, Pete N4ZR
Check out the Reverse Beacon Network 
at <http://reversebeacon.net>, now 
spotting RTTY activity worldwide. 
For spots, please use your favorite 
"retail" DX cluster.
On 9/17/2019 2:23 AM, Hank Pfizenmayer wrote:

I give up --I cannot get PTT to operate when WSJT is opened from N1MM (using ARRL SEPT VHF if that matters)
and tonight using my normal DX day to day "contest" log it acts the same.

Latest version of N1MM and think I am up with latest method of setup. W7 pro  -.

WSJT by itself or N1MM by itself just fine.  Opening WSJT from N1MM using the Config menu - WSJT-x  for EW1 opens
 as shown in top bar above spectrum window  . Have  DX commander in the transceiver window settings.  Get the green box in the
window with the warnings about shutting off WSJT first . . The CAT and PTT buttons work (the K3 shows its inTX  - BUT i get no audio out of WSJT )

In fact if I type FT8 in the N1MM window the WSJT-X opens - dont have to use the config menu .

There  must be some magic UDP or whatever I have missed that is not telling WSJT to put out audio ???

N1MM accepts a FT8 adif file manually just fine (except now it says its all duplicates from the ARRLVHF wsjt adif 
-but when I look at the  file they are NOT duplicates and they dont show in the N1MM day to day "DX" log -so it 
looks like N1MM thinks the  qsos are there but they do not show in the log window - I went ahead and told N1MM
to import anyhow and it worked fine and no dupes inlog wondow and Cabrillo from that was fine.

Hank K7HP

Hank Pfizenmayer
 

OK thanks for inputs - I think I figured out what I did . I had always simply run WSJT stand alone and once I manually set the K3 TX Data to DATA A  it remembered that .   Took til today for me and my  thick skull to realize that N1MM Config was now setting the data mode for WSJT  I know you guys have said to put DIGI as PSK for the K3 a hundred times at least --I even printed that tout - at least I am man enough to fess up.  Anyhow  made a FT8 qso and all seems to work.Thanks for your patience.

The clue was I saw K3 TX DATA had a REV above it when I opened WSJT thru N1MM -I merrily held the mode button to get rid of REV and got the dreaded K3 ERR KEY after one  transmission and it would not stop TX. Poking around I found the WINKEY PTT line was locked on and rebooting did no good -for some reason I had to unplug the USB line to WINKEY and let it find its com port again- at least it went back to COM5 . So that forced me to look at the N1MM config windows again and there it was. This damn 85 year old mind gets frustrated at times.

RE the dupes -- I THINK I have that puzzled out from an exercise to merge some other logs from another database (all on same computer ) .
I kept getting the same "zillion DUPES" even though I had edited the ADIF  to get just the dates I wanted - I finally found  the "Using N1MM Logger+ and ADIF to Merge Logs "-Still dont understand why I had to make a new database to combine same contest type files -but it workee.
Now I will do a long desired merge of all my N1MM logs since about 2010

73
Hank K7HP