Topics

N1MM+ with WSJT-x

Jim Denneny
 

I am trying to run ARRL VHF test tomorrow in FT8 mode.  I have read the wiki but am missing something.  FT8  settings in N1MM look ok. When I launch WSJT with N1MM, WSJT states I have a settting problem and will not load WSJT solo works ok.  It acts like there is a settings conflict.

73, Jim K7EG

Bill Pence
 

in wsjt settings, did you select "radio" to "dxlab suite commander" and PTT via CAT?
 
WSJT will CAT to the radio via N1MM.. This might be your conflict. 

Jim Denneny
 

Thanks Bill.  Changed WSJT-X Radio to DXLab Commander. CAT is checked.

Now, when I start N!MM, I get error thar Radio is trying to use COM12 which is already in use??  How do I fix this?

Jim K7EG

Jim Denneny
 

Trying  to prepare for ARRL VHF test in FT8 mode.  It was suggested I change radio from K3s to DXLab Commander in WSJT settings.  I did that.  Now, when I start N1MM+, I get COM12 is in use by another app??? Commander is only port using COM12 besides N1MM.  How do I fix?  Do I have to enable Commander Secondary Port for N1MM?  I don’t have an available com port for Secondary CAT port.

 

Jim K7EG

Bill Pence
 

you cannot run both dxlab commander and n1mm.

wsjt does not need commander. the wsjt commander setting also connects wsjt to n1mm.
its a bit counter intuitive, but selecting commander in wsjt does not mean run dx lab commander. ....

so:
quit dxlab commander.
run n1mm.
start wsjt from n1mm.

n1mm should get com12 to control the radio, then wsjt will use nmm to interface to the radio.


On Fri, Jun 12, 2020 at 7:49 PM Jim Denneny <57JNDenneny@...> wrote:
Thanks Bill.  Changed WSJT-X Radio to DXLab Commander. CAT is checked.

Now, when I start N!MM, I get error thar Radio is trying to use COM12 which is already in use??  How do I fix this?

Jim K7EG

Patrick Hung
 

Following up on this thread, I'm experiencing a possibly-related issue - WSJT-X will not load from within N1MM+, I get a small dialog box with a RED square, as well as an additional window behind it with ERROR messages/logs listed. WSJT-X seems to work fine when launched independently.

Gleaning from what's written in this thread, I will try changing Radio to DX Commander; I currently have it set to IC-7100, which is my radio. The only other setting that I'm unsure of is USB vs. Data/Pkt.?

Thanks for any comments/thoughts.

ve3ki
 

Your Radio setting in WSJT-X is the reason for your problem - you cannot open the same serial port from two programs at once.

Follow *all* of the instructions in the list at
<https://n1mmwp.hamdocs.com/manual-windows/wsjt-x-decode-list-window/#setup-checklist>.

73,
Rich VE3KI


On Tue, Jul 14, 2020 at 01:23 PM, Patrick Hung wrote:
Following up on this thread, I'm experiencing a possibly-related issue - WSJT-X will not load from within N1MM+, I get a small dialog box with a RED square, as well as an additional window behind it with ERROR messages/logs listed. WSJT-X seems to work fine when launched independently.

Gleaning from what's written in this thread, I will try changing Radio to DX Commander; I currently have it set to IC-7100, which is my radio. The only other setting that I'm unsure of is USB vs. Data/Pkt.?

Thanks for any comments/thoughts.

radio_op
 

Yes, 
DXLabs Commander needs to be set as the radio selection in WSJT-X.  
Once that is set, you should be able to open wsjt-x thru n1mm by typing ft8 in the call window and hitting enter.  

DO NOT RUN Commander.
Just open n1mm and type ft8 in the call area and hit Enter

Bob,  K2RET



Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: Patrick Hung <pathung@...>
Date: 7/14/20 13:23 (GMT-05:00)
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM+ with WSJT-x

Following up on this thread, I'm experiencing a possibly-related issue - WSJT-X will not load from within N1MM+, I get a small dialog box with a RED square, as well as an additional window behind it with ERROR messages/logs listed. WSJT-X seems to work fine when launched independently.

Gleaning from what's written in this thread, I will try changing Radio to DX Commander; I currently have it set to IC-7100, which is my radio. The only other setting that I'm unsure of is USB vs. Data/Pkt.?

Thanks for any comments/thoughts.

Patrick Hung
 

Thank you both, Rich and Bob, for your comments regarding DXLabs Commander - this was in fact one of TWO mis-configurations in my settings that prevented WSJT-X from loading from within N1MM+ on my computer - the other was that I had set an incorrect path to the .exe file - the correct location was in my C-drive, under programs386/bin, etc. etc., and not in my Downloads folder. WSJT-X loads fine now from within N1MM+.

HOWEVER, when I click the Test PTT button, the button turns red, but elicits no reaction from my radio - it's not transmitting, it seems. The Test Connection button turns Green, so I know that there are no interfacing issues between N1MM+ and WSJT-X. To test, I quitted out of both WSJT-X and N1MM, and launched WSJT-X solo, with the exact same settings, other than the Radio field now showing my actual radio model, IC-7100, in place of DXLabs Commander. The solo WSJT-X with IC-7100 works just fine - the radio makes noises when I click the Test PTT button. Since settings are same except for radio model, I'm guessing that somehow DXLabs is being launched? I never downloaded DXLabs, so don't understand how that could be possible.Your help/comments would again be appreciated! Thank you.

ve3ki
 

DXLab Suite is not involved at all. "DX Lab Suite Commander" is just WSJT-X's label for a particular method of communicating with other programs. The WSJT-X team first implemented this method with the DXLab Suite, hence the name. N1MM+ uses the same method as the DXLab suite.

Your symptoms suggest that N1MM+ has not been properly configured to control PTT in the radio. In the N1MM+ Configurer, click on the Set button for the radio control serial port and make sure that the "PTT via Radio Command Digital Mode" checkbox is checked.

All of this is described in detail in the documentation.

73,
Rich VE3KI


On Fri, Jul 17, 2020 at 12:11 AM, Patrick Hung wrote:
Thank you both, Rich and Bob, for your comments regarding DXLabs Commander - this was in fact one of TWO mis-configurations in my settings that prevented WSJT-X from loading from within N1MM+ on my computer - the other was that I had set an incorrect path to the .exe file - the correct location was in my C-drive, under programs386/bin, etc. etc., and not in my Downloads folder. WSJT-X loads fine now from within N1MM+.

HOWEVER, when I click the Test PTT button, the button turns red, but elicits no reaction from my radio - it's not transmitting, it seems. The Test Connection button turns Green, so I know that there are no interfacing issues between N1MM+ and WSJT-X. To test, I quitted out of both WSJT-X and N1MM, and launched WSJT-X solo, with the exact same settings, other than the Radio field now showing my actual radio model, IC-7100, in place of DXLabs Commander. The solo WSJT-X with IC-7100 works just fine - the radio makes noises when I click the Test PTT button. Since settings are same except for radio model, I'm guessing that somehow DXLabs is being launched? I never downloaded DXLabs, so don't understand how that could be possible.Your help/comments would again be appreciated! Thank you.

Patrick Hung
 

Rich,

I came across your exact suggestion in the FAQ section of the documentation, and that resolved my issue. 

Thank you very much for your help.

Jim W7RY
 

What issue?

Thanks
73
Jim W7RY
On 7/17/2020 9:46 AM, Patrick Hung wrote:

Rich,

I came across your exact suggestion in the FAQ section of the documentation, and that resolved my issue. 

Thank you very much for your help.

Patrick Hung
 

The PTT wasn't working when WSJT-X is launched from within N1MM+. I had neglected to tick a box in the settings.

Chet, N8RA
 

Patrick,

What box was that?

I am finding that if my Com PTT is set in N1MM+ that it does not also work in WSJT-X set for the same COM, but if I do not set it to anything in N1MM+ it works fine in WSJT-X.

 

Chet, N8RA

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of Patrick Hung
Sent: Saturday, July 18, 2020 11:21 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM+ with WSJT-x

 

The PTT wasn't working when WSJT-X is launched from within N1MM+. I had neglected to tick a box in the settings.

ve3ki
 

If you configure WSJT-X to use a COM port directly, you cannot use that COM port from any other program that runs at the same time, including N1MM+. If you want to use that COM port from N1MM+ (for example, in SSB), you must not configure WSJT-X to use it.

As per the documentation, the recommended method is to set PTT in WSJT-X to CAT. That tells WSJT-X to send its PTT commands to N1MM+, and N1MM+ in turn can control PTT by whatever method is configured in N1MM+. Unless you are using VOX, this means you need to have a PTT method configured in N1MM+, whether that is from a COM port or via radio command, e.g. using the PTT via Radio Command Digital Modes check box in the radio control port setup.

73,
Rich VE3KI


On Sat, Jul 18, 2020 at 11:57 AM, Chet, N8RA wrote:

Patrick,

What box was that?

I am finding that if my Com PTT is set in N1MM+ that it does not also work in WSJT-X set for the same COM, but if I do not set it to anything in N1MM+ it works fine in WSJT-X.

 

Chet, N8RA

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of Patrick Hung
Sent: Saturday, July 18, 2020 11:21 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM+ with WSJT-x

 

The PTT wasn't working when WSJT-X is launched from within N1MM+. I had neglected to tick a box in the settings.

 


 On Sat, Jul 18, 2020 at 11:57 AM, Chet, N8RA wrote:

Patrick,

What box was that?

I am finding that if my Com PTT is set in N1MM+ that it does not also work in WSJT-X set for the same COM, but if I do not set it to anything in N1MM+ it works fine in WSJT-X.

 

Chet, N8RA

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of Patrick Hung
Sent: Saturday, July 18, 2020 11:21 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM+ with WSJT-x

 

The PTT wasn't working when WSJT-X is launched from within N1MM+. I had neglected to tick a box in the settings.

 

Chet, N8RA
 

That was it- set WSJT-X to CAT.

I thought I’d gone thru the text and checklist but missed that.

Thank you Rich.

 

73, Chet, N8RA

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of ve3ki
Sent: Saturday, July 18, 2020 12:50 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM+ with WSJT-x

 

If you configure WSJT-X to use a COM port directly, you cannot use that COM port from any other program that runs at the same time, including N1MM+. If you want to use that COM port from N1MM+ (for example, in SSB), you must not configure WSJT-X to use it.

As per the documentation, the recommended method is to set PTT in WSJT-X to CAT. That tells WSJT-X to send its PTT commands to N1MM+, and N1MM+ in turn can control PTT by whatever method is configured in N1MM+. Unless you are using VOX, this means you need to have a PTT method configured in N1MM+, whether that is from a COM port or via radio command, e.g. using the PTT via Radio Command Digital Modes check box in the radio control port setup.

73,
Rich VE3KI


On Sat, Jul 18, 2020 at 11:57 AM, Chet, N8RA wrote:

Patrick,

What box was that?

I am finding that if my Com PTT is set in N1MM+ that it does not also work in WSJT-X set for the same COM, but if I do not set it to anything in N1MM+ it works fine in WSJT-X.

 

Chet, N8RA

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of Patrick Hung
Sent: Saturday, July 18, 2020 11:21 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM+ with WSJT-x

 

The PTT wasn't working when WSJT-X is launched from within N1MM+. I had neglected to tick a box in the settings.

 


 On Sat, Jul 18, 2020 at 11:57 AM, Chet, N8RA wrote:

Patrick,

What box was that?

I am finding that if my Com PTT is set in N1MM+ that it does not also work in WSJT-X set for the same COM, but if I do not set it to anything in N1MM+ it works fine in WSJT-X.

 

Chet, N8RA

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of Patrick Hung
Sent: Saturday, July 18, 2020 11:21 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] N1MM+ with WSJT-x

 

The PTT wasn't working when WSJT-X is launched from within N1MM+. I had neglected to tick a box in the settings.

 

Patrick Hung
 

Chet, this was the box that I hadn't checked:

"In the N1MM+ Configurer, click on the Set button for the radio control serial port and make sure that the "PTT via Radio Command Digital Mode" checkbox is checked."