Topics

Error opening com3

Marco Spalluzzi
 

Hi guys, I used N1MM Logger (not Logger+) in cqww rtty and everything worked fine (also today).
Now I have problems when trying to tx on cw or on ssb.
Run 775dsp and microkeyer, pc is Win8.1.
I start N1MM and I get into an "error opening com3", which is the com I setted for cw in the configuration ports.
Check the settings (I made no changes for years); com3 is:
- flagged on cw
- dtr Always on
- rts Always off
- no other flags on other voices, cw/ptt port address is 3E8
Same settings for 4 years, Always worked.
Rebooted the pc twice, no changes.
Disconnected/reconnected microkeyer, no changes.
If I play sample cw messages from the microkeyer, it works, so it's not an hw problem.

Radio is ok, I change bands, vfo frequency on the bandmap, all ok.
Plus, when on ssb, I have a "file not found" message when pressing a key to play a wav file.
I think is related to the com3 error, since everything worked normally until now.
What can I check more?
Alternatively, can anyone give me the settings that you use?
Thanks, bye.

Marco - IK2XSL
marco.spalluzzi@...

Richard Zalewski
 

I have a similar problem.  Go into device manager and disable your com3 and then enable it.  Works for me.

Richard 
W7ZR ex:5C5Z, CN2ZR, K2JSP, W6SBZ, W7KXR, K9ZIJ, W9KNF, W0KDF, W0MQU, J68ZR, KC6ZR, PJ4/W7ZR, KH2,W7ZR, KH6/W7ZR, V31ZR, VK4AAZ, XE2DV


Be joyful in hope, patient in affliction, faithful in prayer


On Sat, Oct 5, 2019 at 7:38 AM Marco Spalluzzi <marco.spalluzzi@...> wrote:
Hi guys, I used N1MM Logger (not Logger+) in cqww rtty and everything worked fine (also today).
Now I have problems when trying to tx on cw or on ssb.
Run 775dsp and microkeyer, pc is Win8.1.
I start N1MM and I get into an "error opening com3", which is the com I setted for cw in the configuration ports.
Check the settings (I made no changes for years); com3 is:
- flagged on cw
- dtr Always on
- rts Always off
- no other flags on other voices, cw/ptt port address is 3E8
Same settings for 4 years, Always worked.
Rebooted the pc twice, no changes.
Disconnected/reconnected microkeyer, no changes.
If I play sample cw messages from the microkeyer, it works, so it's not an hw problem.

Radio is ok, I change bands, vfo frequency on the bandmap, all ok.
Plus, when on ssb, I have a "file not found" message when pressing a key to play a wav file.
I think is related to the com3 error, since everything worked normally until now.
What can I check more?
Alternatively, can anyone give me the settings that you use?
Thanks, bye.

Marco - IK2XSL
marco.spalluzzi@...

Marco Spalluzzi
 

Hi Richard, device manager for what?
N1MM configuration ports?

Marco - IK2XSL.

Richard Zalewski
 

Device Manager....com & lpt ports

Richard 
W7ZR ex:5C5Z, CN2ZR, K2JSP, W6SBZ, W7KXR, K9ZIJ, W9KNF, W0KDF, W0MQU, J68ZR, KC6ZR, PJ4/W7ZR, KH2,W7ZR, KH6/W7ZR, V31ZR, VK4AAZ, XE2DV


Be joyful in hope, patient in affliction, faithful in prayer


On Sat, Oct 5, 2019 at 8:01 AM Marco Spalluzzi <marco.spalluzzi@...> wrote:
Hi Richard, device manager for what?
N1MM configuration ports?

Marco - IK2XSL.

Marco Spalluzzi
 

Richard,
disabled com3, pc reboot requested: made.
Started microkeyer, say com3 will not work: right, it's disabled.
Enabled com3 from pc control panel (no reboot requested, no reboot made).
Run microkeyer, no messages about com3: right, it's enabled now.
Run N1MM, no "error opening com3" messages at startup, but if I put radio on cw and press a key where a message is stored, I still geto into a message like "error sending cw. check port selection in the configuration dialog.
And still no wav files are sent out.
Any other idea?

Marco - IK2XSL

Marco Spalluzzi
 

Richard, problem solved.
The winey was unchecked under com3 configuration.
I don't know why, I've never touched it...
Anyway, now works perfectly on any mode.
Thanks for your hints, see you on air.

Marco - IK2XSL.