Topics

check for new program version and install

Gary Slagel
 

My automatic update started failing a month or so ago with something like an 'invalid communication format' message when I started the program and also when I tried to execute a 'check for new program version and install' from the tools menu.  (sorry I can't post the exact message because I'm not getting it any more)

My first thought was I needed to update N1MM+ so I did a manual update to V1.0.7809.0  .  The update seemed to go smoothly.  I don't get the startup message anymore but when I try to 'check for new program version and install' I get a 'checking for new version is not supported by this operating system' error.   I'm on Windows 7, 

Has anyone else run into this?   I don't mind doing manual updates but the automatic update had been working for quite a while and was really convenient.

Thanks

KT0A/Gary

Tom Wagner (N1MM)
 

We upgraded the web site to use HTTPS.  To read the web pages to download the new version, we need transport layer security TLS 1.2.

We build with .Net 4.0 to maximize compatibility with users of old OS's.

From a quick internet search it appears that in order for TLS 1.2 to work on Windows 7, you will need .Net Framework 4.5 or later installed on your machine. Since we haven't gotten a lot of complaints, my guess is that most Win 7 computers already have it.

If you would like to help, you can check your system to see if it has .Net Framework 4.5 installed, and if not install it and see if the problem corrects itself.  Please report back.

If you don't want to do that or don't know how, then manual updates still work.

73,

Tom - N1MM

On 7/14/2019 4:05 PM, Gary Slagel via Groups.Io wrote:
My automatic update started failing a month or so ago with something like an 'invalid communication format' message when I started the program and also when I tried to execute a 'check for new program version and install' from the tools menu.  (sorry I can't post the exact message because I'm not getting it any more)

My first thought was I needed to update N1MM+ so I did a manual update to V1.0.7809.0  .  The update seemed to go smoothly.  I don't get the startup message anymore but when I try to 'check for new program version and install' I get a 'checking for new version is not supported by this operating system' error.   I'm on Windows 7,

Has anyone else run into this?   I don't mind doing manual updates but the automatic update had been working for quite a while and was really convenient.

Thanks

KT0A/Gary

Gary Slagel
 

Thanks Tom, your solution worked.

I was on .net 4.0.something.  I upgraded to .net7 7.something and all is good.

73,
Gary/KT0A