Topics

Having problem getting K3 and N1MM to communicate

Rob K6RB
 

I just reassembled my station after six months of being disassembled and in storage. What had been an SO2R set up with two K3's is now a SO1V set up with just one K3. In the past, N1MM+ displayed both K3's and their respective bands/frequencies. With just the one K3, however, I am unable to get the K3 and logger to communicate. The computer (running Windows 7) shows a COM3 port for the K3 that is working. I selected the K3 and used the recommended settings. But the logger shows a manual radio and does not seem to be getting data from the K3. I get a message that the radio on COM3 is not responding and to restore polling and hit retry. Nothing I do seems to fix the situation.  I also show a working COM6 to which the Winkey is connected and it is indeed working as expected.

Any suggestions?

Rob K6RB

VE9AA - Mike
 

Hi Rob,

Is the current radio, your old radio #2 in ur old setup?
Make sure it's the correct primary (only) radio and that you've now selected this (see screenshot)

Rob K6RB
 

No, Mike, it was the original radio #1 and I did select SO1V.

 

Sent from Mail for Windows 10

 

From: VE9AA - Mike
Sent: Monday, December 2, 2019 5:56 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] Having problem getting K3 and N1MM to communicate

 

Hi Rob,

Is the current radio, your old radio #2 in ur old setup?
Make sure it's the correct primary (only) radio and that you've now selected this (see screenshot)

 

Michael Walker
 

Hi Mike

It sounds like Com 3 is not the right port number anymore. 

Also, since it has been some time, I highly suggest you go through the exercise of deleting ghosted com ports to clean things up.

Sorry, I don’t have the link handy, but if you search in the Docs for N1MM you will find the instructions.  

Clean up all the ghosted ones, then you have a better chance of making 100% that your radio is connected to the right com port number.  Also, make sure the baud rate you use is the same on the radio and N1MM.  9600 is plenty high enough to provide stable communications between the computer and the radio.

Mike va3mw

On Dec 2, 2019, at 9:01 PM, Rob K6RB <k6rb58@...> wrote:



No, Mike, it was the original radio #1 and I did select SO1V.

 

Sent from Mail for Windows 10

 

From: VE9AA - Mike
Sent: Monday, December 2, 2019 5:56 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] Having problem getting K3 and N1MM to communicate

 

Hi Rob,

Is the current radio, your old radio #2 in ur old setup?
Make sure it's the correct primary (only) radio and that you've now selected this (see screenshot)

<dummyfile.0.part>

 

Rob K6RB
 

Mike,

N1MM+ and Device Manager both show only COM3 and COM6. COM6 is Winkey and it is working. COM3 is the K3. Device manager says the port is operating properly. The baud rates are the same. The setup is exactly what N1MM+ suggests. I tried two different USB-to-COM Port adapters and that is not the problem. I looked up what is involved in removing ghost COM ports and it requires command prompts, etc., which I am not comfortable doing. This system worked before, and there were only three ports involved - one for each K3 and one for Winkey.

Rob K6RB

On 12/2/2019 6:12 PM, Michael Walker wrote:
Hi Mike

It sounds like Com 3 is not the right port number anymore. 

Also, since it has been some time, I highly suggest you go through the exercise of deleting ghosted com ports to clean things up.

Sorry, I don’t have the link handy, but if you search in the Docs for N1MM you will find the instructions.  

Clean up all the ghosted ones, then you have a better chance of making 100% that your radio is connected to the right com port number.  Also, make sure the baud rate you use is the same on the radio and N1MM.  9600 is plenty high enough to provide stable communications between the computer and the radio.

Mike va3mw

On Dec 2, 2019, at 9:01 PM, Rob K6RB <k6rb58@...> wrote:



No, Mike, it was the original radio #1 and I did select SO1V.

 

Sent from Mail for Windows 10

 

From: VE9AA - Mike
Sent: Monday, December 2, 2019 5:56 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] Having problem getting K3 and N1MM to communicate

 

Hi Rob,

Is the current radio, your old radio #2 in ur old setup?
Make sure it's the correct primary (only) radio and that you've now selected this (see screenshot)

<dummyfile.0.part>

 

Michael Walker
 

Yes, but please check for ghosted ports. 

They aren’t visible unless you take some special steps to see them. 


These are the instructions to follow. 

Mike va3mw


On Dec 2, 2019, at 10:34 PM, Rob K6RB <k6rb58@...> wrote:



Mike,

N1MM+ and Device Manager both show only COM3 and COM6. COM6 is Winkey and it is working. COM3 is the K3. Device manager says the port is operating properly. The baud rates are the same. The setup is exactly what N1MM+ suggests. I tried two different USB-to-COM Port adapters and that is not the problem. I looked up what is involved in removing ghost COM ports and it requires command prompts, etc., which I am not comfortable doing. This system worked before, and there were only three ports involved - one for each K3 and one for Winkey.

Rob K6RB

On 12/2/2019 6:12 PM, Michael Walker wrote:
Hi Mike

It sounds like Com 3 is not the right port number anymore. 

Also, since it has been some time, I highly suggest you go through the exercise of deleting ghosted com ports to clean things up.

Sorry, I don’t have the link handy, but if you search in the Docs for N1MM you will find the instructions.  

Clean up all the ghosted ones, then you have a better chance of making 100% that your radio is connected to the right com port number.  Also, make sure the baud rate you use is the same on the radio and N1MM.  9600 is plenty high enough to provide stable communications between the computer and the radio.

Mike va3mw

On Dec 2, 2019, at 9:01 PM, Rob K6RB <k6rb58@...> wrote:



No, Mike, it was the original radio #1 and I did select SO1V.

 

Sent from Mail for Windows 10

 

From: VE9AA - Mike
Sent: Monday, December 2, 2019 5:56 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] Having problem getting K3 and N1MM to communicate

 

Hi Rob,

Is the current radio, your old radio #2 in ur old setup?
Make sure it's the correct primary (only) radio and that you've now selected this (see screenshot)

<dummyfile.0.part>

 

Irwin Darack
 

Rob,

Are you able to communicate with the radio using the K3 Utility? 
If so, make  sure the PTT settings in the radio (Config: PTT-Key) match those in N1MM. In addition, are sure you have the correct Baud rate set in both the radio and N1MM. 

Irwin KD3TB 

On Mon, Dec 2, 2019 at 8:37 PM Rob K6RB <k6rb58@...> wrote:
I just reassembled my station after six months of being disassembled and
in storage. What had been an SO2R set up with two K3's is now a SO1V set
up with just one K3. In the past, N1MM+ displayed both K3's and their
respective bands/frequencies. With just the one K3, however, I am unable
to get the K3 and logger to communicate. The computer (running Windows
7) shows a COM3 port for the K3 that is working. I selected the K3 and
used the recommended settings. But the logger shows a manual radio and
does not seem to be getting data from the K3. I get a message that the
radio on COM3 is not responding and to restore polling and hit retry.
Nothing I do seems to fix the situation.  I also show a working COM6 to
which the Winkey is connected and it is indeed working as expected.

Any suggestions?

Rob K6RB




--
Irwin KD3TB

John Webster
 

FWIW

I've always used a baud rate of 34,800 for my K3's. 

On Tue, Dec 3, 2019, 5:01 AM Irwin Darack <idarack@...> wrote:
Rob,

Are you able to communicate with the radio using the K3 Utility? 
If so, make  sure the PTT settings in the radio (Config: PTT-Key) match those in N1MM. In addition, are sure you have the correct Baud rate set in both the radio and N1MM. 

Irwin KD3TB 

On Mon, Dec 2, 2019 at 8:37 PM Rob K6RB <k6rb58@...> wrote:
I just reassembled my station after six months of being disassembled and
in storage. What had been an SO2R set up with two K3's is now a SO1V set
up with just one K3. In the past, N1MM+ displayed both K3's and their
respective bands/frequencies. With just the one K3, however, I am unable
to get the K3 and logger to communicate. The computer (running Windows
7) shows a COM3 port for the K3 that is working. I selected the K3 and
used the recommended settings. But the logger shows a manual radio and
does not seem to be getting data from the K3. I get a message that the
radio on COM3 is not responding and to restore polling and hit retry.
Nothing I do seems to fix the situation.  I also show a working COM6 to
which the Winkey is connected and it is indeed working as expected.

Any suggestions?

Rob K6RB




--
Irwin KD3TB

Mpridesti
 

And set the computer itself (device manager - com port) to 38,400 too 

Regards,

Mark, K1RX


On Dec 3, 2019, at 9:00 AM, John Webster <nn1ssnh@...> wrote:

FWIW

I've always used a baud rate of 34,800 for my K3's. 

On Tue, Dec 3, 2019, 5:01 AM Irwin Darack <idarack@...> wrote:
Rob,

Are you able to communicate with the radio using the K3 Utility? 
If so, make  sure the PTT settings in the radio (Config: PTT-Key) match those in N1MM. In addition, are sure you have the correct Baud rate set in both the radio and N1MM. 

Irwin KD3TB 

On Mon, Dec 2, 2019 at 8:37 PM Rob K6RB <k6rb58@...> wrote:
I just reassembled my station after six months of being disassembled and
in storage. What had been an SO2R set up with two K3's is now a SO1V set
up with just one K3. In the past, N1MM+ displayed both K3's and their
respective bands/frequencies. With just the one K3, however, I am unable
to get the K3 and logger to communicate. The computer (running Windows
7) shows a COM3 port for the K3 that is working. I selected the K3 and
used the recommended settings. But the logger shows a manual radio and
does not seem to be getting data from the K3. I get a message that the
radio on COM3 is not responding and to restore polling and hit retry.
Nothing I do seems to fix the situation.  I also show a working COM6 to
which the Winkey is connected and it is indeed working as expected.

Any suggestions?

Rob K6RB




--
Irwin KD3TB

Pete Smith
 

I believe that should be 38,400.  Also, from recent experience, be sure that the other variables match between the virtual serial port and N1MM.  I just helped a guy get it going where the issue was one of the subordinate settings.

73, Pete N4ZR
Check out the Reverse Beacon Network 
at <http://reversebeacon.net>, now 
spotting RTTY activity worldwide. 
For spots, please use your favorite 
"retail" DX cluster.
On 12/3/2019 9:00 AM, John Webster wrote:

FWIW

I've always used a baud rate of 34,800 for my K3's. 

On Tue, Dec 3, 2019, 5:01 AM Irwin Darack <idarack@...> wrote:
Rob,

Are you able to communicate with the radio using the K3 Utility? 
If so, make  sure the PTT settings in the radio (Config: PTT-Key) match those in N1MM. In addition, are sure you have the correct Baud rate set in both the radio and N1MM. 

Irwin KD3TB 

On Mon, Dec 2, 2019 at 8:37 PM Rob K6RB <k6rb58@...> wrote:
I just reassembled my station after six months of being disassembled and
in storage. What had been an SO2R set up with two K3's is now a SO1V set
up with just one K3. In the past, N1MM+ displayed both K3's and their
respective bands/frequencies. With just the one K3, however, I am unable
to get the K3 and logger to communicate. The computer (running Windows
7) shows a COM3 port for the K3 that is working. I selected the K3 and
used the recommended settings. But the logger shows a manual radio and
does not seem to be getting data from the K3. I get a message that the
radio on COM3 is not responding and to restore polling and hit retry.
Nothing I do seems to fix the situation.  I also show a working COM6 to
which the Winkey is connected and it is indeed working as expected.

Any suggestions?

Rob K6RB




--
Irwin KD3TB

John Bednar
 


This is not or ever necessary.  Our program sets the com port parameters.

John, K3CT 




-------- Original message --------
From: "Mpridesti via Groups.Io" <mpridesti@...>
Date: 12/3/19 9:18 AM (GMT-05:00)
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MM+] Having problem getting K3 and N1MM to communicate

And set the computer itself (device manager - com port) to 38,400 too 

Regards,

Mark, K1RX


On Dec 3, 2019, at 9:00 AM, John Webster <nn1ssnh@...> wrote:

FWIW

I've always used a baud rate of 34,800 for my K3's. 

On Tue, Dec 3, 2019, 5:01 AM Irwin Darack <idarack@...> wrote:
Rob,

Are you able to communicate with the radio using the K3 Utility? 
If so, make  sure the PTT settings in the radio (Config: PTT-Key) match those in N1MM. In addition, are sure you have the correct Baud rate set in both the radio and N1MM. 

Irwin KD3TB 

On Mon, Dec 2, 2019 at 8:37 PM Rob K6RB <k6rb58@...> wrote:
I just reassembled my station after six months of being disassembled and
in storage. What had been an SO2R set up with two K3's is now a SO1V set
up with just one K3. In the past, N1MM+ displayed both K3's and their
respective bands/frequencies. With just the one K3, however, I am unable
to get the K3 and logger to communicate. The computer (running Windows
7) shows a COM3 port for the K3 that is working. I selected the K3 and
used the recommended settings. But the logger shows a manual radio and
does not seem to be getting data from the K3. I get a message that the
radio on COM3 is not responding and to restore polling and hit retry.
Nothing I do seems to fix the situation.  I also show a working COM6 to
which the Winkey is connected and it is indeed working as expected.

Any suggestions?

Rob K6RB




--
Irwin KD3TB