Topics

Setting Up RTTY with Winkey 3.1

John N0TA
 

I am struggling setting up WinKey 3.1 RTTY in N1MM. I am trying to set it up such that BOTH CW and RTTY are enabled. I would like to have Key1 = CW and PTT2/Key2 = RTTY.
 
In the Config/Winkey screen, I enabled "Use 2nd Output", and was given the choice in Winkey RTTY to use either Key1 or Key2; however, when I chose Key2 and exit the menu, the selection is not saved (so Winkey RTTY is NOT enabled).
 
Any ideas on how to setup both CW and RTTY using a Winkeyer?
Thanks,
  - 73, John, N0TA

Steve London
 

Wait until next Tuesday's N1MM+ version.

73,
Steve, N2IC

On 04/11/2019 11:15 AM, John N0TA wrote:
I am struggling setting up WinKey 3.1 RTTY in N1MM. I am trying to set it up such that BOTH CW and RTTY are enabled. I would like to have Key1 = CW and PTT2/Key2 = RTTY.
In the Config/Winkey screen, I enabled "Use 2nd Output", and was given the choice in Winkey RTTY to use either Key1 or Key2; however, when I chose Key2 and exit the menu, the selection is not saved (so Winkey RTTY is NOT enabled).
Any ideas on how to setup both CW and RTTY using a Winkeyer?
Thanks,
  - 73, John, N0TA

John N0TA
 

I can now select WinKey for RTTY. I have followed the K1EL setup guide, but not able to transmit. I am not printing the info I'm trying to xmit, not hearing the transmission. Using 2Tone, and not seeing a WinKey transmit option in the Setup menu. 

Has anyone successfully setup WinKey with 2Tone?
Thanks,
  - John

Rick Ellison
 

John.

You no longer need to use 2-tone for Winkey RTTY. Open the main config in N1MM. On the digital tab you will see 2 dropdowns to select the interface type for each entry window. Select Winkey from the dropdown. While you’re there set the path to what type of receiver you want to use. (The program already knows the path to MMVARI so that not needed just the path’s to MMTTY/2-tone or Fldigi. Next move over to the Winkey tab and select that you want to use Winkey RTTY and select the keying port you want to use. Next click on the hardware tab and configure the port Winkey is on like you would have done for cw.

When you open the digital window you will see the top portion where received text will be shown and a command window in the middle this will show the commands being sent to and from the Winkey. And At the bottom will be the normal tx window. Once you have the Digital window open you will need to create 3 macro’s to use with the Winkey. If you right click on the TX or RX buttons it will bring up the macro editor. The 3 macro’s you need to config are located on the right side of the editor TX, RX, ESC for TX enter [ for RX enter ] and for ESC enter \ once you have those 3 you should be all set and able to use the Winkey directly in N1MM. If you ave any questions let me know. I have been using the winkey for the last couple of contests and have had no issues with it..

 

73 Rick N2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of John N0TA
Sent: Tuesday, April 23, 2019 10:51 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] Setting Up RTTY with Winkey 3.1

 

I can now select WinKey for RTTY. I have followed the K1EL setup guide, but not able to transmit. I am not printing the info I'm trying to xmit, not hearing the transmission. Using 2Tone, and not seeing a WinKey transmit option in the Setup menu. 

Has anyone successfully setup WinKey with 2Tone?
Thanks,
  - John


Virus-free. www.avast.com

John N0TA
 

Rick,
Thanks for the setup; however, not working yet. I am getting messages printing on the Digital screen, but not going to my K3. I have a cable from WinKey Key2 to the FSK input on the K3 (which is how I have wired other FSK methods). In Config/Hardware, I have Com5 set for WinKey, which is the way it is configured for CW. I looked for the possibility of another Com port for RTTY (Key2), but didn't find one. Can N1MM be setup for both WinKey CW and RTTY at the same time? FWIW, my WinKey version is 31.02, newest N1MM (with the WinKey RTTY code), Windows 10, K3.

Thanks for your help,
  - 73, John, N0TA