Topics

MORTTY Working

Jim W7RY
 

Got one of my MORTTYs working. Seems to work fine.. I have not tried it on the air yet.
 
So.... Do I simply put the transmit command [ into the macro? Then put the receive command in at the end ] ?
 
There is little info out there on actually USING the Tiny FSK. As lease by using an internet search engine.... No into on the N1MM help either that specifically addresses the Tiny FSK that I could fine.
 
Anyone have any links?
 
 
 
Thanks
73
Jim W7RY


ve3ki
 

<http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support&structure=N1MM+Logger+Documentation#TinyFSK_by_Andy_Flowers_K0SM> .

73,
Rich VE3KI


On Mon, May 14, 2018 at 08:00 pm, Jim W7RY wrote:
Got one of my MORTTYs working. Seems to work fine.. I have not tried it on the air yet.
 
So.... Do I simply put the transmit command [ into the macro? Then put the receive command in at the end ] ?
 
There is little info out there on actually USING the Tiny FSK. As lease by using an internet search engine.... No into on the N1MM help either that specifically addresses the Tiny FSK that I could fine.
 
Anyone have any links?
 
 
 
Thanks
73
Jim W7RY


Jim W7RY
 

Perfect! Thanks!
 
Wonder why a Google search on N1MM and Tiny FSK didn’t bring this up...
 
Looks like I need to make a couple of tweaks... But I had it mostly right.
 
Thanks again Rich
 
 
73
Jim W7RY


 

From: ve3ki
Sent: Monday, May 14, 2018 10:20 PM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
<http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support&structure=N1MM+Logger+Documentation#TinyFSK_by_Andy_Flowers_K0SM> .

73,
Rich VE3KI


On Mon, May 14, 2018 at 08:00 pm, Jim W7RY wrote:
Got one of my MORTTYs working. Seems to work fine.. I have not tried it on the air yet.
 
So.... Do I simply put the transmit command [ into the macro? Then put the receive command in at the end ] ?
 
There is little info out there on actually USING the Tiny FSK. As lease by using an internet search engine.... No into on the N1MM help either that specifically addresses the Tiny FSK that I could fine.
 
Anyone have any links?
 
 
 
Thanks
73
Jim W7RY


Rick Ellison
 

Follow the directions in 10.1 and not the way Andy describes it in the second paragraph..…

 

73 Rick N2AMG

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Jim W7RY
Sent: Monday, May 14, 2018 11:34 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] MORTTY Working

 

Perfect! Thanks!

 

Wonder why a Google search on N1MM and Tiny FSK didn’t bring this up...

 

Looks like I need to make a couple of tweaks... But I had it mostly right.

 

Thanks again Rich

 

 

73
Jim W7RY

 

From: ve3ki

Sent: Monday, May 14, 2018 10:20 PM

Subject: Re: [N1MMLoggerPlus] MORTTY Working

 

<http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support&structure=N1MM+Logger+Documentation#TinyFSK_by_Andy_Flowers_K0SM> .

73,
Rich VE3KI


On Mon, May 14, 2018 at 08:00 pm, Jim W7RY wrote:

Got one of my MORTTYs working. Seems to work fine.. I have not tried it on the air yet.

 

So.... Do I simply put the transmit command [ into the macro? Then put the receive command in at the end ] ?

 

There is little info out there on actually USING the Tiny FSK. As lease by using an internet search engine.... No into on the N1MM help either that specifically addresses the Tiny FSK that I could fine.

 

Anyone have any links?

 

 

 

Thanks
73
Jim W7RY

Max NG7M
 

Hi Jim, here is the link to the N1MM+ docs for TinyFSK:

http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support#TinyFSK_by_Andy_Flowers_K0SM

Max NG7M

Skip
 

Good practice is to begin your transmission with {TX}{ENTER} and end it with a single space before the {RX}.  This puts your transmission at the beginning of a new line, and separates the end of it from the noise he will print at your {RX}.  Multiple line feeds are a real PITA for those receiving on a window that scrolls up [or down] as he then needs to chase your call and maybe exchange with the mouse.

73,

Fred ["Skip"] K6DGW
Sparks NV DM09dn
Washoe County

On 5/14/2018 8:00 PM, Jim W7RY wrote:
Got one of my MORTTYs working. Seems to work fine.. I have not tried it on the air yet.
 
So.... Do I simply put the transmit command [ into the macro? Then put the receive command in at the end ] ?
 
There is little info out there on actually USING the Tiny FSK. As lease by using an internet search engine.... No into on the N1MM help either that specifically addresses the Tiny FSK that I could fine.
 
Anyone have any links?
 
Thanks
73
Jim W7RY

Jim W7RY
 

Thanks Max...
 
Did all of that.. I still have to put the transmit command [ into the macro. And the receive command ] at the end of the macros instead of the {TX} and {RX} commands to make them work with Tiny FSK.
 
Nothing in the setup saying this at least that I can find.
 
My TX and RX buttons work fine.
 
Thanks all
73
Jim W7RY


 

From: Max NG7M
Sent: Monday, May 14, 2018 11:32 PM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
Hi Jim, here is the link to the N1MM+ docs for TinyFSK:

http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support#TinyFSK_by_Andy_Flowers_K0SM

Max NG7M

ve3ki
 

Following the instructions in the manual at
<http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support&structure=N1MM+Logger+Documentation#In_the_Digital_Interface_DI_> : Open the DI Setup window, choose the Message Setup tab, select the "Other, TinyFSK" Message Set, click on the TX button at the right and  program a [ character followed by the {ENTER} macro into the Message Text for the TX button and then click on the "Save" button in the blue area. Next, click on the RX button at the right and program a ] character followed by the {ENTER} macro into the Message Text and press "Save". Click on the ESC button at the right and program a \ character into the Message Text and press "Save". When you have done all three, click on the "Save Settings" button to save the changes and exit the DI Setup window. Close the DI window and reopen it. After you have done that, you can check to make sure your changes have taken effect by opening the DI Setup window, "Messages" tab, "Other, TinyFSK" message set and checking that the expected contents are still programmed into those three buttons. Once you have done that,  the {TX} and {RX} macros ought to work in your regular message buttons.

73,
Rich VE3KI


On Tue, May 15, 2018 at 07:27 pm, Jim W7RY wrote:
Thanks Max...
 
Did all of that.. I still have to put the transmit command [ into the macro. And the receive command ] at the end of the macros instead of the {TX} and {RX} commands to make them work with Tiny FSK.
 
Nothing in the setup saying this at least that I can find.
 
My TX and RX buttons work fine.
 
Thanks all
73
Jim W7RY


 
From: Max NG7M
Sent: Monday, May 14, 2018 11:32 PM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
Hi Jim, here is the link to the N1MM+ docs for TinyFSK:

http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support#TinyFSK_by_Andy_Flowers_K0SM

Max NG7M

Jim W7RY
 

Yup! You are correct... I forgot to put the {TX} and {RX} commands back in... I just did some testing and it does work.
 
Sorry for the fire drill...
 
 
 
Thanks
73
Jim W7RY


 

From: ve3ki
Sent: Tuesday, May 15, 2018 10:18 PM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
Following the instructions in the manual at
<http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support&structure=N1MM+Logger+Documentation#In_the_Digital_Interface_DI_> : Open the DI Setup window, choose the Message Setup tab, select the "Other, TinyFSK" Message Set, click on the TX button at the right and  program a [ character followed by the {ENTER} macro into the Message Text for the TX button and then click on the "Save" button in the blue area. Next, click on the RX button at the right and program a ] character followed by the {ENTER} macro into the Message Text and press "Save". Click on the ESC button at the right and program a \ character into the Message Text and press "Save". When you have done all three, click on the "Save Settings" button to save the changes and exit the DI Setup window. Close the DI window and reopen it. After you have done that, you can check to make sure your changes have taken effect by opening the DI Setup window, "Messages" tab, "Other, TinyFSK" message set and checking that the expected contents are still programmed into those three buttons. Once you have done that,  the {TX} and {RX} macros ought to work in your regular message buttons.

73,
Rich VE3KI


On Tue, May 15, 2018 at 07:27 pm, Jim W7RY wrote:
Thanks Max...
 
Did all of that.. I still have to put the transmit command [ into the macro. And the receive command ] at the end of the macros instead of the {TX} and {RX} commands to make them work with Tiny FSK.
 
Nothing in the setup saying this at least that I can find.
 
My TX and RX buttons work fine.
 
Thanks all
73
Jim W7RY


 
From: Max NG7M
Sent: Monday, May 14, 2018 11:32 PM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
Hi Jim, here is the link to the N1MM+ docs for TinyFSK:

http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support#TinyFSK_by_Andy_Flowers_K0SM

Max NG7M

Jim W7RY
 

I removed the [{ENTER} from the transmit button...
 
I already have {enter} in my macros for proper formatting of my buffers. This isn't my first RTTY contesting rodeo...
 
So really the transmit function should only have the [ in it because folks SHOULD already have the proper carriage return/line feeds in their macros. That is my opinion. But to each their own.
 
 
 
 
Thanks
73
Jim W7RY


 

From: ve3ki
Sent: Tuesday, May 15, 2018 10:18 PM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
Following the instructions in the manual at
<http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support&structure=N1MM+Logger+Documentation#In_the_Digital_Interface_DI_> : Open the DI Setup window, choose the Message Setup tab, select the "Other, TinyFSK" Message Set, click on the TX button at the right and  program a [ character followed by the {ENTER} macro into the Message Text for the TX button and then click on the "Save" button in the blue area. Next, click on the RX button at the right and program a ] character followed by the {ENTER} macro into the Message Text and press "Save". Click on the ESC button at the right and program a \ character into the Message Text and press "Save". When you have done all three, click on the "Save Settings" button to save the changes and exit the DI Setup window. Close the DI window and reopen it. After you have done that, you can check to make sure your changes have taken effect by opening the DI Setup window, "Messages" tab, "Other, TinyFSK" message set and checking that the expected contents are still programmed into those three buttons. Once you have done that,  the {TX} and {RX} macros ought to work in your regular message buttons.

73,
Rich VE3KI


On Tue, May 15, 2018 at 07:27 pm, Jim W7RY wrote:
Thanks Max...
 
Did all of that.. I still have to put the transmit command [ into the macro. And the receive command ] at the end of the macros instead of the {TX} and {RX} commands to make them work with Tiny FSK.
 
Nothing in the setup saying this at least that I can find.
 
My TX and RX buttons work fine.
 
Thanks all
73
Jim W7RY


 
From: Max NG7M
Sent: Monday, May 14, 2018 11:32 PM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
Hi Jim, here is the link to the N1MM+ docs for TinyFSK:

http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support#TinyFSK_by_Andy_Flowers_K0SM

Max NG7M

Max NG7M
 

Hi Jim, that is correct.  In the macros, you always designate {tx} and {rx}.  This is 'abstract' to the device you are using.  For example if you have MMTTY setup, N1MM knows how to tell MMTTY to switch between transmit and receive and the same holds true for other RTTY devices / modems like what TinyFSK will appear to be when setup with 2Tone etc...  typically, I don't believe you would ever need to put anything special in the macros., but {tx} and {rx} will always be required so N1MM can take care of sending the tx / rx to the software you have told N1MM to use.

Sounds like you got it all setup and working.  Nice!

I just built a MORTTY tonight for a friend and will building 3 more this week.  Very slick design and compact.  I'm sold... :)  The price can't be beat either.

Max NG7M

Max NG7M

Rick Ellison
 

Jim..

You need at least the [ in the tx macro or the Morrty will not key.

 

73 Rick N2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Jim W7RY
Sent: Tuesday, May 15, 2018 11:34 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] MORTTY Working

 

I removed the [{ENTER} from the transmit button...

 

I already have {enter} in my macros for proper formatting of my buffers. This isn't my first RTTY contesting rodeo...

 

So really the transmit function should only have the [ in it because folks SHOULD already have the proper carriage return/line feeds in their macros. That is my opinion. But to each their own.

 

 

 

 

Thanks
73
Jim W7RY

 

From: ve3ki

Sent: Tuesday, May 15, 2018 10:18 PM

Subject: Re: [N1MMLoggerPlus] MORTTY Working

 

Following the instructions in the manual at
<http://n1mm.hamdocs.com/tiki-index.php?page=Digital+-+External+TNC+Support&structure=N1MM+Logger+Documentation#In_the_Digital_Interface_DI_> : Open the DI Setup window, choose the Message Setup tab, select the "Other, TinyFSK" Message Set, click on the TX button at the right and  program a [ character followed by the {ENTER} macro into the Message Text for the TX button and then click on the "Save" button in the blue area. Next, click on the RX button at the right and program a ] character followed by the {ENTER} macro into the Message Text and press "Save". Click on the ESC button at the right and program a \ character into the Message Text and press "Save". When you have done all three, click on the "Save Settings" button to save the changes and exit the DI Setup window. Close the DI window and reopen it. After you have done that, you can check to make sure your changes have taken effect by opening the DI Setup window, "Messages" tab, "Other, TinyFSK" message set and checking that the expected contents are still programmed into those three buttons. Once you have done that,  the {TX} and {RX} macros ought to work in your regular message buttons.

73,
Rich VE3KI


On Tue, May 15, 2018 at 07:27 pm, Jim W7RY wrote:

Thanks Max...

 

Did all of that.. I still have to put the transmit command [ into the macro. And the receive command ] at the end of the macros instead of the {TX} and {RX} commands to make them work with Tiny FSK.

 

Nothing in the setup saying this at least that I can find.

 

My TX and RX buttons work fine.

 

Thanks all
73
Jim W7RY

 

From: Max NG7M

Sent: Monday, May 14, 2018 11:32 PM

Subject: Re: [N1MMLoggerPlus] MORTTY Working

 

Rick Ellison
 

In the docs on the website it shows that you do actually have to enter some things for the TX,RX, and ESC routines so the program knows what to send to the Tiny. You do not need to setup the Tiny where you have to use 2-Tone only  the program talks directly to the Tiny so that part is no longer needed.

 

73 Rick N2AMG

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Max NG7M
Sent: Tuesday, May 15, 2018 11:49 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] MORTTY Working

 

Hi Jim, that is correct.  In the macros, you always designate {tx} and {rx}.  This is 'abstract' to the device you are using.  For example if you have MMTTY setup, N1MM knows how to tell MMTTY to switch between transmit and receive and the same holds true for other RTTY devices / modems like what TinyFSK will appear to be when setup with 2Tone etc...  typically, I don't believe you would ever need to put anything special in the macros., but {tx} and {rx} will always be required so N1MM can take care of sending the tx / rx to the software you have told N1MM to use.

Sounds like you got it all setup and working.  Nice!

I just built a MORTTY tonight for a friend and will building 3 more this week.  Very slick design and compact.  I'm sold... :)  The price can't be beat either.

Max NG7M

Max NG7M

Jim Sharp
 

Using the [  ]  / in a terminal program work as they should,

But with N1MM set up with tinyfsk for both K3 radios in SO2R, (no problem with SO1V) the radio 
number 2  has a leading and following diddle or varying length with any function commands from N1MM.  Diddle is turned off in both instances of MMTTY.  I've swithched radios and MORTTY units with no difference. Also re-programmed the fsk slices for both MOTTRY units.

Any ideas about stopping the diddle on radio 2

Thanks,  Jim - W5AP

Jim Sharp
 

Just to let  you know I finally got both MORTTY units working with SO2R and N1MM+. without the diddles.

The solution was with setting up N1MM.  That is - in the configurer, I had to make sure "allow exit interrupts" was not checked in the Hardware setup. But mainly to get Dueling CQ working, I found that with the CQ function message I was using for testing  {TX}{ENTER}CQ ARRTY W5AP W5AP CQ {RX}{CLRRX} I had to set the SO2R dueing CQ delay greater than 5 seconds.  Less than 6 seconds caused the "dueling cq" to go off, and I'm guessing let the ptt or something engaged just long enough to throw the K3 into diddle mode (just like when sending fsk with paddle keying) Although thats a guess. Longer CQ messages might require longer than 6 second delay times to work right - I didn't test . So when I put in 6 seconds, it alternated rig CQs without delay or diddles as I wanted. Longer delay times did delay the switching - which is what Im guessing was its intent.  This might warrant a bug report....I don't know.  Or at least an explanation as to the use (and warning) of the SO2R Dueling CQ time delay (at least with K3's)

Hope this helps

The green led always on in one of my MORTTY units was and remains irrelavant to operation

Jim W7RY
 

You need to send diddles. Please see:
 
 
I, for one, would like to know why you don’t want to send them?
 
I would also like to know your callsign.
 
Thanks
73
Jim W7RY


 

From: Jim Sharp
Sent: Saturday, May 19, 2018 5:57 AM
Subject: Re: [N1MMLoggerPlus] MORTTY Working
 
Just to let  you know I finally got both MORTTY units working with SO2R and N1MM+. without the diddles.
 
The solution was with setting up N1MM.  That is - in the configurer, I had to make sure "allow exit interrupts" was not checked in the Hardware setup. But mainly to get Dueling CQ working, I found that with the CQ function message I was using for testing  {TX}{ENTER}CQ ARRTY W5AP W5AP CQ {RX}{CLRRX} I had to set the SO2R dueing CQ delay greater than 5 seconds.  Less than 6 seconds caused the "dueling cq" to go off, and I'm guessing let the ptt or something engaged just long enough to throw the K3 into diddle mode (just like when sending fsk with paddle keying) Although thats a guess. Longer CQ messages might require longer than 6 second delay times to work right - I didn't test . So when I put in 6 seconds, it alternated rig CQs without delay or diddles as I wanted. Longer delay times did delay the switching - which is what Im guessing was its intent.  This might warrant a bug report....I don't know.  Or at least an explanation as to the use (and warning) of the SO2R Dueling CQ time delay (at least with K3's)
 
Hope this helps
 
The green led always on in one of my MORTTY units was and remains irrelavant to operation