Topics

CW on the IC-7610

John Brodie
 

I have just set up the IC-7610 with N1MM+ following K3CT's procedure, so that CW is being sent via the "A" com port, same as radio control.  However, when sending CW messages using the function keys, the CW is distorted, i.e. the ratio of dots to dashes is incorrect and cannot be corrected with the keyer settings on the radio.  It does not improve if I change the N1MM configuration to send via the "B" com port.  Can anyone tell me what is wrong?  Help much appreciated.
John VA7XB

Mike Flowers
 

Does it do the same thing into a dummy load?  Perhaps some RFI in the shack riding in on the COM line?

 

- 73 and good DX de Mike, K6MKF, Past President - NCDXC

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of John Brodie
Sent: Wednesday, March 21, 2018 2:31 PM
To: N1MMLoggerPlus@groups.io
Subject: [N1MMLoggerPlus] CW on the IC-7610

 

I have just set up the IC-7610 with N1MM+ following K3CT's procedure, so that CW is being sent via the "A" com port, same as radio control.  However, when sending CW messages using the function keys, the CW is distorted, i.e. the ratio of dots to dashes is incorrect and cannot be corrected with the keyer settings on the radio.  It does not improve if I change the N1MM configuration to send via the "B" com port.  Can anyone tell me what is wrong?  Help much appreciated.
John VA7XB

John Bednar
 

John,

 

If the USB connection is routed through a USB hub, plug the radio cable directly into the PC, bypassing the USB hub.

 

I seem to remember someone discovering that some PC USB ports suffered from latency so if the computer has multiple USB ports, try another.

 

Could also be a severely underpowered PC. Describe your PC (CPU, speed, OS version, amount of memory, etc).

 

If you are using a MAC with Windows, include that.

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of John Brodie
Sent: Wednesday, March 21, 2018 5:31 PM
To: N1MMLoggerPlus@groups.io
Subject: [N1MMLoggerPlus] CW on the IC-7610

 

I have just set up the IC-7610 with N1MM+ following K3CT's procedure, so that CW is being sent via the "A" com port, same as radio control.  However, when sending CW messages using the function keys, the CW is distorted, i.e. the ratio of dots to dashes is incorrect and cannot be corrected with the keyer settings on the radio.  It does not improve if I change the N1MM configuration to send via the "B" com port.  Can anyone tell me what is wrong?  Help much appreciated.
John VA7XB

John Brodie
 

Many thanks to those who replied to my post by direct email.  For the benefit of the group, here is my response to trying the suggestions offered to the problem of “erratic dot-dash ratio CW sent by function keys” (note: CW sending by paddle and from 7610 canned messages is OK):

1.     RFI in the shack is pretty much ruled out as the problem even occurs at TX low power into a dummy load.  In any case when normally transmitting, RF from properly grounded equipment goes to a resonant antenna with double shielded coax feed.

2.     It was suggested that changing the USB cable to another USB port might fix it – it doesn’t.

3.     It was also suggested that the CPU might be the problem; here is what we are using: Intel (R) Core ™ Quad CPU at 2.66 GHz, with 232 GB memory and only 38 GB used; Win 10 Pro; 8 GB RAM – seems unlikely that CPU horsepower would be the problem but I am certainly no expert.

Spent several hours checking over everything I could think of but no cigar.  This raises another question in my mind:  I see no way of changing the speed of the CW sent from function keys.  Further suggestions will be much appreciated. 

73 to all

Mike Flowers
 

Hi John,

 

Here’s how I change CW keying speed with N1MM+ function keys:

 

 

- 73 and good DX de Mike, K6MKF, Past President - NCDXC

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of John Brodie
Sent: Thursday, March 22, 2018 1:46 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] CW on the IC-7610

 

Many thanks to those who replied to my post by direct email.  For the benefit of the group, here is my response to trying the suggestions offered to the problem of “erratic dot-dash ratio CW sent by function keys” (note: CW sending by paddle and from 7610 canned messages is OK):

  1. RFI in the shack is pretty much ruled out as the problem even occurs at TX low power into a dummy load.  In any case when normally transmitting, RF from properly grounded equipment goes to a resonant antenna with double shielded coax feed.
  2. It was suggested that changing the USB cable to another USB port might fix it – it doesn’t.
  3. It was also suggested that the CPU might be the problem; here is what we are using: Intel (R) Core ™ Quad CPU at 2.66 GHz, with 232 GB memory and only 38 GB used; Win 10 Pro; 8 GB RAM – seems unlikely that CPU horsepower would be the problem but I am certainly no expert.

Spent several hours checking over everything I could think of but no cigar.  This raises another question in my mind:  I see no way of changing the speed of the CW sent from function keys.  Further suggestions will be much appreciated. 

73 to all

Bob Frostholm
 

I use the Page Up and Page Down keys on my keyboard.... easier than getting that little cursor over the arrows shown below

Bob

Ko6Lu


At 01:58 PM 3/22/2018, Mike Flowers wrote:
Hi John,
 
Here’s how I change CW keying speed with N1MM+ function keys:
 

 
- 73 and good DX de Mike, K6MKF, Past President - NCDXC
 
From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of John Brodie
Sent: Thursday, March 22, 2018 1:46 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] CW on the IC-7610
 
Many thanks to those who replied to my post by direct email.  For the benefit of the group, here is my response to trying the suggestions offered to the problem of “erratic dot-dash ratio CW sent by function keys” (note: CW sending by paddle and from 7610 canned messages is OK):
  1. RFI in the shack is pretty much ruled out as the problem even occurs at TX low power into a dummy load.  In any case when normally transmitting, RF from properly grounded equipment goes to a resonant antenna with double shielded coax feed.
  2. It was suggested that changing the USB cable to another USB port might fix it – it doesn’t.
  3. It was also suggested that the CPU might be the problem; here is what we are using: Intel (R) Core ™ Quad CPU at 2.66 GHz, with 232 GB memory and only 38 GB used; Win 10 Pro; 8 GB RAM – seems unlikely that CPU horsepower would be the problem but I am certainly no expert.
Spent several hours checking over everything I could think of but no cigar.  This raises another question in my mind:  I see no way of changing the speed of the CW sent from function keys.  Further suggestions will be much appreciated. 
73 to all

Steve London
 

Hasn't this been answered numerous times ? Replace your Prolifics-based USB-to-serial converter to an FTDI-based converter. Less than $15 at newegg.com .

73,
Steve, N2IC

*From:* N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> *On Behalf Of *John Brodie
*Sent:* Wednesday, March 21, 2018 2:31 PM
*To:* N1MMLoggerPlus@groups.io
*Subject:* [N1MMLoggerPlus] CW on the IC-7610
I have just set up the IC-7610 with N1MM+ following K3CT's procedure, so that CW is being sent via the "A" com port, same as radio control.  However, when sending CW messages using the function keys, the CW is distorted, i.e. the ratio of dots to dashes is incorrect and cannot be corrected with the keyer settings on the radio.  It does not improve if I change the N1MM configuration to send via the "B" com port.  Can anyone tell me what is wrong?  Help much appreciated.
John VA7XB

Joe WB9SBD
 
Edited

Or get a WinKeyer,,,

Joe WB9SBD

The Original Rolling Ball Clock
Idle Tyme
Idle-Tyme.com
http://www.idle-tyme.com

On 3/22/2018 4:09 PM, Steve London wrote:
Hasn't this been answered numerous times ? Replace your Prolifics-based USB-to-serial converter to an FTDI-based converter. Less than $15 at newegg.com .

73,
Steve, N2IC


*From:* N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> *On Behalf Of *John Brodie
*Sent:* Wednesday, March 21, 2018 2:31 PM
*To:* N1MMLoggerPlus@groups.io
*Subject:* [N1MMLoggerPlus] CW on the IC-7610

I have just set up the IC-7610 with N1MM+ following K3CT's procedure, so that CW is being sent via the "A" com port, same as radio control.  However, when sending CW messages using the function keys, the CW is distorted, i.e. the ratio of dots to dashes is incorrect and cannot be corrected with the keyer settings on the radio.  It does not improve if I change the N1MM configuration to send via the "B" com port.  Can anyone tell me what is wrong?  Help much appreciated.
John VA7XB







John Bednar
 

John,

 

Did you try the first two items that I suggested?

 

>If the USB connection is routed through a USB hub, plug the radio cable directly into the PC, bypassing the USB hub.

>I seem to remember someone discovering that some PC USB ports suffered from latency so if the computer has multiple USB ports, try another.

 

 

Here are the CW speed keystrokes:

http://n1mm.hamdocs.com/tiki-index.php?page=Key+Assignments+-+Keyboard+Shortcuts&structure=N1MM+Logger+Documentation#CW_Key_Assignments

 

John

 

 

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of John Brodie
Sent: Thursday, March 22, 2018 4:46 PM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] CW on the IC-7610

 

Many thanks to those who replied to my post by direct email.  For the benefit of the group, here is my response to trying the suggestions offered to the problem of “erratic dot-dash ratio CW sent by function keys” (note: CW sending by paddle and from 7610 canned messages is OK):

1.     RFI in the shack is pretty much ruled out as the problem even occurs at TX low power into a dummy load.  In any case when normally transmitting, RF from properly grounded equipment goes to a resonant antenna with double shielded coax feed.

2.     It was suggested that changing the USB cable to another USB port might fix it – it doesn’t.

3.     It was also suggested that the CPU might be the problem; here is what we are using: Intel (R) Core ™ Quad CPU at 2.66 GHz, with 232 GB memory and only 38 GB used; Win 10 Pro; 8 GB RAM – seems unlikely that CPU horsepower would be the problem but I am certainly no expert.

Spent several hours checking over everything I could think of but no cigar.  This raises another question in my mind:  I see no way of changing the speed of the CW sent from function keys.  Further suggestions will be much appreciated. 

73 to all

John Brodie
 

The IC-7610 has virtual com ports, so there is no USB – serial adaptor involved other than may be in the radio itself. 

John Brodie
 

As I explained earlier, CW sent from the paddle and from the “canned” IC-7610 messages is fine.  It is my understanding that the CW sent using the function keys from mc files is generated within N1MM and an external keyer would not help. 

John VA7XB

John Brodie
 

Yes, thankyou John and others for your suggestions.  Everything suggested has been tried, including relocating the USB connection to other USB ports on the radio, but nothing changed.  I am not using a hub.  

John VA7XB

Tom - N1MM
 

http://n1mm.hamdocs.com/tiki-index.php?page=Most+Frequently+Asked+Questions+or+FAQ#Q._My_CW_weight_is_way_off._I_m_using_a_USB-to-serial_adapter_and_keying_with_RTS_or_DTR._Why_

3.3 - 3.5

Are you sending slowly and using break-in or full break-in? Press the transmit button on the rig. Is the sending better?

73,
Tom - N1MM

 

Matt Murphy
 

I'd suggest testing out the keying on a code practice oscillator or some similar device, to completely rule out the computer hardware+software. 

73,
Matt NQ6N

On Fri, Mar 23, 2018 at 10:27 AM, Tom - N1MM <Tom@...> wrote:

http://n1mm.hamdocs.com/tiki-index.php?page=Most+Frequently+Asked+Questions+or+FAQ#Q._My_CW_weight_is_way_off._I_m_using_a_USB-to-serial_adapter_and_keying_with_RTS_or_DTR._Why_

3.3 - 3.5

Are you sending slowly and using break-in or full break-in? Press the transmit button on the rig. Is the sending better?

73,
Tom - N1MM

 


John Bednar
 

John,

 

Open Device Manager, expand COM ports, turn off the radio power supply or unplug the USB cable. Do two Silicon Labs drivers disappear? If the driver is not “Silicon Labs” based, it is wrong.

 

If it is, open the Properties window, select the Driver tab. What Driver Version are you using? There was a problem version that prevented operation above 4800 baud. You don’t want to be using that version. I am using version 6.7.4.261     Date: 9/16/2016.

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of John Brodie
Sent: Friday, March 23, 2018 9:48 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] CW on the IC-7610

 

Yes, thankyou John and others for your suggestions.  Everything suggested has been tried, including relocating the USB connection to other USB ports on the radio, but nothing changed.  I am not using a hub.  

John VA7XB

John Brodie
 

 

I am grateful to several contributors who have made constructive suggestions over the past couple weeks - hope I have not failed to acknowledge any.  Recall my issue is that CW sent by N1MM+ function keys or with ctrl-k from the keyboard was of unacceptable quality due to improper ratio of dot length to dash length.  To be specific, the dashes are too short.  However, CW sent by paddle is fine, as is CW sent from 7610 memory. 

 

Since reporting previously, I have found that at 20 wpm the CW is OK; it’s only when the speed is increased above say 24 wpm that the problem becomes noticeable. I had been testing only above 30 wpm and didn’t made the discovery until recently that things improved at slower speeds.  Here’s what else:

 

1.      Changing theN1MM+ Logger configuration CW weight under the “Other” tab to lower or higher than the default 50 alters the CW quality but does not fix the problem.

2.      I have re-installed the Silicon Labs UART v. 6.7.4 drivers just for good measure.  Virtual port A turns out to be com 4 and port B is com 5 for my computer.  N1MM+ is configured accordingly.

3.      I have tried changing USB cables and connecting to other USB ports on the computer, with no effect.

4.      Computer speed and memory would appear not to be an issue.  The PC is running Windows 10.

5.      Several times I have checked my installation with K3CT’s detailed instructions and find no discrepancies.

6.      SSB, CW and RTTY appear to work correctly in every way except as described above.

7.      RFI is not an issue – all testing was done on a dummy load at low power.

8.      7610 firmware has been updated to version 1.06.

9.      N1MM+ Logger is up to date.

10.  I have recently paired the 7610 with two other computers running N1MM but the CW problem could not be duplicated, i.e. it works fine on those machines.  Any N1MM settings discrepancies between the two were eliminated before the test, so the problem appears to be the original PC and not N1MM or the 7610.

 

I am now resigned to running the 7610 on a different computer.  Sure wish I knew what caused the problem, though.

 

Many thanks for all the help from the group.

John VA7XB

 

Tom Wagner (N1MM)
 

1. What is the exact make and model of the computer with the issue?

2. Please post snipping tool grabs of the Ports, Universal serial bus controllers and Universal Serial Bus devices sections of Device Manager.  Expand those sections so the items are visible.

3. Try disabling your virus program and see if that affects the timing.

4.  My bet is that the USB interface is delaying the sending of cw to the computer. Set up to monitor audio on the 7610 (assuming it is the same as the 7300).  See the attached pic. Set a message to 50 E's with no spaces and measure the length of the dits with the radio.  At 20 WPM, they should be 60 msec long. At 40 wpm, they should be 30 msec. Note the rise time you are using.  My screen shot has a rise time of 6 msec.

Tom - N1MM

On 3/29/2018 9:27 PM, John Brodie wrote:

I am grateful to several contributors who have made constructive suggestions over the past couple weeks - hope I have not failed to acknowledge any.  Recall my issue is that CW sent by N1MM+ function keys or with ctrl-k from the keyboard was of unacceptable quality due to improper ratio of dot length to dash length.  To be specific, the dashes are too short. However, CW sent by paddle is fine, as is CW sent from 7610 memory.

Since reporting previously, I have found that at 20 wpm the CW is OK; it’s only when the speed is increased above say 24 wpm that the problem becomes noticeable. I had been testing only above 30 wpm and didn’t made the discovery until recently that things improved at slower speeds.  Here’s what else:

1.Changing theN1MM+ Logger configuration CW weight under the “Other” tab to lower or higher than the default 50 alters the CW quality but does not fix the problem.

2.I have re-installed the Silicon Labs UART v. 6.7.4 drivers just for good measure.  Virtual port A turns out to be com 4 and port B is com 5 for my computer.  N1MM+ is configured accordingly.

3.I have tried changing USB cables and connecting to other USB ports on the computer, with no effect.

4.Computer speed and memory would appear not to be an issue.  The PC is running Windows 10.

5.Several times I have checked my installation with K3CT’s detailed instructions and find no discrepancies.

6.SSB, CW and RTTY appear to work correctly in every way except as described above.

7.RFI is not an issue – all testing was done on a dummy load at low power.

8.7610 firmware has been updated to version 1.06.

9.N1MM+ Logger is up to date.

10.I have recently paired the 7610 with two other computers running N1MM but the CW problem could not be duplicated, i.e. it works fine on those machines.  Any N1MM settings discrepancies between the two were eliminated before the test, so the problem appears to be the original PC and not N1MM or the 7610.

I am now resigned to running the 7610 on a different computer.  Sure wish I knew what caused the problem, though.

Many thanks for all the help from the group.

John VA7XB

ART SEARLE <w2nra@...>
 

This may be overkill and/or redundent but what I do to make sure my Windows 10 PC keeps running fast so I don't have any rig control or software issues is as follows:

I got to Control Panel, System and Security, Power Options, Change when the computer sleeps.
1. Turn off the display: I do let the display turn off after one your
2. Put the computer to sleep:  Never
Change advanced power settings:  I go through every setting and either turn off the sleep setting or, if not available, set a really long time (example: Hard disk - Turn off hard disk after 10000 minutes.

In the 2 folders listed below, I go into the properties of each listing looking for the "Power Management" tab and make sure the "Allow the computer to turn off this device to save power" is not checked.
1. Device Manager to Ports (COM & LPT)
2. Universal Serial Bus controllers

I also go into Task Manager (right click on task bar) and check for heavy resource users. Don't forget to check the "More details" option.

Periodically I double check these settings because I have found instances where a Windows 10 updates has turned sleep mode back on.

73, Art W2NRA

On Apr 02, 2018, at 08:12 AM, "Tom Wagner (N1MM)" <n1mmtomwagner@...> wrote:

1. What is the exact make and model of the computer with the issue?

2. Please post snipping tool grabs of the Ports, Universal serial bus
controllers and Universal Serial Bus devices sections of Device
Manager.  Expand those sections so the items are visible.

3. Try disabling your virus program and see if that affects the timing.

4.  My bet is that the USB interface is delaying the sending of cw to
the computer. Set up to monitor audio on the 7610 (assuming it is the
same as the 7300).  See the attached pic. Set a message to 50 E's with
no spaces and measure the length of the dits with the radio.  At 20 WPM,
they should be 60 msec long. At 40 wpm, they should be 30 msec. Note the
rise time you are using.  My screen shot has a rise time of 6 msec.

Tom - N1MM


On 3/29/2018 9:27 PM, John Brodie wrote:

I am grateful to several contributors who have made constructive
suggestions over the past couple weeks - hope I have not failed to
acknowledge any.  Recall my issue is that CW sent by N1MM+ function
keys or with ctrl-k from the keyboard was of unacceptable quality due
to improper ratio of dot length to dash length.  To be specific, the
dashes are too short. However, CW sent by paddle is fine, as is CW
sent from 7610 memory.

Since reporting previously, I have found that at 20 wpm the CW is OK;
it’s only when the speed is increased above say 24 wpm that the
problem becomes noticeable. I had been testing only above 30 wpm and
didn’t made the discovery until recently that things improved at
slower speeds.  Here’s what else:

1.Changing theN1MM+ Logger configuration CW weight under the “Other”
tab to lower or higher than the default 50 alters the CW quality but
does not fix the problem.

2.I have re-installed the Silicon Labs UART v. 6.7.4 drivers just for
good measure.  Virtual port A turns out to be com 4 and port B is com
5 for my computer.  N1MM+ is configured accordingly.

3.I have tried changing USB cables and connecting to other USB ports
on the computer, with no effect.

4.Computer speed and memory would appear not to be an issue.  The PC
is running Windows 10.

5.Several times I have checked my installation with K3CT’s detailed
instructions and find no discrepancies.

6.SSB, CW and RTTY appear to work correctly in every way except as
described above.

7.RFI is not an issue – all testing was done on a dummy load at low power.

8.7610 firmware has been updated to version 1.06.

9.N1MM+ Logger is up to date.

10.I have recently paired the 7610 with two other computers running
N1MM but the CW problem could not be duplicated, i.e. it works fine on
those machines.  Any N1MM settings discrepancies between the two were
eliminated before the test, so the problem appears to be the original
PC and not N1MM or the 7610.

I am now resigned to running the 7610 on a different computer.  Sure
wish I knew what caused the problem, though.

Many thanks for all the help from the group.

John VA7XB







--
73, Art, W2NRA
DXCC CW Honor Roll
CWOPS #1955
SKCC #11634Sx5