Date   
RIGBlaster

Carlos
 

Hi fellows, I am sure this is a familiar topic.  This weekend I could not make M1MM to work on CW from my laptop (Windows 7) to my rig (Icom 7800).  It was sending wrong messages.

Please help , any hint is welcomed.

Carlos (NP4IW)


Virus-free. www.avast.com

Re: Message Transmit Delays

 

I had exactly the same problem on an I7.  "Enter Send Message" was on.  After hitting the enter key to transmit the exchange, I would get a noticeable delay.   The usual fixes did work, eg, limiting spots, etc, etc. Very irritating and it caused numerous problems when working the "real fast" guys. To compensate,  I would ( I usually got out of sync with them) I used F2 to get back in sync. It only seemed to happen when sending the exchange. There were no extra spaces in my macros

73

Jim W7CT.

On 5/28/2018 8:25 AM, Bill K6WSC wrote:


The computer is a Dell Inspiron 3646. I have made no
hardware changes, but regularly update N1MM+ and Windows.

73, Bill K6WSC

Re: CQ-Repeat is lost with {WIPE}{F1}

Steve London
 

Try this in your F8:

{CQ}{WIPE}{F1}

73,
Steve, N2IC

On 05/27/2018 01:29 AM, Bill, K2PO wrote:
On my K3, after a CQ with no answer (with CQ-Repeat set), I'll hit A/B and briefly tune for stations.A callsign will occasionally pop into log window.When I'm ready to resume CQing, I hit A/B again, and hit F8, which I've programmed with {WIPE}{F1}.This has the desired effect of clearing the log window, and sending a CQ.But the CQ doesn't auto-repeat.I have to hit the F1 button to get CQ-Repeat operative again.(The same behavior happens whenever I hit the F8 button; it doesn't seem to involve the A/B operations.It isn't specific to F8 either; it does the same if F7 is programmed that way.)
It seems the {F1} macro should re-activate CQ-Repeat, just as pressing the F1 key does.Is this a bug, or am I missing some rationale for this behavior?
Tks,
/Bill, K2PO

Partial Calls being sent

Bob WB2NVR
 

In S&P, after receiving my report, I want to send HIS Call, followed by R, and then my exchange.  Using ! R {EXCH} {Log} in F2 works, but only sends the last letter of his call.  I had this problem a while ago, and the solution was to uncheck send partial calls. Using W 10, the latest N1MM, with send partial calls unchecked, I still only send the last letter of his call.  I had to press F5  !, and then F2 without the ! To send his call and then the exchange.  In the United file, send partial call was false.  Is this by design, or do I have something set up incorrectly?

TNX, 73,
Bob WB2NVR

Re: Message Transmit Delays

Bill K6WSC
 

The computer is a Dell Inspiron 3646. I have made no hardware changes, but regularly update N1MM+ and Windows.

73, Bill K6WSC

Re: Maximum Q's per database?

Larry K8UT
 

Tim

In our initial database selection/performance testing for N1MM+ (years ago) we tested SQLite with logs of 1 million contacts. We observed a small amount of performance loss, but the difference based on record count was very low - less than 100 milliseconds. Your problem cannot be merely that you're hitting a max number of records in the log. But those tests were performed on hardware that had no other events competing for CPU cycles.

During contests - especially popular contests with a high packet spot load - there are many factors that would impact performance, including record count. I have never witnessed the type of delay you're describing, but my general advice is to throw more horsepower at the problem: faster CPU, SS drive, better graphics card, more RAM. Disable competing applications (browser, chat, email, windows updates...) and when possible outsource programs to another device (for example - run VE7CC on a different PC in the shack).

-larry (K8UT)

------ Original Message ------
From: "Tim Shoppa" <tshoppa@...>
Sent: 2018-05-28 09:20:23
Subject: [N1MMLoggerPlus] Maximum Q's per database?

Is there a recommended maximum number of Q's per database using N1MM+ new database format SQLite?

I ask because in WPX CW I saw some multi-second to most-of-a-minute slowdowns where typing callsigns into the entry box was just frozen. Worst case I had to log a couple Q's to paper (I would say not more than a minute.) I log a lot using N1MM+ and that's not normal.

I am approaching 100,000 Q's in the current database (started over in summer 2016) so I suspect the database is simply too full. That's a pretty vague suspicion.

N1MM-pre-plus it was rare for me to reach 20,000Q's in a database before the database crashed and I started over, so I don't have much experience with logger databases getting this big.

I don't think it was OS swapping because other things on the desktop were still snappy.

Tim N3QE

Re: Maximum Q's per database?

Tom Wagner (N1MM)
 

I was speaking of the Mult Window. The Available Window also will use a lot of resource with WPX because there are so many mults.

73,

Tom

On 5/28/2018 9:35 AM, Tim Shoppa wrote:
Yes, I had spotting turned on and was getting the aggregated reversebeacon spots through a VE7CC node. I can't rule out it being related to telnet spot volume (but maybe that hits the database too?)

The problem this past weekend was very very occasional (happened several times a day). Some random checking typing into the same log today doesn't show it up.

I had the Available Q/Mult window up and would occasonally bounce between "Mults" and "Mults and Q's" display in that window. But I did not have the Mult window up. Tom, Not sure if that narrows down which Mult window you asked about.

Tim N3QE

Re: LOST QSOS

Richard Zalewski
 

Thanks to all....discovered by looking back in log that the sent number was upped by 100.  Must have been some typo at the time....continued without further incidents so all is well.


Richard 
W7ZR ex:5C5Z, CN2ZR, K2JSP, W6SBZ, W7KXR, K9ZIJ, W9KNF, W0KDF, W0MQU, J68ZR, KC6ZR, PJ4/W7ZR, KH2,W7ZR, KH6/W7ZR, V31ZR, VK4AAZ, XE2DV


Be joyful in hope, patient in affliction, faithful in prayer

On Sat, May 26, 2018 at 9:37 AM, Gerald Boutin (VE1DT) <groupsio@...> wrote:
On Sat, May 26, 2018 at 07:23 am, Richard Zalewski wrote:
JUST LOST AN EVEN 100 QSOS....GIVING OUT 577 AND SCORE WINDOW REPORTS 477??????

Richard 
W7ZR ex:5C5Z, CN2ZR, K2JSP, W6SBZ, W7KXR, K9ZIJ, W9KNF, W0KDF, W0MQU, J68ZR, KC6ZR, PJ4/W7ZR, KH2,W7ZR, KH6/W7ZR, V31ZR, VK4AAZ, XE2DV
 
Be joyful in hope, patient in affliction, faithful in prayer

 Richard,

Did you edit a qso record for a recent qso? If you made a typo on the sent number, such as editing 475 to 476, but accidentally typed 576, then the program would continue forward at 577.

--
Gerald, VE1DT


Re: Maximum Q's per database?

Tim Shoppa
 

Yes, I had spotting turned on and was getting the aggregated reversebeacon spots through a VE7CC node. I can't rule out it being related to telnet spot volume (but maybe that hits the database too?)

The problem this past weekend was very very occasional (happened several times a day). Some random checking typing into the same log today doesn't show it up.

I had the Available Q/Mult window up and would occasonally bounce between "Mults" and "Mults and Q's" display in that window. But I did not have the Mult window up. Tom, Not sure if that narrows down which Mult window you asked about.

Tim N3QE

Re: Maximum Q's per database?

Tom Wagner (N1MM)
 

Try logging to that contest now, without any Qs from Telnet.  That will isolate the problem. It might be that you were trying to process too many spots.  It could also be that you were displaying the Mult window.  Not really a good idea with WPX.

Tom - N1MM

On 5/28/2018 9:20 AM, Tim Shoppa wrote:
Is there a recommended maximum number of Q's per database using N1MM+ new database format SQLite?

I ask because in WPX CW I saw some multi-second to most-of-a-minute slowdowns where typing callsigns into the entry box was just frozen. Worst case I had to log a couple Q's to paper (I would say not more than a minute.) I log a lot using N1MM+ and that's not normal.

I am approaching 100,000 Q's in the current database (started over in summer 2016) so I suspect the database is simply too full. That's a pretty vague suspicion.

N1MM-pre-plus it was rare for me to reach 20,000Q's in a database before the database crashed and I started over, so I don't have much experience with logger databases getting this big.

I don't think it was OS swapping because other things on the desktop were still snappy.

Tim N3QE

Maximum Q's per database?

Tim Shoppa
 

Is there a recommended maximum number of Q's per database using N1MM+ new database format SQLite?

I ask because in WPX CW I saw some multi-second to most-of-a-minute slowdowns where typing callsigns into the entry box was just frozen. Worst case I had to log a couple Q's to paper (I would say not more than a minute.) I log a lot using N1MM+ and that's not normal.

I am approaching 100,000 Q's in the current database (started over in summer 2016) so I suspect the database is simply too full. That's a pretty vague suspicion.

N1MM-pre-plus it was rare for me to reach 20,000Q's in a database before the database crashed and I started over, so I don't have much experience with logger databases getting this big.

I don't think it was OS swapping because other things on the desktop were still snappy.

Tim N3QE

Re: N1MM crashed and will not start .. How can I get find the 260 QSO already in the log? #n1mm

Larry K8UT
 

Jan

GOOD NEWS
Your database and log contain a total of 10581 contacts, 272 were from the CQWPXCW contest. The .TRN transaction backup also contains 272 contacts from this contest, verifying the record count in your log. The existence of the SQLite companion .wal and .shm files indicates that your computer suffered an abend of some sort, but your log is intact. 

HOW SHOULD YOU PROCEED?
Did you perform a fresh install of N1MM+ and continue operating in the CQWPXCW contest? Is there now a new database and log with some contacts in it?

Your answer to that question will determine if/how we blend together your contacts for one complete log.

-larry (K8UT)

------ Original Message ------
From: "Jan Visser" <adresrjv@...>
Sent: 2018-05-26 18:39:03
Subject: Re: [N1MMLoggerPlus] N1MM crashed and will not start .. How can I get find the 260 QSO already in the log? #n1mm #n1mm

Hello Larry
My callsign is PG2AA
 
In the folder I see some S3db files
N1MM Admin.s3db with a date time stamp after the crash
and tstlogpg2aa.s3db

I will  try to send you this files

Wonder if I can do a new install and keep the old database?

Hope you receive this mail

Ja PG2AA



2018-05-26 23:06 GMT+02:00 Larry K8UT <k8ut@...>:
Jan,

What is your callsign? 

From your description of what happened, I do not think this is a case of a corrupt database, but I will examine it and let you know.

Look in that copy of your Documents\N1MM Logger+\Databases folder for any files matching the name of your database. There should be one file with a .s3db suffix, and there may be files with .wal and .shm suffixes. ZIP those together and send them to me.

Also, look in the ...\Databases\TransactionLogFiles directory for any .trn files with the name and date of this contest. ZIP them together in a separate file and send them as well.

-larry (K8UT)

------ Original Message ------
Sent: 2018-05-26 14:06:02
Subject: [N1MMLoggerPlus] N1MM crashed and will not start .. How can I get find the 260 QSO already in the log? #n1mm #n1mm

N1MM crashed  and will not start  .. How can I get find the 260 QSO already in the log?  My Pc  running window Vista  crashed
N1MM did not start after the crash.  and got the message Maybe  ini file corrupted. Did try to rename one of the bak file with no luck
In WPX contest now so thats a problem. Do I need to make a new install…   I have made a copy of the old N1MM directory

But  I miss now about 260 QSO's .. Is  there a way the recover the QSO in the corrupt log?

Any Ideas?  
Jan


Re: Message Transmit Delays

Rick Tavan
 

Although I do sometimes run MM on Win 7 under VMware Fusion on a Mac, the message delay problem I reported that initiated this thread long ago was on native Win 10 on a Dell XPS13.

/Rick N6XI 


Rick Tavan
Truckee, CA

On Sun, May 27, 2018 at 1:19 PM, John Bednar <k3ct@...> wrote:
Bill,

I  believe Rick is using a Mac.
Are you using a Mac?

There has been no change specific program change and no reproducible case. You can install any previous update if you want to verify. they are posted on the web page.

John, K3CT

I had the exact same problem Rick described in his initial Message Transmit Delays post. I spent many hours trying many different things to fix it. Nothing helped. The problem exhibited itself for most of the last contest season.
 
Equipment list: Kenwood TS-590SG, a Kenwood TS-590S, microHAM micro2R SO2R controller, Navigator Interface.
 
No delays in the WPX!



-----Original Message-----
From: Bill K6WSC <bill.clark.jr@...>
To: N1MMLoggerPlus <N1MMLoggerPlus@groups.io>
Sent: Mon, May 28, 2018 12:39 am
Subject: Re: [N1MMLoggerPlus] Message Transmit Delays

The Windows 10, version 1803 feature update (May 2018) seemed to fix my Message Transmit Delay problem.
 
I had the exact same problem Rick described in his initial Message Transmit Delays post. I spent many hours trying many different things to fix it. Nothing helped. The problem exhibited itself for most of the last contest season.
 
Equipment list: Kenwood TS-590SG, a Kenwood TS-590S, microHAM micro2R SO2R controller, Navigator Interface.
 
No delays in the WPX!
 
73, Bill K6WSC
 
PS If the N1MM+ team actually fixed the problem, thanks!


Re: [Spectrum Display] Shift-UpArrow needs an OtherRadio companion

Rick Tavan
 

Tom - Great! Thanks for the almost instantaneous response! I'll try it when I get the gear unpacked. I'm already back in the valley after WPX CW in the mountains this weekend. 

Others - This was my first contest with Spectrum Display. I connected my K3 to an Airspy HF+ that Tom convinced me to pick up in Dayton. It totally changed the way I S&P, dramatically reducing arm motion and time between signals. The added feature described above (Alt-Up/Down to take 2nd radio or VFO to the next discerned signal, regardless of whether it has been identified) will provide the same benefit in SO2V operation that I experienced using a single receiver at a time. This really is a $200 panadapter that slides into a shirt pocket behind my glasses case! 

73,

/Rick N6XI 


Rick Tavan
Truckee, CA

On Sun, May 27, 2018 at 4:29 AM, Tom - N1MM <Tom@...> wrote:
Spectrum: Alt+Up/Down will jump from signal to signal on the non-focus radio (N6XI) (Coded by N1MM)

In the experimental files gallery.  

73,
Tom


IC-7610 PC configuration

Tad Danley
 

I found the support file for configuring my 7610 for FSK RTTY with a single USB cable.  Are there instructions available for configuring it for AFSK RTTY, MSK144 and FT8?

 

Thanks and 73,

 

--

Tad Danley, K3TD

 

Re: N1MM crashed and will not start .. How can I get find the 260 QSO already in the log? #n1mm

John Bednar
 


Jan,

Make sure you do not allow mirroring, computer scanning, or backup of the Logger+ Databases directory while the program is running. These programs do not know how to deal with cache files and are a cause of database corruption.

John, K3CT



-----Original Message-----
From: Jan Visser <adresrjv@...>
To: N1MMLoggerPlus <N1MMLoggerPlus@groups.io>
Sent: Sun, May 27, 2018 6:45 am
Subject: Re: [N1MMLoggerPlus] N1MM crashed and will not start .. How can I get find the 260 QSO already in the log? #n1mm #n1mm

Hello Larry
My callsign is PG2AA
 
In the folder I see some S3db files
N1MM Admin.s3db with a date time stamp after the crash
and tstlogpg2aa.s3db

I will  try to send you this files

Wonder if I can do a new install and keep the old database?

Hope you receive this mail

Ja PG2AA



2018-05-26 23:06 GMT+02:00 Larry K8UT <k8ut@...>:
Jan,

What is your callsign? 

From your description of what happened, I do not think this is a case of a corrupt database, but I will examine it and let you know.

Look in that copy of your Documents\N1MM Logger+\Databases folder for any files matching the name of your database. There should be one file with a .s3db suffix, and there may be files with .wal and .shm suffixes. ZIP those together and send them to me.

Also, look in the ...\Databases\TransactionLogFiles directory for any .trn files with the name and date of this contest. ZIP them together in a separate file and send them as well.

-larry (K8UT)

------ Original Message ------
Sent: 2018-05-26 14:06:02
Subject: [N1MMLoggerPlus] N1MM crashed and will not start .. How can I get find the 260 QSO already in the log? #n1mm #n1mm

N1MM crashed  and will not start  .. How can I get find the 260 QSO already in the log?  My Pc  running window Vista  crashed
N1MM did not start after the crash.  and got the message Maybe  ini file corrupted. Did try to rename one of the bak file with no luck
In WPX contest now so thats a problem. Do I need to make a new install…   I have made a copy of the old N1MM directory

But  I miss now about 260 QSO's .. Is  there a way the recover the QSO in the corrupt log?

Any Ideas?  
Jan

Re: Message Transmit Delays

John Bednar
 

Bill,

I  believe Rick is using a Mac.
Are you using a Mac?

There has been no change specific program change and no reproducible case. You can install any previous update if you want to verify. they are posted on the web page.

John, K3CT

I had the exact same problem Rick described in his initial Message Transmit Delays post. I spent many hours trying many different things to fix it. Nothing helped. The problem exhibited itself for most of the last contest season.
 
Equipment list: Kenwood TS-590SG, a Kenwood TS-590S, microHAM micro2R SO2R controller, Navigator Interface.
 
No delays in the WPX!



-----Original Message-----
From: Bill K6WSC <bill.clark.jr@...>
To: N1MMLoggerPlus <N1MMLoggerPlus@groups.io>
Sent: Mon, May 28, 2018 12:39 am
Subject: Re: [N1MMLoggerPlus] Message Transmit Delays

The Windows 10, version 1803 feature update (May 2018) seemed to fix my Message Transmit Delay problem.
 
I had the exact same problem Rick described in his initial Message Transmit Delays post. I spent many hours trying many different things to fix it. Nothing helped. The problem exhibited itself for most of the last contest season.
 
Equipment list: Kenwood TS-590SG, a Kenwood TS-590S, microHAM micro2R SO2R controller, Navigator Interface.
 
No delays in the WPX!
 
73, Bill K6WSC
 
PS If the N1MM+ team actually fixed the problem, thanks!

Re: Message Transmit Delays

Bill K6WSC
 

The Windows 10, version 1803 feature update (May 2018) seemed to fix my Message Transmit Delay problem.

 

I had the exact same problem Rick described in his initial Message Transmit Delays post. I spent many hours trying many different things to fix it. Nothing helped. The problem exhibited itself for most of the last contest season.

 

Equipment list: Kenwood TS-590SG, a Kenwood TS-590S, microHAM micro2R SO2R controller, Navigator Interface.

 

No delays in the WPX!

 

73, Bill K6WSC

 

PS If the N1MM+ team actually fixed the problem, thanks!

Re: [Spectrum Display] Shift-UpArrow needs an OtherRadio companion

Tom - N1MM
 

Spectrum: Alt+Up/Down will jump from signal to signal on the non-focus radio (N6XI) (Coded by N1MM)

In the experimental files gallery.  

73,
Tom

CQ-Repeat is lost with {WIPE}{F1}

Bill, K2PO
 

On my K3, after a CQ with no answer (with CQ-Repeat set), I'll hit A/B and briefly tune for stations.  A callsign will occasionally pop into log window.  When I'm ready to resume CQing, I hit A/B again, and hit F8, which I've programmed with {WIPE}{F1}.  This has the desired effect of clearing the log window, and sending a CQ.  But the CQ doesn't auto-repeat.  I have to hit the F1 button to get CQ-Repeat operative again.  (The same behavior happens whenever I hit the F8 button; it doesn't seem to involve the A/B operations.  It isn't specific to F8 either; it does the same if F7 is programmed that way.)

 

It seems the {F1} macro should re-activate CQ-Repeat, just as pressing the F1 key does.  Is this a bug, or am I missing some rationale for this behavior?

Tks,

/Bill, K2PO