Date   
Re: Ctrl+Up Arrow & Ctrl+Down Arrow inconsistent with Spectrum "Reverse . . ." settings

ART SEARLE <w2nra@...>
 

I think I found the problem.  If you set this “Reverse frequency scale in bar chart mode“ to on without going to the Bar Spectrum display mode, then CTRL+Up/Down Arrow shortcuts are inconsistent. Also you cannot correct it by just turning off the "Reverse frequency scale in bar chart mode“.  However if you go into the Bar mode the CTRL+Up/Down Arrow shortcuts work properly and reverse once you close the Spectrum display.

Unless the programmers can come up with a better fix, I suggest they make the “Reverse frequency scale in bar chart mode“ button grayed out unless the Spectrum Display is in BAR mode.  And for the record, if you close the Spectrum Display while in Bar mode this does not cause any problems with the Ctrl+Up Arrow & Ctrl+Down Arrow shortcuts when the Spectrum is closed. 

 
73, Art W2NRA

On Mar 23, 2018, at 10:47 PM, ART SEARLE <w2nra@...> wrote:

Help,

In the lastest CWOPS CWT I ran into annoying inconsistencies in the function of the Bandmap Ctrl+Up Arrow & Ctrl+Down Arrow macros after closing the Spectrum Display window.  Sometimes the macros were working in reverse order.  I tried reopening and closing the Spectrum Display to get the macros working properly. That didn't work.

After the contest I did some testing. I could not get consistent results when opening or closing the Spectrum display. The bug I found is caused by the Spectrum Display closing with Spectrum setting “Reverse frequency scale in bar chart mode“ enabled.  This causes the order of the Bandmap shortcuts Ctrt+Up Arrow and CTRL+Down Arrow to stay reversed after reopening N1MM Logger+.  To get this corrected I have to opened the Spectrum, turn off the “Rev . . .” then closet the Spectrum, then close and restart N1MM Logger+. The shortcuts were working properly.  I then opened Spectrum.  Now, with Spectrum opened and not set to "Rev . . ." but shortcuts were reversed. If I set "Rev . . . " the macros now are not reversed when they should be. I am totally confused by this because I never got consistent results.

During the CWT contest I found it maddening when I wanted to go up frequency by one spot but the pointer went down one post. 

73, Art, W2NRA

--
73, Art, W2NRA
DXCC CW Honor Roll
CWOPS #1955
SKCC #11634Sx5








--
73, Art, W2NRA
DXCC CW Honor Roll
CWOPS #1955
SKCC #11634Sx5

Re: N1MM Corrupt on Startup

John Bednar
 

Tom,

 

I saw Rich’s email.

 

It would be good to know what caused this. Any corruption of the database cache files will likely lead to garbled database.

 

Do you have the database directory on a disk that briefly lost connectivity, database directory storage on the cloud, or the database directory backed up by a mirror program?  

 

I suspect that that with some computers going into hibernation while the program was running or abnormal program exit could cause the cache file corruption.

 

John, K3CT

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of Thomas Rieff (K0YR)
Sent: Saturday, March 24, 2018 7:30 AM
To: N1MMLoggerPlus@groups.io
Subject: [N1MMLoggerPlus] N1MM Corrupt on Startup

 

Last night I thought I would play a little in the WPX.
In starting N1MM, it gave multiple  error messages which look like corrupt databases.
Other than reinstalling, any options to correct?
Will my settings be saved?
This has been flawless until this point.
Thanks in advance for your comments.
Tom

Re: N1MM Corrupt on Startup

ve3ki
 

It's almost impossible to know what is happening from your description. Can you be a bit more specific about the error messages, and about the state they leave the program in?

Reinstalling will not fix anything. If your program used to work, the problem is not in the installation., and reinstalling will leave whatever caused the problem (either your configuration or the database) unaffected.

What have you changed between the last time it worked and now? New .mc file? Trying a phone contest for the first time? Or maybe the latest update to your anti-malware software getting more aggressive? Something must be different.

73,
Rich VE3KI


On Sat, Mar 24, 2018 at 04:30 am, Thomas Rieff (K0YR) wrote:
Last night I thought I would play a little in the WPX.
In starting N1MM, it gave multiple  error messages which look like corrupt databases.
Other than reinstalling, any options to correct?
Will my settings be saved?
This has been flawless until this point.
Thanks in advance for your comments.
Tom

N1MM Corrupt on Startup

Thomas Rieff (K0YR)
 

Last night I thought I would play a little in the WPX.
In starting N1MM, it gave multiple  error messages which look like corrupt databases.
Other than reinstalling, any options to correct?
Will my settings be saved?
This has been flawless until this point.
Thanks in advance for your comments.
Tom

Re: SO2V NOT AVAILABLE

John Bednar
 

 

 

-----Original Message-----
From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of David W Wood \(G3YXX\) via Groups.Io
Sent: Saturday, March 24, 2018 6:57 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] SO2V NOT AVAILABLE

 

John - thanks for the reply.

 

The message is displayed in the configuration drop down list, as is a similar for SO2R.

 

I am pretty sure that previously I have seen SO1V.

 

73

 

David - G3YXX

 

-----Original Message-----

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of John Bednar

Sent: 24 March 2018 10:22

To: N1MMLoggerPlus@groups.io

Subject: Re: [N1MMLoggerPlus] SO2V NOT AVAILABLE

 

David,

 

Did you select "SO2V" in Config? If so, explain "SO2V NOT AVAILABLE".

 

John, K3CT

 

-----Original Message-----

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of David W Wood \(G3YXX\) via Groups.Io

Sent: Friday, March 23, 2018 3:38 PM

To: N1MMLoggerPlus@groups.io

Subject: [N1MMLoggerPlus] SO2V NOT AVAILABLE

 

Rig interface OK, K3/KAT500/KPA500.

 

Any ideas why not?

 

Nor is SO2R

 

I have set up F11 to swap VFO's in the interim.

 

73

 

David - G3YXX

 

 

 

 

 

 

 

 

Re: CW on the IC-7610

John Bednar
 

John,

 

Open Device Manager, expand COM ports, turn off the radio power supply or unplug the USB cable. Do two Silicon Labs drivers disappear? If the driver is not “Silicon Labs” based, it is wrong.

 

If it is, open the Properties window, select the Driver tab. What Driver Version are you using? There was a problem version that prevented operation above 4800 baud. You don’t want to be using that version. I am using version 6.7.4.261     Date: 9/16/2016.

 

John, K3CT

 

 

From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf Of John Brodie
Sent: Friday, March 23, 2018 9:48 AM
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] CW on the IC-7610

 

Yes, thankyou John and others for your suggestions.  Everything suggested has been tried, including relocating the USB connection to other USB ports on the radio, but nothing changed.  I am not using a hub.  

John VA7XB

Re: SO2V NOT AVAILABLE

David W Wood \(G3YXX\)
 

John - thanks for the reply.

The message is displayed in the configuration drop down list, as is a
similar for SO2R.

I am pretty sure that previously I have seen SO1V.

73

David - G3YXX

-----Original Message-----
From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of John
Bednar
Sent: 24 March 2018 10:22
To: N1MMLoggerPlus@groups.io
Subject: Re: [N1MMLoggerPlus] SO2V NOT AVAILABLE

David,

Did you select "SO2V" in Config? If so, explain "SO2V NOT AVAILABLE".

John, K3CT

-----Original Message-----
From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf
Of David W Wood \(G3YXX\) via Groups.Io
Sent: Friday, March 23, 2018 3:38 PM
To: N1MMLoggerPlus@groups.io
Subject: [N1MMLoggerPlus] SO2V NOT AVAILABLE

Rig interface OK, K3/KAT500/KPA500.

Any ideas why not?

Nor is SO2R

I have set up F11 to swap VFO's in the interim.

73

David - G3YXX

Re: SO2V NOT AVAILABLE

John Bednar
 

David,

Did you select "SO2V" in Config? If so, explain "SO2V NOT AVAILABLE".

John, K3CT

-----Original Message-----
From: N1MMLoggerPlus@groups.io [mailto:N1MMLoggerPlus@groups.io] On Behalf
Of David W Wood \(G3YXX\) via Groups.Io
Sent: Friday, March 23, 2018 3:38 PM
To: N1MMLoggerPlus@groups.io
Subject: [N1MMLoggerPlus] SO2V NOT AVAILABLE

Rig interface OK, K3/KAT500/KPA500.

Any ideas why not?

Nor is SO2R

I have set up F11 to swap VFO's in the interim.

73

David - G3YXX

Ctrl+Up Arrow & Ctrl+Down Arrow inconsistent with Spectrum "Reverse . . ." settings

ART SEARLE <w2nra@...>
 

Help,

In the lastest CWOPS CWT I ran into annoying inconsistencies in the function of the Bandmap Ctrl+Up Arrow & Ctrl+Down Arrow macros after closing the Spectrum Display window.  Sometimes the macros were working in reverse order.  I tried reopening and closing the Spectrum Display to get the macros working properly. That didn't work.

After the contest I did some testing. I could not get consistent results when opening or closing the Spectrum display. The bug I found is caused by the Spectrum Display closing with Spectrum setting “Reverse frequency scale in bar chart mode“ enabled.  This causes the order of the Bandmap shortcuts Ctrt+Up Arrow and CTRL+Down Arrow to stay reversed after reopening N1MM Logger+.  To get this corrected I have to opened the Spectrum, turn off the “Rev . . .” then closet the Spectrum, then close and restart N1MM Logger+. The shortcuts were working properly.  I then opened Spectrum.  Now, with Spectrum opened and not set to "Rev . . ." but shortcuts were reversed. If I set "Rev . . . " the macros now are not reversed when they should be. I am totally confused by this because I never got consistent results.

During the CWT contest I found it maddening when I wanted to go up frequency by one spot but the pointer went down one post. 

73, Art, W2NRA

--
73, Art, W2NRA
DXCC CW Honor Roll
CWOPS #1955
SKCC #11634Sx5

Re: RSP1A / N1MM+ Integration

Bud Trench
 

Steve - many thanks. I've got it up and running using the K3S IF output. Pretty cool! 73, Bud AA3B

-----Original Message-----
From: Steve London <n2icarrl@...>
Sent: Friday, March 23, 2018 2:08 PM
To: N1MMLoggerPlus@groups.io; aa3b.bud@... >> Bud Trench <aa3b.bud@...>
Subject: Re: [N1MMLoggerPlus] RSP1A / N1MM+ Integration

Forget Omni-Rig. Forget Win4K3Suite. Forget VSPE and other port sharing. Look
at Waterfall Bandmap.

https://groups.io/g/waterfallbandmap/

The latest version and the manual are in the Files area.

73,
Steve, N2IC

On 03/23/2018 11:32 AM, Bud Trench wrote:
I recently purchased a RSP1A and would like to integrate it with N1MM+.My
station is configured for SO2R and features 2 Elecraft K3S’s and a microHAM mK2R+.

I have downloaded SDRPlay and I’ve been successful in integrating the RSP1A with
Win-Test using Omni-Rig.I realize the N1MM+ does not support Omin-Rig (too bad).

I’ve seen several messages on this group suggesting the RSP1A / N1MM+
integration can be accomplished using Win4K3Suite. Are there any concerns
related to running Win4K3Suite in a configuration that includes the mK2R+?

Are there any other options for accomplishing the RSP1A / N1MM+ integration?

Does anyone have a step by step procedure for accomplishing the RSP1A / N1MM+
integration?

Thanks in advance,

Bud AA3B

SO2V NOT AVAILABLE

David W Wood \(G3YXX\)
 

Rig interface OK, K3/KAT500/KPA500.

Any ideas why not?

Nor is SO2R

I have set up F11 to swap VFO's in the interim.

73

David - G3YXX

Re: RSP1A / N1MM+ Integration

Drew Vonada-Smith K3PA
 

Hi Bud,

I don't use the RSP1A, but I was using Win4K3 in conjunction with uH router/MK2R+ and had no issues.  I ended up using Waterfall Bandmap to support LPPan/N1MM instead, but it was also fine with Win4K3 and Win4Yaesu.  Waterfall Bandmap is free and was generally lighter and easier to deal with for me.

73,
Drew K3PA

Re: N1MM logger+ on WINE on Linux.

Steef PA2A
 

Graham,

on his website 5tx.de Ulf DK5TX has information about WIn-Test and Wine. For CAT there is the mhuxd router tool for Digikeyers with a built-in Winkeyer. Prolific serial converters also work fine here to combine MMTTY and Win-Test in Wime.

73s Steve PA2A

Re: RSP1A / N1MM+ Integration

ve3ki
 

Hi Bud,

I don't have any experience with Win4K3Suite, but I do use an SDRPlay RSP2 with N1MM+ with the help of N2IC's Waterfall Bandmap software. This works well in either of two configurations - with the RSP connected to the K3's IF OUT jack, or with it connected to a splitter in a jumper between the K3's RX ANT OUT and RX ANT IN jacks. N1MM+'s Spectrum Display window works with the Waterfall Bandmap program.

When using the RX Ant loop, the Waterfall Bandmap settings are simple: no offset, do not check SDR at IF, do not swap I&Q.

When using the IF, I check the SDR at IF box and enter the IF (8215 kHz), I have to check the Swap I&Q box on all bands except for 6 meters, and the offset with 8-pole roofing filters is zero on CW, -1500 for LSB and +1500 for USB (there may also be an 85 Hz offset for RTTY). If you use IF shift, or with some combinations of sidetone pitch and IF bandwidth in CW, the IF offset might need a bit of tweaking. The offset becomes more complicated if you use 5-pole roofing filters, because of the filter offset.

Using the IF puts the RSP behind the bandpass filtering in the K3, which might be an advantage for this method in an SO2R setup. It might also make antenna switching simpler if you use separate RX antennas.

73,
Rich VE3KI


On Fri, Mar 23, 2018 at 10:32 am, Bud Trench wrote:

I recently purchased a RSP1A and would like to integrate it with N1MM+.  My station is configured for SO2R and features 2 Elecraft K3S’s and a microHAM mK2R+.

 

I have downloaded SDRPlay and I’ve been successful in integrating the RSP1A with Win-Test using Omni-Rig.  I realize the N1MM+ does not support Omin-Rig (too bad).

 

I’ve seen several messages on this group suggesting the RSP1A / N1MM+ integration can be accomplished using Win4K3Suite.  Are there any concerns related to running Win4K3Suite in a configuration that includes the mK2R+?

 

Are there any other options for accomplishing the RSP1A / N1MM+ integration?

 

Does anyone have a step by step procedure for accomplishing the RSP1A / N1MM+ integration?

 

Thanks in advance,

 

Bud AA3B

Re: RSP1A / N1MM+ Integration

Steve London
 

Forget Omni-Rig. Forget Win4K3Suite. Forget VSPE and other port sharing. Look at Waterfall Bandmap.

https://groups.io/g/waterfallbandmap/

The latest version and the manual are in the Files area.

73,
Steve, N2IC

On 03/23/2018 11:32 AM, Bud Trench wrote:
I recently purchased a RSP1A and would like to integrate it with N1MM+.My station is configured for SO2R and features 2 Elecraft K3S’s and a microHAM mK2R+.
I have downloaded SDRPlay and I’ve been successful in integrating the RSP1A with Win-Test using Omni-Rig.I realize the N1MM+ does not support Omin-Rig (too bad).
I’ve seen several messages on this group suggesting the RSP1A / N1MM+ integration can be accomplished using Win4K3Suite. Are there any concerns related to running Win4K3Suite in a configuration that includes the mK2R+?
Are there any other options for accomplishing the RSP1A / N1MM+ integration?
Does anyone have a step by step procedure for accomplishing the RSP1A / N1MM+ integration?
Thanks in advance,
Bud AA3B

RSP1A / N1MM+ Integration

Bud Trench
 

I recently purchased a RSP1A and would like to integrate it with N1MM+.  My station is configured for SO2R and features 2 Elecraft K3S’s and a microHAM mK2R+.

 

I have downloaded SDRPlay and I’ve been successful in integrating the RSP1A with Win-Test using Omni-Rig.  I realize the N1MM+ does not support Omin-Rig (too bad).

 

I’ve seen several messages on this group suggesting the RSP1A / N1MM+ integration can be accomplished using Win4K3Suite.  Are there any concerns related to running Win4K3Suite in a configuration that includes the mK2R+?

 

Are there any other options for accomplishing the RSP1A / N1MM+ integration?

 

Does anyone have a step by step procedure for accomplishing the RSP1A / N1MM+ integration?

 

Thanks in advance,

 

Bud AA3B

Re: Reset radio

Mike Flowers
 

Hi Walid,

 

I have my K3 working with N1MM+. 

 

I use an RS-232 COM port for COM4 for CAT control, rather than a USB/RS232 converter.

 

Here’s my Configurer Hardware tab:

 

 

- 73 and good DX de Mike, K6MKF, Past President - NCDXC

 

From: N1MMLoggerPlus@groups.io <N1MMLoggerPlus@groups.io> On Behalf Of walid karami via Groups.Io
Sent: Friday, March 23, 2018 6:29 AM
To: N1MMLoggerPlus@groups.io
Subject: [N1MMLoggerPlus] Reset radio

 

i configuered the n1mm to work with the elecraft k3 but I always get the message 
“ Radio1 stopped responding ! Press reset radio to retry “

any help please 

thank you

Re: CW on the IC-7610

Matt Murphy
 

I'd suggest testing out the keying on a code practice oscillator or some similar device, to completely rule out the computer hardware+software. 

73,
Matt NQ6N

On Fri, Mar 23, 2018 at 10:27 AM, Tom - N1MM <Tom@...> wrote:

http://n1mm.hamdocs.com/tiki-index.php?page=Most+Frequently+Asked+Questions+or+FAQ#Q._My_CW_weight_is_way_off._I_m_using_a_USB-to-serial_adapter_and_keying_with_RTS_or_DTR._Why_

3.3 - 3.5

Are you sending slowly and using break-in or full break-in? Press the transmit button on the rig. Is the sending better?

73,
Tom - N1MM

 


Re: CW on the IC-7610

Tom - N1MM
 

http://n1mm.hamdocs.com/tiki-index.php?page=Most+Frequently+Asked+Questions+or+FAQ#Q._My_CW_weight_is_way_off._I_m_using_a_USB-to-serial_adapter_and_keying_with_RTS_or_DTR._Why_

3.3 - 3.5

Are you sending slowly and using break-in or full break-in? Press the transmit button on the rig. Is the sending better?

73,
Tom - N1MM

 

Re: CW on the IC-7610

John Brodie
 

Yes, thankyou John and others for your suggestions.  Everything suggested has been tried, including relocating the USB connection to other USB ports on the radio, but nothing changed.  I am not using a hub.  

John VA7XB