N1MM+ updates ?

CW Morse
 

I'm on ver 1.0.7825.0
Usually I'm behind and I would get a window asking if I wanted to upgrade, and I'd click Yes.
Now it says my version is over 46 days old and I should update, but I can't find such a choice in any menu.  Am I being punished for getting too far behind ;=)
TIA   Don   K2BIO

Join N1MMLoggerPlus@groups.io to automatically receive all group messages.