AppImage EUMETCastView in WSL2 for Windows


Hugo
 

Hello,

After the experiments of Ernst I was intrigued by the Windows Subsystem for Linux. 
For the AppImage to work in Windows 10 ( without an XServer !) you need the latest version of the Microsoft Windows Insider program ( from the Dev channel).
Also you need the latest GPU driver for your card (AMD, Nvidia or Intel).
I tried to install this Windows version on my MSI portable computer but to no avail ( probably because it's dual boot). Than I installed it on a Windows 10 only machine, and that worked.
The GPU is from AMD.
I was able to install WSL 2 with GUI support on that machine and I could run apps like GIMP .
My AppImage also worked but the maximum GLSL version that is supported is 1.4 and 3.00 ES, so  the 3D Globe was not visible, although I could see that I have 6 paintGL/s writes.
Clearly, there is still a lot of work to do for the WSL team,  but I think this evolution of Windows is very exciting.
More info is available on https://docs.microsoft.com/en-us/windows/wsl/tutorials/gui-apps .

grts,
Hugo


Ernst Lobsiger
 

Hugo,

Graham might want to test that (I certainly will not, but I am curious anyway :-) :
Is it possible to run a TelliCast Linux receiver using the OpenSource TBS drivers
in a CLI WSL setup while doing the image processing under native Windows 10?

Regards,
Ernst