Date   

Re: TP 1 SNR - 'level.'

David J Taylor GM8ARV 🏴󠁧󠁢󠁳󠁣󠁴󠁿 🇪🇺
 

On 23/01/2021 12:11, Douglas Deans via groups.io wrote:
Weather in Europe is awful. I suspect that is the issue.
Regards,
Douglas.
Yes, Europe-wide, both transponders.


https://www.satsignal.eu/mrtg/performance_eumetcast-europe_link_margin.php

Cheers,
David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: PyTROLL/SatPy Starter Kit V3.0

R. Alblas
 

I have currently a PI4 8M in use constantly getting native data from Eumetsat internet (Python script), and creating/updating a multi-channel composite movie (using xrit2pic in commandline). Works very fine. I'll try satpy too.
Christian, how do you get the data? Tellicast doesn't work on ARM processors,as far as I know, so you need to use a "normal" PC for receiving, I assume? And you need ARM compiled Wavelet decompression software too, for MSG.

For Python scripts (based on Eumetsat examples) see:

http://www.alblas.demon.nl/wsat/software/eci.html

Rob.

On 23-01-2021 15:56, Ferdinand Valk wrote:

And all on a Raspberry Pi? Absolutely brilliant Christian. Thanks for sharing.

 

Ferdinand

 

From: MSG-1@groups.io On Behalf Of Christian Peters via groups.io
Sent: Saturday, 23 January, 2021 13:57
To: MSG-1@groups.io
Subject: Re: [MSG-1] PyTROLL/SatPy Starter Kit V3.0

 

Hi PyTROLL/SatPy Starter Kit users,

 

just for info: I installed the PyTROLL/SatPy Starter Kit V3.0 today successfully on a Raspberry Pi 4, 4GB RAM on MicroSD card. 

I had to solve some minor problems, but I’m amazed what is possible, even with the 4GB version. MSG4, Him8 and GOES16 full disk works, even MSG4 eurol area. I even could do a stacked NOAA-20 picture, all in around 3-5min per image.

S3A/B is not possible at the moment with 4GB ram. Maybe you have to install the system on an USB HD and activate swap to solve this issue or you switch to the 8GB RAM version. 



You really get a tiny little satellite image processor in combination with the PyTROLL/SatPy Starter Kit V3.0. 



I hope some native English speaker give the PyTROLL/SatPy Starter Kit V3.0 a try and we maybe will read something in next GEO Quaterly…? 

 

Regards,

 

Christian

 

See attached pics://snip



Re: PyTROLL/SatPy Starter Kit V3.0

Ferdinand Valk
 

And all on a Raspberry Pi? Absolutely brilliant Christian. Thanks for sharing.

 

Ferdinand

 

From: MSG-1@groups.io On Behalf Of Christian Peters via groups.io
Sent: Saturday, 23 January, 2021 13:57
To: MSG-1@groups.io
Subject: Re: [MSG-1] PyTROLL/SatPy Starter Kit V3.0

 

Hi PyTROLL/SatPy Starter Kit users,

 

just for info: I installed the PyTROLL/SatPy Starter Kit V3.0 today successfully on a Raspberry Pi 4, 4GB RAM on MicroSD card. 

I had to solve some minor problems, but I’m amazed what is possible, even with the 4GB version. MSG4, Him8 and GOES16 full disk works, even MSG4 eurol area. I even could do a stacked NOAA-20 picture, all in around 3-5min per image.

S3A/B is not possible at the moment with 4GB ram. Maybe you have to install the system on an USB HD and activate swap to solve this issue or you switch to the 8GB RAM version. 



You really get a tiny little satellite image processor in combination with the PyTROLL/SatPy Starter Kit V3.0. 



I hope some native English speaker give the PyTROLL/SatPy Starter Kit V3.0 a try and we maybe will read something in next GEO Quaterly…? 

 

Regards,

 

Christian

 

See attached pics://snip


Re: PyTROLL/SatPy Starter Kit V3.0

Christian Peters
 

Hi PyTROLL/SatPy Starter Kit users,

just for info: I installed the PyTROLL/SatPy Starter Kit V3.0 today successfully on a Raspberry Pi 4, 4GB RAM on MicroSD card. 
I had to solve some minor problems, but I’m amazed what is possible, even with the 4GB version. MSG4, Him8 and GOES16 full disk works, even MSG4 eurol area. I even could do a stacked NOAA-20 picture, all in around 3-5min per image.
S3A/B is not possible at the moment with 4GB ram. Maybe you have to install the system on an USB HD and activate swap to solve this issue or you switch to the 8GB RAM version. 

You really get a tiny little satellite image processor in combination with the PyTROLL/SatPy Starter Kit V3.0. 

I hope some native English speaker give the PyTROLL/SatPy Starter Kit V3.0 a try and we maybe will read something in next GEO Quaterly…? 

Regards,

Christian

See attached pics:




Am 22.01.2021 um 22:45 schrieb Ernst Lobsiger via groups.io <ernst.lobsiger@...>:

Daniele,

what 'area' do you want to display?
Do you have the GOES16 files you are asking for?
Enable satpy debugging as described in the HOWTO!

Regards,
Ernst


Re: TP 1 SNR - 'level.'

Douglas Deans
 

On 23/01/2021 12:00, geojohnt via groups.io wrote:
Hello All,
Mmmm, something seems to be going on?
I noticed my clear sky SNR around 11:15 this morning had dropped from 13.2/3 dB to 12.00 dB.
And later went down to 11.8 dB.
It's now at 11:59 gone up to 12.3 dB.
Slowly rising back to normal, hopefully.
Regards,
John Tellick.
=========================================================================

Weather in Europe is awful. I suspect that is the issue.

Regards,
Douglas.


TP 1 SNR - 'level.'

geojohnt@...
 

Hello All,

Mmmm, something seems to be going on?

I noticed my clear sky SNR around 11:15 this morning had dropped from 13.2/3 dB to 12.00 dB.
And later went down to 11.8 dB.

It's now at 11:59 gone up to 12.3 dB.
Slowly rising back to normal, hopefully.

Regards,
John Tellick.




Re: PyTROLL/SatPy Starter Kit V3.0

Ernst Lobsiger
 

Daniele,

what 'area' do you want to display?
Do you have the GOES16 files you are asking for?
Enable satpy debugging as described in the HOWTO!

Regards,
Ernst


Re: PyTROLL/SatPy Starter Kit V3.0

Daniele Guardigli
 

Thank you Ferdinand, you solved my problem. Thanks to all of you I got my first picture!
When I try to run GOES16 script I have the attached result.
What can it be?

Il giorno ven 22 gen 2021 alle ore 08:44 Ferdinand Valk <fvalk@...> ha scritto:

Daniele,

 

As the last lines of your debug file indicates, Area "seviri_rss" is not found.

If you did all in accordance with the instructions, you will have an additional areas.yaml in C:\EMCtools\pppconfig. This one contains the seviri_RSS area you defined in your script.

If it doesn’t see this, most likely you omitted point 5 b) from the howto instructions in which you must set the environment variable to this ppp directory.

 

Please check again.

 

Kind regards,

Ferdinand

 

 

From: MSG-1@groups.io On Behalf Of Daniele Guardigli
Sent: Friday, 22 January, 2021 06:43
To: MSG-1@groups.io
Subject: [MSG-1] PyTROLL/SatPy Starter Kit V3.0

d

Hello,

 

I'm m trying to follow the well done Starter Kit readme file but, at the moment of launching MSG3.py script, I get the attached result.

What am I doing wrong?

 

Thanks

 

Daniele Guardigli



--
Daniele Guardigli


Re: Configuration of the receiver

David J Taylor GM8ARV 🏴󠁧󠁢󠁳󠁣󠁴󠁿 🇪🇺
 

On 22/01/2021 18:40, Youssef Bennouna wrote:
Hi Ernst,
Thank you very much for your answer, I wasted 99$ !!!
Could you please recommend another model ?
Youssef Bennouna
The official EUMETSAT list is here:


https://eumetsatspace.atlassian.net/wiki/spaces/DSEC/pages/742260752/Devices

Cheers,
David
--
SatSignal Software - Quality software for you
Web: https://www.satsignal.eu
Email: david-taylor@blueyonder.co.uk
Twitter: @gm8arv


Re: Configuration of the receiver

Youssef Bennouna
 

Hi Ernst,

Thank you very much for your answer, I wasted 99$ !!!

Could you please recommend another model ?

 

 

Youssef Bennouna

ETUDES ET MESURES LES 5 DOMAINES

 

Villa 176, Bassatine El Menzeh

12123 - EL MENZEH

MAROC

TEL :  (+212)    0537 01 14 41

GSM :  (+212) 0661 10 97 43

 

De : MSG-1@groups.io [mailto:MSG-1@groups.io] De la part de Ernst Lobsiger via groups.io
Envoyé : jeudi 21 janvier 2021 18:36
À : MSG-1@groups.io
Objet : Re: [MSG-1] Configuration of the receiver

 

Youssef,

first of all this does not work with your receiver. It must have ACM/VCM what the TBS-5580 has not. Reception of satellite images is not like TV :-).

TD-15 is the document you asked for.

https://www.eumetsat.int/eumetcast

Cheers,
Ernst


Re: PyTROLL/SatPy Starter Kit V3.0 for GNU/Linux

Ernst Lobsiger
 

On Fri, Jan 22, 2021 at 08:34 AM, R. Alblas wrote:
I thought you always try to use PC's as old as possible ;-)
Rob,

amd64 GNU/Linux runs on my 12 Years old Fujitsu/Siemens with a Core Duo like a charm ;-).

Regards,
Ernst


Re: PyTROLL/SatPy Starter Kit V3.0 for GNU/Linux

R. Alblas
 

Ernst,

I thought you always try to use PC's as old as possible ;-)
Anyway, I'll give it a try, otherwise I have to give myself a 64-bitter.
Regards,
Rob.

On 22-01-2021 11:27, Ernst Lobsiger via groups.io wrote:
Rob,

I never even tried to install PyTROLL/SatPy on a 32Bit GNU/Linux. Let's face it 32Bit Linux is fading away and
the PyTROLL/SatPy developers maybe don't want to maintain both 32Bit and 64Bit packages on conda-forge.
And as you certainly know amd64 is only a name (type of instruction set) but that's also for Intel processors.

Regards,
Ernst

P.S. Maybe you get a better answer on the PyTROLL/SatPy list on google:

https://groups.google.com/g/pytroll




Re: PyTROLL/SatPy Starter Kit V3.0 for GNU/Linux

Christian Peters
 

Ernst

indeed....3.7/3.8 is recommended. 2.7 support is dropped recently.
They will check if there are 32bit conda builds...

Martin wrote (a developer):
..."ah, it could be that we aren't building 32bit packages for conda..."

Regards,

Christian

Am 22.01.21 um 12:57 schrieb Ernst Lobsiger via groups.io:

On Fri, Jan 22, 2021 at 02:40 AM, Christian Peters wrote:
So it should work, maybe not with conda? You could try to do the install with pip3...?
Rob and Christian

In any case it must be Python 3.7 / 3.8 now. If you install with pip(3) then use "virtualenv"
as described in my HOWTO 2.0 that I recently referenced for Nigel some posts behind.

https://groups.io/g/MSG-1/message/28324


Good luck
Ernst


Re: PyTROLL/SatPy Starter Kit V3.0 for GNU/Linux

Ernst Lobsiger
 

On Fri, Jan 22, 2021 at 02:40 AM, Christian Peters wrote:
So it should work, maybe not with conda? You could try to do the install with pip3...?
Rob and Christian

In any case it must be Python 3.7 / 3.8 now. If you install with pip(3) then use "virtualenv"
as described in my HOWTO 2.0 that I recently referenced for Nigel some posts behind.

https://groups.io/g/MSG-1/message/28324


Good luck
Ernst


Re: PyTROLL/SatPy Starter Kit V3.0 for GNU/Linux

Christian Peters
 

Rob,

form one of the developers
"...I don't see why it wouldn't work on 32 bit architecture, as long as the dependencies are available..."

So it should work, maybe not with conda? You could try to do the install with pip3...?
But as Ernst said....32bit is fading away and many distribution dropped it already....

Regards,

Christian

Am 22.01.21 um 10:53 schrieb R. Alblas:

Ernst,
Since this seems to be special for AMD 64-bits, what about Intel 32-bits?
Trying it with Ubuntu, 32-bits Intel machine ( to see if that would work), with:
conda install satpy

I get:
PackagesNotFoundError: The following packages are not available from current channels:

  - satpy
...
Current channels:

  - https://conda.anaconda.org/conda-forge/linux-32
...

Maybe I missed it, but as far as I can see there is nothing about "Pytroll/satpy only runs on 64-bits machines".

Regards,
Rob.

On 17-01-2021 17:04, Ernst Lobsiger via groups.io wrote:
Dear All,

here comes the Kit for GNU/Linux amd64 as promised. It's as easy to install and use as the one for Windows. It has been
developed under Debian 10 (Buster) but you should have no problems to get it running on any amd64 GNU/Linux distro.



It's based on Miniconda3 as the Windows companion. Christian Peters took "virtualenv" (as described in my GNU/Linux HOWTO 2.0)
to install the PyTROLL/SatPy environment and made a first Meteosat image on a RASPI (8GB RAM needed) with one of my scripts :-).

Have fun
Ernst



Re: PyTROLL/SatPy Starter Kit V3.0 for GNU/Linux

Ernst Lobsiger
 

On Fri, Jan 22, 2021 at 01:53 AM, R. Alblas wrote:
Maybe I missed it, but as far as I can see there is nothing about "Pytroll/satpy only runs on 64-bits machines".
Rob,

I never even tried to install PyTROLL/SatPy on a 32Bit GNU/Linux. Let's face it 32Bit Linux is fading away and
the PyTROLL/SatPy developers maybe don't want to maintain both 32Bit and 64Bit packages on conda-forge.
And as you certainly know amd64 is only a name (type of instruction set) but that's also for Intel processors.

Regards,
Ernst

P.S. Maybe you get a better answer on the PyTROLL/SatPy list on google:

https://groups.google.com/g/pytroll



Re: PyTROLL/SatPy Starter Kit V3.0 for GNU/Linux

R. Alblas
 

Ernst,
Since this seems to be special for AMD 64-bits, what about Intel 32-bits?
Trying it with Ubuntu, 32-bits Intel machine ( to see if that would work), with:
conda install satpy

I get:
PackagesNotFoundError: The following packages are not available from current channels:

  - satpy
...
Current channels:

  - https://conda.anaconda.org/conda-forge/linux-32
...

Maybe I missed it, but as far as I can see there is nothing about "Pytroll/satpy only runs on 64-bits machines".

Regards,
Rob.

On 17-01-2021 17:04, Ernst Lobsiger via groups.io wrote:
Dear All,

here comes the Kit for GNU/Linux amd64 as promised. It's as easy to install and use as the one for Windows. It has been
developed under Debian 10 (Buster) but you should have no problems to get it running on any amd64 GNU/Linux distro.



It's based on Miniconda3 as the Windows companion. Christian Peters took "virtualenv" (as described in my GNU/Linux HOWTO 2.0)
to install the PyTROLL/SatPy environment and made a first Meteosat image on a RASPI (8GB RAM needed) with one of my scripts :-).

Have fun
Ernst


Re: PyTROLL/SatPy Starter Kit V3.0

Ferdinand Valk
 

Daniele,

 

As the last lines of your debug file indicates, Area "seviri_rss" is not found.

If you did all in accordance with the instructions, you will have an additional areas.yaml in C:\EMCtools\pppconfig. This one contains the seviri_RSS area you defined in your script.

If it doesn’t see this, most likely you omitted point 5 b) from the howto instructions in which you must set the environment variable to this ppp directory.

 

Please check again.

 

Kind regards,

Ferdinand

 

 

From: MSG-1@groups.io On Behalf Of Daniele Guardigli
Sent: Friday, 22 January, 2021 06:43
To: MSG-1@groups.io
Subject: [MSG-1] PyTROLL/SatPy Starter Kit V3.0

d

Hello,

 

I'm m trying to follow the well done Starter Kit readme file but, at the moment of launching MSG3.py script, I get the attached result.

What am I doing wrong?

 

Thanks

 

Daniele Guardigli


PyTROLL/SatPy Starter Kit V3.0

Daniele Guardigli
 

Hello,

I'm m trying to follow the well done Starter Kit readme file but, at the moment of launching MSG3.py script, I get the attached result.
What am I doing wrong?

Thanks

Daniele Guardigli


Re: Configuration of the receiver

Ernst Lobsiger
 

Youssef,

first of all this does not work with your receiver. It must have ACM/VCM what the TBS-5580 has not. Reception of satellite images is not like TV :-).

TD-15 is the document you asked for.

https://www.eumetsat.int/eumetcast

Cheers,
Ernst

1641 - 1660 of 32623