Date   
Re: write permission for rateup.exe - was: Getting MRTG to work

David J Taylor
 

David, Giuseppe, and other MRTGeroes,
the problem in my setup seems to be the write permission for rateup.exe,
which is unexplainable to me. I never experienced any problems with these
access rights on that machine (XP Pro).

The error messsages sent from MRTG / Rateup.exe indicate, though, that
rateup can't rename any *.png.tmp file to the corresponding ~.png file.
It seems to miss to delete the pevious ~png file first.
It writes new ~.tmp files, though.

When I rename a ~png.tmp file to, say, ~2.png, the content shows a correct
result, like a realistic strength value. So, apart from the rewriting function,
most other things look good so far.

I checked the permission properties. The files themselves are fully writable,
no restrictions

The folder(s), though, show a write-protect-box symbol filled with a pale
green square, not the 'v' check mark. I can clear that, but it reappears
immediately. As said, I have not experienced any other permission
restricitons on that machine.

Finally, MRTG somehow thinks it lives on a Win 2000 machine - that's what
the cfgmaker wrote into the mrtg-cfg header block. No idea why, no idea
what consequences this has upon the permission structure.

Thanks for any help.

Cheers,U.
Ulrich,

My recent installs have been to C:\Tools\MRTG\, where C:\Tools\ was given "everyone" "full control" access when it was created. Obviously, the log-files directory might need similar treatment were it created elsewhere. Perhaps copy the log files somewhere else for the moment and re-create the log directory?

I've not looked at the version guess - I don' think it is anything other than descriptive text.

Cheers,
David
--
SatSignal software - quality software written to your requirements
Web: http://www.satsignal.eu
Email: david-taylor@...

Re: write permission for rateup.exe - was: Getting MRTG to work

Ulrich G. Kliegis
 

An: <MSG-1@...>
Von: "David J Taylor" <gm8arv@...>
Datum: Sun, 27 Feb 2011 12:56:49 -0000
Betreff: Re: [MSG-1] write permission for rateup.exe - was:
Getting MRTG to work
Antwort an: MSG-1@...

My recent installs have been to C:&#92;Tools&#92;MRTG&#92;, where C:&#92;Tools&#92; was
given "everyone" "full control" access when it was created.
Obviously, the log-files directory might need similar treatment were
it created elsewhere. Perhaps copy the log files somewhere else for
the moment and re-create the log directory?
David,
thanks, I had tried that already, created a new virginal directory
c:&#92;mrtg_data and set the pointer in the config file there. No avail.
Strange.

Cheers,
U.


.

Re: write permission for rateup.exe - was: Getting MRTG to work

David J Taylor
 

David,
thanks, I had tried that already, created a new virginal directory
c:&#92;mrtg_data and set the pointer in the config file there. No avail.
Strange.

Cheers,
U.
I assume you gave everyone, full control of the directory?

The other possibility, Ulrich, is to change the ownership of the directory, perhaps to everyone. But I just checked on my Win-7/64 PC, and the owner is "David", not "everyone". Are you running MRTG as a service or, like me, just from the Startup directory (menu), and from the command-line when testing?

Cheers,
David
--
SatSignal software - quality software written to your requirements
Web: http://www.satsignal.eu
Email: david-taylor@...

Re: write permission for rateup.exe - was: Getting MRTG to work

Ulrich G. Kliegis
 

I assume you gave everyone, full control of the directory?
Yes, installed with admin rights in XP / 32, no restrictions.

The other possibility, Ulrich, is to change the ownership of the
directory, perhaps to everyone. But I just checked on my Win-7/64 PC,
and the owner is "David", not "everyone". Are you running MRTG as a
service or, like me, just from the Startup directory (menu), and from
the command-line when testing?
Just command line testing so far, no continuous run yet.
Must be a stupid little detail I forgot.
Thanks for your patience, again.

Cheers,
U.

Re: derfag

James Brown
 

In message <ikddc9+klb5@...>, Duncan Edwards <sueandunc@...> writes
Hi Could anyone please advise on which defrag program to use . At this time i am running Smart Defrag2 but since this was installed i seem to have an issue with occasional missing segments. Any Help would be apreciated.
Best Regards Duncan
Hello Duncan
I'm using smartdefrag2 on a Windows 7 64bit machine - and don't see missing segments. The prog runs on auto-defrag with a RAM drive excluded, and the defrag timer (for no CPU usage) set to minimum. This way it does a defrag about every three hours.

I used MST as well in the past which worked fine - but the older one wasn't suitable for a modern machine.

Can you see from the log if there is a correlation between the defrag times and the missing segments?

Cheers

James
--
James Brown

Re: derfag

Ian Deans
 

I have used Smart Defrag and Auslogics Defrag on my Windows 7 64-bit computer without any issues.

I used mstdefrag successfully for a number of years, but I am using a new
( and not to be released ) Tellicast client 2.5.17 and mstdefrag causes
losses on this client as does Kaspersky Internet Security 2011.

Regards
Ian.

-----Original Message-----
From: Duncan Edwards
Sent: Sunday, February 27, 2011 11:43 AM
To: MSG-1@...
Subject: [MSG-1] derfag

Hi Could anyone please advise on which defrag program to use . At this time
i am running Smart Defrag2 but since this was installed i seem to have an
issue with occasional missing segments. Any Help would be apreciated.
Best Regards Duncan



------------------------------------

Re: derfag

Alan Banks <alan@...>
 

Like Ian, I use Auslogics Defrag. Used to use MSTDefrag but ran into problems with version number and it would crash.
I schedule defrag once every 24 hrs, on a PC that receives MSG2, MSG1, Metop, Modis, AVHRR plus 2 iterations MSGDM, MSGAnimator, GSS jobs and Microsoft Essentials, Win XP Pro SP3.
No losses.

Alan

On 27/02/2011 15:35, Ian Deans wrote:
I have used Smart Defrag and Auslogics Defrag on my Windows 7 64-bit
computer without any issues.

I used mstdefrag successfully for a number of years, but I am using a new
( and not to be released ) Tellicast client 2.5.17 and mstdefrag causes
losses on this client as does Kaspersky Internet Security 2011.

Regards
Ian.

re defrag

duncan
 

Thanks for the support James..Ian..Alan.Yes i have found that when the program goes into defrag mode then the missing segments start. So as a test today from 2pm today i have stopped the program and all seems well .I also had the dreded red t also when the program was engaged this only happened until the program went into standby then all was well once again .I am one of the few that run on a one pc system so this might be the problem .I have a reasonable machine with an athlon 3000+ processor,,2gb ddr2 ram and a 500mb graphics card running windows xp with 2 250gb h drives. i recieve metop/msg/and avhrr only so i have not had much trouble until now.....Thanks Duncan

Re: re defrag

Alan Banks <alan@...>
 

Hi Duncan,

Your PC spec seems similar to mine. Although I process all the msg stuff on the Rx PC, the Metop/AVHRR & Modis is processed on another. If losses are only an issue when running defrag - try as I do run Auslogics defrag (its free)at night and see what happens. One could always start and stop Metop Manager using the command line before and after the defrag as one way of reducing the load.
AMD Sempron 1800MHz. 80Gb/200GB hard drives, 2Gb RAM and Win XP Home
Q Soft 320 Mb Ramdrive on 24/7.
Alan

On 27/02/2011 16:34, Duncan Edwards wrote:
Thanks for the support James..Ian..Alan.Yes i have found that when the program goes into defrag mode then the missing segments start. So as a test today from 2pm today i have stopped the program and all seems well .I also had the dreded red t also when the program was engaged this only happened until the program went into standby then all was well once again .I am one of the few that run on a one pc system so this might be the problem .I have a reasonable machine with an athlon 3000+ processor,,2gb ddr2 ram and a 500mb graphics card running windows xp with 2 250gb h drives. i recieve metop/msg/and avhrr only so i have not had much trouble until now.....Thanks Duncan

Re: write permission for rateup.exe - was: Getting MRTG to work

Ulrich G. Kliegis
 


I assume you gave everyone, full control of the directory?
JFTR: Rebooting did not help either, except that I had to alter the ethernet
interface number from 3 to 2. It was just an idea, but not the right one.

Cheers,
U.

re defrag

duncan
 

Good idea Alan i think i will do that and see the results. I hope to go to a 2 pc system soon which will take the load off this one as i do all the usual browsing on this one as well so i must expect some loss of data but it just seemed strange that this only happened when i use the defrag program and of course the red T buisness as well .Thanks for your advice Best Regards Duncan.

Re: write permission for rateup.exe - was: Getting MRTG to work

David J Taylor
 

JFTR: Rebooting did not help either, except that I had to alter the ethernet
interface number from 3 to 2. It was just an idea, but not the right one.

Cheers,
U.
Yes, that's why I said I usually reboot before settling on the interface numbers. Rebooting from cold give consistent values. You have me puzzled on the rateup.exe problem, though. I've simply not seen this on Win-7 systems.

Cheers,
David
--
SatSignal software - quality software written to your requirements
Web: http://www.satsignal.eu
Email: david-taylor@...

Re: write permission for rateup.exe - was: Getting MRTG to work

Ulrich G. Kliegis
 

You have me puzzled
on the rateup.exe problem, though. I've simply not seen this on Win-7
systems.
Maybe a buggy version? I'll contact the author tomorrow.

Cheers,
U.

Re: write permission for rateup.exe - was: Getting MRTG to work

Ulrich G. Kliegis
 

You
have me puzzled on the rateup.exe problem, though. I've simply not
seen this on Win-7 systems.

David, just found this:

http://www.mail-archive.com/mrtg@.../

Seems I was not the only one who stumbled over this...

"Messages by Thread

...

* [mrtg] mrtg-2.17.1 the "BUGFIX" release Tobias Oetiker
o Re: [mrtg] mrtg-2.17.1 the "BUGFIX" release Don Rhodes
* [mrtg] RateUP WARNING : Can`t rename error Chris Blake
o Re: [mrtg] RateUP WARNING : Can`t rename error Steve Shipway
o Re: [mrtg] RateUP WARNING : Can`t rename error Chris Blake

...

Cheers,
U.

MSG Animator

e.macgurk@...
 

Hi.

Just need to tie up a few loose ends on some of the software,

1st with the MSG animator how do i get the false colour as all my animations have been in black and white not sure how to activate the false colour option.

2nd when using METOP manager can you confirm the channals needed to activate in the recv channals-ini, i believe its EPS 10 and EPS 15, needed to get METOP and GAC, when i remove the hash for EPS 15 nouthing is being received when checked in active channals, all fine with EPS 10.

3rd what channals are needed for the AVHRR manager.

Thankyou.

Regareds.

Eric

Re: s o l v e d ! write permission for rateup.exe - was: Getting MRTG to work

Ulrich G. Kliegis
 

It seems it took Tobi Oetiker, author of MRTG, two iterations to get this bug
fixed. No more error messages now with version 2.17.2, tomorrow I'll try to
achieve a contiuous operation.

So, after all, all is well.

Thanks to David and Giuseppe for their "quality time", as Tobi put it for the
time he invested in debugging.

Cheers,
U.

Re: s o l v e d ! write permission for rateup.exe - was: Getting MRTG to work

Ulrich G. Kliegis
 

From the MRTG-homepage:

Changes 2.17.2, 2011-02-20
--------------------------
From: Tobi
* can not replace a file by renaming another to its name under WIN32
fix in rateup #104

http://oss.oetiker.ch/mrtg/pub/CHANGES

It seems it took Tobi Oetiker, author of MRTG, two iterations to get
this bug fixed. No more error messages now with version 2.17.2,

Just FYI

Cheers,
U.

Re: s o l v e d ! write permission for rateup.exe - was: Getting MRTG to work

David J Taylor
 

It seems it took Tobi Oetiker, author of MRTG, two iterations to get this bug
fixed. No more error messages now with version 2.17.2, tomorrow I'll try to
achieve a contiuous operation.

So, after all, all is well.

Thanks to David and Giuseppe for their "quality time", as Tobi put it for the
time he invested in debugging.

Cheers,
U.
I checked and it's 2.17.0 I have on the 64-bit Win-7 PC, so should I have seen the problem as well, Ulrich? I'm slightly surprised that a stable component which has been in so long (i.e. rateup.exe) needed modification - FYI mine is 2220.208 bytes, and dated: 09:15 (UTC) 2010-Dec-15, and there is no built-in version information (right-click, Properties, Details tab).

Cheers,
David
--
SatSignal software - quality software written to your requirements
Web: http://www.satsignal.eu
Email: david-taylor@...

Re: s o l v e d ! write permission for rateup.exe - was: Getting MRTG to work

David J Taylor
 

From the MRTG-homepage:

Changes 2.17.2, 2011-02-20
--------------------------
From: Tobi
* can not replace a file by renaming another to its name under WIN32
fix in rateup #104

http://oss.oetiker.ch/mrtg/pub/CHANGES

It seems it took Tobi Oetiker, author of MRTG, two iterations to get
this bug fixed. No more error messages now with version 2.17.2,

Just FYI

Cheers,
U.
Amazes me that in /any/ operating system you can simply overwrite an existing file by doing the operation:

rename <my-new-file> <your-existing-file>

Oh, well!

Thanks for the info.

Cheers,
David
--
SatSignal software - quality software written to your requirements
Web: http://www.satsignal.eu
Email: david-taylor@...

Re: MSG Animator

David J Taylor
 

Hi.

Just need to tie up a few loose ends on some of the software,

1st with the MSG animator how do i get the false colour as all my animations have been in black and white not sure how to activate the false colour option.

2nd when using METOP manager can you confirm the channals needed to activate in the recv channals-ini, i believe its EPS 10 and EPS 15, needed to get METOP and GAC, when i remove the hash for EPS 15 nouthing is being received when checked in active channals, all fine with EPS 10.

3rd what channals are needed for the AVHRR manager.

Thankyou.

Regareds.

Eric
Eric,

As questions about my software, these would be more appropriately asked in the SatSignal Yahoo group:

http://tech.groups.yahoo.com/group/SatSignal/

(1) To use the colour LUTs, be sure to select Video processing "None", and ensure that GeoSatSignal has been installed on run once on the same PC.

(2) Metop AVHRR is on [EPS-10], and NOAA-19 GAC on [EPS-15]. Make sure these are sent to separate directories in your recv-channels.ini. NOAA-GAC data may not be continuous - there should be a 30 minute gap or more between orbits.

(3) EARS data is on [EUMETSAT Data Channel 1]

Cheers,
David
--
SatSignal software - quality software written to your requirements
Web: http://www.satsignal.eu
Email: david-taylor@...