Re: EUMETCastView on GNU/Linux

hb9erg.kd0hop@...
 

Good morning, Christoph and Ernst

Thank you a lot for your quick responses, I appreciate it very much!

After many hours of - unfortunately unsuccessfully! - trying to install different drivers by means of
- PPA oibaf,
- sgfxi script,
- linux internal driver management
on both the
- HP Pavilion dv7 laptop (AMD Radeon GPU) and
- Intel NUC (Intel Graphics 5000),

I managed to have found a working solution:
 - ASUS K56CB
 - Linux Mint Xfce 19.2 Tina
 - nVidia GeForce 740M >> Proprietary Driver chosen from Linux Mint "Treiberverwaltung": nvidia-driver-390 (metapackage)
 - 3D Globe now working, with about 220 paintGL calls / s
 - EUMETCastView had been compiled on Ubuntu 18.04 LTS, which works flawlessly also on Linux Mint 19.2 Tina.

glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 740M/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.116
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.116
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.116
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20


*** What's strange ***
Tthe nVidia proprietary driver chosen by the "Treiberverwaltung" didn't work on Ubuntu 18.04 LTS > system crashed or displaying was very slow... (llvs...)

Unfortunately, on the HP Pavilion dv7, Linux Mint always freezes after 10 seconds, so it's not usable there.

*** oibaf PPA ***
Is it correct how I "activated" the PPA oibaf drivers on the Intel NUC?
>> After adding the PPA repository and apt-get upgrade, apt dist-upgrade (or apt full-upgrade), I think it installed it, but OpenGL in EUMETCastView still didn't work...

glxinfo | grep OpenGL, it says (below is just an excerpt!) that it's using
OpenGL core profile version string: 4.5 Mesa 20.0.0 devel (bionic-oibaf-ppa)
OpenGL version string: 3.0 Mesa 20.0.0-devel (bionic-oibaf-ppa)
OpenGL ES GLSL ES 3.10
*** Intel NUC ***
My goal is it to run EUMETCastView on the Intel NUC - maybe you can help me with this driver issue further?

Vyle Dangg Euch und e sunnige Daag!

Cheers,
Olivier

Join MSG-1@groups.io to automatically receive all group messages.