Group renaming incomplete #groupname


bob@...
 

I just set up a group, but realized the group name (e-mail name) needed to be changed.  I changed it yesterday in Settings as described in the guide for changing the group name.  Then today I tried adding member that was not currently registered with groups.io.  Everything seemed fine in that the new group name properly appeared in the e-mail address for the group and in the "confirm your e-mail" message to the new member.  But there is a problem with the "welcome to <newname>@groups.io" message the new member gets.  The new name does indeed appear in the subject line of the message, and the "from" address is also the new group name @groups.io.  But the content of that message contains all references to the original name of the group which was in effect over 18 hours ago, including:

  • Welcome to the <oldname>@groups.io group at Groups.io, a free, easy-to-use...
  • You can visit your group, start reading messages and posting them here: https://groups.io/g/<oldname>
  • You can set your subscription settings here: https://groups.io/g/<oldname>/editsub. 
  • If you do not wish to belong to this group, you may unsubscribe by sending an email to: <oldname>+unsubscribe@groups.io
  • Regards, The <oldname>@groups.io Moderator

And if the new member follows any of the links involving the oldname, they get a "sorry, but that group does not exist" page from groups.io.
It appears the new group name is only partially propagated within the groups.io system.  Is this just a time delay problem?  If I wait another day will the "welcome to.." message for new members contain the new group name?


Duane
 

On Wed, Nov 6, 2019 at 09:58 AM, <bob@...> wrote:
But there is a problem with the "welcome to <newname>@groups.io" message the new member gets.
The initial Welcome message is automatically created when you create the group using the proper name.  If you change the group name, you have to edit that notice (and possibly others) since they're not regenerated.

Duane
--
Help: https://groups.io/static/help
GMF's Wiki: https://groups.io/g/GroupManagersForum/wiki
Search button at the top of Messages list
A few site FAQs: https://groups.io/static/pricing#frequently-asked-questions


Bruce Bowman
 

On Wed, Nov 6, 2019 at 10:58 AM, <bob@...> wrote:
I changed it yesterday in Settings as described in the guide for changing the group name.  Then today I tried adding member that was not currently registered with groups.io.  Everything seemed fine in that the new group name properly appeared in the e-mail address for the group and in the "confirm your e-mail" message to the new member.  But there is a problem with the "welcome to <newname>@groups.io" message the new member gets.  The new name does indeed appear in the subject line of the message, and the "from" address is also the new group name @groups.io.  But the content of that message contains all references to the original name of the group...etc.
Bob -- This is covered in the wiki entry (https://groups.io/g/GroupManagersForum/wiki/Renaming-a-Group) as the final bullet point under "Some Impacts of Renaming a Group." I suggest re-reading this page to ensure you have detected and remedied all such issues before proceeding further.

Renaming a group can create some big problems. Although it's nice to be able to if you really need it, prospective group owners should carefully decide what they want their group to be called from the outset, and not rely on this as a safety net.

Regards,
Bruce


bob@...
 

Thanks, Duane.  I found the Welcome message and fixed it.  All is well now.
I found it under Admin / Settings / Member Notices.