Re: MAX-M8Q GPS lock problem

Leo Bodnar <leo@...>
 

You don't need RFI interference in GPS L1 band to disable GPS.

Ublox MAX-8Q and all other MAX series modules do not have *any* antenna input preselector filtering - just an impedance match.  Their antenna input is attached to on-chip LNA followed by a mixer.  Imagine bypassing all the bandpass filters in your HAM rig and trying to listen to DX station close to a powerful nearby broadband transmitter.

For complex payloads I would suggest using either module with internal filter - like NEO - or simply placing a GPS band SAW filter between the antenna and the module.  Having only a few dB insertion loss It would not hurt the sensitivity but can help with nearby out of band EMI.  If you really need these few extra dB back take it out and bypass it with a short piece of wire.

Cheers
Leo

On 24 Mar 2019, at 02:55, Bill Brown via Groups.Io wrote:

Hi Zack,

  Digital cameras are a huge source of EMI to desense GPS receivers. I always try to keep about 6 to 10 feet of isolation between GPS trackers and camera payloads. Aluminum shielding on the top or bottom of the camera payload is also a good idea.

  By identical sister do you mean the other board also uses the MAX-8Q or does it use some other version of the MAX series?  In the case of the MAX-8Q if you don't send it the command to only use the US GPS constellation, it will also use the Chinese and Russian GPS sytems and will access more satellites. That might help.

- Bill WB8ELK

I use the MAX-7Q and MAX-8Q almost exclusively now. However, for extreme EMI environments such as coexisting next to an ATV transmitter with digital cameras, then I use the Trimble Copernicus module as it is a lot more impervious to EMI effects. I still offer them every once in awhile for folks using ATV on gliders or RC aircraft as well as ATV payload on balloons.


-----Original Message-----
From: Michael <mw@...>
To: GPSL <GPSL@groups.io>
Sent: Sat, Mar 23, 2019 11:58 am
Subject: Re: [GPSL] MAX-M8Q GPS lock problem

Looks like you have an EMI issue, try wrapping the cameras with aluminum foil with just a small hole for the lens as small as you can get it without interfering with the view. Most likely your cameras are using a frequency that has a harmonic on the GPS frequency and with a GPS having say 165db of sensitivity, you pretty much can not get far enough away on a flight string to realize some impact, but more shielding and space will likely help. 

--Michael Willett
K5NOT

On Mar 23, 2019, at 11:08 AM, Zack Clobes W0ZC <zclobes@...> wrote:

I'm looking for some ideas on troubleshooting some lock problems on a new board/capsule/camera design.  The board has worked well during testing up until I started integration testing with the actual capsule with the cameras under it.  

The capsule is about 6cm thick and is mostly two layers of foam.  There are two cameras sandwiched in the middle and there is an aluminum bar holding them in place.  The GPS antenna is as far away from that as I can get.  Lid open or lid closed doesn't seem to make any difference.

During testing I noticed that this board would take a lot longer to get a lock than it's identical sister.  Initially I thought it was a bad GPS or antenna, and eventually replaced both.  Then I noticed if I unplug an external (optics) sensor, the GPS would lock up almost immediately.

So I nixed the sensor at the 11th hour and went flying.  The GPS never locked on a single time during the whole flight.  There's about 2m of separation to the next capsule.


This morning I plugged everything back in just like it flew, and it immediately got a lock.  The only thing I noticed was that after powering up the cameras, the altitude was reading about 100 meters high.  But I still had 5-9 sats.


I'm running low on ideas on what to try to isolate this problem. 


Zack
<IMG_20190319_163333.jpg>
<IMG_20190319_163351.jpg>

Join GPSL@groups.io to automatically receive all group messages.