FTDX101D & N1MM+ setting


Martin, PE1EEC
 

Hello all

New 101D-user here. Been trying to get N1MM+ to work for a CW contest. It was a bit fo a puzzle. Tried some solutions but none worked, but this settingworks for me with a single cable connected to my Windows 10 PC.

N1MM+ v1.0.9157.0
FTDX101D with May 2021 f/w
Enhanced COM port COM5
Standard COM port COM4

Radio:
Operation setting -> General -> CAT rate ->38400
CW Setting -> Mode CW -> PC Keying -> RTS
(CW Setting -> Mode CW -> CW Bk-In Type -> Semi/Full    ...... this determines whether semi or fullbreak-in and is independent of the BK-In switch on the front)

N1MM -> Portconfigurations

COM5, FTDX101D, CW/Other = off, 38400, N, 8, 2, DTR=handshake, RTS=handshake, Radio=1. The 4 PTT controlboxes = off.
COM4, NONE, CW/Other = on, DTR=PTT, RTS=CW, VFO=1

In all the other recipes I saw DTR was set to CW and RTS to PTT, but this didn't work in my case.

Hope this helps for whoever is struggling with this as well, hi.

73, Martin, PE1EEC/PH75MAA


Rejean Leveille
 

Hi Martin
I am confused with your settings, first you need to decide from Ftdx101 what will do RTS & DTR before programming N1MM. (Operation Setting - General) RTS On or Off and I kept ON
You cannot have DTR & RTS handshake at the same time.
PTT & CW should use the same command (CW Setting -Mode CW - PC Keying) I selected DTR
Enhanced port for the radio control (COM 5)
Standard port for PTT - CW (COM 4),,, Strange because the lower port number normally gets the Enhanced but I am not 100% sure about that.
When you install a new port driver you should have not done any USB connection with the radio, You can see the new port keeping the radio Off with just the USB connected after the new install driver.
In my case I kept CAT RTS ON (default), then I use DTR for PTT & CW. That means if you used other programs you cannot mix-up RTS & DTR command but all the same way.
 Note: Program default is always the yellow color (Ftdx101)

73, Rejean, va2am