PCmill50 programming errors

David Rabenius
 

  To all I am trying to get a part programmed on the PCmill50. I used to have a friend wo was a EMCO dealer in Arizona but he passed away  earlier this year. My problem is with G02 & G03, keep getting the "wrong circle parameter" alarm. I used MasterCam X3 and for some reason it isn't happy. My friend used Maxnc software and MasterCam previously with no problems. I am not running the post processor specific for the EMCO, does anyone have that?
  The part I am making is 4pcs. on a 1.00 x .500 thick strip about 5.4 inches long. I am using a 1\2 inch Carbide endmill and a .750 dia. x .125 thick Keo cutter. The parts are spaced 1.400 inches apart. I have programmed & cut the ruffing passes already. I left about .020 for a cleanup cut as I ruffed with a staggered \finishing 3 flute carbide endmill.
   I don't have the EMCO milling software, have the 50 Lathe software but haven't used it yet. I need to make chips at this point and time is running out. Its a stupid problem to have and without someone who knows the machine & programming am S.O.L.
   The machine is certainly capable as I have done some "out of the box" programming using a single point threadmill to thread a large diameter tube with a thread Horizontally. I had a problem figuring that out, called EMCO (no help) and finally my local dealer (deceased) drew the thread as a helix and used Maxnc software to program. It worked like a champ. programs were huge thou.
  If anyone out there could look at my code or using the PC50 software reprogram it I would be happy to pay for the service. I have all files & drawings.

Join Emco-CNC-Users@groups.io to automatically receive all group messages.