Topics

Sub-receiver anomaly on 30M

David Mackey
 

A couple of weeks ago the sub-receiver in my K3S became intermittent, and eventually stopped working entirely, however only on 30M. It works fine on all other bands. When activating it on 30M I hear a noise level, but tuning across the primary frequency or any other frequency where a signal is present on the P3, does not result in a signal on the subRX. RF gain is up. Not sure what would result in such behaviors on only 1 band.

73 Dave K1KA

David G3YYD
 

Band Pass Filter fault?

 

73 David G3YYD

 

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of David Mackey
Sent: 16 February 2020 20:31
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] Sub-receiver anomaly on 30M

 

A couple of weeks ago the sub-receiver in my K3S became intermittent, and eventually stopped working entirely, however only on 30M. It works fine on all other bands. When activating it on 30M I hear a noise level, but tuning across the primary frequency or any other frequency where a signal is present on the P3, does not result in a signal on the subRX. RF gain is up. Not sure what would result in such behaviors on only 1 band.

73 Dave K1KA

Larry
 

Check to make sure your "main" antenna is connected.  This has been happening to me

as well.  Change bands, no real antenna noise. or when working split nothing from the

B receiver.  Punch the Antenna button a couple times and it then connects.  It has always

been connected before so why all of a sudden i have to go thru the ANT. connecting

routine, don't know.  Came back from the last factory workover that way.

Larry W0OGH


On 2/16/2020 1:30 PM, David Mackey wrote:
A couple of weeks ago the sub-receiver in my K3S became intermittent, and eventually stopped working entirely, however only on 30M. It works fine on all other bands. When activating it on 30M I hear a noise level, but tuning across the primary frequency or any other frequency where a signal is present on the P3, does not result in a signal on the subRX. RF gain is up. Not sure what would result in such behaviors on only 1 band.

73 Dave K1KA