settings issue with KIO3B


Andy GD0TEP
 

Hi to the group,

 

I had an issue with the original line in/out board fitted to my K3, so, for a short term fix I changed LIN OUT in Config to PHONES, and then changed the connections to the radio, using the phones socket on the front of the radio as the line out.. I then ordered the KIO3B upgrade kit. That was in 2019… I’ve only now had the kit fitted (with many thanks to Roger G4BVY)

 

Once the new board was fitted, I could get audio from the radio to my PC, but it went via the front panel volume control. At the time we didn’t know why… but now I remembered that I changed the LIN OUT setting..

 

But I’ve now got a problem that I don’t seem to be able to change the setting from PHONES to anything else… What am I missing??

 

Just to clarify, the received audio IS getting to my PC from the K3 via the new internal sound card and USB cable. There is no other connection to the PC from my K3.

 

To add to this, I don’t seem to be getting audio from the PC to the K3…

 

Any suggestions would be gratefully received 😊

 

73

Andy

GD0TEP


Ray Maxfield
 

Andy…….

As I remember ……”Phones” is a Oneway Audio

Your need an Mic audio back.

Ray WA6VAB

 

 

From: Andy GD0TEP
Sent: Monday, July 26, 2021 3:33 PM
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] settings issue with KIO3B

 

Hi to the group,

 

I had an issue with the original line in/out board fitted to my K3, so, for a short term fix I changed LIN OUT in Config to PHONES, and then changed the connections to the radio, using the phones socket on the front of the radio as the line out.. I then ordered the KIO3B upgrade kit. That was in 2019… I’ve only now had the kit fitted (with many thanks to Roger G4BVY)

 

Once the new board was fitted, I could get audio from the radio to my PC, but it went via the front panel volume control. At the time we didn’t know why… but now I remembered that I changed the LIN OUT setting..

 

But I’ve now got a problem that I don’t seem to be able to change the setting from PHONES to anything else… What am I missing??

 

Just to clarify, the received audio IS getting to my PC from the K3 via the new internal sound card and USB cable. There is no other connection to the PC from my K3.

 

To add to this, I don’t seem to be getting audio from the PC to the K3…

 

Any suggestions would be gratefully received 😊

 

73

Andy

GD0TEP

 


Joe Subich, W4TV
 

On 2021-07-26 6:32 PM, Andy GD0TEP wrote:

But I’ve now got a problem that I don’t seem to be able to change the
setting from PHONES to anything else… What am I missing??
Select CONFIG:LIN OUT and tap A/B (1)

73,

... Joe, W4TV


On 2021-07-26 6:32 PM, Andy GD0TEP wrote:
Hi to the group,
I had an issue with the original line in/out board fitted to my K3, so, for a short term fix I changed LIN OUT in Config to PHONES, and then changed the connections to the radio, using the phones socket on the front of the radio as the line out.. I then ordered the KIO3B upgrade kit. That was in 2019… I’ve only now had the kit fitted (with many thanks to Roger G4BVY)
Once the new board was fitted, I could get audio from the radio to my PC, but it went via the front panel volume control. At the time we didn’t know why… but now I remembered that I changed the LIN OUT setting..
But I’ve now got a problem that I don’t seem to be able to change the setting from PHONES to anything else… What am I missing??
Just to clarify, the received audio IS getting to my PC from the K3 via the new internal sound card and USB cable. There is no other connection to the PC from my K3.
To add to this, I don’t seem to be getting audio from the PC to the K3…
Any suggestions would be gratefully received 😊
73
Andy
GD0TEP


Andy GD0TEP
 

On 2021-07-26 6:32 PM, Andy GD0TEP wrote:
>
> But I’ve now got a problem that I don’t seem to be able to change the > setting from PHONES to anything else… What am I missing??

Select CONFIG:LIN OUT and tap A/B (1)

73,

... Joe, W4TV


So simple... Thanks very much Joe... 😊 That has resolved the audio from the radio To the PC issue... Now for the audio from the PC to the K3. I have the WSJT set to (speakers USB audio codec), and 'both' selected but getting nothing in the K3.. I have so far tried MIC SEL to rP.L, FP.L and LInE In, and none seem to work... If I look at MIC+LIN I get not APPL and cant change it.

I think I'm missing something again, but what??

Thanks,


Andy
GD0TEP


Andy GD0TEP
 

Hi Ray,

 

Thanks for the reply..

 

It would seem I had two ‘issues’ 1, the audio TO the PC from the radio. (speakers or line out) and 2, the audio FROM the PC to the radio, (mic or line in)

 

Looking at issues 1. The audio from the radio to the PC, (speakers/line out) This has now been resolved… thanks to W4TV.

 

I’ve yet to get the audio in (mic or line in) sorted out

 

In WSJT I have the audio out of the PC set to the right place, i.e. USB audio codec, and I’ve tried mono, left, right & both. Without success, so I kinds scratching my head a bit..

 

There also appears to be a keying delay, but one thing at a time 😊

 

Thanks,

 

Andy

GD0TEP

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Ray Maxfield
Sent: 26 July 2021 23:20
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

Andy…….

As I remember ……”Phones” is a Oneway Audio

Your need an Mic audio back.

Ray WA6VAB

 

 

From: Andy GD0TEP
Sent: Monday, July 26, 2021 3:33 PM
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] settings issue with KIO3B

 

Hi to the group,

 

I had an issue with the original line in/out board fitted to my K3, so, for a short term fix I changed LIN OUT in Config to PHONES, and then changed the connections to the radio, using the phones socket on the front of the radio as the line out.. I then ordered the KIO3B upgrade kit. That was in 2019… I’ve only now had the kit fitted (with many thanks to Roger G4BVY)

 

Once the new board was fitted, I could get audio from the radio to my PC, but it went via the front panel volume control. At the time we didn’t know why… but now I remembered that I changed the LIN OUT setting..

 

But I’ve now got a problem that I don’t seem to be able to change the setting from PHONES to anything else… What am I missing??

 

Just to clarify, the received audio IS getting to my PC from the K3 via the new internal sound card and USB cable. There is no other connection to the PC from my K3.

 

To add to this, I don’t seem to be getting audio from the PC to the K3…

 

Any suggestions would be gratefully received 😊

 

73

Andy

GD0TEP

 


ve3ki
 

With the rig in DATA A mode, set MAIN:MIC SEL to LINE IN, then rotate the MIC gain control so it reads something like LINE 8 or LINE 10 - something more than zero. Adjust the LO CUT and HI CUT controls to get the filter bandwidth you want, set the audio frequency to somewhere between 1500 Hz and 2000 Hz, transmit a tuning signal from the software and set the MIC gain and Windows level controls so the ALC meter reads 4-5 bars.

Re the delay, in the WSJT-X Settings window try setting the Split mode to Fake It instead of Rig (or vice versa).

73,
Rich VE3KI


On Tue, Jul 27, 2021 at 06:48 AM, Andy GD0TEP wrote:
On 2021-07-26 6:32 PM, Andy GD0TEP wrote:
>
> But I’ve now got a problem that I don’t seem to be able to change the > setting from PHONES to anything else… What am I missing??

Select CONFIG:LIN OUT and tap A/B (1)

73,

... Joe, W4TV


So simple... Thanks very much Joe... 😊 That has resolved the audio from the radio To the PC issue... Now for the audio from the PC to the K3. I have the WSJT set to (speakers USB audio codec), and 'both' selected but getting nothing in the K3.. I have so far tried MIC SEL to rP.L, FP.L and LInE In, and none seem to work... If I look at MIC+LIN I get not APPL and cant change it.

I think I'm missing something again, but what??

Thanks,


Andy
GD0TEP


Andy GD0TEP
 

Thanks Rich… audio issues now seem to be sorted out…

 

But TX delay is still a problem.. I’ve tried fake it and the other settings in that box, but no different…

 

If I push any TX button within WSJT (tune or any of the TX buttons) the delay is about 3 seconds.

 

I’d like to find a way to PTT the radio rom a different bit a software, to rule out WSJT, (or not) just to see if it really is an issue with the radio or not…

 

73

Andy

GD0TEP

 

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of ve3ki
Sent: 27 July 2021 11:53
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

With the rig in DATA A mode, set MAIN:MIC SEL to LINE IN, then rotate the MIC gain control so it reads something like LINE 8 or LINE 10 - something more than zero. Adjust the LO CUT and HI CUT controls to get the filter bandwidth you want, set the audio frequency to somewhere between 1500 Hz and 2000 Hz, transmit a tuning signal from the software and set the MIC gain and Windows level controls so the ALC meter reads 4-5 bars.

Re the delay, in the WSJT-X Settings window try setting the Split mode to Fake It instead of Rig (or vice versa).

73,
Rich VE3KI


On Tue, Jul 27, 2021 at 06:48 AM, Andy GD0TEP wrote:

On 2021-07-26 6:32 PM, Andy GD0TEP wrote:
>
> But I’ve now got a problem that I don’t seem to be able to change the > setting from PHONES to anything else… What am I missing??

Select CONFIG:LIN OUT and tap A/B (1)

73,

... Joe, W4TV


So simple... Thanks very much Joe... 😊 That has resolved the audio from the radio To the PC issue... Now for the audio from the PC to the K3. I have the WSJT set to (speakers USB audio codec), and 'both' selected but getting nothing in the K3.. I have so far tried MIC SEL to rP.L, FP.L and LInE In, and none seem to work... If I look at MIC+LIN I get not APPL and cant change it.

I think I'm missing something again, but what??

Thanks,


Andy
GD0TEP


Jim - N4ST
 

Andy,

Wonder what your update rate is for your coms to the K3?

Also, you could try operating VOX.  That’s how I get the best results with my K3S.

 

__________

73,

Jim – N4ST

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Andy GD0TEP
Sent: Wednesday, July 28, 2021 15:14
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

Thanks Rich… audio issues now seem to be sorted out…

 

But TX delay is still a problem.. I’ve tried fake it and the other settings in that box, but no different…

 

If I push any TX button within WSJT (tune or any of the TX buttons) the delay is about 3 seconds.

 

I’d like to find a way to PTT the radio rom a different bit a software, to rule out WSJT, (or not) just to see if it really is an issue with the radio or not…

 

73

Andy

GD0TEP

 

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of ve3ki
Sent: 27 July 2021 11:53
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

With the rig in DATA A mode, set MAIN:MIC SEL to LINE IN, then rotate the MIC gain control so it reads something like LINE 8 or LINE 10 - something more than zero. Adjust the LO CUT and HI CUT controls to get the filter bandwidth you want, set the audio frequency to somewhere between 1500 Hz and 2000 Hz, transmit a tuning signal from the software and set the MIC gain and Windows level controls so the ALC meter reads 4-5 bars.

Re the delay, in the WSJT-X Settings window try setting the Split mode to Fake It instead of Rig (or vice versa).

73,
Rich VE3KI


On Tue, Jul 27, 2021 at 06:48 AM, Andy GD0TEP wrote:

On 2021-07-26 6:32 PM, Andy GD0TEP wrote:
>
> But I’ve now got a problem that I don’t seem to be able to change the > setting from PHONES to anything else… What am I missing??

Select CONFIG:LIN OUT and tap A/B (1)

73,

... Joe, W4TV


So simple... Thanks very much Joe...
😊 That has resolved the audio from the radio To the PC issue... Now for the audio from the PC to the K3. I have the WSJT set to (speakers USB audio codec), and 'both' selected but getting nothing in the K3.. I have so far tried MIC SEL to rP.L, FP.L and LInE In, and none seem to work... If I look at MIC+LIN I get not APPL and cant change it.

I think I'm missing something again, but what??

Thanks,


Andy
GD0TEP


Andy GD0TEP
 

Jim,

 

All sorted out thanks, the delay was caused within WSJT nothing to do with my K3.

 

If you are interested, in WSJT. In settings and under the ‘radio’ tab, I changed mode to none, and split to none. And all was ok again 😊

 

73

Andy

GD0TEP

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Jim - N4ST
Sent: 28 July 2021 19:35
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

Andy,

Wonder what your update rate is for your coms to the K3?

Also, you could try operating VOX.  That’s how I get the best results with my K3S.

 

__________

73,

Jim – N4ST

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Andy GD0TEP
Sent: Wednesday, July 28, 2021 15:14
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

Thanks Rich… audio issues now seem to be sorted out…

 

But TX delay is still a problem.. I’ve tried fake it and the other settings in that box, but no different…

 

If I push any TX button within WSJT (tune or any of the TX buttons) the delay is about 3 seconds.

 

I’d like to find a way to PTT the radio rom a different bit a software, to rule out WSJT, (or not) just to see if it really is an issue with the radio or not…

 

73

Andy

GD0TEP

 

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of ve3ki
Sent: 27 July 2021 11:53
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

With the rig in DATA A mode, set MAIN:MIC SEL to LINE IN, then rotate the MIC gain control so it reads something like LINE 8 or LINE 10 - something more than zero. Adjust the LO CUT and HI CUT controls to get the filter bandwidth you want, set the audio frequency to somewhere between 1500 Hz and 2000 Hz, transmit a tuning signal from the software and set the MIC gain and Windows level controls so the ALC meter reads 4-5 bars.

Re the delay, in the WSJT-X Settings window try setting the Split mode to Fake It instead of Rig (or vice versa).

73,
Rich VE3KI


On Tue, Jul 27, 2021 at 06:48 AM, Andy GD0TEP wrote:

On 2021-07-26 6:32 PM, Andy GD0TEP wrote:
>
> But I’ve now got a problem that I don’t seem to be able to change the > setting from PHONES to anything else… What am I missing??

Select CONFIG:LIN OUT and tap A/B (1)

73,

... Joe, W4TV


So simple... Thanks very much Joe... 😊 That has resolved the audio from the radio To the PC issue... Now for the audio from the PC to the K3. I have the WSJT set to (speakers USB audio codec), and 'both' selected but getting nothing in the K3.. I have so far tried MIC SEL to rP.L, FP.L and LInE In, and none seem to work... If I look at MIC+LIN I get not APPL and cant change it.

I think I'm missing something again, but what??

Thanks,


Andy
GD0TEP


Brian K0DTJ
 

In the Settings/Radio dialog set Mode to “None” and Split Operaton to “Fake It”. It’s the Mode=None that killed the delay for me. 
73,
Brian, K0DTJ 

On Jul 28, 2021, at 12:14, Andy GD0TEP <gd0tep@...> wrote:



Thanks Rich… audio issues now seem to be sorted out…

 

But TX delay is still a problem.. I’ve tried fake it and the other settings in that box, but no different…

 

If I push any TX button within WSJT (tune or any of the TX buttons) the delay is about 3 seconds.

 

I’d like to find a way to PTT the radio rom a different bit a software, to rule out WSJT, (or not) just to see if it really is an issue with the radio or not…

 

73

Andy

GD0TEP

 

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of ve3ki
Sent: 27 July 2021 11:53
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B

 

With the rig in DATA A mode, set MAIN:MIC SEL to LINE IN, then rotate the MIC gain control so it reads something like LINE 8 or LINE 10 - something more than zero. Adjust the LO CUT and HI CUT controls to get the filter bandwidth you want, set the audio frequency to somewhere between 1500 Hz and 2000 Hz, transmit a tuning signal from the software and set the MIC gain and Windows level controls so the ALC meter reads 4-5 bars.

Re the delay, in the WSJT-X Settings window try setting the Split mode to Fake It instead of Rig (or vice versa).

73,
Rich VE3KI


On Tue, Jul 27, 2021 at 06:48 AM, Andy GD0TEP wrote:

On 2021-07-26 6:32 PM, Andy GD0TEP wrote:
>
> But I’ve now got a problem that I don’t seem to be able to change the > setting from PHONES to anything else… What am I missing??

Select CONFIG:LIN OUT and tap A/B (1)

73,

... Joe, W4TV


So simple... Thanks very much Joe... 😊 That has resolved the audio from the radio To the PC issue... Now for the audio from the PC to the K3. I have the WSJT set to (speakers USB audio codec), and 'both' selected but getting nothing in the K3.. I have so far tried MIC SEL to rP.L, FP.L and LInE In, and none seem to work... If I look at MIC+LIN I get not APPL and cant change it.

I think I'm missing something again, but what??

Thanks,


Andy
GD0TEP


Joe Subich, W4TV
 

Andy,

Try upgrading to WSTJX 2.5.0-rc3. It includes an update to hamlib
that allegedly fixes the delay with the K3/K3s when using split =
radio and mode=data.

The issue has long been that WSJTX waits until the K3/K3S reports
that VFOB has settled on its "new" frequency. However, WSJTX waits
to set VFOB until xx:00/xx:15/xx:30/xx:45 and the K3/K3s can take
several hundred ms (or more), particularly when WSJTX is also
setting split, data mode, etc. at the same time. The combination
results in a delay to the PTT ON (TX1;) command.

I have no idea what changes have been made to hamlib but reports
are that the delay is eliminated (or significantly reduced).

73,

... Joe, W4TV

On 2021-07-28 3:52 PM, Andy GD0TEP wrote:
Jim,
All sorted out thanks, the delay was caused within WSJT nothing to do with my K3.
If you are interested, in WSJT. In settings and under the ‘radio’ tab, I changed mode to none, and split to none. And all was ok again 😊
73
Andy
GD0TEP
From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Jim - N4ST
Sent: 28 July 2021 19:35
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] settings issue with KIO3B
Andy,
Wonder what your update rate is for your coms to the K3?
Also, you could try operating VOX. That’s how I get the best results with my K3S.
__________
73,
Jim – N4ST
From: Elecraft-K3@groups.io <mailto:Elecraft-K3@groups.io> <Elecraft-K3@groups.io <mailto:Elecraft-K3@groups.io> > On Behalf Of Andy GD0TEP
Sent: Wednesday, July 28, 2021 15:14
To: Elecraft-K3@groups.io <mailto:Elecraft-K3@groups.io>
Subject: Re: [Elecraft-K3] settings issue with KIO3B
Thanks Rich… audio issues now seem to be sorted out…
But TX delay is still a problem.. I’ve tried fake it and the other settings in that box, but no different…
If I push any TX button within WSJT (tune or any of the TX buttons) the delay is about 3 seconds.
I’d like to find a way to PTT the radio rom a different bit a software, to rule out WSJT, (or not) just to see if it really is an issue with the radio or not…
73
Andy
GD0TEP
From: Elecraft-K3@groups.io <mailto:Elecraft-K3@groups.io> <Elecraft-K3@groups.io <mailto:Elecraft-K3@groups.io> > On Behalf Of ve3ki
Sent: 27 July 2021 11:53
To: Elecraft-K3@groups.io <mailto:Elecraft-K3@groups.io>
Subject: Re: [Elecraft-K3] settings issue with KIO3B
With the rig in DATA A mode, set MAIN:MIC SEL to LINE IN, then rotate the MIC gain control so it reads something like LINE 8 or LINE 10 - something more than zero. Adjust the LO CUT and HI CUT controls to get the filter bandwidth you want, set the audio frequency to somewhere between 1500 Hz and 2000 Hz, transmit a tuning signal from the software and set the MIC gain and Windows level controls so the ALC meter reads 4-5 bars.
Re the delay, in the WSJT-X Settings window try setting the Split mode to Fake It instead of Rig (or vice versa).
73,
Rich VE3KI
On Tue, Jul 27, 2021 at 06:48 AM, Andy GD0TEP wrote:
On 2021-07-26 6:32 PM, Andy GD0TEP wrote:

But I’ve now got a problem that I don’t seem to be able to change the > setting from PHONES to anything else… What am I missing??
Select CONFIG:LIN OUT and tap A/B (1)
73,
... Joe, W4TV
So simple... Thanks very much Joe... 😊 That has resolved the audio from the radio To the PC issue... Now for the audio from the PC to the K3. I have the WSJT set to (speakers USB audio codec), and 'both' selected but getting nothing in the K3.. I have so far tried MIC SEL to rP.L, FP.L and LInE In, and none seem to work... If I look at MIC+LIN I get not APPL and cant change it.
I think I'm missing something again, but what??
Thanks,
Andy
GD0TEP