Topics

K3 not responding to computer command to XMIT


George Fletcher
 

I can not get my K3 (s\n 5215) to transmit in RTTY mode from Ham Radio Deluxe (HRD).  HRD will key the K3 in CW mode (KYcmd) just fine.  I have confirmed that AFSK signals are getting to the K3 by forcing the K3 to xmit mode using XMIT button and listening to the outgoing signal on another receiver.  I just have to manually turn the XMIT on and off.   It use to work automatically.   I am suspecting something in the K3 is not setup correct.  I am using the USB mode with HRD set for AFSK RTTY-45, using line in for audio input.  The same thing happens in DATA-A mode (wont key the xmtr).  BTW the K3 does not key the transmitter from HRD in PSK31 mode either.

 

HRD and K3 utility all updated to latest configurations.

 

I am using a USB to RS-232 Prolific chipset converter.

 

Computer is Windows 10 (latest update).

 

Any suggestions would be greatly appreciated.  Thanks.

--George Fletcher, AD5CQ


Joe Subich, W4TV
 

Turn on the VOX.

73,

... Joe, W4TV

On 2020-07-18 4:43 PM, George Fletcher wrote:
I can not get my K3 (s\n 5215) to transmit in RTTY mode from Ham Radio Deluxe (HRD). HRD will key the K3 in CW mode (KYcmd) just fine. I have confirmed that AFSK signals are getting to the K3 by forcing the K3 to xmit mode using XMIT button and listening to the outgoing signal on another receiver. I just have to manually turn the XMIT on and off. It use to work automatically. I am suspecting something in the K3 is not setup correct. I am using the USB mode with HRD set for AFSK RTTY-45, using line in for audio input. The same thing happens in DATA-A mode (wont key the xmtr). BTW the K3 does not key the transmitter from HRD in PSK31 mode either.
HRD and K3 utility all updated to latest configurations.
I am using a USB to RS-232 Prolific chipset converter.
Computer is Windows 10 (latest update).
Any suggestions would be greatly appreciated. Thanks.
--George Fletcher, AD5CQ


Mike Flowers
 

Hi George,

 

Have you had some recent Window updates?   If I remember correctly Prolific chipsets have had driver problems in the past.   There are some issues with counterfeit chips and inoperable drivers, etc.  You may want to update your Prolific drivers to see if that helps.

 

FTDI chipsets are recommended in the USB/RS-232 converters.

 

And, as Joe suggests, VOX works fine for this.

 

- 73 and good DX de Mike, K6MKF, NCDXC Secretary

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of George Fletcher
Sent: Saturday, July 18, 2020 13:44
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] K3 not responding to computer command to XMIT

 

I can not get my K3 (s\n 5215) to transmit in RTTY mode from Ham Radio Deluxe (HRD).  HRD will key the K3 in CW mode (KYcmd) just fine.  I have confirmed that AFSK signals are getting to the K3 by forcing the K3 to xmit mode using XMIT button and listening to the outgoing signal on another receiver.  I just have to manually turn the XMIT on and off.   It use to work automatically.   I am suspecting something in the K3 is not setup correct.  I am using the USB mode with HRD set for AFSK RTTY-45, using line in for audio input.  The same thing happens in DATA-A mode (wont key the xmtr).  BTW the K3 does not key the transmitter from HRD in PSK31 mode either.

 

HRD and K3 utility all updated to latest configurations.

 

I am using a USB to RS-232 Prolific chipset converter.

 

Computer is Windows 10 (latest update).

 

Any suggestions would be greatly appreciated.  Thanks.

--George Fletcher, AD5CQ


Joe Subich, W4TV
 

Specifically, HRD is not issuing a "TX" command with KY<cmd> in CW,
the KY<cmd> forces the K3/K3S into transmit (CW "vox" or QSK).

You need to utilize VOX for USB or configure HRD to generate PTT.
That can be done on the RS232 Port RTS line (if CONFIG:PTT-KEY =
RTS-xxx) in HRD. See the HRD and DM-780 documentation for information
configuring PTT.

73,

... Joe, W4TV

On 2020-07-19 9:38 AM, Joe Subich, W4TV wrote:
Turn on the VOX.
73,
   ... Joe, W4TV
On 2020-07-18 4:43 PM, George Fletcher wrote:
I can not get my K3 (s\n 5215) to transmit in RTTY mode from Ham Radio Deluxe (HRD). HRD will key the K3 in CW mode (KYcmd) just fine. I have confirmed that AFSK signals are getting to the K3 by forcing the K3 to xmit mode using XMIT button and listening to the outgoing signal on another receiver. I just have to manually turn the XMIT on and off. It use to work automatically. I am suspecting something in the K3 is not setup correct. I am using the USB mode with HRD set for AFSK RTTY-45, using line in for audio input. The same thing happens in DATA-A mode (wont key the xmtr). BTW the K3 does not key the transmitter from HRD in PSK31 mode either.

HRD and K3 utility all updated to latest configurations.

I am using a USB to RS-232 Prolific chipset converter.

Computer is Windows 10 (latest update).

Any suggestions would be greatly appreciated. Thanks.

--George Fletcher, AD5CQ


Rick NK7I
 

If HRD transmits on other modes, it will transmit on Data mode as well, something is not right in your set up.

VOX is *not* required with data modes in HRD if properly set for a K3.  It is required for CW.

Do not set CTS or DTR when you initially set up for control of the K3.  Make sure the baud rate is correct and you will be able to read the frequency and control the K3.

Data-A or AFSK-A mode (if you want PBT), with line in selected as the audio source; (per band  if my memory is correct); adjust the mic control to adjust the audio drive level as appropriate.

HRD will set the transmitter on, the audio provides the diddles, it just works (but I've chosen to use FSK, a little more complex).

If you want FSK, you need to use another com port to control it.

73,
Rick NK7I

On 7/19/2020 7:11 AM, Joe Subich, W4TV wrote:

Specifically, HRD is not issuing a "TX" command with KY<cmd> in CW,
the KY<cmd> forces the K3/K3S into transmit (CW "vox" or QSK).

You need to utilize VOX for USB or configure HRD to generate PTT.
That can be done on the RS232 Port RTS line (if CONFIG:PTT-KEY =
RTS-xxx) in HRD.  See the HRD and DM-780 documentation for information
configuring PTT.

73,

   ... Joe, W4TV


On 2020-07-19 9:38 AM, Joe Subich, W4TV wrote:

Turn on the VOX.

73,

    ... Joe, W4TV


On 2020-07-18 4:43 PM, George Fletcher wrote:
I can not get my K3 (s\n 5215) to transmit in RTTY mode from Ham Radio Deluxe (HRD). HRD will key the K3 in CW mode (KYcmd) just fine. I have confirmed that AFSK signals are getting to the K3 by forcing the K3 to xmit mode using XMIT button and listening to the outgoing signal on another receiver. I just have to manually turn the XMIT on and off. It use to work automatically. I am suspecting something in the K3 is not setup correct. I am using the USB mode with HRD set for AFSK RTTY-45, using line in for audio input. The same thing happens in DATA-A mode (wont key the xmtr). BTW the K3 does not key the transmitter from HRD in PSK31 mode either.

HRD and K3 utility all updated to latest configurations.

I am using a USB to RS-232 Prolific chipset converter.

Computer is Windows 10 (latest update).

Any suggestions would be greatly appreciated. Thanks.

--George Fletcher, AD5CQ



n7wy
 

George - 
You want the K3 to be in AFSKa mode at 45 baud for AFSK RTTY from HRD,.  FSK RTTY requires a TU keying via the ACC connector on the rear panel.  I use a microHam digikeyer for FSK.
Press the DATA MD button, set it properly.  
You definitely do not want to be in USB as normally the polarity of RTTY45 would be better with LSB.
However, AFSKa is preferred to LSB.  DATA-A is for FSK.

Is the K3 PTT-KEY configuration set up compatible with how you want PTT to work from HRD?   It could be either RTS or PTT, but HRD has to be on the same page.

Bob R - N7WY


Rick NK7I
 

Data A is for ANY digital mode that requires audio, AFSK RTTY, FT8, PSK etc etc.  You can use Data A for any digital mode requiring audio with HRD.

Using Data A turns OFF audio processing and NR functions which cause distortion on both TX and RX.  Using USB/LSB does not.

Do NOT use USB/LSB on an Elecraft radio for data.

IF you want to use the PBT function on RTTY, use the AFSK A mode, within the Data mode.

IF you want to use FSK (with an outside source toggling the aux line), use FSK within the Data mode.

It really is, that simple.

With HRD and FSK, using 'reverse' in HRD to copy properly, is normal.

Rick NK7I


On 7/19/2020 11:01 AM, n7wy via groups.io wrote:
George - 
You want the K3 to be in AFSKa mode at 45 baud for AFSK RTTY from HRD,.  FSK RTTY requires a TU keying via the ACC connector on the rear panel.  I use a microHam digikeyer for FSK.
Press the DATA MD button, set it properly.  
You definitely do not want to be in USB as normally the polarity of RTTY45 would be better with LSB.
However, AFSKa is preferred to LSB.  DATA-A is for FSK.

Is the K3 PTT-KEY configuration set up compatible with how you want PTT to work from HRD?   It could be either RTS or PTT, but HRD has to be on the same page.

Bob R - N7WY


Ray Maxfield
 

I use my K3 on USB All the Time for FT8 Traffic.

Why do you Say Not to ?    WA6VAB   K3.   

 

From: Rick NK7I
Sent: Sunday, July 19, 2020 12:56 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] K3 not responding to computer command to XMIT

 

Data A is for ANY digital mode that requires audio, AFSK RTTY, FT8, PSK etc etc.  You can use Data A for any digital mode requiring audio with HRD.

Using Data A turns OFF audio processing and NR functions which cause distortion on both TX and RX.  Using USB/LSB does not.

Do NOT use USB/LSB on an Elecraft radio for data.

IF you want to use the PBT function on RTTY, use the AFSK A mode, within the Data mode.

IF you want to use FSK (with an outside source toggling the aux line), use FSK within the Data mode.

It really is, that simple.

With HRD and FSK, using 'reverse' in HRD to copy properly, is normal.

Rick NK7I

 

On 7/19/2020 11:01 AM, n7wy via groups.io wrote:

George - 
You want the K3 to be in AFSKa mode at 45 baud for AFSK RTTY from HRD,.  FSK RTTY requires a TU keying via the ACC connector on the rear panel.  I use a microHam digikeyer for FSK.
Press the DATA MD button, set it properly.  
You definitely do not want to be in USB as normally the polarity of RTTY45 would be better with LSB.
However, AFSKa is preferred to LSB.  DATA-A is for FSK.

Is the K3 PTT-KEY configuration set up compatible with how you want PTT to work from HRD?   It could be either RTS or PTT, but HRD has to be on the same page.

Bob R - N7WY

 


Rick NK7I
 

Because you will not be sending or receiving the best signal you can. 

“Using Data A turns OFF audio processing and NR functions which cause distortion on both TX and RX.  Using USB/LSB does not.”

Rick NK7I

Email spiel Czech corruptions happen

On Jul 19, 2020, at 9:23 PM, Ray Maxfield <wa6vab@...> wrote:

Using Data A turns OFF audio processing and NR functions which cause distortion on both TX and RX.  Using USB/LSB does not.


Ed Muns, W0YK
 

The answer to your question is the second paragraph of NK7I's post below.

Of course you can use USB for FT modes, but you have to set compression to zero and turn off NR.  And then reset these functions when you go back to SSB.  Using DATA-A is easier and prevents inadvertently transmitting a dirty signal.

73,
Ed W0YK


-------- Original message --------
From: Ray Maxfield <wa6vab@...>
Date: 7/19/20 21:23 (GMT-08:00)
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] K3 not responding to computer command to XMIT

I use my K3 on USB All the Time for FT8 Traffic.

Why do you Say Not to ?    WA6VAB   K3.   

 

From: Rick NK7I
Sent: Sunday, July 19, 2020 12:56 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] K3 not responding to computer command to XMIT

 

Data A is for ANY digital mode that requires audio, AFSK RTTY, FT8, PSK etc etc.  You can use Data A for any digital mode requiring audio with HRD.

Using Data A turns OFF audio processing and NR functions which cause distortion on both TX and RX.  Using USB/LSB does not.

Do NOT use USB/LSB on an Elecraft radio for data.

IF you want to use the PBT function on RTTY, use the AFSK A mode, within the Data mode.

IF you want to use FSK (with an outside source toggling the aux line), use FSK within the Data mode.

It really is, that simple.

With HRD and FSK, using 'reverse' in HRD to copy properly, is normal.

Rick NK7I

 

On 7/19/2020 11:01 AM, n7wy via groups.io wrote:

George - 
You want the K3 to be in AFSKa mode at 45 baud for AFSK RTTY from HRD,.  FSK RTTY requires a TU keying via the ACC connector on the rear panel.  I use a microHam digikeyer for FSK.
Press the DATA MD button, set it properly.  
You definitely do not want to be in USB as normally the polarity of RTTY45 would be better with LSB.
However, AFSKa is preferred to LSB.  DATA-A is for FSK.

Is the K3 PTT-KEY configuration set up compatible with how you want PTT to work from HRD?   It could be either RTS or PTT, but HRD has to be on the same page.

Bob R - N7WY

 


Bob McGraw - K4TAX
 

FT-8 is a USB mode thus Data A should be used where as RTTY or specifically AFSK is a LSB mode.   

With HRD I choose AFSK A mode which puts the radio the correct mode and sideband for AFSK.  Thus it is in LSB mode.     VOX is not needed as HRD will key the radio correctly in AFSK A mode.  

73

Bob, K4TAX



1h.  Re: K3 not responding to computer command to XMIT
From: Ray Maxfield
Date: Sun, 19 Jul 2020 21:23:20 PDT

I use my K3 on USB All the Time for FT8 Traffic.

Why do you Say Not to ?    WA6VAB   K3.  


George Fletcher
 

All,

Problem solved.

 

Thanks to everyone that responded with suggestions.  It was Joe’s comment that prompted me to go back and look at the HRD software settings.  Indeed it was an HRD setup issue and not the K3 operation or settings.  See snip below:

 

Apparently the HRD software switch had changed.  I don’t remember changing it (memory is not what it use to be).  The problem was baffling to me since I had used all this before and everything worked great.  So now I can join the next RTTY contest.

 

--George Fletcher, AD5CQ

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Rick NK7I
Sent: Sunday, July 19, 2020 2:56 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] K3 not responding to computer command to XMIT

 

Data A is for ANY digital mode that requires audio, AFSK RTTY, FT8, PSK etc etc.  You can use Data A for any digital mode requiring audio with HRD.

Using Data A turns OFF audio processing and NR functions which cause distortion on both TX and RX.  Using USB/LSB does not.

Do NOT use USB/LSB on an Elecraft radio for data.

IF you want to use the PBT function on RTTY, use the AFSK A mode, within the Data mode.

IF you want to use FSK (with an outside source toggling the aux line), use FSK within the Data mode.

It really is, that simple.

With HRD and FSK, using 'reverse' in HRD to copy properly, is normal.

Rick NK7I

 

On 7/19/2020 11:01 AM, n7wy via groups.io wrote:

George - 
You want the K3 to be in AFSKa mode at 45 baud for AFSK RTTY from HRD,.  FSK RTTY requires a TU keying via the ACC connector on the rear panel.  I use a microHam digikeyer for FSK.
Press the DATA MD button, set it properly.  
You definitely do not want to be in USB as normally the polarity of RTTY45 would be better with LSB.
However, AFSKa is preferred to LSB.  DATA-A is for FSK.

Is the K3 PTT-KEY configuration set up compatible with how you want PTT to work from HRD?   It could be either RTS or PTT, but HRD has to be on the same page.

Bob R - N7WY


Bob McGraw - K4TAX
 

With using DATA-A or AFSK- modes, this automatically negates the RX and TX EQ values and the CMP value normally used for SSB. Thus one does not need to change those values when going between data modes and SSB modes. All sources recommend not using any EQ or processing with data modes.

73
Bob, K4TAX