K3 frozen


Pete Barletto
 

When I turned the rig on today I was greeted with the following error code: E04004C ERR DSC.  After consulting the manual the suggestion was to reload firmware.

I fired up the utility and downloaded the firmware and instructed the utility to load all (I was at the current level 5.67).

The result is shown below - the key seems to be the lack of an echo of D at 1641.52.
At this point the display shows MCU LD.

I removed power and tried again but the display continues to indicate MCU LD (and it's dark) and the TX light is flashing about once per second or so....

Anyone have this before?  And how did you recover?

Thanks,

Pete // KU2C

16:41:18 Elecraft K3 Utility Version 1.20.1.15
16:41:18 OS Version 10.0 Build 19041 
16:41:23 Open connection to ftp.elecraft.com
16:41:24 Copying files to C:\Users\peteb\AppData\Roaming\Elecraft\K3 Firmware
16:41:24 Copied DTBL0014.HEX from Elecraft
16:41:24 Copied haux0288.hex from Elecraft
16:41:25 Copied hdsp0288.hex from Elecraft
16:41:25 Copied hfpf0126.hex from Elecraft
16:41:25 Copied hfwnotes.rtf from Elecraft
16:41:26 Copied hmcu0567.hex from Elecraft
16:41:26 Copied hmcu0567b.hex from Elecraft
16:41:26 Copied tboot8.hex from Elecraft
16:41:26 Copied 8 files from Elecraft to C:\Users\peteb\AppData\Roaming\Elecraft\K3 Firmware
16:41:26 Ready
16:41:44 Sending firmware from C:\Users\peteb\AppData\Roaming\Elecraft\K3 Firmware
16:41:44 Elecraft K3 Utility Version 1.20.1.15
16:41:44 OS Version 10.0 Build 19041 
16:41:44 K3 MCU version 05.66 on COM1 at 38400 bit/s
16:41:44 MCU firmware file C:\Users\peteb\AppData\Roaming\Elecraft\K3 Firmware\hmcu0567.hex checksum reconciliation value is 0x0
16:41:44 MCU computed checksum reconciliation value is 0xCEF6
16:41:44 MCU firmware file C:\Users\peteb\AppData\Roaming\Elecraft\K3 Firmware\hmcu0567.hex checksum reconciliation value is 0x0
16:41:44 MCU computed checksum reconciliation value is 0x2D3C
16:41:44 Attempting to contact K3 on COM1 at 38400 bit/s
16:41:52 K3 Bootstrap Loader did not echo "D"
Remove power and retry firmware load
16:41:52 K3 is not responding
16:41:52 Ready
16:41:52 Error code 0xE2000043: Bootstrap Loader did not echo a D
16:41:52 Click "Close" to close this window
16:42:30 Elapsed time: 46 seconds


Jerry
 

GA Peter,

 

I had something similar happen to me some time ago and if memory serves me correctly, the cure was a compete reinitialization of the rig.  This meant that I would be starting over with no memories or configuration except for the default as provided in the reinitialization.

 

So before you do anything at all, talk with Elecraft support first. It would be the best thing to do.

 

Best regards,

 

Jerry, W1IE

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Pete Barletto via groups.io
Sent: Tuesday, June 8, 2021 12:55 PM
To: Elecraft K3 Group <elecraft-k3@groups.io>
Subject: [Elecraft-K3] K3 frozen

 

When I turned the rig on today I was greeted with the following error code: E04004C ERR DSC.  After consulting the manual the suggestion was to


Pete Barletto
 

Jerry, 

Many thanks - found the re-initializing process in the manual and I’ll give that a shot.  I do have saved configurations so I hope that can be used afterwords.

Thanks,
Pete // KU2C


On Jun 8, 2021, at 3:39 PM, Jerry <W1IE@...> wrote:

GA Peter,
 
I had something similar happen to me some time ago and if memory serves me correctly, the cure was a compete reinitialization of the rig.  This meant that I would be starting over with no memories or configuration except for the default as provided in the reinitialization. 
 
So before you do anything at all, talk with Elecraft support first. It would be the best thing to do.
 
Best regards,
 
Jerry, W1IE
 
From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Pete Barletto via groups.io
Sent: Tuesday, June 8, 2021 12:55 PM
To: Elecraft K3 Group <elecraft-k3@groups.io>
Subject: [Elecraft-K3] K3 frozen
 
When I turned the rig on today I was greeted with the following error code: E04004C ERR DSC.  After consulting the manual the suggestion was to 


Jerry
 

Peter,

 

You have the one most important  thing that is needed in a reinitializing a K3 – A configuration file. Well done and best wishes.

 

Jerry, W1IE

 

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Pete Barletto via groups.io
Sent: Tuesday, June 8, 2021 16:59 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] K3 frozen

 

Jerry, 

 

Many thanks - found the re-initializing process in the manual and I’ll give that a shot.  I do have saved configurations so I hope that can be used afterwords.

 

Thanks,

Pete // KU2C

 



On Jun 8, 2021, at 3:39 PM, Jerry <W1IE@...> wrote:

 

GA Peter,

 

I had something similar happen to me some time ago and if memory serves me correctly, the cure was a compete reinitialization of the rig.  This meant that I would be starting over with no memories or configuration except for the default as provided in the reinitialization. 

 

So before you do anything at all, talk with Elecraft support first. It would be the best thing to do.

 

Best regards,

 

Jerry, W1IE

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Pete Barletto via groups.io
Sent: Tuesday, June 8, 2021 12:55 PM
To: Elecraft K3 Group <elecraft-k3@groups.io>
Subject: [Elecraft-K3] K3 frozen

 

When I turned the rig on today I was greeted with the following error code: E04004C ERR DSC.  After consulting the manual the suggestion was to