Topics

Intermittent xmit pulse output, SOLVED (Kind of)

John H. Long Jr.
 

Tried all the USB suggestions without any suggestions..
 
Soooo.....
  Someone mentioned they used native RS-232 (Like in the good old days).
 
My computer is old enough that it has a hardware RS-232 port on the bac.
 
Connected a through RS-232 com cable from the RS-232 port to the K3 and everything seems to be working fine now.
Something to do with Windows 10 and USB or the USB/Com converter cable.
 
 
 
THANKS everyone for their input and assistance.
 
 
 
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 

--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
From: 'John H. Long Jr.' <john@...>
Date: 11/18/19 8:10 pm
To: Elecraft-K3@groups.io

Where / how do I do that?
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
From: 'Ed Pflueger' <ab4iq@...>
Date: 11/18/19 1:49 pm
To: Elecraft-K3@groups.io

Need to turn the USB sleep or power mode to OFF in Windows.

Ed.. AB4IQ

-----Original Message-----
From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Mike Flowers
Sent: Monday, November 18, 2019 2:26 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output

So, I wonder if the Windows USB port 'Power Management' is in play here?

Wake ... sleep ... wake ... sleep ...

- 73 and good DX de Mike, K6MKF, NCDXC Secretary

> -----Original Message-----
> From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Bob
> McGraw - K4TAX
> Sent: Monday, November 18, 2019 12:01
> To: Elecraft-K3@groups.io
> Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
>
> USB at the radio, one cable to a USB port on the computer. Not using any RS-
> 232 converter. The radio control {CAT} along with audio is all on the same cable.
>
> 73
>
> Bob, K4TAX
>
>
> On 11/18/2019 1:52 PM, Mike Flowers wrote:
> > How is CAT control achieved here ... RS232 or USB/RS232?
> >
> > Sounds to me as if the PC is 'poling' the COM port for some reason.
> >
> > - 73 and good DX de Mike, K6MKF, NCDXC Secretary
> >
> >> -----Original Message-----
> >> From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Ed
> >> Pflueger
> >> Sent: Monday, November 18, 2019 11:50
> >> To: Elecraft-K3@groups.io
> >> Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
> >>
> >> That's the way mine is Bob. No Issues
> >>
> >> Ed.. AB4IQ
> >>
> >> -----Original Message-----
> >> From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On
> >> Behalf Of Bob McGraw - K4TAX
> >> Sent: Monday, November 18, 2019 11:46 AM
> >> To: Elecraft-K3@groups.io
> >> Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
> >>
> >> I find this method does work and does not give a brief PTT command
> >> on initialization of the application. See comments and suggestions from VE3KI.
> >>
> >> With WSJT-X I have the following values:
> >>
> >> PTT Method = CAT
> >>
> >> Data Bits = 8
> >>
> >> Stop Bits = 1
> >>
> >> Handshake = None
> >>
> >> Mode = Data/Pkt
> >>
> >> Split Operation = Rig
> >>
> >> 73
> >>
> >> Bob, K4TAX
> >>
> >> On 11/18/2019 9:57 AM, ve3ki wrote:
> >>> Here is a suggestion for an alternative configuration: Set the
> >>> K3's CONFIG:PTT-KEY to OFF-OFF. In each of your radio
> >>> control/logging programs, disable the PTT via RTS and instead
> >>> configure the software to do PTT via CAT (radio command). In
> >>> N1MM+, set RTS to Always Off and check the check box for "PTT via Radio Command Digital Mode"
> >>> (and other modes if you use PTT in them). In WSJT-X, select CAT as
> >>> the PTT method.
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
> >
> >
> >
>
>
>







Bob McGraw - K4TAX
 

If you use a RS-232 to USB converter and it has Prolific chip set, that is most likely the problem.  Many have counterfeit devices and Windows drivers do not work reliably.  

The RS-232 to USB converter with the FDTI chipset is 100% reliable and the Windows drivers are correct.    The others are less expensive and are basically junk.   Has nothing to do with Windows 10.

The best and most reliable and highly supported device here in the USA is the USB-RTS03 from R T Systems.  

73

Bob, K4TAX

On 11/18/2019 9:29 PM, John H. Long Jr. wrote:
Tried all the USB suggestions without any suggestions..
 
Soooo.....
  Someone mentioned they used native RS-232 (Like in the good old days).
 
My computer is old enough that it has a hardware RS-232 port on the bac.
 
Connected a through RS-232 com cable from the RS-232 port to the K3 and everything seems to be working fine now.
Something to do with Windows 10 and USB or the USB/Com converter cable.
 
 
 
THANKS everyone for their input and assistance.
 
 
 
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
From: 'John H. Long Jr.' <john@...>
Date: 11/18/19 8:10 pm
To: Elecraft-K3@groups.io

Where / how do I do that?
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
From: 'Ed Pflueger' <ab4iq@...>
Date: 11/18/19 1:49 pm
To: Elecraft-K3@groups.io

Need to turn the USB sleep or power mode to OFF in Windows.

Ed.. AB4IQ

-----Original Message-----
From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Mike Flowers
Sent: Monday, November 18, 2019 2:26 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output

So, I wonder if the Windows USB port 'Power Management' is in play here?

Wake ... sleep ... wake ... sleep ...

- 73 and good DX de Mike, K6MKF, NCDXC Secretary

> -----Original Message-----
> From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Bob
> McGraw - K4TAX
> Sent: Monday, November 18, 2019 12:01
> To: Elecraft-K3@groups.io
> Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
>
> USB at the radio, one cable to a USB port on the computer. Not using any RS-
> 232 converter. The radio control {CAT} along with audio is all on the same cable.
>
> 73
>
> Bob, K4TAX
>
>
> On 11/18/2019 1:52 PM, Mike Flowers wrote:
> > How is CAT control achieved here ... RS232 or USB/RS232?
> >
> > Sounds to me as if the PC is 'poling' the COM port for some reason.
> >
> > - 73 and good DX de Mike, K6MKF, NCDXC Secretary
> >
> >> -----Original Message-----
> >> From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Ed
> >> Pflueger
> >> Sent: Monday, November 18, 2019 11:50
> >> To: Elecraft-K3@groups.io
> >> Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
> >>
> >> That's the way mine is Bob. No Issues
> >>
> >> Ed.. AB4IQ
> >>
> >> -----Original Message-----
> >> From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On
> >> Behalf Of Bob McGraw - K4TAX
> >> Sent: Monday, November 18, 2019 11:46 AM
> >> To: Elecraft-K3@groups.io
> >> Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
> >>
> >> I find this method does work and does not give a brief PTT command
> >> on initialization of the application. See comments and suggestions from VE3KI.
> >>
> >> With WSJT-X I have the following values:
> >>
> >> PTT Method = CAT
> >>
> >> Data Bits = 8
> >>
> >> Stop Bits = 1
> >>
> >> Handshake = None
> >>
> >> Mode = Data/Pkt
> >>
> >> Split Operation = Rig
> >>
> >> 73
> >>
> >> Bob, K4TAX
> >>
> >> On 11/18/2019 9:57 AM, ve3ki wrote:
> >>> Here is a suggestion for an alternative configuration: Set the
> >>> K3's CONFIG:PTT-KEY to OFF-OFF. In each of your radio
> >>> control/logging programs, disable the PTT via RTS and instead
> >>> configure the software to do PTT via CAT (radio command). In
> >>> N1MM+, set RTS to Always Off and check the check box for "PTT via Radio Command Digital Mode"
> >>> (and other modes if you use PTT in them). In WSJT-X, select CAT as
> >>> the PTT method.
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
> >
> >
> >
>
>
>







Bob Wilson, N6TV
 

If you are using a K3S or any FTDI-based USB-to-Serial adapter, please follow the important advice documented here to prevent the adapter from generating spurious signals on the DTR and RTS pins:

https://bit.ly/FTDItip  (redirects to Google Doc, which you may download as a PDF for Print).

The default Windows FTDI device options will cause the K3S to go into transmit mode briefly (usually three or four slow beeps) especially if CONFIG:RTS-DTR is set to anything other than OFF-OFF.

If it is already set to OFF-OFF and you are still getting intermittent transmissions, it sounds like something is generating software PTT.

I personally prefer hardware PTT via the RTS pins and disable all software PTT and all handshake signals on both DTR and RTS (K3 does not support any type of RS-232 handshaking).

73,
Bob, N6TV


On Mon, Nov 18, 2019 at 11:00 PM Bob McGraw - K4TAX <rmcgraw@...> wrote:

If you use a RS-232 to USB converter and it has Prolific chip set, that is most likely the problem.  Many have counterfeit devices and Windows drivers do not work reliably.  

The RS-232 to USB converter with the FDTI chipset is 100% reliable and the Windows drivers are correct.    The others are less expensive and are basically junk.   Has nothing to do with Windows 10.

The best and most reliable and highly supported device here in the USA is the USB-RTS03 from R T Systems.  

73

Bob, K4TAX

On 11/18/2019 9:29 PM, John H. Long Jr. wrote:
Tried all the USB suggestions without any suggestions..
 
Soooo.....
  Someone mentioned they used native RS-232 (Like in the good old days).
 
My computer is old enough that it has a hardware RS-232 port on the bac.
 
Connected a through RS-232 com cable from the RS-232 port to the K3 and everything seems to be working fine now.
Something to do with Windows 10 and USB or the USB/Com converter cable.
 
 
 
THANKS everyone for their input and assistance.
 
 
 
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
From: 'John H. Long Jr.' <john@...>
Date: 11/18/19 8:10 pm
To: Elecraft-K3@groups.io

Where / how do I do that?
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
From: 'Ed Pflueger' <ab4iq@...>
Date: 11/18/19 1:49 pm
To: Elecraft-K3@groups.io

Need to turn the USB sleep or power mode to OFF in Windows.

Ed.. AB4IQ

-----Original Message-----
From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Mike Flowers
Sent: Monday, November 18, 2019 2:26 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] Intermittent xmit pulse output

So, I wonder if the Windows USB port 'Power Management' is in play here?

Wake ... sleep ... wake ... sleep ...

- 73 and good DX de Mike, K6MKF, NCDXC Secretary

> -----Original Message-----
> From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Bob
> McGraw - K4TAX
> Sent: Monday, November 18, 2019 12:01
> To: Elecraft-K3@groups.io
> Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
>
> USB at the radio, one cable to a USB port on the computer. Not using any RS-
> 232 converter. The radio control {CAT} along with audio is all on the same cable.
>
> 73
>
> Bob, K4TAX
>
>
> On 11/18/2019 1:52 PM, Mike Flowers wrote:
> > How is CAT control achieved here ... RS232 or USB/RS232?
> >
> > Sounds to me as if the PC is 'poling' the COM port for some reason.
> >
> > - 73 and good DX de Mike, K6MKF, NCDXC Secretary
> >
> >> -----Original Message-----
> >> From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Ed
> >> Pflueger
> >> Sent: Monday, November 18, 2019 11:50
> >> To: Elecraft-K3@groups.io
> >> Subject: Re: [Elecraft-K3] Intermittent xmit pulse output
> >>
> >> That's the way mine is Bob. No Issues
> >>
> >> Ed.. AB4IQ
> >>
> >> -----Original Message-----
> >> From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On
> >> Behalf Of Bob McGraw - K4TAX
> >> Sent: Monday, November 18, 2019 11:46 AM
> >> To: Elecraft-K3@groups.io
> >> Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
> >>
> >> I find this method does work and does not give a brief PTT command
> >> on initialization of the application. See comments and suggestions from VE3KI.
> >>
> >> With WSJT-X I have the following values:
> >>
> >> PTT Method = CAT
> >>
> >> Data Bits = 8
> >>
> >> Stop Bits = 1
> >>
> >> Handshake = None
> >>
> >> Mode = Data/Pkt
> >>
> >> Split Operation = Rig
> >>
> >> 73
> >>
> >> Bob, K4TAX
> >>
> >> On 11/18/2019 9:57 AM, ve3ki wrote:
> >>> Here is a suggestion for an alternative configuration: Set the
> >>> K3's CONFIG:PTT-KEY to OFF-OFF. In each of your radio
> >>> control/logging programs, disable the PTT via RTS and instead
> >>> configure the software to do PTT via CAT (radio command). In
> >>> N1MM+, set RTS to Always Off and check the check box for "PTT via Radio Command Digital Mode"
> >>> (and other modes if you use PTT in them). In WSJT-X, select CAT as
> >>> the PTT method.
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
> >
> >
> >
>
>
>