Topics

Intermitent xmit pulse output

John H. Long Jr.
 

Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

Bob McGraw - K4TAX
 

With full CAT control in each case, I use WSJT-X, HRD, FLDIGI, JS8Call, and MMTTY with no issues or artifacts as described.   I use these individually and not through or run by another application. 

With all due respect, I absolutely despise logging programs.   Every one I've evaluated is best described as a P I T A.  I prefer to log manually although still computer based.  It is much less problematic and much more predictable and reliable.

I'd speculate that the logging application and the operating application both interrogating the radio is the likely cause.

73

Bob, K4TAX


On 11/17/2019 6:44 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

John H. Long Jr.
 

I only use one at a time.  But they all exhibit the same problem.
Update:  WSJT-X in WSPR mode does not do it ?????


Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Bob McGraw - K4TAX <rmcgraw@...>
Date: 11/17/19 6:31 PM (GMT-07:00)
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output

With full CAT control in each case, I use WSJT-X, HRD, FLDIGI, JS8Call, and MMTTY with no issues or artifacts as described.   I use these individually and not through or run by another application. 

With all due respect, I absolutely despise logging programs.   Every one I've evaluated is best described as a P I T A.  I prefer to log manually although still computer based.  It is much less problematic and much more predictable and reliable.

I'd speculate that the logging application and the operating application both interrogating the radio is the likely cause.

73

Bob, K4TAX


On 11/17/2019 6:44 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

Bob McGraw - K4TAX
 

Do you use the logging program with  WSPR?  Could be the difference. 

Bob, K4TAX



On Nov 17, 2019, at 9:28 PM, John H. Long Jr. <john@...> wrote:

I only use one at a time.  But they all exhibit the same problem.
Update:  WSJT-X in WSPR mode does not do it ?????


Sent from my Verizon, Samsung Galaxy smartphone

-------- Original message --------
From: Bob McGraw - K4TAX <rmcgraw@...>
Date: 11/17/19 6:31 PM (GMT-07:00)
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output

With full CAT control in each case, I use WSJT-X, HRD, FLDIGI, JS8Call, and MMTTY with no issues or artifacts as described.   I use these individually and not through or run by another application. 

With all due respect, I absolutely despise logging programs.   Every one I've evaluated is best described as a P I T A.  I prefer to log manually although still computer based.  It is much less problematic and much more predictable and reliable.

I'd speculate that the logging application and the operating application both interrogating the radio is the likely cause.

73

Bob, K4TAX


On 11/17/2019 6:44 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

ve3ki
 

What is CONFIG:PTT-KEY set to? If you set it to OFF-OFF, does that stop the intermittent triggering of PTT?

73,
Rich VE3KI


On Sun, Nov 17, 2019 at 07:53 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

John H. Long Jr.
 

Good suggestion.
 
A bit of trouble shooting using WSJT-X v2.1.0
K3 set to Data mode.
 
CONFIG:PTT-KEY
 
   OFF-OFF    No pulse output, No PTT control
 
   RST-OFF    Random pulse output, PTT control
   DTR-OFF   Constant pulse chatter, No PTT
 
   OFF-RST   No Pulse, No PTT
   OFF-DTR   No pulse, No PTT
 
Additional observations:
   When WSJT-X's setup window is open, and I do a "Test CAT" which turns Green, things seem OK.
         On the K3 the yellow Delta f light is off (Just below the Power switch on the K3).
   Once I exit the WSJT-X setup window the yellow light (Delta F) turns on and the problem returns.
          It seems that the timing of the random xmit pulse is in sync with when I receive a signal higher that S-9
 
 
If I press A>B to align the two frequencies, everything seems to work ?????
If I change the "Split Mode" in WSJT-X to "Fake it" everything seems to work.
 
Now to do testing with HRD & N1MM.
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 

--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
From: 've3ki' <ve3iay@...>
Date: 11/18/19 5:12 am
To: Elecraft-K3@groups.io

What is CONFIG:PTT-KEY set to? If you set it to OFF-OFF, does that stop the intermittent triggering of PTT?

73,
Rich VE3KI


On Sun, Nov 17, 2019 at 07:53 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

John H. Long Jr.
 

Additional testing with N1MM.
 
Still have the random pulse even if the yellow "Delta f" light is off.
 
 
 
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 

--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
From: 'John H. Long Jr.' <john@...>
Date: 11/18/19 8:08 am
To: Elecraft-K3@groups.io
Cc: 'John Long' <john@...>

Good suggestion.
 
A bit of trouble shooting using WSJT-X v2.1.0
K3 set to Data mode.
 
CONFIG:PTT-KEY
 
   OFF-OFF    No pulse output, No PTT control
 
   RST-OFF    Random pulse output, PTT control
   DTR-OFF   Constant pulse chatter, No PTT
 
   OFF-RST   No Pulse, No PTT
   OFF-DTR   No pulse, No PTT
 
Additional observations:
   When WSJT-X's setup window is open, and I do a "Test CAT" which turns Green, things seem OK.
         On the K3 the yellow Delta f light is off (Just below the Power switch on the K3).
   Once I exit the WSJT-X setup window the yellow light (Delta F) turns on and the problem returns.
          It seems that the timing of the random xmit pulse is in sync with when I receive a signal higher that S-9
 
 
If I press A>B to align the two frequencies, everything seems to work ?????
If I change the "Split Mode" in WSJT-X to "Fake it" everything seems to work.
 
Now to do testing with HRD & N1MM.
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
From: 've3ki' <ve3iay@...>
Date: 11/18/19 5:12 am
To: Elecraft-K3@groups.io

What is CONFIG:PTT-KEY set to? If you set it to OFF-OFF, does that stop the intermittent triggering of PTT?

73,
Rich VE3KI


On Sun, Nov 17, 2019 at 07:53 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

John H. Long Jr.
 

Additional testing with N1MM.
 
Still have the random pulse even if the yellow "Delta f" light is off.
 
 
 
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 

--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
From: 'John H. Long Jr.' <john@...>
Date: 11/18/19 8:08 am
To: Elecraft-K3@groups.io
Cc: 'John Long' <john@...>

Good suggestion.
 
A bit of trouble shooting using WSJT-X v2.1.0
K3 set to Data mode.
 
CONFIG:PTT-KEY
 
   OFF-OFF    No pulse output, No PTT control
 
   RST-OFF    Random pulse output, PTT control
   DTR-OFF   Constant pulse chatter, No PTT
 
   OFF-RST   No Pulse, No PTT
   OFF-DTR   No pulse, No PTT
 
Additional observations:
   When WSJT-X's setup window is open, and I do a "Test CAT" which turns Green, things seem OK.
         On the K3 the yellow Delta f light is off (Just below the Power switch on the K3).
   Once I exit the WSJT-X setup window the yellow light (Delta F) turns on and the problem returns.
          It seems that the timing of the random xmit pulse is in sync with when I receive a signal higher that S-9
 
 
If I press A>B to align the two frequencies, everything seems to work ?????
If I change the "Split Mode" in WSJT-X to "Fake it" everything seems to work.
 
Now to do testing with HRD & N1MM.
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
From: 've3ki' <ve3iay@...>
Date: 11/18/19 5:12 am
To: Elecraft-K3@groups.io

What is CONFIG:PTT-KEY set to? If you set it to OFF-OFF, does that stop the intermittent triggering of PTT?

73,
Rich VE3KI


On Sun, Nov 17, 2019 at 07:53 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

ve3ki
 

If you are not getting PTT when CONFIG:PTT-KEY is set to OFF-OFF, but only when it is set to RTS-OFF, it looks as if you have configured your software programs to use RTS on the radio control port for PTT. Unfortunately, either the computer is toggling RTS at unexpected times or perhaps there is a problem with the voltage levels on the RTS pin on the cable.

Here is a suggestion for an alternative configuration: Set the K3's CONFIG:PTT-KEY to OFF-OFF. In each of your radio control/logging programs, disable the PTT via RTS and instead configure the software to do PTT via CAT (radio command). In N1MM+, set RTS to Always Off and check the check box for "PTT via Radio Command Digital Mode" (and other modes if you use PTT in them). In WSJT-X, select CAT as the PTT method.

If you don't like the PTT via CAT method, VOX works just fine on the K3 in digital modes. For VOX, you don't configure any form of PTT control in N1MM+, and in WSJT-X you select VOX as the PTT method. I can't speak for HRD.

Regarding the Split mode in WSJT-X, I have never been happy with the results using the "Rig" setting; "Fake It" works better for me. Just don't be disconcerted by seeing the frequency on the rig's dial change between RX and TX; that's what "Fake It" does.

73,
Rich VE3KI


On Mon, Nov 18, 2019 at 10:08 AM, John H. Long Jr. wrote:
Good suggestion.
 
A bit of trouble shooting using WSJT-X v2.1.0
K3 set to Data mode.
 
CONFIG:PTT-KEY
 
   OFF-OFF    No pulse output, No PTT control
 
   RST-OFF    Random pulse output, PTT control
   DTR-OFF   Constant pulse chatter, No PTT
 
   OFF-RST   No Pulse, No PTT
   OFF-DTR   No pulse, No PTT
 
Additional observations:
   When WSJT-X's setup window is open, and I do a "Test CAT" which turns Green, things seem OK.
         On the K3 the yellow Delta f light is off (Just below the Power switch on the K3).
   Once I exit the WSJT-X setup window the yellow light (Delta F) turns on and the problem returns.
          It seems that the timing of the random xmit pulse is in sync with when I receive a signal higher that S-9
 
 
If I press A>B to align the two frequencies, everything seems to work ?????
If I change the "Split Mode" in WSJT-X to "Fake it" everything seems to work.
 
Now to do testing with HRD & N1MM.
 
 
John H. Long Jr.
KW7A
1370 N 150 E
Nephi, UT 84648
USA
 
(435) 888-LONG
 
 
--------- Original Message ---------
Subject: Re: [Elecraft-K3] Intermitent xmit pulse output
From: 've3ki' <ve3iay@...>
Date: 11/18/19 5:12 am
To: Elecraft-K3@groups.io

What is CONFIG:PTT-KEY set to? If you set it to OFF-OFF, does that stop the intermittent triggering of PTT?

73,
Rich VE3KI


On Sun, Nov 17, 2019 at 07:53 PM, John H. Long Jr. wrote:
Whenever I am connected to the K3 using CAT control software the K3 randomly goes into XMIT mode for a split second and then back to normal.

It happens when I use N1MM, WSJT-X, HRD etc.

Since it happens when connected using CAT control on all 3 software programs I wonder if I have something setup wrong in the K3?

When I shut off any CAT control program, the random XMIT pulse does not happen.

K3 firmware version MCU 05.60

Any suggestions?

Bob McGraw - K4TAX
 

I find this method does work and does not give a brief PTT command on initialization of the application.  See comments and suggestions from VE3KI.

With WSJT-X I have the following values:

PTT Method = CAT

Data Bits = 8

Stop Bits = 1

Handshake = None

Mode = Data/Pkt

Split Operation = Rig

73

Bob, K4TAX

On 11/18/2019 9:57 AM, ve3ki wrote:
Here is a suggestion for an alternative configuration: Set the K3's CONFIG:PTT-KEY to OFF-OFF. In each of your radio control/logging programs, disable the PTT via RTS and instead configure the software to do PTT via CAT (radio command). In N1MM+, set RTS to Always Off and check the check box for "PTT via Radio Command Digital Mode" (and other modes if you use PTT in them). In WSJT-X, select CAT as the PTT method.

Bill Mader
 

Regarding logging programs, I have frequently seen the rate meter on N1MM+ rise above 200 QSO's/hour.  Try doing that with paper and pen and still avoid duplicates!

Daily loggers like DXLab Suite make tracking awards simple.  Additionally, the many features make it very powerful and useful.

Unless you're operating FD and saying "Please Copy", the time has passed for paper and pen to have any value except as a back-up for a Windows-caused re-boot.  Like the radios tied to the loggers, users need to RTFM and practice.  I would be without an electronic logger as much as I would give up my solder station--not in this lifetime!

73, Bill Mader, K8TE
W6H NM Coordinator, Route 66 On-the-Air 4-13 Sep 2020
ARRL New Mexico Section Manager
ARRL - The national association for Amateur Radio
Duke City Hamfest BoD Vice-Chairman www.dukecityhamfest.org 18-20 Sep 2020
Secretary and Past President, Albuquerque DX Association 


--
73, Bill Mader, K8TE
K-Line, KX3, KX1, K2
W6H NM Coordinator, Route 66 On-the-Air 4-13 Sep 2020
ARRL New Mexico Section Manager
ARRL - The national association for Amateur Radio
Duke City Hamfest BoD Vice-Chairman www.dukecityhamfest.org 18-20 Sep 2020
Secretary and Past President, Albuquerque DX Association 

Michael Kopec
 

Dear Bull K8TE; A little hard to use N1MM logger while operating cw mobile, but am open to suggestion by the best, HI de Mike K8NS

On Tuesday, November 19, 2019, 5:35:00 PM EST, Bill Mader <billamader@...> wrote:


Regarding logging programs, I have frequently seen the rate meter on N1MM+ rise above 200 QSO's/hour.  Try doing that with paper and pen and still avoid duplicates!

Daily loggers like DXLab Suite make tracking awards simple.  Additionally, the many features make it very powerful and useful.

Unless you're operating FD and saying "Please Copy", the time has passed for paper and pen to have any value except as a back-up for a Windows-caused re-boot.  Like the radios tied to the loggers, users need to RTFM and practice.  I would be without an electronic logger as much as I would give up my solder station--not in this lifetime!

73, Bill Mader, K8TE
W6H NM Coordinator, Route 66 On-the-Air 4-13 Sep 2020
ARRL New Mexico Section Manager
ARRL - The national association for Amateur Radio
Duke City Hamfest BoD Vice-Chairman www.dukecityhamfest.org 18-20 Sep 2020
Secretary and Past President, Albuquerque DX Association 


--
73, Bill Mader, K8TE
K-Line, KX3, KX1, K2
W6H NM Coordinator, Route 66 On-the-Air 4-13 Sep 2020
ARRL New Mexico Section Manager
ARRL - The national association for Amateur Radio
Duke City Hamfest BoD Vice-Chairman www.dukecityhamfest.org 18-20 Sep 2020
Secretary and Past President, Albuquerque DX Association