Support


Paul Bowen <paulbowen@...>
 

Hi

Well I have tried and failed to get support from Elecraft or even a
meaningful reply to emails during the last seven months. Today my 90 year
old friend went out and brought an IC 7300. To quote him "I will probably be
dead by the time Elecraft reply".

Sometimes you have to cut your losses. I had heard Elecraft support was
legendary I was expecting more, at least more than MFJ. I now have to try
and sell a K3S at a massive loss. Please don`t reply I have left the group.



Cheers

Paul

M0PNN


Eric Swartz - WA6HHQ, Elecraft
 
Edited

Hi Paul,

I apologize for the support problem you are encountering This is really odd, as we are not backlogged multiple months on cs mails.  We have had response delays of several weeks on occasion due to a huge surge in questions and support emails received during the covid crisis and we are working hard to get that down. (We've also seen much stronger sales than we expected. I guess more hams are at home and are increasing their operating time!) Its also possible your email is getting incorrectly caught in a spam filter on this end. 

And as a general note we are definitely continuing our support for the K3 and K3S. 

Can you email me, at my address below, the email address you are sending to for your support requests? 
Also send me a copy of your support request email and I'll make sure it gets to our support team.

73,   Eric WA6HHQ
eric@...


Paul Petherick
 

Thanks Eric but all is good now.  Got my amp back repaired and working fine
The problem may have been on my end.
Paul. K1sec

Sent from my Verizon, Samsung Galaxy smartphone


From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> on behalf of Eric Swartz - WA6HHQ, Elecraft <wa6hhq_lists@...>
Sent: Wednesday, May 19, 2021 2:26:45 PM
To: Elecraft-K3@groups.io <Elecraft-K3@groups.io>
Subject: Re: [Elecraft-K3] Support
 

[Edited Message Follows]

Hi Paul,

I apologize for the support problem you are encountering This is really odd, as we are not backlogged multiple months on cs mails.  We have had response delays of several weeks on occasion due to a huge surge in questions and support emails received during the covid crisis and we are working hard to get that down. (We've also seen much stronger sales than we expected. I guess more hams are at home and are increasing their operating time!) Its also possible your email is getting incorrectly caught in a spam filter on this end. 

And as a general note we are definitely continuing our support for the K3 and K3S. 

Can you email me, at my address below, the email address you are sending to for your support requests? 
Also send me a copy of your support request email and I'll make sure it gets to our support team.

73,   Eric WA6HHQ
eric@...


K1dj
 

Good morning -  As of yesterday, it has been 14 weeks since Elecraft acknowledged receipt of my K3S for repair.  My email request for a status update a few weeks ago was not answered.   It would be helpful to those of us similarly situated to know, at least, approximately where we are in the queue, please.
Best wishes - Rich, K1DJ



On May 19, 2021, at 11:54 PM, Paul Petherick <paul.peth@...> wrote:


Thanks Eric but all is good now.  Got my amp back repaired and working fine
The problem may have been on my end.
Paul. K1sec

Sent from my Verizon, Samsung Galaxy smartphone


From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> on behalf of Eric Swartz - WA6HHQ, Elecraft <wa6hhq_lists@...>
Sent: Wednesday, May 19, 2021 2:26:45 PM
To: Elecraft-K3@groups.io <Elecraft-K3@groups.io>
Subject: Re: [Elecraft-K3] Support
 

[Edited Message Follows]

Hi Paul,

I apologize for the support problem you are encountering This is really odd, as we are not backlogged multiple months on cs mails.  We have had response delays of several weeks on occasion due to a huge surge in questions and support emails received during the covid crisis and we are working hard to get that down. (We've also seen much stronger sales than we expected. I guess more hams are at home and are increasing their operating time!) Its also possible your email is getting incorrectly caught in a spam filter on this end. 

And as a general note we are definitely continuing our support for the K3 and K3S. 

Can you email me, at my address below, the email address you are sending to for your support requests? 
Also send me a copy of your support request email and I'll make sure it gets to our support team.

73,   Eric WA6HHQ
eric@...


Dave (NK7Z)
 

I too would like to get a rough idea of where we are if I send in a device for repair. I have a P3, that is temperature sensitive on boot, (if cold fails to boot), that I am holding off on sending in right now.

Any ideas how long that might take if I send it in?

73, and thanks,
Dave (NK7Z)
https://www.nk7z.net
ARRL Volunteer Examiner
ARRL Technical Specialist, RFI
ARRL Asst. Director, NW Division, Technical Resources

On 5/20/21 2:34 AM, K1dj via groups.io wrote:
Good morning -  As of yesterday, it has been 14 weeks since Elecraft acknowledged receipt of my K3S for repair.  My email request for a status update a few weeks ago was not answered.   It would be helpful to those of us similarly situated to know, at least, approximately where we are in the queue, please.
Best wishes - Rich, K1DJ

On May 19, 2021, at 11:54 PM, Paul Petherick <paul.peth@hotmail.com> wrote:


Thanks Eric but all is good now.  Got my amp back repaired and working fine
The problem may have been on my end.
Paul. K1sec

Sent from my Verizon, Samsung Galaxy smartphone
Get Outlook for Android <https://aka.ms/ghei36>

------------------------------------------------------------------------
*From:* Elecraft-K3@groups.io <Elecraft-K3@groups.io> on behalf of Eric Swartz - WA6HHQ, Elecraft <wa6hhq_lists@elecraft.com>
*Sent:* Wednesday, May 19, 2021 2:26:45 PM
*To:* Elecraft-K3@groups.io <Elecraft-K3@groups.io>
*Subject:* Re: [Elecraft-K3] Support

[Edited Message Follows]

Hi Paul,

I apologize for the support problem you are encountering This is really odd, as we are not backlogged multiple months on cs mails.  We have had response delays of several weeks on occasion due to a huge surge in questions and support emails received during the covid crisis and we are working hard to get that down. (We've also seen much stronger sales than we expected. I guess more hams are at home and are increasing their operating time!) Its also possible your email is getting incorrectly caught in a spam filter on this end.

And as a general note we are definitely continuing our support for the K3 and K3S.

Can you email me, at my address below, the email address you are sending to for your support requests?
Also send me a copy of your support request email and I'll make sure it gets to our support team.

73,   Eric WA6HHQ
eric@elecraft.com


Bill Carpenter
 

My W2 sensor unit burned a resistor this morning so I also am interested in repair turn around time.  I could replace the resistor myself but I Imagine the unit will need to be recalibrated as it's R22 in the sensing circuit.

That said, I certainly understand that delays are unavoidable at this time!

73, Bill NZ0T


David Ferrington, M0XDF
 

As per an email from Eric this morning, if you email   support@..., you’re likely to get a response from them, faster than emailing this reflector.

73 de David, M0XDF
-- 
Anyone can do any amount of work, provided it isn't the work he is supposed
to be doing at that moment. -Robert Benchley

On 20 May 2021, at 14:52, Bill Carpenter <nz0tham@...> wrote:

My W2 sensor unit burned a resistor this morning so I also am interested in repair turn around time.  I could replace the resistor myself but I Imagine the unit will need to be recalibrated as it's R22 in the sensing circuit.

That said, I certainly understand that delays are unavoidable at this time!

73, Bill NZ0T


Bill Carpenter
 

I sent a request for help on the form provided on the Elecraft website on Wednesday and haven't heard anything yet.  But I understand that things are not normal yet!

73, Bill NZ0T


Bob Novas
 

Bill – can we help? What’s the issue?  Bob – W3DK

 

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Bill Carpenter
Sent: Saturday, May 22, 2021 09:08
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] Support

 

I sent a request for help on the form provided on the Elecraft website on Wednesday and haven't heard anything yet.  But I understand that things are not normal yet!

73, Bill NZ0T


Dave (NK7Z)
 

As did I... No response either.

73, and thanks,
Dave (NK7Z)
https://www.nk7z.net
ARRL Volunteer Examiner
ARRL Technical Specialist, RFI
ARRL Asst. Director, NW Division, Technical Resources

On 5/22/21 6:08 AM, Bill Carpenter wrote:
I sent a request for help on the form provided on the Elecraft website on Wednesday and haven't heard anything yet.  But I understand that things are not normal yet!
73, Bill NZ0T


Bill Carpenter
 

Hi Bob,

R22 in my 2KW sensing unit for my W2 which is in the sensing circuit and runs to ground smoked the other day.  I have no idea why and it happened suddenly on 20 meters FT8 at 100 watts.  I think I could try to replace it but I imagine it's a precision resistor and the sensor will need to be calibrated.  So I think I will need to send it in for repair - just waiting to hear from tech at Elecraft.

73, Bill NZ0T


Bob Novas
 

Ah.  Sorry, I can’t help you with that. I thought maybe you were referring to the form for ordering K3 parts.  73, Bob W3DK

 

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Bill Carpenter
Sent: Saturday, May 22, 2021 10:15
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] Support

 

Hi Bob,

R22 in my 2KW sensing unit for my W2 which is in the sensing circuit and runs to ground smoked the other day.  I have no idea why and it happened suddenly on 20 meters FT8 at 100 watts.  I think I could try to replace it but I imagine it's a precision resistor and the sensor will need to be calibrated.  So I think I will need to send it in for repair - just waiting to hear from tech at Elecraft.

73, Bill NZ0T


Don Nesbitt
 

Me too - twice - waited 10 days after the first one and still waiting after the second request. I’m thinking that the Support Form on the web site is not working :0
Hate to add to the phone 📞 load but guess I’ll try the phone next - Don N4HH 




On Saturday, May 22, 2021, 10:07 AM, Dave (NK7Z) <dave@...> wrote:

As did I...  No response either.

73, and thanks,
Dave (NK7Z)
https://www.nk7z.net
ARRL Volunteer Examiner
ARRL Technical Specialist, RFI
ARRL Asst. Director, NW Division, Technical Resources

On 5/22/21 6:08 AM, Bill Carpenter wrote:
> I sent a request for help on the form provided on the Elecraft website
> on Wednesday and haven't heard anything yet.  But I understand that
> things are not normal yet!
>
> 73, Bill NZ0T
>






Michael
 

My 2 cents: emailed a support request & almost 30 days later received a reply. Simply no excuse, none, unacceptable.

 

Mike

W8TRN

 

Sent from Mail for Windows 10

 

From: Don Nesbitt via groups.io
Sent: Saturday, May 22, 2021 10:19
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] Support

 

Me too - twice - waited 10 days after the first one and still waiting after the second request. I’m thinking that the Support Form on the web site is not working :0

Hate to add to the phone 📞 load but guess I’ll try the phone next - Don N4HH 



On Saturday, May 22, 2021, 10:07 AM, Dave (NK7Z) <dave@...> wrote:

As did I...  No response either.

73, and thanks,
Dave (NK7Z)
https://www.nk7z.net
ARRL Volunteer Examiner
ARRL Technical Specialist, RFI
ARRL Asst. Director, NW Division, Technical Resources

On 5/22/21 6:08 AM, Bill Carpenter wrote:
> I sent a request for help on the form provided on the Elecraft website
> on Wednesday and haven't heard anything yet.  But I understand that
> things are not normal yet!
>
> 73, Bill NZ0T
>




 


Dale, K9VUJ
 

They will respond eventually.  Yes, it's still not back to normal, they are in California.  I'm sure they are doing the best they can under the conditions out there.  

Dale, K9VUJ


Lou W7HV
 

On Sun, May 23, 2021 at 06:12 AM, southdaleus wrote:
...they are in California.  I'm sure they are doing the best they can under the conditions out there.  

Dale, K9VUJ
Funny.


Jim Brown
 

What is funny about COVID and widlfires destroying our homes? THAT'S what folks out here are dealing with.

73, Jim K9YC

On 5/23/2021 5:05 AM, Lou W7HV via groups.io wrote:
On Sun, May 23, 2021 at 06:12 AM, southdaleus wrote:
...they are in California.  I'm sure they are doing the best they
can under the conditions out there.
Dale, K9VUJ
Funny.


Lou W7HV
 

Yes, covid and wildfires are not funny, but you didn't say that.  You said California, as if that was the problem. Covid is pretty equally everywhere, not just CA.  And yes Elecraft was close ti and affected by the fire zones, but the vast majority of CA was not affected.  So fires and Covid, yeah.  CA, HI HI.


Jim Brown
 

I didn't write what you were responding to.

73, Jim K9YC

On 5/23/2021 1:45 PM, Lou W7HV via groups.io wrote:
Yes, covid and wildfires are not funny, but you didn't say that.  You said California, as if that was the problem. Covid is pretty equally everywhere, not just CA.  And yes Elecraft was close ti and affected by the fire zones, but the vast majority of CA was not affected.  So fires and Covid, yeah.  CA, HI HI.


Bill Carpenter
 

Been a week now since I filled out and sent the tech request form in.  Also emailed tech support and nothing yet.

73, Bill NZ0T