FW: [Elecraft-K3] K3 repairs


Robert W5AJ
 

Keith,   I believe in your mind you removed the bottom cover for FET temperature test, which is a no no for this test

 

Leave the K3 as is, place finger on three screws on bottom cover (The screws with locking washer on them are for three FETs)

 

One has to be able to use the XMIT function (long press)  with bottom cover on and FET’s screwed on to bottom cover (NORMAL OPERATION!)

 

I set my TUNE power to 10 watts for the temperature test on three FETs on bottom

Or 100 watts, or 50 watts,  I don’t use 11 or 12 since FT8 at those levels is most likely cause of Driver FET burn out

insure your favorite dummy load is attached.

 

73 W5AJ

 

PS:  Moderator really – really needs to fix list outgoing messages so replies to messages include original message

 

Robert

Midland, Texas

http://w5aj.eqth.net/Infinity.pdf

 

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Keith_WE6R
Sent: Wednesday, November 11, 2020 11:04 AM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] K3 repairs

 

Hi Chet;
Sub RX filter settings will NOT affect transmit.
But if there was a glitch, certainly check the MAIN filters. The filters with TX settings are important.

NOTE to ALL; on the 3-Finger FET test!!! Do NOT go into transmit!! You can cook the FETs. 
Just TAP XMIT to turn on the BIAS only! (Red LED will be on, with NO RF going out).

If you have a KAT3, check the L10-C10 8.215 trap. It can get burnt and affect some bands. If burnt, just put a jumper in place of L10.
Also inspect the LPF components on the RF board under the KPA3 (pull the KPA3). Look around L20 or check the schematic for the components for your trouble band.
Keith WE6R Elecraft K3 Tech.

_._,_._,_


 

 

Chet, before doing total reset try checking FETs with the simple Hot/Warm/Cold test suggested by Ray https://groups.io/g/Elecraft-K3/message/32891?p=,,,20,0,0,0::relevance,,Cold

,20,2,0,74706396

 

In case the link doesn't work, Ray's email inserted here:

........

Hi Robert.... I would look for a bad Driver Fet Transistor There are 3 Fets that are Heat sinked to the bottom of the radio.

Check your manual for the Correct location..

They are connected to the bottom plate for use as a Heat sink Using Phillips head screws....

Place the radio so it is raised up using the Front Bail.

Place your fingers on the 3 Screw that are holding the 3 Fets.

Key the PTT so the XT is on.   All 3 should get Warm, Not HOT

Or Cold.   Hot= Shorted, Cold Open,  Warm Operation normal.

I found one of my Fets was Cold..  Give it a try... Ray WA6VAB ..........................

 

While the band which failed the 5watt TX calibration failure here, sounds similar Based on prior postings on reflector, using a K3 on FT8 at 11 or 12 watt output maybe possible cause of failure of the driver FETs I found similar - one COLD FET, replaced, all happy (my recommendation is get replacement FET from Elecraft or RFParts)

 

GL!  73 and Good DX

 

73 W5AJ

 

Robert

Midland, Texas

http://w5aj.eqth.net/Infinity.pdf

 

-----Original Message-----

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Chet, N8RA

Sent: Tuesday, November 10, 2020 12:18 PM

To: Elecraft-K3@groups.io

Subject: [Elecraft-K3] K3 repairs

 

Good afternoon K3 folks,

 

Recently my K3 has experienced a couple of issues. I have been unable to get a response from Elecraft e-mail or telephone service regarding the situation. It's been almost two weeks now so thought I'd ask here if anyone has some suggestions for me to try myself.

 

Here is the main concern:

 

When getting ready for CQWWDX SSB a few weeks ago, I went through setting the transmit power on each band to drive an amplifier properly. The power display seemed a bit sluggish and had a delay in indicating the SWR. Worse yet, when I got to 40M, I could not crank the power up past about 30 watts; it would momentarily display a higher number but then fall back to 30w. All other bands cold be set higher.

 

First I reloaded all the current firmware in the main and subreceiver. No change to 40M.

 

So next I went to the K3 Utility ver 1.20.1.15 to do a transmitter gain calibration. Starting with the 5W calibration, it stepped thru the first few bands OK but then stopped (I think on 40M) and displayed "ERR TXG" and the message "calibration settled at 3.6W, TX gain failed because transmit power did not reach the expected value".

 

In anticipation of having to send the radio to Elecraft where it might be totally reset, I manually started recording all the configuration settings.

When I looked at my filter settings, I was shocked to see that filter 1 in the subreceiver was set to 1.35. Huh? It should have been 2.80 !! Was my config info corrupted? I reset that to 2.80 and then for the heck of it tried again to set the power on 40M. That now  worked "OK"  and the swr and pwr display during "tune" showed instantly on all bands. Something had changed.

 

Next, I decided to rerun the TX calibration gain routine. This time if successfully completed the 5w and 50w routines. However, with a good dummy load, 40M displays an swr of 1.4, while the other bands are 1.0 or 1.1, so something is still a little funny on 40M. What might that be?

 

I have now been considering doing a total reset of the radio using the EE INIT function and then the self calibrations. Is this wise?

 

Any experiences or suggestions appreciated.

 

73,

Chet, N8RA