Topics

K3S and WSJT-X on 160M


Bob McGraw - K4TAX
 

I've posted this item on the WSJT-X site and not received a valid response.   Am I the only one having this issue?   I know of at least one KX3 owner and one K3 owner that has this issue.  Any help or assistance will be appreciated.

73

Bob, K4TAX











I've encountered an issue which I have failed to resolve.    I'm using an Elecraft K3S on 160M.  I have WSJT-X configured to work normally and find that indeed it does for what I'll describe as normal operation.

However, I'm trying to set up to work the JA/s.   To do this I need to transmit on 1.840 and to receive on 1.908.   I have WSJT-X set in the MODE to Data/PKT which does switch the radio to the correct DATA mode.  Then in the Split Operation I have that set to NONE.    Now for the radio I have the VFO A set to 1.908 for receive and VFO B set to 1.840 for transmit.   I have SPLIT manually activated on the radio.  When I initiate and release the PTT on the radio all switches correctly.

Now the issue.  Using WSJT-X v2.1.2 I find that when I initiate TUNE the radio goes into transmit on VFO B at 1.840, there is power out, and it transmits on 1.840.  When I release TUNE the VFO B changes to 1.908.  Thus the next transmission is on 1.908 and is NOT on 1.840 as it should be.

I have tried many options and configurations without success. This includes using Fake It, Rig, None for SPLIT operation with WSJT. The operating system is Windows 10 Pro 64 bit.

From my efforts, it appears that a command is being sent to the radio to make VFO A and VFO B equal upon release of the PTT command from WSJT-X.

Your thoughts and suggestions please.

73

Bob, K4TAX




Ed Pflueger
 

Dave Perry N4QS does this all the time working the JA’s on 160.  N4qs@...

Ed…

 

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Bob McGraw - K4TAX
Sent: Tuesday, April 14, 2020 1:37 PM
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] K3S and WSJT-X on 160M

 

I've posted this item on the WSJT-X site and not received a valid response.   Am I the only one having this issue?   I know of at least one KX3 owner and one K3 owner that has this issue.  Any help or assistance will be appreciated.

73

Bob, K4TAX

I've encountered an issue which I have failed to resolve.    I'm using an Elecraft K3S on 160M.  I have WSJT-X configured to work normally and find that indeed it does for what I'll describe as normal operation.

However, I'm trying to set up to work the JA/s.   To do this I need to transmit on 1.840 and to receive on 1.908.   I have WSJT-X set in the MODE to Data/PKT which does switch the radio to the correct DATA mode.  Then in the Split Operation I have that set to NONE.    Now for the radio I have the VFO A set to 1.908 for receive and VFO B set to 1.840 for transmit.   I have SPLIT manually activated on the radio.  When I initiate and release the PTT on the radio all switches correctly.

Now the issue.  Using WSJT-X v2.1.2 I find that when I initiate TUNE the radio goes into transmit on VFO B at 1.840, there is power out, and it transmits on 1.840.  When I release TUNE the VFO B changes to 1.908.  Thus the next transmission is on 1.908 and is NOT on 1.840 as it should be.

I have tried many options and configurations without success. This includes using Fake It, Rig, None for SPLIT operation with WSJT. The operating system is Windows 10 Pro 64 bit.

From my efforts, it appears that a command is being sent to the radio to make VFO A and VFO B equal upon release of the PTT command from WSJT-X.

Your thoughts and suggestions please.

73

Bob, K4TAX



Robert W5AJ
 

Bob,   have made several JA contacts on 160 with this method

WSJT V2.1.2
radio mode Data/Pkt
Split None
the Frequency selected at WSJT is 1.908
WSJT shows an "S" in the green circle for split operation

VFO A on K3 is 1.908 set to TX DATA
VFO B on K3 is 1.840 set to TX DATA
Insure both VFOs have TX DATA that is set to DATA A
K3 in split mode 
None of the frequencies changes on K3 when "TUNE" 
the K3 is in split and transmits on VFO B as it should, 1.840 continues to read on BOTTOM line!
1.908 on VFO A will always stay on TOP line
The frequency in the WSJT window changes to match freq being used by rig....

I'm not seeing VFO B change to 1.908 like you are.
F/H mode is not selected
I have tried selecting 1.840 at WSJT -> writing that to VFO B 
then selecting 1.908 at WSJT and that works too

WIN7 here 
V2.1.2 0068f9
no other logging programs running when WSJT in use

GL
73 W5AJ



On Tue, Apr 14, 2020 at 1:37 PM Bob McGraw - K4TAX <rmcgraw@...> wrote:

I've posted this item on the WSJT-X site and not received a valid response.   Am I the only one having this issue?   I know of at least one KX3 owner and one K3 owner that has this issue.  Any help or assistance will be appreciated.

73

Bob, K4TAX











I've encountered an issue which I have failed to resolve.    I'm using an Elecraft K3S on 160M.  I have WSJT-X configured to work normally and find that indeed it does for what I'll describe as normal operation.

However, I'm trying to set up to work the JA/s.   To do this I need to transmit on 1.840 and to receive on 1.908.   I have WSJT-X set in the MODE to Data/PKT which does switch the radio to the correct DATA mode.  Then in the Split Operation I have that set to NONE.    Now for the radio I have the VFO A set to 1.908 for receive and VFO B set to 1.840 for transmit.   I have SPLIT manually activated on the radio.  When I initiate and release the PTT on the radio all switches correctly.

Now the issue.  Using WSJT-X v2.1.2 I find that when I initiate TUNE the radio goes into transmit on VFO B at 1.840, there is power out, and it transmits on 1.840.  When I release TUNE the VFO B changes to 1.908.  Thus the next transmission is on 1.908 and is NOT on 1.840 as it should be.

I have tried many options and configurations without success. This includes using Fake It, Rig, None for SPLIT operation with WSJT. The operating system is Windows 10 Pro 64 bit.

From my efforts, it appears that a command is being sent to the radio to make VFO A and VFO B equal upon release of the PTT command from WSJT-X.

Your thoughts and suggestions please.

73

Bob, K4TAX




Bob McGraw - K4TAX
 

Here is the solution.    Thanks to Bill Sommerville of the WSJT-X support group.  The K3 response may be different than that of the K3S.   Using USB communication between the radio and computer.

<snip>
Bob,

Although running this sort of split will work on some rigs using CAT control, by selecting "Settings->Radio->Split Operating->None", it is not officially supported.

If it doesn't work for your rig then you can disable CAT control and set the rig's VFOs and SPLIT manually by selecting "Settings->Radio->Rig->None". This clearly cannot be used with CAT PTT commands but if your rig supports PTT via RTS use that, or VOX (or DATA VOX) on the rig.

You can make a separate configuration in WSJT-X to support this including the Rx frequency for logging.

73
Bill
G4WJS
<snip>

Thanks Bill for the info and solution.

73
Bob, K4TAX


Carl Moreschi
 

Another solution that keeps CAT completely working is to use OmniRig in WSJT-X and connect that to my N4PY Pegasus Plus. That solves everything. And you can still use CAT PTT.

Carl Moreschi N4PY
127 River Moss Way
Hertford, NC 27944
www.n4py.com

On 4/15/2020 10:56 AM, Bob McGraw - K4TAX wrote:
Here is the solution. Thanks to Bill Sommerville of the WSJT-X
support group. The K3 response may be different than that of the K3S.
Using USB communication between the radio and computer.

<snip>
Bob,

Although running this sort of split will work on some rigs using CAT
control, by selecting "Settings->Radio->Split Operating->None", it is
not officially supported.

If it doesn't work for your rig then you can disable CAT control and set
the rig's VFOs and SPLIT manually by selecting
"Settings->Radio->Rig->None". This clearly cannot be used with CAT PTT
commands but if your rig supports PTT via RTS use that, or VOX (or DATA
VOX) on the rig.

You can make a separate configuration in WSJT-X to support this
including the Rx frequency for logging.

73
Bill
G4WJS
<snip>

Thanks Bill for the info and solution.

73
Bob, K4TAX




Adrian Fewster <vk4tux@...>
 

Bob, as the discover on this issue regarding the KX3, I appreciated the time you have spent researching for a solution.

after our exchange on the KX3 group, and video below revealed the issue still exists with wsjtx split set none,

with manual txcr split set.

I thought there would be a source code fix to make this possible. It seems Bill is not interested in that.

I will stick with cat control, as I use it for ptt also. When I get busy on FT8 I like to hit gaps etc quickly.

Apparently the Japanese will be allowed to TX on 1840 in the near future, so I will wait for that.

Here was my video I showed Bob the issue here ;


Adrian ... vk4tux


On 16/4/20 12:56 am, Bob McGraw - K4TAX wrote:
Here is the solution.    Thanks to Bill Sommerville of the WSJT-X support group.  The K3 response may be different than that of the K3S.   Using USB communication between the radio and computer.

<snip>
Bob,

Although running this sort of split will work on some rigs using CAT control, by selecting "Settings->Radio->Split Operating->None", it is not officially supported.

If it doesn't work for your rig then you can disable CAT control and set the rig's VFOs and SPLIT manually by selecting "Settings->Radio->Rig->None". This clearly cannot be used with CAT PTT commands but if your rig supports PTT via RTS use that, or VOX (or DATA VOX) on the rig.

You can make a separate configuration in WSJT-X to support this including the Rx frequency for logging.

73
Bill
G4WJS
<snip>

Thanks Bill for the info and solution.

73
Bob, K4TAX






Adrian Fewster <vk4tux@...>
 

Another note is that using vfo frequency lock on both A/B, also did not help.



On 16/4/20 1:18 am, Adrian Fewster via groups.io wrote:

Bob, as the discover on this issue regarding the KX3, I appreciated the time you have spent researching for a solution.

after our exchange on the KX3 group, and video below revealed the issue still exists with wsjtx split set none,

with manual txcr split set.

I thought there would be a source code fix to make this possible. It seems Bill is not interested in that.

I will stick with cat control, as I use it for ptt also. When I get busy on FT8 I like to hit gaps etc quickly.

Apparently the Japanese will be allowed to TX on 1840 in the near future, so I will wait for that.

Here was my video I showed Bob the issue here ;


Adrian ... vk4tux


On 16/4/20 12:56 am, Bob McGraw - K4TAX wrote:
Here is the solution.    Thanks to Bill Sommerville of the WSJT-X support group.  The K3 response may be different than that of the K3S.   Using USB communication between the radio and computer.

<snip>
Bob,

Although running this sort of split will work on some rigs using CAT control, by selecting "Settings->Radio->Split Operating->None", it is not officially supported.

If it doesn't work for your rig then you can disable CAT control and set the rig's VFOs and SPLIT manually by selecting "Settings->Radio->Rig->None". This clearly cannot be used with CAT PTT commands but if your rig supports PTT via RTS use that, or VOX (or DATA VOX) on the rig.

You can make a separate configuration in WSJT-X to support this including the Rx frequency for logging.

73
Bill
G4WJS
<snip>

Thanks Bill for the info and solution.

73
Bob, K4TAX






John Canfield
 

Were you having this issue only on 160M or on any band with WSJT-X?


Bob McGraw - K4TAX
 

I've tried it on a couple of different bands and find that under CAT control, regardless if SPLIT is selected or not in the application, it does occur.  The only solution I've found which works is one suggested by Bill Sommerville and that is to set CAT control Radio choice to NONE.    That allows one to use the radio manually and this does work.      As Bill stated, some radios will work and some will not.   And it is not supported in WSJT-X.

73

Bob, K4TAX


Carl Moreschi
 

You can use OmniRig as the radio type and then set OmniRig for the K3. That will work.

Carl Moreschi N4PY
127 River Moss Way
Hertford, NC 27944
www.n4py.com

On 4/16/2020 11:02 AM, Bob McGraw - K4TAX wrote:
I've tried it on a couple of different bands and find that under CAT
control, regardless if SPLIT is selected or not in the application, it
does occur. The only solution I've found which works is one suggested
by Bill Sommerville and that is to set CAT control Radio choice to
NONE. That allows one to use the radio manually and this does
work. As Bill stated, some radios will work and some will not.
And it is not supported in WSJT-X.

73

Bob, K4TAX





Adrian Fewster <vk4tux@...>
 

Carl, absolutely brilliant thankyou. This is the real answer I have been looking for since discovering the issue,

and I have just tested split function here now all ok, retaining the B vfo freq without cat change.

I never even realised that OmniRig was in the list until you mentioned it here.


Thankyou very much for solving the issue.


regards


Adrian ... vk4tux

On 17/4/20 1:56 am, Carl Moreschi wrote:
You can use OmniRig as the radio type and then set OmniRig for the K3. That will work.

Carl Moreschi N4PY
127 River Moss Way
Hertford, NC 27944
www.n4py.com


Adrian Fewster <vk4tux@...>
 

I just made the contact with Mas JA3FYC, just now , thanks to Carl

http://vk4tux.duckdns.org/KX3/1908_1.jpg

http://vk4tux.duckdns.org/KX3/1908_2.jpg

On 17/4/20 4:04 am, Adrian Fewster via groups.io wrote:
Carl, absolutely brilliant thankyou. This is the real answer I have been looking for since discovering the issue,

and I have just tested split function here now all ok, retaining the B vfo freq without cat change.

I never even realised that OmniRig was in the list until you mentioned it here.


Thankyou very much for solving the issue.


regards


Adrian ... vk4tux

On 17/4/20 1:56 am, Carl Moreschi wrote:
You can use OmniRig as the radio type and then set OmniRig for the K3. That will work.

Carl Moreschi N4PY
127 River Moss Way
Hertford, NC 27944
www.n4py.com