Topics

K3S, MacOS, fldigi


Jim
 

Hi folks,
Can anyone help with getting fldigi waterfall to appear? I'm using a 2019 iMac, Catalina fully upated, with a K3S and trying to get fldigi to work. However, I get no waterfall and the signal in the lower right corner (barely noticed it) only jumps a few pixels on strong signals. WSJT-X works fine, decodes great, and the waterfall on it is perfect. I've got plenty of signal on the P3 also. Just sitting on 14.074 shows absolutely nothing on the fldigi waterfall. I must be missing something simple, but can't figure out what. Thanks for any help!
73,
Jim, WD9HBC


wh6ebs@...
 

Hi Jim,

I suggest you check the Config - Audio Card settings in Fldigi. From your description it seems like Fldigi is not listening to the correct device.

I am running Fldigi successfully on a 2019 MacBook Pro/Catalina.

73,

Tom
WH6EBS


wh6ebs@...
 

Oh, I also need to mention that my radio is a K3 with the KIO3B upgrade. Radio connects with a single USB cable. CAT and Audio CODEC work fine.

73

Tom
WH6EBS


redarlington
 

Make sure you're using the right sound device, but also turn the volume up on it in the audio control panel *for the usb audio codec device* as you watch the waterfall.  I've noticed with recent versions of fldigi it seems a lot less sensitive than it used to be.  I have to turn it up for fldigi, and back down for wsjt-x.

-Bob N3XKB

On Tue, Mar 10, 2020 at 2:18 PM <wh6ebs@...> wrote:
Oh, I also need to mention that my radio is a K3 with the KIO3B upgrade. Radio connects with a single USB cable. CAT and Audio CODEC work fine.

73

Tom
WH6EBS


Ray
 

Check K3s line output level
Ray
W8LYJ


Jim
 

HI, OK, but when you say "check" what am I checking? What's the proper setting? Everything was at default and I haven't changed much, especially stuff I don't understand.


Jim
 

Hi Bob, So what IS the right sound device? I'm using the USB Audio Codec, which I thought was correct. How do I turn up the "volume"? I'm seeing any setting for that in fldigi nor on the radio.


Jim
 

Hi Ray,
When you say "Check" what am I checking for? Like I said, it works fine with WSJT, but fldigi doesn't seem to be picking up the signal. 


redarlington
 

Jim, 

I'm using Windows 10.  You can right click on the little speaker icon at the bottom right corner near the clock and pull to "open sound settings".    From there you can select the usb audio codec output device and change the volume level.  Same for the input device (how loud  the radio sounds to the computer -like mic gain) below that, but I think there's another menu to hit to get it.  It's basically a software control for the hardware in the rig.  Windows sees a serial port and a sound device over that USB connection.   I'm probably not doing this any justice with how I'm describing it so I apologize for that.   Windows itself (or rather, we humans) would typically use the sound device built into the computer for things like listening to music or watching youtube.   And because you have more than one device (the other being the radio's internal sound hardware), you can have that completely separated out so youtube doesn't go out over the air when your PTT is in use.   

So far as I know, the only way to adjust this audio level setting is via the operating system's mixer settings, but for all I know there might be something in a menu somewhere on the radio.   Anyway, best of luck, and again I apologize for being terrible at explaining this stuff.

73,
Bob - N3XKB

On Thu, Jun 4, 2020 at 11:19 PM Jim <soareagle@...> wrote:
Hi Bob, So what IS the right sound device? I'm using the USB Audio Codec, which I thought was correct. How do I turn up the "volume"? I'm seeing any setting for that in fldigi nor on the radio.


ve3ki
 

In the K3S, make sure CONFIG:LIN OUT is not set to zero; that's the radio's level control for receive audio to the audio codec. A setting in the range 5-10 works for me. Then, to make further fine adjustments to the codec volume level, level adjustments for the codec can be done in the Windows control panel's "Sound" section, which you can get to from the little speaker icon on the Windows Task Bar.

73,
Rich VE3KI


On Fri, Jun 5, 2020 at 01:19 AM, Jim wrote:
Hi Bob, So what IS the right sound device? I'm using the USB Audio Codec, which I thought was correct. How do I turn up the "volume"? I'm seeing any setting for that in fldigi nor on the radio.


ve3ki
 

Oops - skipped past the "Mac OS" in the title. There must be a Mac equivalent to the Windows sound card level adjustment - sorry, I don't know what it is, but it's provided by the operating system.

73,
Rich VE3KI


On Fri, Jun 5, 2020 at 07:19 AM, ve3ki wrote:
In the K3S, make sure CONFIG:LIN OUT is not set to zero; that's the radio's level control for receive audio to the audio codec. A setting in the range 5-10 works for me. Then, to make further fine adjustments to the codec volume level, level adjustments for the codec can be done in the Windows control panel's "Sound" section, which you can get to from the little speaker icon on the Windows Task Bar.

73,
Rich VE3KI


On Fri, Jun 5, 2020 at 01:19 AM, Jim wrote:
Hi Bob, So what IS the right sound device? I'm using the USB Audio Codec, which I thought was correct. How do I turn up the "volume"? I'm seeing any setting for that in fldigi nor on the radio.


Jim
 

Rich, Thanks! Yes, this is a Mac, so things are a little different. My CONFIG:LIN OUT is set to nor 050. I can go up to 100 and it doesn't put a spec on the waterfall in fldigi. The settings for the CODEC in Preferences are full to the right. 
I certainly appreciate the help!
Jim, WD9HBC