Topics

No USB Audio Codec


w0rw
 

Thanks Rich,
i just made my first Q with the K3s internal modem.
The back panel Aux jacks had no cables in them.
i did get the computer to show CODEC audio input/output.
But the Settings are set for Rig: 'None' and 'VOX',   Not set for 'K3s'.
i think i am 'On the Air'.
Thanks for all the help guys.
73
Paul    w0rw


ve3ki
 

Is there something plugged into the Line In jack on the back of the K3S? I believe that will disable the internal codec in the radio. Also, for CAT control via the USB connection, you need to set CONFIG:RS232 to USB - and, of course, the correct FTDI device driver needs to be installed in the computer for the USB serial port. This is not necessary for the audio codec, as the default Windows driver works for that. You should, however, check to make sure that Windows has not assigned the audio codec in the radio as its default sound card device for either recording or playback (ditto for default communications device). Make sure all of those are reset to the motherboard sound card in the Windows sound card settings window.

73,
Rich VE3KI


On Mon, Apr 13, 2020 at 02:37 PM, w0rw wrote:
i am having trouble getting my K3s on  FT8.
i have an old Dell Optiplex 980, Windows 7, with probably some missing drivers.
i don't get and CODEC labels when i go to the Device Manager and look at the Sound input/outputs.
as described by  K4TAX:
On Wed, Aug 29, 2018 at 09:03 PM, Bob McGraw - K4TAX wrote:

Windows Device manager you should have two items.  The first under Ports (COM & LPT) showing the USB Serial port and a port number.  This is the port that controls the radio under CAT.   Shown below.

Then a bit further down you should see under Sound, Video and Game controllers the USB CODEC.   This should appear when you connect the USB cable from the radio to the computer and then turn on the radio. 

i have set up the WSTJ program using the USB cable and the simple method using Fig 6-6 in Fred Cady (KE7X's) book. i have set up the WSTJ settings to K3s, USB and multiple variations of the Radio and Audio settings and always get a Rig i/o configure failure.
The Frequency Box goes Red and displays 00.0000, i can only get the correct frequency to come back by resetting the rig configuration.
i have read many of the K3s  FT8 setups on the web but nothing has worked so far.
i did get some FT8 receive data when using direct audio connections.
i have set all the K3s menu items up Data A, Mic Sel to Line In, Nothing is plugged into the Line in/out jacks for the USB connection.
There are 12 variables and i have not been able to get the right key.
Paul     w0rw


w0rw
 

i am having trouble getting my K3s on  FT8.
i have an old Dell Optiplex 980, Windows 7, with probably some missing drivers.
i don't get and CODEC labels when i go to the Device Manager and look at the Sound input/outputs.
as described by  K4TAX:
On Wed, Aug 29, 2018 at 09:03 PM, Bob McGraw - K4TAX wrote:

Windows Device manager you should have two items.  The first under Ports (COM & LPT) showing the USB Serial port and a port number.  This is the port that controls the radio under CAT.   Shown below.

Then a bit further down you should see under Sound, Video and Game controllers the USB CODEC.   This should appear when you connect the USB cable from the radio to the computer and then turn on the radio. 

i have set up the WSTJ program using the USB cable and the simple method using Fig 6-6 in Fred Cady (KE7X's) book. i have set up the WSTJ settings to K3s, USB and multiple variations of the Radio and Audio settings and always get a Rig i/o configure failure.
The Frequency Box goes Red and displays 00.0000, i can only get the correct frequency to come back by resetting the rig configuration.
i have read many of the K3s  FT8 setups on the web but nothing has worked so far.
i did get some FT8 receive data when using direct audio connections.
i have set all the K3s menu items up Data A, Mic Sel to Line In, Nothing is plugged into the Line in/out jacks for the USB connection.
There are 12 variables and i have not been able to get the right key.
Paul     w0rw


Brian KF6C
 

I had another problem with the K3s in that it was unable to key the KPA500 using the AUX cable. I have had to use the RCA key line for a while. I could see no connection between the two issues but decided to investigate this problem as it could also have been related to KIO3B board.

 

The Keying problem turned out to be R9 on the KIO3B board which is simply a resistor in series with pin 10 of the AUX connector. As the Speaker IO problem was there with and without the AUX connector plugged in I see no reason this would affect the issue.

 

However on reassembling the radio the speaker USB IO was now present on the WSJT F2 menu.  I have no idea what corrected the problem but it now works fine.

 

I had checked the LIN_SW circuitry while the KOI3B board was accessible and seen no problems.

 

73 KF6C.


Bob McGraw - K4TAX
 

Then within  the WSJT-X F2 menu, audio tab, expand the lines using the down arrow at the end of the line.   Do this both for INPUT and OUTPUT.    There may be other choices which when expanded show the CODEC.  Depends on how the sound card in the computer is configured. 

Also be sure you have the correct radio selected under the Radio tab.

The Signalink and KX3 are totally different animals.

73

Bob, K4TAX


On 8/30/2018 12:13 PM, Brian wrote:

Hi Bob

 

Thanks for the reply.

 

I have all set as you described. The Codec reports it is working and is up to date.

 

The input to the Codec is detected and working fine but the output does not show up on the WSJT-X F2 Menu .

I have a SignalLink and that shows up correctly on the WSJT Menu when used in place of the K3s, and works fine with the KX3.

 

73

 

Brian KF6C



Brian KF6C
 

Hi Bob

 

Thanks for the reply.

 

I have all set as you described. The Codec reports it is working and is up to date.

 

The input to the Codec is detected and working fine but the output does not show up on the WSJT-X F2 Menu .

I have a SignalLink and that shows up correctly on the WSJT Menu when used in place of the K3s, and works fine with the KX3.

 

73

 

Brian KF6C


Gordon LaPoint
 

Is the radio a K3 or K3s, does it have a usb cable interface?  If no usb cable there is no USB codec to select.

Gordon - N1MGO



On 08/30/2018 10:00 AM, David Mackey wrote:
Look for a checkbox on the screen that shows the Audio sources that says something like: “Display disable Inputs”, (or outputs).  
Dave Mackey

From: <Elecraft-K3@groups.io> on behalf of Brian <brian@...>
Reply-To: <Elecraft-K3@groups.io>
Date: Wednesday, August 29, 2018 at 8:57 PM
To: <Elecraft-K3@groups.io>
Subject: [Elecraft-K3] No USB Audio Codec

In trying to set up FT8 I cannot set the Speakers to  USB codec. The USB codec is not displayed. I have the Mic set to LInE In on the K3s.

The Microphone input works fine with USB codec selected and signals are received.

Are there settings I could have wrong or is there a problem with the IO board.

Thanks

Brian KF6C.


-- 
Gordon - N1MGO


David Mackey
 

Look for a checkbox on the screen that shows the Audio sources that says something like: “Display disable Inputs”, (or outputs).  
Dave Mackey
K1KA@...

From: <Elecraft-K3@groups.io> on behalf of Brian <brian@...>
Reply-To: <Elecraft-K3@groups.io>
Date: Wednesday, August 29, 2018 at 8:57 PM
To: <Elecraft-K3@groups.io>
Subject: [Elecraft-K3] No USB Audio Codec

In trying to set up FT8 I cannot set the Speakers to  USB codec. The USB codec is not displayed. I have the Mic set to LInE In on the K3s.

The Microphone input works fine with USB codec selected and signals are received.

Are there settings I could have wrong or is there a problem with the IO board.

Thanks

Brian KF6C.


Mal
 

Make sure you have mic gain. The first time I switched to data A the mic gain was set to 0.

 

Mal

 

From: Elecraft-K3@groups.io <Elecraft-K3@groups.io> On Behalf Of Bill Maddock via Groups.Io
Sent: Thursday, August 30, 2018 6:57 AM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] No USB Audio Codec

 

Make sure you have USB turned on instead of a baud rate in menu

 

On Wed, Aug 29, 2018 at 8:31 PM, Brian

<brian@...> wrote:

In trying to set up FT8 I cannot set the Speakers to  USB codec. The USB codec is not displayed. I have the Mic set to LInE In on the K3s.

The Microphone input works fine with USB codec selected and signals are received.

Are there settings I could have wrong or is there a problem with the IO board.

Thanks

Brian KF6C.


Bill Maddock
 

Make sure you have USB turned on instead of a baud rate in menu


On Wed, Aug 29, 2018 at 8:31 PM, Brian
<brian@...> wrote:
In trying to set up FT8 I cannot set the Speakers to  USB codec. The USB codec is not displayed. I have the Mic set to LInE In on the K3s.

The Microphone input works fine with USB codec selected and signals are received.

Are there settings I could have wrong or is there a problem with the IO board.

Thanks

Brian KF6C.


Bob McGraw - K4TAX
 

Brian:

In the WSJT-X F2 Menu you should have the choice display as follows:


From Windows Device manager you should have two items.  The first under Ports (COM & LPT) showing the USB Serial port and a port number.  This is the port that controls the radio under CAT.   Shown below.

Then a bit further down you should see under Sound, Video and Game controllers the USB CODEC.   This should appear when you connect the USB cable from the radio to the computer and then turn on the radio.  Shown below.




As to the radio, in the CONFIG menu:  for RS232  should be set to USB.   LIN OUT should be NOR and a value of 010 being default {I run mine at 006 to reduce the level into the computer}.  Also be sure there is nothing plugged into the Line IN and Line Out on the rear of the radio.  The radio DATA MODE {manual page 33} should be DATA A.

Check all of the above.  Should work.

73
 Bob, K4TAX






On 8/29/2018 7:57 PM, Brian wrote:
In trying to set up FT8 I cannot set the Speakers to  USB codec. The USB codec is not displayed. I have the Mic set to LInE In on the K3s.

The Microphone input works fine with USB codec selected and signals are received.

Are there settings I could have wrong or is there a problem with the IO board.

Thanks

Brian KF6C.


Brian KF6C
 

In trying to set up FT8 I cannot set the Speakers to  USB codec. The USB codec is not displayed. I have the Mic set to LInE In on the K3s.

The Microphone input works fine with USB codec selected and signals are received.

Are there settings I could have wrong or is there a problem with the IO board.

Thanks

Brian KF6C.