Date   

Re: K3 PIN Diodes blown ?

Vic Lindgren G4BYG <g4byg@...>
 

Yes will do Henk.

Many thanks for the info.

Just downloaded the schematics from the Elecraft Website.

Will let you folks know how I get on.

Now if only I could remember how to rotate a PDF file 😅

73 and Stay Safe.

Vic G4BYG

On 21/04/2021 17:52, Henk PA0C wrote:
Check the switching voltage on those diodes as well. 
My dead receiver was caused by an open rf-choke while the diodes were still ok.
73 Henk
PA0C


-------- Oorspronkelijk bericht --------
Van: Ken K6MR <k6mr@...>
Datum: 21-04-2021 18:30 (GMT+01:00)
Onderwerp: Re: [Elecraft-K3] K3 PIN Diodes blown ?

Once when my SO2R filters quit working I fried D25 and D26 in the TR switch.  Page 2 of 4 of the schematic.  The path is very easy to trace if you have a sig gen and scope.  When they go dead, they are dead. 

 

If you have a parts supplier over there you can get the exact part number from Elecraft support.  They are pretty common devices.

 

Ken K6MR

 

From: Vic Lindgren G4BYG
Sent: Wednesday, April 21, 2021 04:39
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] K3 PIN Diodes blown ?

 

Can anyone help  with my K3 fault
Which PIN diodes are most likely to need replaceing with a no rx fault condition??
Transmitter is good.Just the rx that is dead.
No error messages.
Both Main and Sub rcvrs not working.
Checked seating of plug in boards and patch leads all appear to be seated correctly.
Configuration has not been altered. One day ok next day faulty.
Suspect rf has got into the RX path.
Any help would be greatly appreciated.
73
Vic G4BYG

 


Re: K3 PIN Diodes blown ?

Vic Lindgren G4BYG <g4byg@...>
 

Thanks for your suggestions Ken and will drag out the old oscilloscope and sig genny for further investigation.

Sherlock Holmes Deer Stalker Hat and Pipe at the ready.

73 and Stay Safe.

Vic G4BYG

On 21/04/2021 17:30, Ken K6MR wrote:

Once when my SO2R filters quit working I fried D25 and D26 in the TR switch.  Page 2 of 4 of the schematic.  The path is very easy to trace if you have a sig gen and scope.  When they go dead, they are dead. 

 

If you have a parts supplier over there you can get the exact part number from Elecraft support.  They are pretty common devices.

 

Ken K6MR

 

From: Vic Lindgren G4BYG
Sent: Wednesday, April 21, 2021 04:39
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] K3 PIN Diodes blown ?

 

Can anyone help  with my K3 fault
Which PIN diodes are most likely to need replaceing with a no rx fault condition??
Transmitter is good.Just the rx that is dead.
No error messages.
Both Main and Sub rcvrs not working.
Checked seating of plug in boards and patch leads all appear to be seated correctly.
Configuration has not been altered. One day ok next day faulty.
Suspect rf has got into the RX path.
Any help would be greatly appreciated.
73
Vic G4BYG

 


Re: K3 PIN Diodes blown ?

Henk PA0C
 

Check the switching voltage on those diodes as well. 
My dead receiver was caused by an open rf-choke while the diodes were still ok.
73 Henk
PA0C


-------- Oorspronkelijk bericht --------
Van: Ken K6MR <k6mr@...>
Datum: 21-04-2021 18:30 (GMT+01:00)
Aan: Elecraft-K3@groups.io
Onderwerp: Re: [Elecraft-K3] K3 PIN Diodes blown ?

Once when my SO2R filters quit working I fried D25 and D26 in the TR switch.  Page 2 of 4 of the schematic.  The path is very easy to trace if you have a sig gen and scope.  When they go dead, they are dead. 

 

If you have a parts supplier over there you can get the exact part number from Elecraft support.  They are pretty common devices.

 

Ken K6MR

 

From: Vic Lindgren G4BYG
Sent: Wednesday, April 21, 2021 04:39
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] K3 PIN Diodes blown ?

 

Can anyone help  with my K3 fault
Which PIN diodes are most likely to need replaceing with a no rx fault condition??
Transmitter is good.Just the rx that is dead.
No error messages.
Both Main and Sub rcvrs not working.
Checked seating of plug in boards and patch leads all appear to be seated correctly.
Configuration has not been altered. One day ok next day faulty.
Suspect rf has got into the RX path.
Any help would be greatly appreciated.
73
Vic G4BYG

 


Re: K3 PIN Diodes blown ?

Ken K6MR
 

Once when my SO2R filters quit working I fried D25 and D26 in the TR switch.  Page 2 of 4 of the schematic.  The path is very easy to trace if you have a sig gen and scope.  When they go dead, they are dead. 

 

If you have a parts supplier over there you can get the exact part number from Elecraft support.  They are pretty common devices.

 

Ken K6MR

 

From: Vic Lindgren G4BYG
Sent: Wednesday, April 21, 2021 04:39
To: Elecraft-K3@groups.io
Subject: [Elecraft-K3] K3 PIN Diodes blown ?

 

Can anyone help  with my K3 fault
Which PIN diodes are most likely to need replaceing with a no rx fault condition??
Transmitter is good.Just the rx that is dead.
No error messages.
Both Main and Sub rcvrs not working.
Checked seating of plug in boards and patch leads all appear to be seated correctly.
Configuration has not been altered. One day ok next day faulty.
Suspect rf has got into the RX path.
Any help would be greatly appreciated.
73
Vic G4BYG

 


K3 PIN Diodes blown ?

Vic Lindgren G4BYG <g4byg@...>
 

Can anyone help  with my K3 fault
Which PIN diodes are most likely to need replaceing with a no rx fault condition??
Transmitter is good.Just the rx that is dead.
No error messages.
Both Main and Sub rcvrs not working.
Checked seating of plug in boards and patch leads all appear to be seated correctly.
Configuration has not been altered. One day ok next day faulty.
Suspect rf has got into the RX path.
Any help would be greatly appreciated.
73
Vic G4BYG


Re: Display Anomaly

 

Mel,

Is this something that has just recently started to occur?

Have you done any recent reconfigurations in your shack with the equipment layout?

Maybe take the cover off the P3 and see if slightly touching or moving the flat ribbon cable makes any differences.

I know Elecraft had provided a sticky-back clip to help hold that ribbon cable flat and in place snug against the sidewall of the P3's cabinet.

Interesting to note your noted noise level is quite consistent and/or precise with the band changes.
---
73 - Nolan K.
KI5IO


Re: P3 - SVGA & TX Monitor Options ?

Ray Maxfield
 

Thanks , I guess iam out of the Loop these Days

Ray  WA6VAB   

 

From: David Bunte
Sent: Monday, April 19, 2021 1:35 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

Ray -

 

It means a deposit of HALF or a deposit of the FULL cost of the item. 

 

Dave - K9FN

 

On Mon, Apr 19, 2021 at 4:29 PM Ray Maxfield <wa6vab@...> wrote:

Ok… what does Half-dep and Full-dep mean ?

I did not see any Notes….  Ray WA6VAB K3

 

 

From: Nolan - KI5IO
Sent: Monday, April 19, 2021 1:22 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

My question answered.  I just got an e-mail from Elecraft and they have posted a quick order form for K3 & K3S and P3 units / parts as noted on the form.

I got my order placed and in queue.

Here is the URL:  https://elecraft.com/pages/k3-k3s-options  
---
73 - Nolan K.
KI5IO

 

 


Re: P3 - SVGA & TX Monitor Options ?

Steve
 

I have no history of how they work but MFJ makes a plug in tuner for the K3. 
If I needed a K3 tuner and this were my only option I would try it.
WM6P


Re: P3 - SVGA & TX Monitor Options ?

David Bunte
 

Ray -

It means a deposit of HALF or a deposit of the FULL cost of the item. 

Dave - K9FN

On Mon, Apr 19, 2021 at 4:29 PM Ray Maxfield <wa6vab@...> wrote:

Ok… what does Half-dep and Full-dep mean ?

I did not see any Notes….  Ray WA6VAB K3

 

 

From: Nolan - KI5IO
Sent: Monday, April 19, 2021 1:22 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

My question answered.  I just got an e-mail from Elecraft and they have posted a quick order form for K3 & K3S and P3 units / parts as noted on the form.

I got my order placed and in queue.

Here is the URL:  https://elecraft.com/pages/k3-k3s-options  
---
73 - Nolan K.
KI5IO

 


Re: P3 - SVGA & TX Monitor Options ?

Ed Pflueger
 

Then you owe the other half before it’s shipped if you went the Half Price route.

 

Ed..

 

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Ray Maxfield
Sent: Monday, April 19, 2021 3:29 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

Ok… what does Half-dep and Full-dep mean ?

I did not see any Notes….  Ray WA6VAB K3

 

 

From: Nolan - KI5IO
Sent: Monday, April 19, 2021 1:22 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

My question answered.  I just got an e-mail from Elecraft and they have posted a quick order form for K3 & K3S and P3 units / parts as noted on the form.

I got my order placed and in queue.

Here is the URL:  https://elecraft.com/pages/k3-k3s-options  
---
73 - Nolan K.
KI5IO

 


Re: P3 - SVGA & TX Monitor Options ?

Ed Pflueger
 

You pay either the full price or half price upfront when you order.

 

Ed.. AB4IQ

 

From: Elecraft-K3@groups.io [mailto:Elecraft-K3@groups.io] On Behalf Of Ray Maxfield
Sent: Monday, April 19, 2021 3:29 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

Ok… what does Half-dep and Full-dep mean ?

I did not see any Notes….  Ray WA6VAB K3

 

 

From: Nolan - KI5IO
Sent: Monday, April 19, 2021 1:22 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

My question answered.  I just got an e-mail from Elecraft and they have posted a quick order form for K3 & K3S and P3 units / parts as noted on the form.

I got my order placed and in queue.

Here is the URL:  https://elecraft.com/pages/k3-k3s-options  
---
73 - Nolan K.
KI5IO

 


Re: P3 - SVGA & TX Monitor Options ?

Ray Maxfield
 

Ok… what does Half-dep and Full-dep mean ?

I did not see any Notes….  Ray WA6VAB K3

 

 

From: Nolan - KI5IO
Sent: Monday, April 19, 2021 1:22 PM
To: Elecraft-K3@groups.io
Subject: Re: [Elecraft-K3] P3 - SVGA & TX Monitor Options ?

 

My question answered.  I just got an e-mail from Elecraft and they have posted a quick order form for K3 & K3S and P3 units / parts as noted on the form.

I got my order placed and in queue.

Here is the URL:  https://elecraft.com/pages/k3-k3s-options  
---
73 - Nolan K.
KI5IO

 


Re: P3 - SVGA & TX Monitor Options ?

 

My question answered.  I just got an e-mail from Elecraft and they have posted a quick order form for K3 & K3S and P3 units / parts as noted on the form.

I got my order placed and in queue.

Here is the URL:  https://elecraft.com/pages/k3-k3s-options  
---
73 - Nolan K.
KI5IO


Re: P3 - SVGA & TX Monitor Options ?

Geert Jan de Groot
 

Seems the mechanism to order has been opened up today - https://elecraft.com/pages/k3-k3s-options


Re: P3 - SVGA & TX Monitor Options ?

W4PF-Steve
 

I spoke with Elecraft last week via email on if/when might the video card for the P3 be available. Their response was they hope to have some information at the end of the month to share.


P3 - SVGA & TX Monitor Options ?

 

I have my name on the wish list for the above noted options for my P3. Of course (like most everyone else) we don't know if or when any of the 'wish-list options' will be available.

That being said has anyone seen or dared consider getting a 3rd party product and putting in their P3?

I know Elecraft will eventually come through, but figured I would ask the users in case someone has found something that I've not yet been able to uncover.

---
73 - Nolan K.
KI5IO


Re: KPA500 - EE INIT?

Bob McGraw - K4TAX
 

Use the KPA500 Utility to restore the configuration.    You did save the original factory configuration, didn't you?

Otherwise, just go through the MENU and set the values to those shown on page 19 in the manual.

73

Bob, K4TAX

On 4/16/2021 9:42 AM, Martin Kratoska, OK1RR wrote:
Is there any possibility to make a reset to factory default (ie. EE INIT at K3) of the KPA500 amp? Can't find it in the manual...

73,

Martin, OK1RR







KPA500 - EE INIT?

Martin Kratoska, OK1RR <martin@...>
 

Is there any possibility to make a reset to factory default (ie. EE INIT at K3) of the KPA500 amp? Can't find it in the manual...

73,

Martin, OK1RR


Re: VFO settings for different Bands

SGS 126
 

Thank you Rich That did it.

Ben KJ4CC


Re: K3 Issues

Adrian G0KOM
 

Yep John def no second receiver installed, that much I now know, slowly getting there, im confident I can get this baby up and running again, I may even become an elecraft convert :-)

Adrian G0KOM

1141 - 1160 of 36035