Date   

Fw: K3 MCU problem.

Mike Streeter
 



This message to Elecraft, in the meantime anyone have any ideas?

Mike, WM5DX.

----- Forwarded Message -----

From: Mike Streeter
To: "k3support@..."
Sent: Monday, December 26, 2016 10:07 AM
Subject: Fw: K3 MCU problem.




----- Forwarded Message -----
From: Mike Streeter

Sent: Monday, December 26, 2016 9:31 AM
Subject: K3 MCU problem.

Hope you all had a great Christmas.

I have been using my K3 for a long time with no problems but now do have one.
A couple of weeks ago I worked the OK RTTY contest 40 meter single band. The radio, S/N 684 worked faultlessly. It was connected to the KAT tuner, KPA amp, P3 with SVGA monitor and Navigator interface.
Yesterday I wanted to use it on 40 meters and it was showing a high SWR and would not key the amp. Only on 40 meters, other bands were OK. That made me suspect the 40m antenna was giving a problem so I used my backup radio to check the antenna and cables and all was good. With reference to the Manual and Fred Cadys book I checked everything in the config menu, no obvious problems.

So then I then disconnected everything except the power cable from the back of the K3 so it is completely stand alone, connected the KUSB cable and PC, both of which I have used previously to check the firmware, and found that in the firmware tab, under firmware revisions it showed:

Installed in K3         Available

MCU    ??.??               05.50
FPF     ??.??               01.25
DSP1  ??.??               02.87
DSP2  ??.??               02.87
DVR    ??.??

Activity Log:

20:03:50 Elecraft K3 Utility Revision 1.15.6.29
20:03:50 OS Version 6.0 Build 6002 Windows Vista 
20:03:50 Serial Port is closed
20:03:50 Serial port Com 10 is open.
20:03:51 Attempting to contact K3 on port COM4 at 38400 bit/s
20:03:51 K3 waiting for firmware load. RS-232 speed 38400 bit/s.ed in the K3".

I then check "Send all firmware to the K3" with the K3 turned on and the following window comes up:

Elecraft K3 Utility Revision 1.15.6.29
OS Version 6.0 Build 6002 Windows Vista
K3 MCU Revision ??.?? . RS 232 speed 38400 bit/s.
Sending firmware file C:\Users \WM5DX\AppData\Roaming\Elecraft\K3 Firmware\ hmcu0550.hex to MCU
Error code 0xE2000048: No response to poll while synchronizing to buffer boundary
MCU verification failed. Reload MCU.
Click "close" to close this window. 

The Activity Log then shows that the serial port Com10 is open and the K3 is waiting for firmware load.

I therefore try to reload the MCU following exactly the instructions in the Utility Program help file, with the K3 still being disconnected from everything except the power cable, and after rebooting the PC. The K3 power is shut off for several minutes.  Everything happens exactly as the help file shows but when I get to "Send all new firmware to K3" and click on it I get the "Sending MCU Firmware" window which shows  the exact same messages and error code as above.

I'm sorry to take so long to explain but I really do need your help to resolve this.

73, de Mike, WM5DX.








Re: [Elecraft_K3] K3 RX/TX switching times?

David G3YYD <g3yyd@...>
 

Martin

I measured RX to TX for the new synth in a K3. With QRQ on it took 3 to 4 mS
from PTT out going low on the K3 to RF just starting to appear. With QRQ off
it was 7 to 8mS. I measured it so I knew how fast to make QSK relay
switching for a new amplifier. I did not measure from key down to RF out.

Using 10amp mains 12v coil relays with a series resistor and a small speed
up capacity across the resistor fed from 26v I got 2.5mS including bounce
time. I will actually be using 50v so the relay will easily be fast enough.

73 David G3YYD

-----Original Message-----
From: Elecraft_K3@yahoogroups.com [mailto:Elecraft_K3@yahoogroups.com]
Sent: 26 December 2016 15:21
To: Elecraft_K3@yahoogroups.com
Subject: [Elecraft_K3] K3 RX/TX switching times?

I need to know the K3 RX/TX switching times with and without QRQ option,
also for both old KSYN3 and new KSYN3 synthesizers. And K3s as well...

It was published somewhere but I am unable to find it. Can someone help?

73,
Martin, OK1RR


------------------------------------

------------------------------------


------------------------------------

Yahoo Groups Links


K3 RX/TX switching times?

 

I need to know the K3 RX/TX switching times with and without QRQ option, also for both old KSYN3 and new KSYN3 synthesizers. And K3s as well...

It was published somewhere but I am unable to find it. Can someone help?

73,
Martin, OK1RR


P3 For Sale

joe_word
 

For Sale Elecraft P3-F factory built panadapter in as new condition with optional P3SVGA adapter for computer monitor use. No scratches and has not been around tobacco smoke. Serial number 36xx. No longer have a K3, so selling the P3. Comes with original box, manual and cable set: RF cable, data cable and 2 power cables (from P3 or from power supply). $720 plus half of shipping, $12 is about half, shipped in CONUS. Payment by money order, Cashier's check or cash. I do not have a Papal account. My email is correct on QRZ.


Joe  N9VX



Re: Confused on K3-Remote and microphones

Mitch Wolfson
 

There is no easy way to solve it. I would probably just use a microphone that doesn't take bias and set the jumper for both. 

Another way would be to use a microphone like the Yamaha CM500 that has its own bias box and turn it off in the RRC. That's how I do it.

73,
Mitch DJ0QN / K7DX


Re: Confused on K3-Remote and microphones

ve3ki@...
 

Another related question: If you want to combine the use of an electret microphone with sound-card based digital voice keyer messages, or if you simply want to switch back and forth between SSB (with the electret mic) and sound-card digital modes, you aren't going to want to have to change the jumper every time. If you leave the jumper in the position that supplies bias, I am guessing that in addition to an attenuator you will also need a blocking capacitor between the sound card's high-level output and the RRC's input? or is there a better way to do this?

73,
Rich VE3KI


---In Elecraft_K3@..., <dj0qn@...> wrote :

The microphone jack is actually on the RRC's AUX/MIC jack. If you use a K3/0, then this is just passively routed through to its microphone jack.

So to answer your question: yes, it doesn't matter.

73,
Mitch DJ0QN / K7DX


Re: Confused on K3-Remote and microphones

Mitch Wolfson
 

The microphone jack is actually on the RRC's AUX/MIC jack. If you use a K3/0, then this is just passively routed through to its microphone jack.

So to answer your question: yes, it doesn't matter.

73,
Mitch DJ0QN / K7DX


Re: [Elecraft_K3] Confused on K3-Remote and microphones

Scott Townley
 

Thanks.  I still don't see any reference to that in the Elecraft manual.  Surely they didn't ASSume that everyone in the world used electret mics?

Still wondering where the microphone is supposed to be connected.  Does it not matter?


Re: [Elecraft_K3] Confused on K3-Remote and microphones

Mitch Wolfson
 

Scott,

The secret is contained in the RemoteRig manual; you will see that JMP-1 in the RRC turns the bias on and off.

Happy holidays and 73,
Mitch DJ0QN / K7DX
Mitch Wolfson DJØQN / K7DX
10285 Boca Cir, Naples, FL 34109
Skype: mitchwo
USA: Home:+1-239-221-9600 - Mobile:+1-424-288-9171
Germany: Home:+49 89 32152700 - Mobile:+49 172 8374436
On 24.12.2016 11:32, scott@... [Elecraft_K3] wrote:

 

I'm looking at Rev D of the K3-Remote manual.

On page 16 (remote site setup) it says:  "2. Set the K3 for rear panel mic input and no bias, regardless of the type of mic used".

OK, that makes sense.

It goes on to say:

"The RRC-1258 units automatically supply bias".

Hmm.


Going to the control site setup diagrams, that last statement makes sense for the K3/10 or K3/100 controller shown on p. 19.  The diagram explicitly shows a microphone connection to the RRC-1258.


However, neither the K3/0-mini (p. 17) nor the K3/0 (p. 18) have any illustration of the microphone connection.


Is bias still being supplied via the RRC-1258 AUX/MIC port, and routed internal to the K3/0 or K3/0-mini to the 8-pin Foster and the 3.5mm jack on the side?

If so, what if I want to use a dynamic mic?  Can you turn off the supply of bias in the RRC-1258?


Unless I'm just not seeing it, this appears to be a noteworthy omission in the setup instructions.


Thanks for any insights,

Scott NX7U



Confused on K3-Remote and microphones

Scott Townley
 

I'm looking at Rev D of the K3-Remote manual.

On page 16 (remote site setup) it says:  "2. Set the K3 for rear panel mic input and no bias, regardless of the type of mic used".

OK, that makes sense.

It goes on to say:

"The RRC-1258 units automatically supply bias".

Hmm.


Going to the control site setup diagrams, that last statement makes sense for the K3/10 or K3/100 controller shown on p. 19.  The diagram explicitly shows a microphone connection to the RRC-1258.


However, neither the K3/0-mini (p. 17) nor the K3/0 (p. 18) have any illustration of the microphone connection.


Is bias still being supplied via the RRC-1258 AUX/MIC port, and routed internal to the K3/0 or K3/0-mini to the 8-pin Foster and the 3.5mm jack on the side?

If so, what if I want to use a dynamic mic?  Can you turn off the supply of bias in the RRC-1258?


Unless I'm just not seeing it, this appears to be a noteworthy omission in the setup instructions.


Thanks for any insights,

Scott NX7U


New overview ARRL Lab QST Magazine Product Reviews Key Measurements Summary

Hans Remeeus
 


Dear groupmembers,

I just published a new overview of the ARRL Lab Reviews:

http://www.remeeus.eu/hamradio/pa1hr/productreview.pdf

New is the review of the FlexRadio Flex6500.

New is an overview of the TX/RX turnaround time of the HF-Transceivers.

New is an overview of the weight of the HF Power Amplifiers.

Please let me know if you have any remarks/comments.

Merry Christmas and 73, Hans.


Vriendelijke groeten,
Hans Remeeus (PA1HR/OE3JRC)
http://www.remeeus.eu
http://www.hansremeeus.nl
Communication is about people, the rest is technology. 



New overview ARRL Lab QST Magazine Product Reviews Key Measurements Summary

Hans Remeeus
 


Dear groupmembers,

I just published a new overview of the ARRL Lab Reviews:

http://www.remeeus.eu/hamradio/pa1hr/productreview.pdf

New is the review of the FlexRadio Flex6500.

New is an overview of the TX/RX turnaround time of the HF-Transceivers.

New is an overview of the weight of the HF Power Amplifiers.

Please let me know if you have any remarks/comments.

Merry Christmas and 73, Hans.



-- 

Vriendelijke groeten,
Hans Remeeus (PA1HR/OE3JRC)
http://www.remeeus.eu
http://www.hansremeeus.nl
Communication is about people, the rest is technology. 


Re: [Elecraft_K3] Splitting ACC port on K3 to 4 devices

Randy Farmer W8FN
 

I have a similar arrangement that I use as an ACC splitter to distribute the appropriate signals to my microHAM MK2R+ SO2R controller, my KPA500 and my XV144. It's been in service for a couple of years and works quite well.

I did exactly what you propose. I used a 4-position VGA switch from cablewholesale.com (P/N
40H1-03604 -- currently $19.01) modified as you suggest. I removed the switch and all internal wiring and wired only the necessary lines to each of the jacks from the I/O connector. If you are interested, I can send a pdf file of my drawing for the modified box and the interconnect cable to the K3.

You're right to be concerned about RFI on these lines. I have a bunch of antennas crammed into a very small lot and therefore lots of common mode RF running around. I had previously been using a bunch of Y connectors and experienced some weird problems, such as the K3 turning off its power when I transmitted on 30 meters. By putting all the wiring in a metal box and bonding the hoods of the DE15HD connectors to the box chassis and the return lines in the cable I was able to operate using the KPA500 on all bands with no RF problems. That's not to say that your installation might not require some ferrites; you just have to experiment.

Hope this helps.

73...
Randy, W8FN


On 12/23/2016 3:49 PM, ny4i@... [Elecraft_K3] wrote:
 

Due to what seems like every device I have wanting to use the ACC port on the K3, I need to split out the single connector on the radio to 4 connectors. I have real Y cables and this works fine, but the problem is that Y cables seem to grab on to other cables like Velcro and makes the rat's nest of cables worse by adding to the tangling.


I had a thought to use a simple 4 way VGA switch that basically has 5 jacks on it. PLEASE NOTE I KNOW THIS IS NOT STANDARD VGA. I am just thinking about using the box as it already has the pins wired to the back of the connectors. I will also REMOVE the SWITCH as this is not about switching—just using the box. (Sorry about the caps, but I wanted to be clear).


Has anyone done this? My plan is to just take each wire from the four different jacks and wire them to the 5th and connect them together (all pins 1 together, all pins 2 together, etc). I would either use two terminal strips or just solder the 5 wires from each pin together and heat shrink them. I was also thinking about putting ferrites over each wire but I'm not sure about the need for that.


I believe this would keep the cabling simpler as I can run the box to the side of the rig and just hook each accessory to it. I could just make a box with 5 connectors on it but honestly I can get these boxes cheap enough and it has the wires and connectors already.


I would be most interested in feedback from anyone that has hooked this many ACC devices together and how you did it.


In case anyone is wondering, the devices are:


FSK Interface (W3YY)

RemoteRig Interface

SPE1.3 amp

Top Ten Devices antenna selector (needs band data).


Regards,


Tom NY4I



Splitting ACC port on K3 to 4 devices

ny4i@...
 

Due to what seems like every device I have wanting to use the ACC port on the K3, I need to split out the single connector on the radio to 4 connectors. I have real Y cables and this works fine, but the problem is that Y cables seem to grab on to other cables like Velcro and makes the rat's nest of cables worse by adding to the tangling.


I had a thought to use a simple 4 way VGA switch that basically has 5 jacks on it. PLEASE NOTE I KNOW THIS IS NOT STANDARD VGA. I am just thinking about using the box as it already has the pins wired to the back of the connectors. I will also REMOVE the SWITCH as this is not about switching—just using the box. (Sorry about the caps, but I wanted to be clear).


Has anyone done this? My plan is to just take each wire from the four different jacks and wire them to the 5th and connect them together (all pins 1 together, all pins 2 together, etc). I would either use two terminal strips or just solder the 5 wires from each pin together and heat shrink them. I was also thinking about putting ferrites over each wire but I'm not sure about the need for that.


I believe this would keep the cabling simpler as I can run the box to the side of the rig and just hook each accessory to it. I could just make a box with 5 connectors on it but honestly I can get these boxes cheap enough and it has the wires and connectors already.


I would be most interested in feedback from anyone that has hooked this many ACC devices together and how you did it.


In case anyone is wondering, the devices are:


FSK Interface (W3YY)

RemoteRig Interface

SPE1.3 amp

Top Ten Devices antenna selector (needs band data).


Regards,


Tom NY4I



Re: USB codec not working

ve3ki@...
 

Have you changed the power settings in Windows to prevent it from shutting off USB ports to save power? The codec and the rig control port are separate devices in Windows even though they use the same cable, and perhaps Windows may have shut one off while keeping the other one going. There are two places I know of that might affect this. One is in Power Options, under Change plan settings, Change advanced power settings, USB settings, USB selective suspend setting (disabled). The other is in Device Manager, Universal Serial Bus Controllers, each and every USB 3.0 Host Controller, USB Root Hub or Generic USB Hub, under Properties, Power Management tab, uncheck the check box called Allow the computer to turn off this device to save power.

If you haven't done this already, you might try it to see if it helps.

73,
Rich VE3KI


---In Elecraft_K3@..., <K2QPN@...> wrote :

Still having the Codec quit. Tonight I was listening to JT65 on 160m. Codec working. Switched to listening to 80CW. After a few minutes I noticed the Codec had stopped working. THe USB serial port for rig control remains working. Tried unplugging and plugging the USB cable. No help. I have uninstall the Codec using device manager and reboot. Then it starts working. 

73, Bob K2QPN


Re: USB codec not working

ROBERT NELSON
 

Still having the Codec quit. Tonight I was listening to JT65 on 160m. Codec working. Switched to listening to 80CW. After a few minutes I noticed the Codec had stopped working. THe USB serial port for rig control remains working. Tried unplugging and plugging the USB cable. No help. I have uninstall the Codec using device manager and reboot. Then it starts working. 

73, Bob K2QPN


P3 Macros

w3qt_mike
 

I'm trying to add some macros to my P3.  I'm able to use the keyboard and compose them, but I'm stuck with labeling them.  Is it possible to have my personalized macro label appear in the P3 window?  I've probably flubbed something.  I'm seeing "Macro 1", "Macro 2", etc.  I'd like to have my label so I know quickly which button to tap/hold if that's possible.  Any guidance would be greatly appreciated.

73,
Mike, W3QT


Re: K3 remote power ON/OFF

Ed
 

Remote Power On/Off (pg 44 in K3 manual)

A remote-control system can pull the POWER ON
line to ground (ACC connector, pg. 18) to turn the
K3 ON. To turn it OFF, the controller must send
the K3 a “PS0;” remote-control command via the
RS232 interface, wait at least 100 ms, then
deactivate the POWER ON signal. This sequence
ensures that nonvolatile memory is updated
correctly before shut-down.

73
N2BHD


Re: K3 remote power ON/OFF

Bill
 

I got an email from VA2FSQ (WIN4K3 designer) with his suggestions.

Maybe the problem is solved - A usb controlled controlled relay to pull ACC pin 8 to
ground. This one even comes with its own sofrware that will leave an icon on the desktop:


I ordered this today, maybe it is the last step! 

73, Bill KO7SS


 







Re: [Elecraft_K3] Re: K3 remote power ON/OFF

Martin Sole
 

It would be kinda neat if Win4k3 could toggle an RS232 (or other) pin that could then be used, say via a transistor driver or W.H.Y. to turn the power on. Could be on the setup screen that it pulls up when a radio cannot be found.


Martin, HS0ZED



On 16/12/2016 15:31, dsolberg@... [Elecraft_K3] wrote:
 

Bill,


I use Win4K3Suite for rig control and it has the ability to shutdown the K3 remotely.  It will not however turn it back on.  There is no way in a CAT command to turn the radio on.  You need to pull pin 8 on the KI03 connector low. You could use a transistor switch or a small relay, but you would also need a user interface of some time to provide the logic signal.  

I use W0JEC's Remote Station Antenna Control application, which was in QST, to remotely switch antennas and it also provides the ability to turn on/off other devices. I use this to remotely turn 12V on/off to my MFJ 998 autotuner.  I elected to not do this with the K3.

Instead I run my K3 off of a deep cycle battery with a batter conditioner.  I leave the K3 on all the time.

73,

Don
K9AQ

8201 - 8220 of 35714