Re: KPA1500 Temperature Management #kpa1500


K9MA
 

In CW contest operation, I've never see the temperature get much above 60 C. I have, however, tested the fans at maximum speed. You will know if they ever reach that speed, and there better not be any loose papers lying around.

73,
Scott K9MA 

On 8/30/2021 1:56 PM, Jim Brown wrote:
On 8/30/2021 9:20 AM, David Mackey wrote:
I just added a KPA1500 to the shack, and  I am unsure about how much I should worry about temperature management. I know the maximum specified in the specs is 110C, but that does seem very high. The fans kick in about 40C and start ratcheting up at about 50c. I've had issues with LDMOS devices in the past so I am a bit nervous to just letting things increase to "see what happens". Can anyone give some longer term user advice as to their experience, and at what point things stabilize? The ambient temp here in the shack is not high, about 60-75F.

K6XX, a neighbor and good friend, is the engineer for Elecraft tasked with putting both of Elecraft's amps into production. We are both contesters, and I do a lot of WSJT modes on 6M and 160M. Bob advised me to accept the default settings for the fan, and let the firmware take care of the devices. I run legal limit on all bands but 6M, where I limit power to about 1.1kW, and a bit lower for long TX modes on 6M like Q65 120 sec.

I looked around for a KPA1500 group, but couldn't find one. Let me know if this is the wrong venue.

The best venue is the list set up by Elecraft, which both Wayne and Eric read. Sign up on the website.

73, Jim K9YC








-- 
Scott  K9MA

k9ma@...

Join Elecraft-K3@groups.io to automatically receive all group messages.