Re: Audio issue - loud speaker?


Colin Smithers
 

Its in the audio chain. I’d suspect the speaker first. Try ext speaker. If thats bad then AF amp?

73, Colin G4CWH


On 21 Jul 2020, at 13:20, Alan Baker via groups.io <g4gnx@...> wrote:


An audio issue of this kind is very unlikely to have been caused by a very strong RF signal being received. It could be the loudspeaker - try plugging in an external speaker or headphones. If it's still distorted, it could be the AF amplifier stage that's gone faulty.

It's also possible that the issue is in the earlier RF stages and not the audio at all.

73,

Alan. G4GNX


------ Original Message ------
From: "Petr Ourednik" <indians@...>
Sent: 21/07/2020 13:11:12
Subject: [Elecraft-K3] Audio issue - loud speaker?

Hi folks,

after super strong station signal hit my K3, the audio from speaker is distorted and it resonates somehow (with cover?).
Also band noise has been distorted somehow at first and band noise audio sound was changed itself. 


When switchen K3 off/on the strong beep was heard during boot/start. 

After switching K3 off again and keeping K3 off for longer time then turned it on again it sounds better > no strong beep heard but still distorted all signals (even weak) and speaker’s membrane resonates...

SPOT is also distorted and K3 side tone also...

I am a bit surprised and disappointed what could happened in K3. Could it be the loud speaker damage?

Thanks for hints,
Petr, OK1RP

Join Elecraft-K3@groups.io to automatically receive all group messages.