Re: No USB Audio Codec


ve3ki
 

Is there something plugged into the Line In jack on the back of the K3S? I believe that will disable the internal codec in the radio. Also, for CAT control via the USB connection, you need to set CONFIG:RS232 to USB - and, of course, the correct FTDI device driver needs to be installed in the computer for the USB serial port. This is not necessary for the audio codec, as the default Windows driver works for that. You should, however, check to make sure that Windows has not assigned the audio codec in the radio as its default sound card device for either recording or playback (ditto for default communications device). Make sure all of those are reset to the motherboard sound card in the Windows sound card settings window.

73,
Rich VE3KI


On Mon, Apr 13, 2020 at 02:37 PM, w0rw wrote:
i am having trouble getting my K3s on  FT8.
i have an old Dell Optiplex 980, Windows 7, with probably some missing drivers.
i don't get and CODEC labels when i go to the Device Manager and look at the Sound input/outputs.
as described by  K4TAX:
On Wed, Aug 29, 2018 at 09:03 PM, Bob McGraw - K4TAX wrote:

Windows Device manager you should have two items.  The first under Ports (COM & LPT) showing the USB Serial port and a port number.  This is the port that controls the radio under CAT.   Shown below.

Then a bit further down you should see under Sound, Video and Game controllers the USB CODEC.   This should appear when you connect the USB cable from the radio to the computer and then turn on the radio. 

i have set up the WSTJ program using the USB cable and the simple method using Fig 6-6 in Fred Cady (KE7X's) book. i have set up the WSTJ settings to K3s, USB and multiple variations of the Radio and Audio settings and always get a Rig i/o configure failure.
The Frequency Box goes Red and displays 00.0000, i can only get the correct frequency to come back by resetting the rig configuration.
i have read many of the K3s  FT8 setups on the web but nothing has worked so far.
i did get some FT8 receive data when using direct audio connections.
i have set all the K3s menu items up Data A, Mic Sel to Line In, Nothing is plugged into the Line in/out jacks for the USB connection.
There are 12 variables and i have not been able to get the right key.
Paul     w0rw

Join Elecraft-K3@groups.io to automatically receive all group messages.