WSPR problem with PTT


Tony EI8JK
 

Hello group,
I have a problem that's driving me up the wall.
New(ish) computer is set up for WSJT and WSPR in particular, using my DUO. I have set up several computers in the past and I have another one set up that works perfectly.
The problem I have is CAT works fine, I set the PTT up for CAT and it works for maybe 2 or 3 TX periods and then fails with Hamlib error.
I have a clean install on WSJT-X v 1.9.1 and it is set EXACTLY the same as the computer it runs perfectly on, TS-480, baud rate, COM port, etc.
I have tried this set up with my Yaesu FT-897 and that works perfectly.
Any ideas?
Thanks in advance,
Tony, EI8JK.

Why don't I use the other computer?
It's a large tower and I'm setting up in a small area indoors for winter ops.


Neil Smith G4DBN
 

Have you set hardware serial port PTT? Hamlib is badly broken for PTT
Neil G4DB,



Sent from my Samsung Galaxy smartphone.

-------- Original message --------
From: Tony EI8JK <ei8jk@...>
Date: 12/11/2018 13:29 (GMT+00:00)
To: EladSDR@groups.io
Subject: [EladSDR] WSPR problem with PTT

Hello group,
I have a problem that's driving me up the wall.
New(ish) computer is set up for WSJT and WSPR in particular, using my DUO. I have set up several computers in the past and I have another one set up that works perfectly.
The problem I have is CAT works fine, I set the PTT up for CAT and it works for maybe 2 or 3 TX periods and then fails with Hamlib error.
I have a clean install on WSJT-X v 1.9.1 and it is set EXACTLY the same as the computer it runs perfectly on, TS-480, baud rate, COM port, etc.
I have tried this set up with my Yaesu FT-897 and that works perfectly.
Any ideas?
Thanks in advance,
Tony, EI8JK.

Why don't I use the other computer?
It's a large tower and I'm setting up in a small area indoors for winter ops.


Tony EI8JK
 

Thanks Neil, I have now regained some of my sanity.

I didn't even realise that there was a PTT+RTS in the Duo menu. That has fixed it together with altering the WSJT setting of RTS (instead of CAT) and setting the the COM to the same as the CAT.

Tony, EI8JK


On 12/11/2018 14:13, Neil Smith G4DBN wrote:
Have you set hardware serial port PTT? Hamlib is badly broken for PTT
Neil G4DB,



Sent from my Samsung Galaxy smartphone.

-------- Original message --------
From: Tony EI8JK <ei8jk@...>
Date: 12/11/2018 13:29 (GMT+00:00)
Subject: [EladSDR] WSPR problem with PTT

Hello group,
I have a problem that's driving me up the wall.
New(ish) computer is set up for WSJT and WSPR in particular, using my DUO. I have set up several computers in the past and I have another one set up that works perfectly.
The problem I have is CAT works fine, I set the PTT up for CAT and it works for maybe 2 or 3 TX periods and then fails with Hamlib error.
I have a clean install on WSJT-X v 1.9.1 and it is set EXACTLY the same as the computer it runs perfectly on, TS-480, baud rate, COM port, etc.
I have tried this set up with my Yaesu FT-897 and that works perfectly.
Any ideas?
Thanks in advance,
Tony, EI8JK.

Why don't I use the other computer?
It's a large tower and I'm setting up in a small area indoors for winter ops.


Udo Isaenko
 

Hello Neil

Interesting subject. I have also similar (or even the same) problems
with WSJT-X modes since I try to use it on my Raspberry Pi with the
Elad FDM DUO.

In the settings, it seems the best settings are for CAT:
Port: /dev/ttyUSB0
Baud Rate: 38400
Data Bits: 8
Stop Bits: 1
Handshake: Default
Force Control Lines: DTR and RTS are "High"

This works for me, the QRG is written and read to/from the DUO.

PTT method: The only one that works, is "CAT", but it works for
testing OK and then transmitting works sometimes two or three times,
sometimes it stops almost immediately to transmit, then I get an error,
saying: "Rig Control Error - Do you want to reconfigure the radio
interface?" and the details show "Hamlib error: Protocol error while
setting PTT on".

Of course, reconfiguring the interface does not help.

Clicking on "Tune" sometimes work, sometimes not.

Unfortunately, the DUO has no VOX. Maybe I have to construct an
external VOX?

Or is there any other help?

73
Udo, HB9ERD

La Mon, 12.11.2018 je 14:13 skribis "Neil Smith G4DBN" <neil@g4dbn.uk>:

Have you set hardware serial port PTT? Hamlib is badly broken for
PTTNeil G4DB,Sent from my Samsung Galaxy smartphone. --------


Neil Smith G4DBN
 

There is a race condition in the Hamlib TS480 driver where it sends two commands but does not parse the output correctly when the first one responds after the second one is sent.  Very simple programming error, but not easy to fix.  It works fine with a REAL TS480 because the answers come in the order the program is expecting.  The DUO follows the protocol, but sadly, the Hamlib TS480 functions do not.

I would set handshake=NONE.

On a Windows machine, if you set menu 54 to PTT+RTS then you can simply set RTS high to set the DUO on transmit and tell the program to use RTS.  If the RTS does not work, you may need to do some experiments.  It is possible that the Pi serial port USB drivers do not support the use of RTS.

We need a brave volunteer to create reliable Hamlib library functions specifically for the DUO.
Neil G4DBN


On 12/11/2018 22:19, Udo Isaenko wrote:
Hello Neil

Interesting subject. I have also similar (or even the same) problems
with WSJT-X modes since I try to use it on my Raspberry Pi with the
Elad FDM DUO.

In the settings, it seems the best settings are for CAT:
Port: /dev/ttyUSB0
Baud Rate: 38400
Data Bits: 8
Stop Bits: 1
Handshake: Default
Force Control Lines: DTR and RTS are "High"

This works for me, the QRG is written and read to/from the DUO.

PTT method: The only one that works, is "CAT", but it works for
testing OK and then transmitting works sometimes two or three times,
sometimes it stops almost immediately to transmit, then I get an error,
saying: "Rig Control Error - Do you want to reconfigure the radio
interface?" and the details show "Hamlib error: Protocol error while
setting PTT on".

Of course, reconfiguring the interface does not help.

Clicking on "Tune" sometimes work, sometimes not.

Unfortunately, the DUO has no VOX. Maybe I have to construct an
external VOX?

Or is there any other help?

73
Udo, HB9ERD

La Mon, 12.11.2018 je 14:13 skribis "Neil Smith G4DBN" <neil@...>:

Have you set hardware serial port PTT? Hamlib is badly broken for
PTTNeil G4DB,Sent from my Samsung Galaxy smartphone. --------





Neil Smith G4DBN
 

If anyone fancies creating a new Hamlib backend for the DUO, the place to start is https://github.com/Hamlib/Hamlib/wiki

The process to add a new brand and model is simple enough, and there is a well-defined process for adding in and testing the new functions.

Neil G4DBN


Udo Isaenko
 

Hello Neil

Thanks for the quick answer.

I did not think about Menu 54 on the DUO. After setting it,
transmitting works now with my Pi.

But I have now another, bigger, problem. In the meantime, I also tried
FLDIGI. CAT worked there, the PTT also, but transmitting (PSK31) did not
output anything and the DUO did not go back to Rx, I had to switch it
off (and I also switched off FLDIGI). Now, even after a restart of the
Pi and Plug out/in of the USB cable (which goes to an SB hub near the
DUO), I cannot receive anymore signals via the DUO soundcard.
Transmitting works and my signal is even received by other OMs, but
in rx mode, the wide graph of WSJT-X shows only a big carrier on 800 Hz
and its harmonics (1600, 2400), but no signals.

I hope that FLDIGI did not damage the sound card of the FDM-DUO.

73
Udo, HB9ERD

La Mon, 12.11.2018 je 22:34 skribis "Neil Smith G4DBN" <neil@g4dbn.uk>:

There is a race condition in the Hamlib TS480 driver where it sends
two commands but does not parse the output correctly when the first
one responds after the second one is sent.  Very simple programming
error, but not easy to fix.  It works fine with a REAL TS480 because
the answers come in the order the program is expecting.  The DUO
follows the protocol, but sadly, the Hamlib TS480 functions do not.

I would set handshake=NONE.

On a Windows machine, if you set menu 54 to PTT+RTS then you can
simply set RTS high to set the DUO on transmit and tell the program
to use RTS.  If the RTS does not work, you may need to do some
experiments.  It is possible that the Pi serial port USB drivers do
not support the use of RTS.


Giovanni Franza
 

Hi Neil,
I already have added a DUO backend on hamlib some weeks ago.
The backend is a clone of ts480 backens, with a change in TX command:
ts480 do not answer to TX cat command, so its backend send TX + ID commands and check the result
(supposed to be the ID answer) but DUO answers to TX and the control fails.
Unfortunatly the new backend will appear on hamlib 4.0 release, at the moment not yet indegrated in wsjt.
I'm reasoning how to compile wsjt-x to include the new hamlib, it seems that I can setup a transcompiler on my linux box,
but is seems not too clear how.
Regards,

Giovanni - HB9EIK


Neil Smith G4DBN
 

Excellent news, thanks Giovanni.

Neil


On 13/11/2018 09:28, Giovanni Franza wrote:
Hi Neil,
I already have added a DUO backend on hamlib some weeks ago.
The backend is a clone of ts480 backens, with a change in TX command:
ts480 do not answer to TX cat command, so its backend send TX + ID commands and check the result
(supposed to be the ID answer) but DUO answers to TX and the control fails.
Unfortunatly the new backend will appear on hamlib 4.0 release, at the moment not yet indegrated in wsjt.
I'm reasoning how to compile wsjt-x to include the new hamlib, it seems that I can setup a transcompiler on my linux box,
but is seems not too clear how.
Regards,

Giovanni - HB9EIK


Conrad, PA5Y <g0ruz@...>
 

Hi Giovanni, thank you for doing the work for our benefit. Does the Elad allow a change in TX frequency during TX via CAT? At some point I hope to use the FDM-Duo on 10GHz EME and I hope that WSJT-X is able to handle the doppler automatically.


73


Conrad PA5Y






From: EladSDR@groups.io <EladSDR@groups.io> on behalf of Giovanni Franza <gfranza@...>
Sent: 13 November 2018 10:28
To: EladSDR@groups.io
Subject: Re: [EladSDR] WSPR problem with PTT
 
Hi Neil,
I already have added a DUO backend on hamlib some weeks ago.
The backend is a clone of ts480 backens, with a change in TX command:
ts480 do not answer to TX cat command, so its backend send TX + ID commands and check the result
(supposed to be the ID answer) but DUO answers to TX and the control fails.
Unfortunatly the new backend will appear on hamlib 4.0 release, at the moment not yet indegrated in wsjt.
I'm reasoning how to compile wsjt-x to include the new hamlib, it seems that I can setup a transcompiler on my linux box,
but is seems not too clear how.
Regards,

Giovanni - HB9EIK


Vianney Colombat
 


The FDM-DUO allows frequency change during TX only if TX OUTPUT (menu 33) is set to 0dBm.

Il 13/11/2018 10:44, Conrad, PA5Y ha scritto:

 Does the Elad allow a change in TX frequency during TX via CAT?



Mail priva di virus. www.avg.com

Le informazioni contenute in questo messaggio di posta elettronica sono riservate e confidenziali e ne è vietata la diffusione in qualunque modo eseguita (DL 196/2003). Qualora Lei non fosse la persona a cui il presente messaggio è destinato, La invitiamo ad eliminarlo e a non leggerlo, dandone gentilmente comunicazione al mittente.

The information contained in this e-mail and any attachments is confidential and may well also be legally privileged (DL 196/2003). If you are not among the named recipients, please notify the sender immediately by reply e-mail and then delete this message from your system, do not use the contents for any purpose whatsoever nor disclose them to anyone else.


Neil Smith G4DBN
 

Setting WSJT-X to run doppler tracking and constant frequency on the moon, and permitting TX frequency changes during transmit works fine in 1Hz steps.  At the moment, using 10GHz, it changes at about 1Hz every 10 seconds.

Neil G4DBN


On 13/11/2018 10:04, Vianney Colombat wrote:

The FDM-DUO allows frequency change during TX only if TX OUTPUT (menu 33) is set to 0dBm.

Il 13/11/2018 10:44, Conrad, PA5Y ha scritto:

 Does the Elad allow a change in TX frequency during TX via CAT?




Maurizio Picerni
 

Hi friends, i had same probklem as EI8JK, my DUO working good in windows 10, but i want to set a PI4 to work WSPR longtime .
Using my FDM DUO CAT, RX, TX are working well, but PTT.  or better, sometimes. random PTT is ok 1-2 times and after return a ERROR to reconfigure interface.
Reading post, i have known about MENU #54 PTT.
I tried several combinations. and seems to have found a good choice with menu 54  PTT IN+RTS and set is successful ! 
seems that PTT is stable now...
here image of setttings
thanks regards 
Maurizio IK1NAF 


Neil Smith G4DBN
 

Hi Maurizio, this is a bug in the TS-480 Hamlib which causes failures with the DUO.  Try using the correct "ELAD FDM-DUO" Hamlib rig. Then PTT via CAT works fine.

Neil G4DBN

On 26/04/2021 21:29, Maurizio Picerni wrote:
Hi friends, i had same probklem as EI8JK, my DUO working good in windows 10, but i want to set a PI4 to work WSPR longtime .
Using my FDM DUO CAT, RX, TX are working well, but PTT.  or better, sometimes. random PTT is ok 1-2 times and after return a ERROR to reconfigure interface.
Reading post, i have known about MENU #54 PTT.
I tried several combinations. and seems to have found a good choice with menu 54  PTT IN+RTS and set is successful ! 
seems that PTT is stable now...
here image of setttings
thanks regards 
Maurizio IK1NAF 
-- 
Neil
http://g4dbn.uk


Antony Watts
 

The FDM-DUO sure does have VOX. But don't ask me how to configure it for use with WSJT audio output as a source...


Andy G4JNT
 

Mic only box

On Thu, 29 Apr 2021 at 15:35, Antony Watts via groups.io <antonywatts=me.com@groups.io> wrote:
The FDM-DUO sure does have VOX. But don't ask me how to configure it for use with WSJT audio output as a source...

--
Andy (out keeping fit)