Topics

Elad S2 repair

barry williams <ba.williams@...>
 

Hello group,

I've rejoined the group to get help with my Elad S2. It didn't have much sensitivity, and some sections of HF seemed to not have any input signal. Using SDR-Console 3.0.19 the radio would have audio cutting in and out on all bandwidths except the lowest. Otherwise, it seemed to be on. The blue light works. It will tune up and down, shut off and turn on normally. I used a desktop computer power source, and changed USB cables.

My S2 was bought probably in 2014, or early 2015. It has worked fine all this time. It is probably one of the first batches from Elad. I would appreciate any help in diagnosing what is going on and any info on repair possibilities. It is a nice SDR and I would like to continue using it if it can be repaired without too much cost.

Thanks,


Barry Williams

Neil Smith G4DBN
 

Hi Barry, how does it behave when running with SW2 at various bandwidths?  How about on different computers?  What about when you remove all other USB devices temporarily?  Is there any pattern to the "missing" bits of HF?  Do you have another receiver to compare it with, or any signal sources?

Neil G4DBN

On 10/02/2020 04:56, barry williams wrote:
Hello group,

I've rejoined the group to get help with my Elad S2. It didn't have much sensitivity, and some sections of HF seemed to not have any input signal. Using SDR-Console 3.0.19 the radio would have audio cutting in and out on all bandwidths except the lowest. Otherwise, it seemed to be on. The blue light works. It will tune up and down, shut off and turn on normally. I used a desktop computer power source, and changed USB cables.

My S2 was bought probably in 2014, or early 2015. It has worked fine all this time. It is probably one of the first batches from Elad. I would appreciate any help in diagnosing what is going on and any info on repair possibilities. It is a nice SDR and I would like to continue using it if it can be repaired without too much cost.

Thanks,


Barry Williams
-- 
Neil
<a href="http://g4dbn.uk/"><small>g4dbn.uk</small></a>

barry williams <ba.williams@...>
 

Hi Neil,

Thanks for your suggestions. I happened to have FDM-SD2 still installed, and the S2 performed normally. It seems something in SDR-Console has gone wrong. I sent screenshots to Simon.

That is the good news- the radio is still operational.



Barry

-----------------------------------------

From: "Neil Smith G4DBN"
To: EladSDR@groups.io
Cc:
Sent: Monday February 10 2020 4:39:39AM
Subject: Re: [EladSDR] Elad S2 repair

Hi Barry, how does it behave when running with SW2 at various bandwidths?  How about on different computers?  What about when you remove all other USB devices temporarily?  Is there any pattern to the "missing" bits of HF?  Do you have another receiver to compare it with, or any signal sources?

Neil G4DBN

On 10/02/2020 04:56, barry williams wrote:
Hello group,

I've rejoined the group to get help with my Elad S2. It didn't have much sensitivity, and some sections of HF seemed to not have any input signal. Using SDR-Console 3.0.19 the radio would have audio cutting in and out on all bandwidths except the lowest. Otherwise, it seemed to be on. The blue light works. It will tune up and down, shut off and turn on normally. I used a desktop computer power source, and changed USB cables.

My S2 was bought probably in 2014, or early 2015. It has worked fine all this time. It is probably one of the first batches from Elad. I would appreciate any help in diagnosing what is going on and any info on repair possibilities. It is a nice SDR and I would like to continue using it if it can be repaired without too much cost.

Thanks,


Barry Williams
-- 
Neil
<a href="http://g4dbn.uk/"><small>g4dbn.uk</small></a>